Tag Info

New answers tagged

0

The external content types is very prone for security issues. Do you have pass though authentication enabled on the connection to your Database? This means that you have to give individual users access. Which will not work since anonymous users are not actually logged in. An other option is to use the Secure Store and 'impersonate' the user. This means ...


1

Hiding the Ribbon : In your master page, find the SharePoint ribbon by looking for the line of code that begins with . Place the SPSecurityTrimmedControl code around your ribbon to conditionally hide it based on user permissions. In my example, i've hidden the ribbon from any user who doesn't have the ManagePermissions ability, which is going to be almost ...


1

This built-in account does not need a password and will be the default identity that is used when anonymous authentication is enabled. If you look in the applicationHost.config file you will see the following definition: <anonymousAuthentication enabled="true" userName="IUSR" defaultLogonDomain="" /> This tells IIS to use the new ...


3

When giving anonymous access to a publishing portal or a site with the publishing feature activate, there is an additional feature getting activated called ViewFormPagesLockdown. This feature prevents anonymous users from gaining access to certain areas of a site. That includes list forms. From the blog: This feature still exists in SharePoint 2010 and ...


1

It sounds like your urls aren't being rewritten. When you connected the remote list to your publishing site did you tick the box to "Make URLs relative to this site"? This video around 49:45 talks about it. Anonymous access only grants the search index the ability to share the content without requiring security checks. This video has more about it around ...



Top 50 recent answers are included