XsltListViewWebPart class in Microsoft SharePoint Foundation derives from the XSL-based DataFormWebPart class. It replaces the ListViewWebPart class as the default view type in list views, although it generates equivalent HTML for the same view settings.

learn more… | top users | synonyms

1
vote
2answers
1k views

Ribbon not available for list item in dynamically created XsltListViewWebPart

The situation is the following. I'm creating an XsltListViewWebPart during the Page LifeCycle which is added to the page Controls collection (or UserControl Controls collection). The ...
0
votes
1answer
698 views

deploy XSLT list view webpart using “AllUserWebPart” through a feature from the solution package

I am trying to deploy custom pages from feature. I came to know that the webparts(oob or custom) are to be deployed from the elements file using the "AllUserWebPart" wherein we have to include the ...
1
vote
0answers
217 views

Web part only displays after refreshing page?

I've got a web part that displays one item in a list in a custom view. When going to the page that houses the web part, it errors, giving me a "Unable to display this Web Part. To troubleshoot ...
2
votes
4answers
5k views

How can I filter a calendar (ListViewWebPart) web part?

I've entered a lookup field to a calendar list that corresponds with the values in a list of links. I would like to show only calendar entries on the web part that correspond with the selected link. ...
6
votes
3answers
7k views

How do I change the underlying list in an XsltListViewWebPart?

I have a list of lists and an empty XsltListViewWebPart. When the user clicks on a list in the list of lists, I'd like to show that list inside the XsltListViewWebPart. How can I change the underlying ...
0
votes
4answers
2k views

Anonymous users denied access to XSL stylesheet

I have a XSLTListViewWebPart on a page and it is linked to an XSL stylesheet located in the Style Library. Anonymous users have read access to the Style Library. When a logged in user views the page, ...
0
votes
2answers
525 views

Get ID for selected item in connected web part

I have an XSLTListView (RoleAssignments list) web part that is connected to another XSLTListview (Authorities list) web part which provides a filtered listing based on the selected role. I need to get ...
2
votes
1answer
888 views

How do I show single/multiple attachments from a XsltListViewWebPart of a list?

SharePoint 2007, trying to display attachments via an XsltListViewWebPart. Doesn't seem clear on how to accomplish this via designer.
2
votes
1answer
428 views

aggregate data source and pseudo join?

Is it possible to use the aggregatedatasource to show all "parents" and theirs "children" where at least one "children" is created by the current user ? To be more clear, imagine the following : ...
3
votes
0answers
555 views

Filtering an XLV with a Managed Metadata Field in a Publishing Page Layout

I have a custom Page Layout which inherits from Enterprise Wiki, with an additional column of type Managed Metadata. In SharePoint Designer, I place this field as a control onto my customised page ...
1
vote
3answers
2k views

Hide column in xslt view

I've got an xslt list view. I have one column that should be used in the xslt calculation (shown as a row tooltip) but it should not be visible as a column in the list. Question: Must the column be ...
1
vote
3answers
975 views

content query web part versus custom web part

In a publishing site, I want to create a webpart that display the result of a query with a custom display (a kind of rotator). As the goal of the web part is to be reusable and must be quite simply ...
1
vote
0answers
456 views

XSLT Transform failed: 0x80004005 : Type Mismatch UrlDirName

I get the following error in sharePoint designer design mode when I add a thumbnail field to a xsltlistviewwebpart Any ideas on how to avoid? In addition, i want to modify the output of the ...
0
votes
1answer
1k views

XsltListViewWebPart and Content Deployment

I would like to know if there is a way to deploy (or migrate) an XsltListViewWebPart with a content deployment job ? To explain further, I have two environments, "Authoring" and "Production", and I ...
5
votes
3answers
1k views

Why don't folders work when adding an XsltListViewWebPart to the page via code?

I have an issue with adding an XsltListViewWebPart to a page for a Document Library. When I do it using the code below everything works fine unless I create a folder and upload a document there. Such ...