XsltListViewWebPart class in Microsoft SharePoint Foundation derives from the XSL-based DataFormWebPart class. It replaces the ListViewWebPart class as the default view type in list views, although it generates equivalent HTML for the same view settings.

learn more… | top users | synonyms

1
vote
0answers
153 views

Dynamically changed view of XsltListViewWebPart (in the custom form)

I have a form with custom XLV: <WebPartPages:XsltListViewWebPart ID="Xlv" runat="server" />, AFAIK, the view for this webpart is stored in the list as hidden. When user open form, the XLV query ...
1
vote
0answers
76 views

Remove ECB from XsltListViewWebPart

I have created XsltListViewWebPart programatically. I want to remove ecb on list items, I know this can be done by changing xsl of the webpart but I am getting null in it. Is there any way to do this? ...
1
vote
0answers
319 views

Connect XsltListViewWebPart with multiple providers

I have two lists defined: A: Projects (with a lookup column to B) B: Customer For list A I have two listviews: Open Projects Closed Projects Now I have a webpart page with three ...
1
vote
0answers
715 views

SharePoint 2010 OOTB filtering and sorting is not working in XsltListViewWebPart in Arabic

I am working on a multilingual site in English and Arabic. I have some pages with XsltListViewWebPart to view custom lists with no more than 12 fields to display. These are connecting webparts and ...
1
vote
0answers
559 views

Target Audience does not work with site SharePoint groups for XSLT List View web part

On some xsltlistview web parts, whenever I try to set the target audience to use one of the SharePoint site groups (These are groups created when you create a new site), it tells me that it does not ...
1
vote
0answers
163 views

xsltlistviewwebpart - view edit delete (ribbon) with filter

Is it possible to enable view, edit and delete (on the ribbon), when there is a filter applied? Thanks, David Esteves
1
vote
0answers
263 views

Disable Modal Dialogs from XSLTListView

i need to disable some modal dialogs for the form display in a listview. At the list settings I have disabled the modal dialog (NavigateForFormsPages="TRUE"). For the items of the list it works fine. ...
1
vote
1answer
165 views

Copying code over in Sharepoint Designer 2010 and changing it, deletes code from the original file, how can I fix this

Suppose I have two files, A, and B respectively. Everytime I copy xsl code from file A to B and modify the code in B and save it. The code in A gets removed (all except for the WebPartZone tags and a ...
1
vote
0answers
221 views

Web part only displays after refreshing page?

I've got a web part that displays one item in a list in a custom view. When going to the page that houses the web part, it errors, giving me a "Unable to display this Web Part. To troubleshoot ...
1
vote
0answers
481 views

XSLT Transform failed: 0x80004005 : Type Mismatch UrlDirName

I get the following error in sharePoint designer design mode when I add a thumbnail field to a xsltlistviewwebpart Any ideas on how to avoid? In addition, i want to modify the output of the ...
0
votes
3answers
6k views

Creating an XsltListViewWebPart programmatically: Columns & toolbar

I add an XsltListViewWebpart to a page in an event receiver like this: public void CreateWebPart(SPList documentsList, SPLimitedWebPartManager wpm) { var documentsWP = new XsltListViewWebPart(); ...
0
votes
3answers
41 views

hiding duplicates in a SharePoint view

I have a list with the following information: I have attempted to create a table of contents by grouping results in the following manner: However, as you can see, I have duplicated results in ...
0
votes
3answers
2k views

XSL to customize XsltListViewWebPart - Sharepoint Foundation 2013

I have created an external list. After it's rendered, link for each item looks like the following: <a class="ms-listlink ms-draggable" onfocus="OnLink(this)" ...
0
votes
1answer
906 views

xsltlistview overiding the column headings using Xsl Link

I have a listview webpart that used specific columns. Changing the names of the columns is not an option. Our users are insisting that the heading for these columns be updated, so I am thinking of ...
0
votes
4answers
2k views

Anonymous users denied access to XSL stylesheet

I have a XSLTListViewWebPart on a page and it is linked to an XSL stylesheet located in the Style Library. Anonymous users have read access to the Style Library. When a logged in user views the page, ...
0
votes
1answer
73 views

How to provision XsltListviewwebpart programmatically

I want to add Xsltlistviewwebpart with some pre difened property(like list,view,zoneid) and also apply xsl to it.Does anyone has any example/code sample to show how can it be achieved. Thanks for ...
0
votes
2answers
141 views

Listviewwebpart doesn't render the data and shows “RENDER FAILED”

I have created a custom solution and used listviewwebpart to display the data. It works fine if I have only one webpart added on a page but as soon as I add another webpart I get RENDER FAILED error ...
0
votes
1answer
76 views

Displaying thumbnail preview of a document

I have an xslt list view webpart where I am displaying all the documents in a list. I want to implement on functionality where if user hover on a document link then I should display a small popup with ...
0
votes
1answer
521 views

How to edit xslt for thumbnail view of Asset Library.?

I have added an XsltListViewWebPart which refers to the Asset Library in the site. I have given reference of AssetPick.xslt for thumbnail view for that web part. I want to put the Title in place of ...
0
votes
1answer
406 views

XsltListViewWebPart is not displaying proper view when added programmatically

I am adding an XsltListViewWebPart from code behind, my code is: static void Main(string[] args) { SPSite site = new SPSite("http://bipc11:1234/sites/publishing1"); SPWeb ...
0
votes
3answers
368 views

XSLT Listview webpart not showing site column lookup values

The Problem: We have a top level site that contains various lists of data. The information in these lists are exposed to subsites using site lookup columns. In our subsites we have various lists that ...
0
votes
1answer
314 views

Windows security update KB28544286 cause xsl:stylesheet error message: Unable to display this Web Part

Error Message- Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Microsoft SharePoint Foundation-compatible HTML editor such as Microsoft SharePoint Designer. If ...
0
votes
1answer
1k views

Sharepoint 2013 Discussion Board OOB Webpart on a publishing page causes the Edit Page functionality not to work/function after publishing the page

Discussion Board OOB Webpart (xsltListViewWebpart) on a publishing page causes the Edit Page functionality not to work/function after publishing the page. Steps to reproduce: Create a Site ...
0
votes
1answer
273 views

Sharepoint 2010 grouped xsltlistview with custom XSL does not show items when initial settings for group is 'fold'

Following problem : I have a xsltListView (auto created on a publishing site). I have editted the default view and copied the stylesheet to a new .xsl file and placed it into the style lybrary. On ...
0
votes
2answers
284 views

Unlink page from master

Is there a way to "unlink" a page from the master page? Specifically, what I want to do is have a completely blank page display a SharePoint ListViewWebPart. Alternatively, if I start by creating a ...
0
votes
2answers
526 views

Create external list without link to the item

I've got an External Item List (from a SQL Database source) and it works OK. However, it doesn't seem to matter what I do, I cannot remove the "link to item" from the first column. I'd like the list ...
0
votes
1answer
230 views

XSLV web part: default xsl templates

Where default xsl templates for xslt view list web part are soterd? As I know I can override any template in custom XSL file, but where can I find all the default templates? For example I need a ...
0
votes
1answer
116 views

Column that show the title of an item and point to a lookup value?

I have two lists, let's say "Parent" and "Child". There is a lookup in "child" list that point to "parent". In a custom view of Child list, I'd like to have the title of "Child" display, with a link ...
0
votes
1answer
653 views

Condition on hidden field in xsl?

I have a custom xsl file that I use to show items in bold when a boolean fields equals to false. I've set up the xsl using SharePoint Designer, then I exported the Xsl node in a xsl file. I deploy ...
0
votes
1answer
966 views

Using a list view to filter another list view

I have two lists; List A and List B. List B has a lookup column to List A. I want to filter List B based on the value in the field that looks up A. This can of course be done using the default OOTB ...
0
votes
2answers
502 views

How to use XmlDefinitionLink & CAML to reuse View definitions in multiple XsltListViewWebPart controls?

This is what I want to achieve (in SharePoint 2010): A custom page containing 2 XsltListViewWebPart Both of them rendering the same list data, but with different XSLT definition for display I ...
0
votes
2answers
207 views

two xslt list vew webparts

Is it possible to send different parameters like "rootfolder" (usually fount in the url as a get-parameter) to two different xslt list view webparts on one single page? How can I achieve this?
0
votes
1answer
754 views

deploy XSLT list view webpart using “AllUserWebPart” through a feature from the solution package

I am trying to deploy custom pages from feature. I came to know that the webparts(oob or custom) are to be deployed from the elements file using the "AllUserWebPart" wherein we have to include the ...
0
votes
2answers
538 views

Get ID for selected item in connected web part

I have an XSLTListView (RoleAssignments list) web part that is connected to another XSLTListview (Authorities list) web part which provides a filtered listing based on the selected role. I need to get ...
0
votes
0answers
8 views

SP13: Dataview Webpart &nbsp

I have a Dataview Webpart that is used in a page that originated in SP07 however was migrated to 2013 version. Looking at the xsl script there are no hard spaces are indicated by using &nbsp or ...
0
votes
0answers
4 views

BCS list view webpart filters

I've added a list view webpart to a page and created a query string parameter which filters the data based on a finder method provided via the ECT. I also want users to have the ability to further ...
0
votes
1answer
18 views

Cant add list view webpart through XML

I'm trying to add a listview webpart to my default page of my sandboxed solution for SharePoint 2013 in Office 365. I'm using a ONET file to define my webtemplate based on the STS template. Among ...
0
votes
0answers
32 views

Compound filtering SharePoint 2010 list with Partial Postback to page

I am filtering a SharePoint 2010 list as explained in the below link, http://dcsharepointchick.blogspot.in/2013/05/filter-sharepoint-list-with-partial-postback.html Now I need to add one more filter ...
0
votes
0answers
33 views

Increase Column width in SharePoint Designer 2010

I am trying to increase the column width through SharePoint Designer. I dragged the column to desired width in AllItems.aspx. However, if I save it I cannot find the change in the respective list. ...
0
votes
0answers
24 views

Custom List View Link always changes

my custom list view xsl's path is between tags. For example: <XslLink>http://blahblah/site/customview.xslt</XslLink> But after a while it changes as ...
0
votes
0answers
51 views

Sharepoint 2013 List WYSIWYG Designer views

We need to offer our users a way to freeform format Custom List fields anywhere on a SharePoint page. The designer can not be InfoPath, SharePoint Designer or Reporting Services. Design experience ...
0
votes
0answers
29 views

Edit Column in XsltListViewWebPart from code behind

I would like to edit the columns of a XsltListViewWebPart. I want to add a Column like "Sum" which shows a calculated value (maybe including fetched data from different lists). That's why I would like ...
0
votes
1answer
68 views

asp Update Panel with timer control updates XSLTListViewWebPart

I have used one user control in SharePoint master page which will automatically refresh on every five seconds ( I have used asp Update Panel and asp timer control for doing this) And I have one ...
0
votes
0answers
35 views

dsQueryResponse : Single line text is automatically wrapped in anchor tag

I am trying to customized the view of list using XSL. I have a single line text filed named 'LinkUrl' which has value like http://someurl The problem is that dsResponseRow is not outputs the raw ...
0
votes
0answers
131 views

XsltListViewWebPart not working in Sharepoint 2013

I am having an issue with getting the XsltListViewWebPart working in Sharepoint 2013 installed on a Windows Server 2012. The Sharepoint error log is this: Area : SharePoint Foundation ...
0
votes
0answers
4 views

Unable to get selected items using JavaScript from XsltListViewWebPart on Publishing page after published [duplicate]

I have placed xslt list view web part on publishing page. And above that I have placed one content editor web part to get selected items from the view. My JavaScript is: var ctx = ...
0
votes
0answers
38 views

Filtered List View XSLT Web Part empty when the page loads first time

I've added two date pickers 'From' and 'To' in a SharePoint list view through SharePoint Designer and assign the values from the datepicker to two hidden fields. I use these hidden fields as ...
0
votes
0answers
50 views

How to apply alternate colors to filtered table rows using XSLT

Hi i am able to apply alternate colors to table rows when i am not applying any filter using: <xsl:when test="position() mod 2 != 0"> But when i apply filter of unique values, i will get ...
0
votes
1answer
92 views

How to embed OOTB web part in a user control?

I'm planning to create a Visual Web Part. In the Visual Web Part's user control, I plan to embed an OOTB XSLTListViewWebPart, preferably through a declarative manner (in the .ascx). Has anyone done ...
0
votes
1answer
46 views

Data view web part joined subview fails due to extra characters in ID field

I created a joined subview in a data view web part however it is failing to find any matching items because one of my join columns IdeaID. is bringing in additional characters (see image below). ...