Web parts are ASP.NET controls that can be added to web part zones. They are generally distributed as WSP files. Pre-2013, they could be developed off the hosting server. With 2013, WebParts for the most part have to be developed the hosting server for propery library inclusion.

learn more… | top users | synonyms (3)

2
votes
1answer
380 views

Do connectable webparts need to be in the same project?

I've found two tutorials that I'm looking at: http://msdn.microsoft.com/en-us/library/ms469765.aspx http://mstecharchitect.blogspot.com/2010/04/creating-connectable-web-parts-using.html But both ...
1
vote
2answers
65 views

Can I filter a Web Part list using parameters from the URL?

In my rich content area I've inserted a Pages Web Part (to show a list of pages in the subsite). I'm using JS Link to customize the presentation of the list. Can I pass a parameter to the page and ...
1
vote
1answer
3k views

Folders in document libraries: how to navigate back up to parent folder (web part on page)?

I have a document library web part on a page and it contains a folder. When a user clicks on the folder it opens and shows the documents inside, but there is no way to go back to the parent folder ...
1
vote
1answer
3k views

Deployed web parts don't show up in Web Part Gallery

I have created several custom web parts in a Visual Studio solution which deploys to my development environment site perfectly directly through Visual Studio. However, I also want to be able to ...
1
vote
1answer
2k views

Trending #tags webpart not working - SP 2013

We are having a problem with our "Trending #tags" webpart that is not displaying any data. It resides on the MySite host default page, (default.aspx). From my understanding #tags which are mentioned ...
1
vote
2answers
87 views

How to find where a web part has been placed

I have a task where I need to locate every page that has a particular web part on it. It looks like I may be able to get this info from the database itself but I'm not sure how thorough this may be. ...
1
vote
1answer
1k views

Force Chart Web Part to show all labels

When using the Chart Web Part (horizontal bars) only every fifth bar-label gets displayed. The end user can't see what the other bars represent. Is there a way to display every label for one axis?
1
vote
1answer
7k views

How to add web part in page layout?

Ok I created my first master page and now I am working on page layout. I created a new "Publishing Content Type" page layout in SharePoint Designer whose content type was "Page". In that page I want ...
1
vote
1answer
3k views

SPLimitedWebPartManager throwing “File is not checked out” error on AddWebPart and DeleteWebPart

I'm writing a powershell function to add custom webparts (i.e. not Out Of The Box webparts such as ContentEditor) to publishing pages on a SharePoint Server 2010 site. I encountered a frustrating ...
1
vote
1answer
740 views

Web Part Data into Sharepoint LIst

I have a custom web part which have lot of fields that will be filed out by user and on submit is there a way that i can populate these values into a SharePoint list .I don't want to use info path as ...
1
vote
3answers
6k views

HTTP/1.1 200 OK Server: Microsoft-IIS/7.5 , Connection: close

I am getting this error in sharepoint 2010 portal after i restore the site collection for my portal from SharePoint 2010 management shell. The problem is the restoring process does not complete and i ...
1
vote
1answer
198 views

default custome webpart became static on custom site page

I have created a custom site page in sharepoint 2010 and added the following code to it <WebPartPages:WebPartZone runat="server" FrameType="TitleBarOnly" ID="Main" Title="loc:Main" > ...
1
vote
1answer
287 views

SharePoint 2010 and ASP Profile Provider

We have web application with SQL ASP Membership Provider, Role manager and profile provider. This web application has both authentication methods: NTLM and forms. Everything works fine. Problem ...
1
vote
1answer
502 views

Is it safe to store the credentials in the properties of a Web Part?

In my web part, I use a class WebProxy. The object of this class uses special credentials. It would be nice to store the credentials in the Web Part properties. And so the user can change them. For ...
1
vote
1answer
223 views

How to set XSL property on inherited core search results webpart

I have created a custom Search results web part by inheriting from coreresultswebpart. I would like to override the default XSL with some modified XSL in my project instead of having to set the XSL ...
1
vote
2answers
2k views

Using the Now() function in CAML Query?

i am trying to get the 3 most upcoming events from the current date and time (The current data and time refers the time everytime my web part loads. Basically it is not a fixed date and picks up the ...
1
vote
1answer
352 views

Sharepoint Ribbon for view item form going full option

I have a view item form which contains a custom WebPart for displaying that item. I have no issue with that but the ribbon for the display form looks weird: It contains lots of options that don't ...
1
vote
4answers
691 views

How to access a library that is not in same farm. i.e. WebPart is in Farm1 and library is in Farm2

How to access a library that is not in same farm. i.e. WebPart is in Farm1 and library is in Farm2 My company has many farms and now I need to create one WebPart that is going to sit in farm1 but it ...
1
vote
2answers
7k views

How do get selected item of list?

I have a webpart .I add a listviewbyquary in createchildcontrols and a hyperlink in visualwebpart. i use this http://graegert.com/featured/using-the-editorpart-to-create-a-custom-listview-web-part ...
1
vote
1answer
1k views

Custom web part throws error when I try to add it to page

I am working on a custom web part, that keeps error out with: A web part or web form control on this page cannot be displayed or imported. the type is not registered as safe any time I ...
1
vote
1answer
7k views

A Web Part or Web Form Control on this Page cannot be displayed or imported

I'm working on Create a Custom Web Part i'm able to do a build and run the new project in debug mode. However, after trying to add the new web part to the site, I get the following error. "A Web Part ...
1
vote
5answers
6k views

Can't edit page after adding custom web part!

When I click on the edit icon nothing happens. No errors, no post back nothing. I ended up turning on the Console in FireBug and it throws this error: SP.Ribbon.PageState.ImportedNativeData is ...
1
vote
3answers
311 views

Possible to have users configure a few values when adding a webpart to a page?

I have a web part that has to does something specific with a list. I would like to have users specify which list they want the web part to use when they add it to a page and not worry about it again. ...
0
votes
1answer
758 views

Sharepoint 2013 Custom Web Part: Get and display data from Oracle and SqlServer databases

I'm developing a Custom WebPart to retrieve data (based on certain queries) from a SqlServer and Oracle databases: The data should be displayed in a grid/table/etc with sorting, filtering and ...
0
votes
2answers
208 views

How to upload jQuery library into web parts without master page

I am in the process of migrating from SP2010 to SP2013. In SP2010 the Scriptlink feature was used to upload all of the jQuery libraries from the master page. Currently I want to test some web parts in ...
0
votes
0answers
228 views

Why edit option is not working on the SPGridView in SharePoint 2010?

Have created the Webpart based on http://kitmenke.com/blog/2010/02/18/editing-in-sharepoints-spgridview It does work however I want display the results based on the filter value as below it ...
0
votes
1answer
479 views

The file /_controltemplates/15/ does not exist

We are planning to migrate from share point 2010 to SharePoint 2013.So we have created one POC environment to test the customizations(master pages,Page layouts,web parts,site definition,Site ...
0
votes
2answers
332 views

Multiple Webparts with the same Javascript

I have a site with multiple Webparts. Some Webparts are linking on the same .html file. The HTML file reads data from a list and displays it in a table by using javascript. My problem is that there ...
0
votes
1answer
2k views

RegAsm : error RA0000 : Could not load file or assembly or one of its dependencies. The system cannot find the file specified

I am new to sharepoint. I try to add the Microsoft.SharePoint.dll to GAC. For that one I have used below code Code : `c:\WINDOWS\Microsoft.NET\Framework\v4.0.30319> Regasm.exe ...
0
votes
1answer
692 views

openfiledialog in webpart

How to implement openfile dialog in a webpart ? OpenFileDialog class could not be accessed in webpart. Is there any other way to achieve this ?
0
votes
2answers
2k views

how to hide webpart in Home.aspx based on some condition

I work in a financial company where we have Resident Engineers and they have account in Active Directory but they dont have official email addresses. My portal acrhitecture is like everyonce can ...
0
votes
3answers
2k views

How can I access Controls in VisualWebPart1.cs from UserControl.ascx

I make a Webpart and want to use the controls from the VisualWebpart1UserControl.ascx in the VisualWebpart1.cs. Is this possible? I wrote following code in the VisualWebpart1.cs: ...
0
votes
3answers
588 views

Webpart properties getting empty after IIS Reset

I created a custom visual user control webpart property for my SharePoint webpart. The property has a textbox which is getting empty after an IIS reset. Can anyone tell me how to solve this issue ...
0
votes
1answer
1k views

Feature Elements File

I'm having some difficulty creating a Feature which contains a Web Part and a links.xml which is processed by the WP code-behind. My difficulty is in understanding the Feature XML config files and ...
0
votes
2answers
409 views

Does web part property validation only work for visual web parts?

Suppose I define a web part property like this: private string _myString = "default value"; [WebBrowsable(true), WebDisplayName("My string"), WebDescription("A simple bit of text to ...
0
votes
1answer
347 views

Customizing XLV web part's xslt

I have a list with few views. I've updated one view. Made column to be bold in the list's view. Then I opened a web part page and added this list (Page Tools -> Insert -> Existing Lists) then opened ...
0
votes
2answers
537 views

Rendering Webpartzone is to large

I have a Div box with an Webpartzone in it. But when i'm rendering my page, the webpartzone is to large. I thought a webpart zone has the width of 100% of his parent container. But not in my case. ...
0
votes
2answers
261 views

Client Object Model Javascript intellisense

I created a new test.js file in the project node of my web part solution with VS 2010 and included the references: /// <reference path="C:\Program Files\Common Files\Microsoft Shared\Web Server ...
0
votes
1answer
1k views

Forms Based Authentication Users in the SharePoint 2010 People Picker Not Working

I Created custom login page . I use this code for login if (Membership.ValidateUser(Username.Text, Password.Text)) { SecurityToken tk = SPSecurityContext.SecurityTokenForFormsAuthentication( ...
0
votes
1answer
331 views

How do I retrieve the “Title (linked to edit)” column from event list to display in my custom web part.

I am creating a visual web part to display the calendar events in the form of an events list with custom css. The web part will be on the home page of my site. Here is what I have right now and it is ...
0
votes
3answers
10k views

Cannot connect to the Sharepoint Site from Visual Studio 2010

I'm new to Sharepoint. I'm trying to create a simple webpart using Visual Studio 2010 but when I try to validate my Sharepoint Server (both VS 2010 and Sharepoint are present in two different system - ...
0
votes
1answer
1k views

How Do I Get the MySite Images and Full Name of the MySite owner in MOSS 2007 in C#

I am building a simple web part that needs the image that is used from the MySite and the First and Last name of the site owner. I know how to get the current user, I need the name. I am also having ...
0
votes
2answers
4k views

How to remove “created by” on SharePoint blog post item?

I recently created a blog site and posted few blog posts but then I realized that "created by" column is showing on the item. I tried to check what page layout a post is using but I simple found ...
0
votes
1answer
2k views

GridView control - paging with linq. Where is objectDataSource?

I have visual web part with custom logic which retrieves me strongly typed list (not SPList -> .NET list object) which than I bind to gridview which has paging enabled. That works fine. Problem is: ...
0
votes
0answers
75 views

how to validate custom web part property? [duplicate]

Possible Duplicate: How to validate Web Part property value? below is a custom prop and a code that i am using for my custom web part, my question is, how to validate a custom web part and ...
0
votes
2answers
5k views

target audience not working as expected with site group

In my SP2010 farm, I have : one domain group "AD Group" the group have domain\user2 as a member one site group "SP group" with the following members AD group domain\user1 On the home page, I ...
0
votes
2answers
789 views

<WebPartPages:PictureLibrarySlideshowWebPart adding links

Does anyone know how to change the link on the image to be whatever is in [link] field within the same library? (I added a column/field called link). The link on the image is a link to the image, but ...
0
votes
1answer
156 views

SharePoint Web Part Gallery details of each web part

When using SPWeb.GetCatalog(SPListTemplateType.WebPartCatalog), it returns an SPList which of course contains a SPListItemCollection of the web parts in the web part gallery. When looping through the ...
0
votes
3answers
634 views

Filter webpart on the Search Page

Basically, I am Sharepoint administrator and my bad time have to create/introduce a Filter webpart on the search page Expectations are I have a custom List with 10+ columns (like CustomerID, ...
0
votes
3answers
169 views

Solution deploying 'succesfully', yet doesn't..

MOSS 2007 :) I am having problems deploying a webpart.. This webpart was successfully installed and deployed on a similar environment with no problems. However when trying to deploy it in its ...