Web parts are ASP.NET controls that can be added to web part zones. They are generally distributed as WSP files. Pre-2013, they could be developed off the hosting server. With 2013, WebParts for the most part have to be developed the hosting server for propery library inclusion.

learn more… | top users | synonyms (3)

1
vote
0answers
51 views

Access Request Web Part

I was modifying the pendingreq.aspx page to change the Master Page. While doing so, the Access Request web part was removed. I can't find the web part to insert, nor do I know how to get the list ID ...
1
vote
0answers
240 views

why is Gridview moving infinetly to the right in visual studio 2010 designer view

In visual studio 2010, I have a gridview, with another inside, this has been working fine for 3 weeks, but today, it randomly begins to move to the right in designer, not when deployed, its jumping a ...
1
vote
0answers
125 views

How do I localize web part title?

I'm adding a bunch of web parts to a page using a module like this: <AllUsersWebPart WebPartZoneID="TopLeftRow" WebPartOrder="1"> <![CDATA[ <webParts> ...
1
vote
0answers
123 views

Customizing Native Calendar view of SharePoint 2010/ 2013

I am designing a Training calendar. Instead of designing an entirely new webpart, I want to utilize the existing calendar given by SharePoint. I need to replace "+Add" button from each day in ...
1
vote
0answers
23 views

How to upload documents FROM sharepoint to an external content management server?

How to upload documents "FROM" sharepoint to an external content management server? Is there a way to provide external CMS as source to sharepoint content server?
1
vote
0answers
100 views

Web Part ApplyChanges not working properly

I have my Tool Part class to handle the properties of my Web Part. My method to create the properties( CreateChildControls ) is working fine but everytime I run this method it's reading a parameter ...
1
vote
0answers
132 views

How to get PublishingRollupImage in a sandbox solution using server OM?

I am trying to get the PublishingRollupImage of a list item using the server object model (requirement) in a sandbox solution. The problem I have is that I can't reference the ...
1
vote
0answers
107 views

CQWP bind sorting with query string

Is there a way to use PageQueryString in CQWP to control the sort order and sort by behavior? I am trying to implement this kind of sortable and filterable table with pagination: Would it be ...
1
vote
0answers
191 views

What's wrong with the manual refresh web part option?

I have a task list in SharePoint 2013 that I have enabled the AJAX manual refresh button for. This option can be found by editing the list web part, then going to AJAX options and then ticking "Show ...
1
vote
0answers
56 views

WebPart to dynamically display links to all views within a list or library

I'm trying to develop a WebPart that I can place on the top of a SharePoint 2010 list or library page that will dynamically display links to the views created within the library. I want to also format ...
1
vote
0answers
126 views

Failed to apply XSLT to the content

I am using "XML Viewer" webpart to display some data from another website. I have applied XSL on it and it works fine on my VM. But when I moved the site to development server, it showed error message ...
1
vote
0answers
52 views

Accessing custom property value of webpart in application page

We have a custom property in a webpart. and we are opening an application page as a popup dialog. In that page we want to access the webpart property. The custom property is as follows: ...
1
vote
0answers
127 views

O365 autohosted app passing parameters to iframe or alternatives

We have autohosted app web-part for Office online (based of course on Sharpeoint 2013) Ours app is display list of products from database and by clicking on product display information about product, ...
1
vote
0answers
117 views

executeAsync strange behavior - sharepoint rest services

I'm using Sharepoint Rest services to update List Items. To do the update, I'm using the function executeAsync from the SP.RequestExecutor object. The code was working fine, but while I was testing it ...
1
vote
0answers
17 views

Web Part Category List - Appearance of random space

Once a web part category is selected the web parts list is displayed having empty space/gap beneath it eventhough the list is long (with left and right arrow heads enabled). Is there a reason for ...
1
vote
0answers
97 views

Filter a connected list- How to show all by default?

I have two lists embedded as individual webparts on my SP2010 page. The two lists are connected so that the first list can act as a filter for the second one- there is a column which is common between ...
1
vote
0answers
288 views

CreateChildControls() in Visual Web Part in SharePoint 2010 called twice

(x-post from http://stackoverflow.com/q/17065543/1943) I have a Custom SharePoint 2010 Visual Web Part which I've realized is calling the CreateChildControls() method twice. I've tried setting the ...
1
vote
0answers
360 views

SharePoint 2013 and advanced webpart connections

Since WSS 3.0, we have used custom webparts and webpart connections to build customer solutions. A connection between two webparts can contain multiple parameters, which was fully supported in WSS ...
1
vote
0answers
95 views

ViewState Timing Issues with SharePoint 2013 & ListView plus DataPager

Good morning! I'm porting an existing custom 2010 webpart containing a ListView and a DataPager to 2013 and seeing some weirdness with the DataPager and I believe the cause is associated with the ...
1
vote
0answers
91 views

Import Error on ChartDataProvider Webpart

My Sharepoint project contains a visual Webpart which retrieves data and works fine. In addition to that, I want to display some Chart webparts which visualize this data. In order to do so, i added a ...
1
vote
0answers
28 views

Can't edit site page without loosing all content

I have a major issue with my landing page. Everytime I try to edit the page, I loose all the content, everything gets wiped out once I hit save and I've had to redo this page about 6 times now. I ...
1
vote
0answers
99 views

Lookup column automatic selection in list form upon adding new item

I have a site page with two related lists, this relation being established via the webpart option "insert related list", and I'm using ID column in my child list as the lookup column. The child list ...
1
vote
0answers
109 views

SharePoint-hosted app, with edit mode to update its own properties

I'm using the editMode parameter to detect and display a simple web part admin UI. When the admin clicks a particular button, I want to use CSOM to update the web part's properties for the page it is ...
1
vote
0answers
74 views

Remove ECB from XsltListViewWebPart

I have created XsltListViewWebPart programatically. I want to remove ecb on list items, I know this can be done by changing xsl of the webpart but I am getting null in it. Is there any way to do this? ...
1
vote
0answers
101 views

How to make a connection with SharePoint's simpleformwebpart?

I am using SharePoint 2010. I primarily work out of SharePoint 2010 Designer, and have some experience with visual studio 2010. I currently have a log-in page that my "Form" members go to, to log ...
1
vote
0answers
208 views

“Actions” menu hidden in Report Viewer web part?

The Actions menu which allows for export to excel, pdf and other functions is hidden in all of my report viewer web parts. I did try to browse to the web part galleries to see if I can set it up ...
1
vote
0answers
147 views

Comments webpart and anonymous access

I added the "Comments" webpart from the Social web part group to a page on a SharePoint 2010 web site. My site is currently configured with anonymous access so I wanted to confirm if only registered ...
1
vote
0answers
254 views

cann't add web part to PublishingWebControls:RichHtmlField

I have created a Page Layout based on a custom Content type which inherits from Page Content Type. It contains four Custom Fields and a PublishingWebControls:RichHtmlField for each field. When I try ...
1
vote
0answers
115 views

'Like' button on Intranet Blog - SP2007

does anyone know if a webpart exists for adding a 'like' button on a Sharepoint Blog post? the button will not link to facebook (applet) it is solely for an Intranet site. the counter for the ...
1
vote
0answers
78 views

Sharepoint Webaprt

How to call sharepoint webpart usercontrol method in AJAX $.ajax({ type: "POST", url: "FundUserRegister2.asmx\validateEmail", data: "{'strMailID': '" ...
1
vote
0answers
58 views

SharePoint 2010 Connectable webparts

I wanted to create a custom webpart with acts as both consumer and provider. So I want my custom webpart to act as a bridge between two OOB sharepoint webparts. WP1 -> WP2 -> WP3 I want to get the ...
1
vote
0answers
110 views

XML Viewer Web Part: XML feed requires username and password. How to pass credentials?

I am getting the following error message: "Cannot retrieve the URL specified in the XML Link property. For more assistance, contact your site administrator." I have an xml feed that prompts a ...
1
vote
0answers
233 views

Setting Custom Property of SharePoint WP readonly

How to set the custom property(bool) of sharepoint 2010 custom webpart as read Only based on a condition?
1
vote
0answers
135 views

Choice Filter list based on User Group

I have two List web parts being filtered based on a connected Choice Filter web part. I would like the choices available in the filter web part to be the members of a SharePoint user group. For now, I ...
1
vote
0answers
138 views

Webpart Filter on Infopath Form Library

I have a webpart page that displays an infopath form, with the associated form library in list view next to the form. I'm trying to create a Sharepoint List filter webpart to show only forms with a ...
1
vote
0answers
16 views

Poll - way to identify user or group

I am creating a public poll on a topic site - is there a way to see who has answered/their user group (team) to see what areas have replied with what instead of the individuals (needs to be ...
1
vote
0answers
228 views

Config standard SiteUsers WebPart in SP2010

I´ve got a problem with a normal SiteUsers WebPart. Currently I have this code: <WebPart xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" ...
1
vote
0answers
344 views

Two different link web parts on one page problem

In one of my subsites, lets call it 'Our Workplace', I have two link lists called 'Employee Centre' and 'Manager Centre' respectively. They both contain a few folders with subfolders eventually ...
1
vote
0answers
108 views

Issue with web parts disappearing

First time here and I'm hoping someone can help me. I've searched all over and can't find anything... We have an application running in Central Administration that generates ASPX files to specified ...
1
vote
0answers
130 views

inheriting from WebPart with custom ToolPart

There is a custom web part (let's call it WebPartA) and custom Tool Part for it. We need to inherit from this web part and extend it with two integer properties (WebPartB). And add default controls ...
1
vote
0answers
316 views

Custom aspx page with web part

What would be the best way to have a custom asp.net page which runs on sharepoint and displays a web part? TIA
1
vote
0answers
294 views

Declarative WebPart on publishing page

I have made a publishing page layout that has a WebPartZone and a MediaWebPart in the ZoneTemplate. Example below. <WebPartPages:WebPartZone runat="server" Title="Fokusøki Media" ...
1
vote
0answers
65 views

Hide report builder link on Report Services Report Explorer web part

Is it possible to hide the "Report Builder" link that is displayed in the upper right hand corner of the Report Explorer web part? This is on SharePoint Services 3.0
1
vote
0answers
309 views

Connect XsltListViewWebPart with multiple providers

I have two lists defined: A: Projects (with a lookup column to B) B: Customer For list A I have two listviews: Open Projects Closed Projects Now I have a webpart page with three ...
1
vote
0answers
96 views

Editorpart positioning at the bottom

I created my own custom editor part for my web part. But when I add it to the web part, it displays by default at the top, what i would like to have is to position it at the bottom. Anyona has any ...
1
vote
0answers
45 views

Configure search to show particular cells of a list

this might be some kind of a stupid question, but I'm absolutely new to SharePoint and I've no idea what to do. I uploaded a list to my SharePoint and added a search scope for it. Now I can search, ...
1
vote
0answers
297 views

Custom filter provider web part and multiple values

I'm trying to build a custom filter provider that can detect the user language (the language selected in SharePoint by the user) and provide it as a filter. As a language can be represented in many ...
1
vote
0answers
23 views

Displaying Children from a Connected List in a Parent List

I have 3 Lists, Site, Product and Module, which are all displayed as List WebParts on a Page. I only want to show the Site List, which needs to show the Product and it's Modules. I have connected ...
1
vote
0answers
92 views

Modify CoreResultsWebPart XML data before it is transformed?

I'm extending CoreResultsWebPart. Do I have an opportunity to modify the search results XML before it is transformed (against the XSL)?
1
vote
0answers
297 views

Add Web part automatically when root web has created

I have created web scoped feature and added it to onet.xml of a web template. this feature tries to add a web part to default.aspx file. the problem is when I create a site and feature triggers the ...