0
votes
2answers
17 views

Customize a webpart directly added to pagelayout

I have a page layout with embedded web parts. These web parts are not added in any web part zones. I want to edit properties of the web-part but when I edit the page I cannot see any way of doing it. ...
0
votes
1answer
17 views

Webpart not appearing in site

We have deployed webpart using powershell but cannot find it under the Edit page-> add webpart -> custom, there is no folder called 'custom'. This folder otherwise comes up when deployed via VS. ...
0
votes
1answer
29 views

How to create setup for Sharepoint 2010 web application

I have patch 1 until 3. To do the installation for each solution package may take a long time which is it is needed a long step. So, is there any solution or tools that I can simplify the ...
1
vote
1answer
1k views

Setting “Chrome Type” to “None” for a web part using power shell

I have added a custom web part on page. Some how I am not been able to change its Chrome Type to None because when I mouse over the corner of web part where the arrow is supposed to show under ...
0
votes
2answers
184 views

Upload a Web part to All Site Collections

We have designed a custom Content editor web part and we exported the dwp file and added it in an site collection (Web part gallery ) and the web part is working fine when we add in any sub site in ...
0
votes
2answers
657 views

How to get all the SharePoint web parts that are there inside a page and not inside a web part zone

I need some C# or powershell script where I need to list down all the web parts that are defined inside a page and not inside a web part zone. I tried with GetLimitedWebPartManager, but that API, ...
1
vote
1answer
2k views

SPLimitedWebPartManager throwing “File is not checked out” error on AddWebPart and DeleteWebPart

I'm writing a powershell function to add custom webparts (i.e. not Out Of The Box webparts such as ContentEditor) to publishing pages on a SharePoint Server 2010 site. I encountered a frustrating ...
1
vote
1answer
722 views

Hide a feature in Site Collection Administration => Features area

I have a feature with webparts that needs to be activated using powershell. I need a way to either hide the feature on the Site Collection Administration => Features (under Site Settings) or to ...
4
votes
2answers
3k views

Removing Orphaned WebParts via PowerShell - CheckIn/CheckOut Requirement Loop

A client migrated from 2007 to 2010 doing a database detach/reattach without checking the database for orphaned objects first. I whipped up a PowerShell script to programmatically remove orphaned ...
2
votes
1answer
525 views

Can You Add a WebPart to a Wiki Home Page via Powershell?

Salvete! Is it possible to add a webpart to a Wiki Home Page via Powershell? I have 100 sites for which I need to add a web-part to their home-pages. I know this is easily possible with normal ...
1
vote
1answer
498 views

Add Calendar list to WikiPage using Powershell

I have inserted a Calendar list to a page(SitePages/Home.aspx) using a powershell script, But I want to insert it in to a specific location as shown in image. When I insert the calendar list it insert ...
0
votes
1answer
97 views

How to open or access a webpart's XML and rename its namespace Using PowerShell?

We have some web parts deployed in our Sites, which are not working due to Migration from MOSS to SPS2010, and I need to replace the namespace used by power shell by accessing the Webpart's XML..
2
votes
1answer
629 views

Can't save webpart after editing with PowerShell

I'm using the code below to edit the image in a webpart: $webPartCollection = $web.GetWebPartCollection("default.aspx","Shared") $imagePart = $webPartCollection | Where-Object { $_.Title -eq "Site ...
1
vote
2answers
1k views

This powershell runs but why is it so slow

I ran this powershell which automates wsp addition, activate, deploy web parts and it runs fine. However, it takes about 3 minutes to go through the whole process. Is this norm? = = = powershell code ...
0
votes
0answers
560 views

How to set custom Web Part values through powershell?

I am using a powershell script to initialize several values of a custom webpart and then insert that webpart onto a page. I have been partially successful using the method below: ...
0
votes
1answer
1k views

How to add an instance of a custom webpart to a web page using PowerShell?

I found this article which does a very good job explaining how to add built in web parts (like the content editor webpart). Unfortunately when I tried to add my own I couldn't get it to work. I have ...
1
vote
2answers
644 views

SharePoint 2010 - Find WebPart in WebApplication

I´m searching for an good way to find the ContentQuery WebPart in my WebApplication. My plan is to write a PowerShell script and create a url list. I found the following possible ways: SharePoint ...
2
votes
1answer
1k views

SharePoint 2010 - Add WebPart reference to PowerShell script

I want to add a new developed WebPart to a SharePoint site with PowerShell. How it is possible to add the WebPart reference from my WebPart to the PowerShell script? $web = Get-SPWeb $urlWeb ...
2
votes
4answers
2k views

SharePoint 2010 - Add WebPart to a Web with PowerShell

I want to add a webpart to a great number of existing pages. Is there any PowerShell command to add a webpart to a webpart page?
6
votes
1answer
2k views

Problem installing web part using Powershell

We've developed a custom Visual Web Part using Visual Studio 2010 for Sharepoint 2010 Server. The webpart gets deployed when executed from VS (F5), so we can add it wherever we want using Sharepoint ...
2
votes
3answers
11k views

Install-SPSolution : This solution contains no resources scoped for a Web application and cannot be deployed to a particular Web application

I have a powershell script that deploys about 12 web parts. They have all been created in the manner through visual studio 2010 and are being deployed to sharepoint 2010. I am getting the following ...