1
vote
1answer
49 views

Dependency of feature deployment with List and webpart

We have a project containing a webpart and a list instance (rootwebonly). The webpart and the list instance are activated via a single feature. Now problem is that, everytime a change is requested, ...
0
votes
1answer
17 views

Webpart not appearing in site

We have deployed webpart using powershell but cannot find it under the Edit page-> add webpart -> custom, there is no folder called 'custom'. This folder otherwise comes up when deployed via VS. ...
0
votes
0answers
40 views

Deploying web part to https site

I'm trying to deploy custom Visual Web Part created in Visual Studio 2013 as a farm solution in Sharepoint 2013. The thing is, the site I want to specify for debugging is a https site. After ...
2
votes
1answer
36 views

Migrate Web Part from one environment to another?

SharePoint Foundation 2010. I have added a very basic web part to my development environment. It is honestly just the Visual Web Part template. I would like to export this web part and import to ...
1
vote
1answer
72 views

Converting an ASP.NET application into a SharePoint application, need assistance on doubts and good practice [closed]

we have a ASP.NET simple application with custom functionality that performs certain calculations based on data entered in text box and shows output in a label. We would now like to use it in ...
0
votes
1answer
25 views

Binding documents along with a custom webpart

I have these 2 two word documents which should be added to the web part ( a document library ) as soon as it is deployed. Is there any way to bind documents in a web part (during custom development) ...
1
vote
1answer
230 views

Setting the value of a sandbox web part's custom properties in .webpart file

I've created a new web part in a sandbox solution. This web part has a custom string property called 'PetName'. I'd expect to be able to set the initial value of this property in the .webpart file. ...
0
votes
1answer
88 views

What should be the Content Search Web Part max per page?

I'm currently working on a department site prototype for an Intranet, which is to be packaged up and used to spawn around a dozen sites using the same Web Template. While trying to convert the ...
0
votes
2answers
2k views

Visual Studio WebPart Not Showing Up in SharePoint

I created a simple WebPart in Visual Studio 2010 that I was using to test some functionality for a project. When the WebPart was built and deployed, the messages in the Output box in VS all state ...
0
votes
1answer
197 views

Deploying Aspx in specific subsite

I need to deploy an .aspx from visual studio, to a sharepoint subsite. I can deploy it fine in the layout folder. How can i deploy it in a subsite so that it can be added in the quick link section ? ...
1
vote
2answers
211 views

error when start new project in visual studio 2010

I am a new administrator to a SharePoint farm and I want to start developing *web-part*s for our sites. In our company we have installed SharePoint 2010 on Windows Server 2008 R2. And we have ...
0
votes
1answer
1k views

visual basic in sharepoint 2010

I am new to SharePoint. My head in the office told me that if you want to learn SharePoint, you have to learn ASP.Net first because we need to add webparts to the portal. I installed visual ...
5
votes
3answers
131 views

SharePoint Admin and Developer Roles [closed]

Currently in our organization we have a three man SharePoint development team where we do everything other than SharePoint admin. Our organization has development, test, and production servers. We, ...
0
votes
3answers
875 views

Get deployed .aspx page in feature receiver to add WebPart

I have a SharePoint solution which deploys an aspx page in a custom folder in the Layouts folder. I need to get this page in the Feature Event Receiver so I can add to it a WebPart. In the ...
0
votes
2answers
680 views

How to Deploy the Feature with Scope=Site & Scope=Web for WebParts & EventReceiver respectively?

I have only 1 Visual Studio Project. It contains 1 EventReceiver(for DocumentLibrary) and multiple-WebParts. I have defined the Scope=Site of Feature.xml file of Project. I have created 1 custom ...
1
vote
2answers
2k views

Deploying web part from Visual Studio?

I exported a Core Search Results Web Part and created a new Visual Web Part in a Visual Studio project. I have added some code to the .cs page and the code for my exported webpart to the .webpart file ...
4
votes
3answers
3k views

How to deploy web part solution to multi-server farm?

I am having a heck of a time deploying a simple web part to a multi-server farm. The error I receive when deploying is: Error occurred in deployment step 'Activate Features': Feature with Id ...
1
vote
2answers
226 views

Web Part Module Itens error 404

We have a WebPart that has a module with resources (images, css and js files). Locally it works perfectly when deploying from VisualStudio. In a testing server we're deploying the webpart via ...
2
votes
1answer
388 views

Is it possible to update .Webpart file and reflect the change on all uses of a webpart

I have a webpart that is a modified XSLT list view webpart in SharePoint 2010. I exported the webpart as a file and uploaded it to the webpart gallery manually. If the user adds this webpart to ...
2
votes
3answers
4k views

How do you create webpart-specific config files?

How do you create application specific config files for a GAC-deployed webpart in SharePoint 2010? Which one or more of app.config/web.config/supplemental config are appropriate to use for webparts? ...
1
vote
2answers
2k views

How do I deploy custom web part to Sharepoint Online Site Collection?

After uploading the wsp to the site collection using the browser and activating it, everything seems to work fine and i see all the page layouts, masterpage, content types, lists and webparts. BUT, ...
2
votes
2answers
2k views

Can’t add deployed web part to SharePoint (web part missing)

I’m trying to add my first web part to the working environment and have some problems with the deployment. I clicked on my development machine release and copy the *.wsp file from the "bin/release" ...
0
votes
0answers
122 views

Updated SharePoint Solution not recongnized

I've modified a minor bug in a User Control of a custom SharePoint solution that was initially deployed on SharePoint 2007 but now it is deployed on SharePoint 2010. I was hoping to just update the ...
1
vote
0answers
136 views

Deploy Sharepoint Dashboad page and KPI List to other site

I have a report library in Sharepoint site where i have several dashboard pages. Each of these dashboard pages have kpi and excel web acess web parts in them (only out of box no custom web parts). A ...
1
vote
0answers
1k views

File not found on WebPart Deployment

I followed the Instructions on msdn and also this one here but unfortunatley nothing seems to work. I've built a custom webpart and packaged it into a .wsp file since i'm trying to import this ...
0
votes
1answer
214 views

how to use SharePoint 2010 web-part - after deployed?

i execute this command on power shell Add-SPSolution C:\Deployment\MyFristWebPart.wsp after execute i get this result: Name SolutionId Deployed ...
0
votes
1answer
2k views

how to deploy custom webpart from one server to another (sharepoint 2010)

Update1: PS C:\> Add-SPSolution c:\Deployment\MyFirstWebPart.wsp Install -SPSolution -Identity NameOfWSP -WebApplication http://sp2010 -GACDeployment Add-SPSolution : A positional parameter cannot ...
1
vote
3answers
8k views

How to deploy webpart on production (not debugging) server?

I've created a web part, debugging it on a test Sharepoint 2010 install on my local workstation. I'd like to test it on our production server. It seems that I won't be able to use Build --> Deploy to ...
6
votes
4answers
5k views

Sandboxed web part failing with “No available sandboxed code execution server could be found”

I'm deploying a web part as a component of a sandboxed solution from Visual Studio 2010 to Windows 7 SharePoint Foundation Server 2010 on my development box, and I receive the following error when ...
0
votes
1answer
207 views

unable to deployWSPBuilder visual webpart in sharepoint 2010

i have created simple webpart in visual studio 2010 with the WSPBuilder Template (restricted to use this template. can not use the sharepoint tooling). I have added the Visual Webpart type. i found a ...
0
votes
1answer
219 views

Sharepoint 2010 deployment one way whats the best way to get external data back in

As sharepoint 2010 can not deploy back to the source what could be the best method of getting data back into the source site collection? eg lets say a webpart asks a user some questions, which needs ...
9
votes
6answers
3k views

How do I deploy the new version of a webpart?

As stated here (and as i checked), to upload a new version of an installed webpart, uninstalling the assembly from the GAC and installing the new version would suffice. I've tried it and it worked. ...
6
votes
1answer
2k views

Problem installing web part using Powershell

We've developed a custom Visual Web Part using Visual Studio 2010 for Sharepoint 2010 Server. The webpart gets deployed when executed from VS (F5), so we can add it wherever we want using Sharepoint ...
5
votes
4answers
10k views

Custom web part deployment produces 'Cannot import this webpart' error

I have built an empty SharePoint project in Visual Studio 2010 with some custom web parts in it. When I've tested these on my local development machine they can be added to a page without any trouble. ...
17
votes
5answers
1k views

Organizing WebParts in Visual Studio - Best Practices

My team is responsible for maintaining a SharePoint 2010 site that was developed by another group. This maintenance includes updates to existing web parts (approximately 20). Currently, all of these ...
0
votes
1answer
588 views

Office Web Components 11 in SP2010

Can somebody confirm me is it possible to use owc 11 in SharePoint 2010?! I use owc chart control, and in my other project(asp.net web app) I can use owc without problems. In SP 2010 I can build and ...
1
vote
1answer
915 views

Deploying WSP from saved as template - editing binary serialized web part in Visual Studio

I have deployed a WSP site template that originally came from "Save Site as Template" (our site was customized from a team site - STS#0). Now, we're making changes to it in in Visual Studio (as it's ...
1
vote
1answer
468 views

2010: Problem trying to install web part using power shell

I'm trying to deploy my first web part on 2010. I developed a web part using VS2008 and tested it on SP2007. I copied the CAB to the 2010 server and tried to use PowerShell to install it and got the ...
0
votes
2answers
307 views

SharePoint 2010 Web part Deployment Error

When I deploy my web part locally everything is fine. The web part is registered as safe, and is completely usable. When I deploy the wsp to another server the web part comes back with the following ...
0
votes
1answer
601 views

how to nest a visual webpart inside another?

I just wanna insert a visual webpart inside another, I'm using this tag to register the inserted web part like this: <%@ Register Src="~/PL/VisualWebPart1/VisualWebPart1UserControl.ascx" ...
2
votes
2answers
1k views

“A Web Part or Web Form Control on this Page cannot be displayed or imported. The type could not be found or it is not registered as safe.”

I have deployed a webpart to my MOSS 2007 environment and have the following error: "A Web Part or Web Form Control on this Page cannot be displayed or imported. The type could not be found or it ...
2
votes
2answers
676 views

Deploy a visual web part developed with VS2010 to SharePoint 2007

I developed a simple webpart using the Visual Web Part template in Visual Studio 2010 and have been testing it within SharePoint 2010. I want to know if this web part could be deployed to SharePoint ...
0
votes
1answer
1k views

WebPart not registered as safe

I have a webpart that is part of a larger solution, deployed as a WSP using WSPBuilder. I can see the SafeControl entry in the web.config and can see that the assembly has deployed to the GAC. The ...
3
votes
3answers
1k views

problem deploying webpart on a farm

a customer has a problem deploying a webpart I developed for them on a farm. The webpart is packaged as a .WSP solution with WSPBuilder and it seems to work fine when deployed to a single server. ...