1
vote
2answers
73 views

Automated deployment and environment-specific configuration

We are using TeamCity and Octopus Deploy to perform CI/CD with the custom WSP's that we use for SharePoint, and I'm currently trying to solve the problem of how to handle environment-specific ...
0
votes
1answer
60 views

Web.config was wiped out by Visual Studio

Upon trying to edit our web.config file on our SharePoint 2010 Enterprise server via "wss\VirtualDirectories\80", Visual Studio started up to load the file for editing and then threw an error, ...
1
vote
3answers
456 views

applicationSettings ignored in web.config

I've written a feature assembly that includes an SPFeatureReceiver. I can successfully deploy the feature's WSP, the assembly goes to the GAC, and the feature (mostly) does what it's supposed to. ...
2
votes
3answers
1k views

Accessing connection string in custom job

I have configured connection string in my IIS since I'm reusing it through my sharepoint solutions and custom services running next to sharepoint sites. I'm using following snippet throughout my ...
1
vote
1answer
326 views

Custom settings file

Is is possible to use a custom settings file in SharePoint? Where do I place the .config file, containing the settings - I can only get it to read the default values defined in .settings file. ...
1
vote
2answers
362 views

Is it possible to unextend a web application from a specific WFE?

I have a scenario that I can't seem to find a good solution to. I have two servers in my SharePoint farm, one of them is the legitimate web front end that external users connect to, the other is not ...