In SharePoint, a web application is a site in IIS. It is where an administrator defines what the root URL of the site will be, type of authentication that will be used, and other site-wide settings.

learn more… | top users | synonyms

1
vote
0answers
71 views

How to create simple OAuth / REST application for hosted sharepoint? [closed]

We are looking for information on how to create very simple REST application for sharepoint hosted by Microsoft (Office 365) which uses OAuth. Basically, we are just started investigating this and we ...
0
votes
1answer
100 views

Sharepoint not sending mail using alternate access mapping path

I am using load balancer (WFE1 + WFE2) and my web application is configured as http://server which I defined in host header. I have also added AAM http://realsite. So when a user types AAM in URL then ...
0
votes
1answer
48 views

Creating two web applications under different host headers

I am reading a material about SharePoint 2013; “2013 A Core Solutions of Microsoft® SharePoint® Server 2013”. And on one of the examples they want to create two web applications representing two ...
1
vote
1answer
169 views

IIS 8 error page?

Just created a new (and the first) web application for a new SharePoint environment. When I try to access the main address it takes me to what appears to be an IIS 8 error page. The strange thing ...
0
votes
1answer
3k views

How do you move or remove the App Catalog site from a web app?

I created an App Catalog site under the root of my web app (/), and I would like to move it to another path (e.g. /sites/appcatalog). Does anyone know how to remove an existing App Catalog site, or ...
2
votes
1answer
435 views

SharePoint creating web application on APP instead of WFE

I have one APP and one WFE server. Microsoft SharePoint Foundation Web Application service is stopped on APP but is running on WFE. When I go to CA to create a new Web Application, in the URL ...
1
vote
1answer
90 views

Stuck in Sharepoint. How do I grow as a web developer when I'm stuck in Sharepoint?

I apologize if this is out of scope but I've seen other career type questions. I can't just switch jobs because the only reason I'm a quasi developer in the first place is because my company let me ...
2
votes
3answers
1k views

Two different versions of RSViewerPage.aspx on same farm?

I have a SharePoint 2013 farm with SSRS. On this farm, I have two web-apps (A and B). When we created web-app "A", we made some branding customizations to the RSViewerPage.aspx page. The problem is ...
1
vote
3answers
644 views

SharePoint2010 - install WFE & App Servers

My question is probably very stupid, but .... I have installed 2 servers with SharePoint 2010, i have created one web application. My question is: how to know if my server is a WFE or an application ...
1
vote
0answers
331 views

Timeout while creating applications from Central Admin

For the last few days I have been unable to create a new application through central administration. The creation times out. I have searched high and low through the internet. Every other site says ...
0
votes
0answers
615 views

page cannot be displayed for newly created web sites

I just installed SP 2013 on a brand new VM with Server 2012 and Sql Server 2012. After running SharePoint product configuration wizard, I created a new web application on machineName and a root site ...
3
votes
2answers
652 views

Creating My Site web application destroys application running on port 80

This is happening for the past 2 days. I have a web application running on port 80. When I create a new web application for My Site on port 8080, my port 80 web app stops working and shows "500 ...
1
vote
1answer
690 views

Implementing SSL for SharePoint High trust Apps

I have been struggling to configure an SSL Certificate based environment for hight trust apps in SharePoint 2013. I have on-premises installation of SharePoint 2013 (Enterprise). Following google and ...
0
votes
2answers
711 views

Creating a WebApp via PowerShell is mapping the site to wrong AppPool

I have a weird issue with creating WebApps using the below script. Seemingly when I create my WebApp everything is working and looking fine. I can look in IIS and see that it is correctly configured, ...
1
vote
0answers
31 views

Web App only allows workflow creation on one server in farm, all others fail

I have a 3 tier farm, with a clusterd db, 2 app servers and 4 WFE. The WFE are being load balanced on a netscaler. We have 3 web apps deployed to the farm. We are able to create workflows fine on ...
1
vote
1answer
106 views

Is it normal that web application URL is always of app server rather than WFE?

I have 1 App server and 2 WFEs. Web Application service is stopped on App server while it is started on WFEs. I created a new web application and I noticed the URL is of App server for e.g. ...
0
votes
0answers
187 views

Top Level Site page not found

I'm trying to make a site collection. When I create one and give it a host header, the URL for the top site it gives me after creating the site collection never works. When I visit the URL, it says ...
0
votes
1answer
309 views

How to remove port 80 from the application URL

i want to create a new web application on port 80. but i need to allow the user to login to this web application without typing the port number. currently under the administration section i have the ...
0
votes
1answer
61 views

New wen appliction button is disabled for a farm user

i am uisng SP 2013, but when i login to the central admin suing a farm user ,, the new web application button was disabled.. can anyone advice what is causing this ?/
0
votes
1answer
389 views

Create a Web Application using Powershell

I want to create a web application using powershell. Below is a list of commands I execute to achieve this and all works fine. Web application exists everywhere. But I cannot access it by it's url. I ...
0
votes
2answers
375 views

HTTP Error 503. “The service is unavailable.”

One of my Web Applications shows error: HTTP Error 503. The service is unavailable I checked in IIS Application pool and started the respective services but the error still persist How can I ...
0
votes
2answers
2k views

SharePoint 2010 --> New Web Application --> New Site Collection: IE can't display it

Morning all, Here's my scenario: - I've made a new web application within SharePoint 2010 via the GUI. This went ahead with no problems. From here, I've created the root site, which also reported ...
0
votes
2answers
2k views

Programmatically checking if a site collection already exists before creating a new one.

I have created a visual webpart that creates site collections programmatically. It works through SelfServiceCreateSite and does its job flawlessly but for one thing. I need to check if the site ...
1
vote
1answer
273 views

Execute URL File in Sharepoint (Mime Type?)

I have unblocked the ".URL" file extension in SharePoint that allows them to upload a link/shortcut, however SharePoint's strict Browser File Handling seemingly won't render the file - but requires ...
4
votes
3answers
2k views

Is one Web Application Architecture preferred over several Web Applications?

In almost all of the SharePoint projects I’ve participated in, the general architecture is three different web applications for intranet, cooperation and mysite. This has been the standard setup in ...
0
votes
1answer
120 views

using host headers with sharepoint

I need to make a development machine, so I have made a web application on port 80, gave it host header: google.sharepoint.com, I just wanted to play with names and see how it will be, so I added a ...
2
votes
2answers
3k views

How to get all the web application of SharePoint.

How do I get url of all the web application created in SharePoint 2010 with client object model using C#.
0
votes
0answers
154 views

Just set up Item Level Auditing in SP2010, can see months of audit data

I'm fairly new to SharePoint administration... Up until this point, I've been mostly a front-end guy (custom lists, dashboards, all that jazz) and while I've had occasion to go into Central Admin or ...
1
vote
1answer
150 views

Deploying a VS SharePoint solution to the “Web Application”

When deploying a VS SharePoint solution to the "Web Application", where does the actual assembly go? I mistakenly switched the Assembly Deployment Target of several of my projects to "Web ...
0
votes
1answer
53 views

New Web Application only works using default settings

I've been trying to create a web application and site collection using intranet.contoso.com. However after the webapp and site collections have been successfully created, the site won't display. I've ...
0
votes
3answers
4k views

Can't display new site collection

I'm going through the steps to create a site collection but after I created it, I can't access it via "intranet.contoso.com". I keep getting the error "Internet Explorer cannot display the webpage". ...
2
votes
1answer
3k views

Remove-SPWebApplication not working if SPAdminV4 service is run by Local System?

I have sucessfully removed my Web Application with the following script: PS C:\Users\SP2013Farm> Remove-SPWebApplication http://portal.com -Confirm -Dele teIISSite -RemoveContentDatabases Confirm ...
0
votes
1answer
29 views

Webpart display in all web application

I have created webpart and deploy it on web application level. It is displaying in all web application. How can i restrict to display on specific site. Regards,
1
vote
1answer
325 views

SharePoint Site App Pools restarting outside of scheduled time

in our production environment (we are running SP 2010 Enterprise) I have noticed that we are starting to see the App Pool for the main SharePoint Web Application restart during the day. These are ...
2
votes
1answer
540 views

Accessing data from another web application throws an SQLInvalidException

The scenario is: A MySiteHost site collection (example name: MY SITE). Web application's application pool account is spmysite. A TeamSite site collection (example name: TEAM SITE). Web application's ...
0
votes
2answers
344 views

403 Forbidden error on creation of new webapplication in SP2010

I am getting an error 403 forbidden on creating new weapplication or extending web application although I have signed in as System Account. I am able to create new sitecollection from central admin. ...
0
votes
2answers
1k views

Sharepoint Web analytics configuration wrong web application

I've tried to configure Sharepoint web analytics on the web application on my development machine but without success. I've followed various guides on the internet including runing some timer jobs and ...
1
vote
1answer
976 views

Programmatically get port 80 Web Application Default URL for Farm?

How would I programmatically get the port 80 Web Application Default URL for the Farm?
1
vote
2answers
2k views

How to remove the Central Admin web app?

How to remove the Central Admin web app from IIS? I am using SharePoint 2010 on Windows Server 2012. I know I can remove an app with the SharePoint 2010 Management Shell by issuing: ...
1
vote
1answer
742 views

Application pool not visible in IIS, SharePoint or PowerShell

I have a PowerShell script that creates a web application using New-SPWebApplication. It crashed for some reason a while back and now it keeps telling me the application pool exists. I've looked in ...
0
votes
2answers
689 views

Root Site on New Web Application Can't be browsed to

Testing box is SharePoint 2010 Standard, single box install, local SQL. Default Web Application works fine. I've created a new web app, create a root site collection for it and no joy. I've tried / ...
0
votes
1answer
26 views

SP2010 Default Application not available after new Web Application was made / deleted

I have a SharePoint 2010 test environment was working perfectly with it's default Web Application and root site. This is a single server install, with its own local copy of SQL. I've made and ...
4
votes
1answer
655 views

Enumerate every solution for each WebApplication

I'm performing an inventory and I need to get list of sharepoint solutions (*.wsp) deployed to every individual web-application and ideally, it would also be great to list what Application pool on ...
0
votes
2answers
749 views

How to place My Sites inside another site's URL but still keep them logically isolated?

I'm setting up SharePoint 2013 as a company intranet site, and we want to implement My Sites; I know the best practices call for placing them in their own web application and content DB, but we'd ...
0
votes
0answers
326 views

Web Page Security Validation (Taxonomy AJAX Bug vs Silverlight Bug)

The situation began like this: We upgraded our SharePoint 2010 (using the Project Server 2010 February 2013 Cumulative Update) We found a bug where on the 'Project Page' layout the 'Managed ...
0
votes
1answer
296 views

Creating SPSiteCollection, top level site programmatically

I have been given a task to create an event that dynamically creates new site collections on our sharepoint webApp. Thing is using Central Admin I can create "http://testsite.com/sites/newSite_1" and ...
2
votes
1answer
1k views

App issue with SharePoint 2013 Developer Site

In SharePoint 2013 Developer Site: I am installing an app to my site and it worked fine with default stuff. I added some custom .js file in this app which will set the master page of site coll and ...
0
votes
1answer
52 views

Authentication problem in SP web application 2010

I have created a web application and then site collection by using my custom template site definition. Its created successfully. But when I access my application I get authentication dialog box for ...
0
votes
2answers
11k views

Web Application/Site collection can't displaying Problem

I created a new web application. I try to restore a site collection from a backup. It finished succesfully but when I type the url This page can't be displayed occurs. I think the problem is about ...
0
votes
1answer
92 views

how to install app in sharepoint 2013 Publishing site?

I am trying to create one App for sharepoint 2013 publishing site. I can not see Apps catalog from where I can upload an app to the publishing site. On the other hand, if I see in developer site, I ...