In SharePoint, a web application is a site in IIS. It is where an administrator defines what the root URL of the site will be, type of authentication that will be used, and other site-wide settings.

learn more… | top users | synonyms

1
vote
0answers
23 views

SharePoint web application port numbers

Can we create SharePoint web application on any port numbers or we have to be careful about some port numbers?
0
votes
1answer
44 views

How to connect to another web application

I have a SP 2013 web application. In this site have a custom list. (Ex: site: http://site1:1111, list name is "AAA") I want to write a Common Library project c#, this project can get data from ...
0
votes
1answer
297 views

How to duplicate Web Application with its site collection?

SharePoint 2013 has Web Application with port 2323 I want to know how to duplication this Web Application with its site collection for port 80 as example.
0
votes
1answer
1k views

Export subsite and Import in another web app (means another db)

I have one web application with site collections. Then I have a subsite inside. I want to export this subsite (and only this one), and import it in a new web app I will create. Question is : Is this ...
0
votes
1answer
25 views

How to add application account access to SharePoint site?

I have an application that ingests scan data files that are manually fed. I would like to grant it access to our SharePoint site so it can pull the data automatically from a Document Library. What do ...
1
vote
1answer
415 views

Using a temporary DNS/host header for SharePoint 2013

I built a new SP farm using intranet.domain.com for the host name and public URL of the main web app. We are migrating from 2007 to 2013. Unfortunately, intranet.domain.com is currently tied to our SP ...
1
vote
3answers
2k views

Not able to create a web application and site collection in SharePoint 2013

I am not able to create a site collection or web application from Central Administration in SharePoint 2013. It gives me server error. One month back I was able to create but now I am unable to create ...
1
vote
1answer
43 views

Extending Claims Application - Cannot View Afterwards

I am trying to extend a claims based application (which uses a custom token provider) to enable SharePoint Search on SharePoint Foundation 2010. After I extend the application to use windows login I ...
2
votes
3answers
643 views

How to find the creation date of the Web Application?

I wanted to find how the count of the web application in the farm increases in the past year. For this I wanted to find out the date when each web application is created. Is there anyway to find the ...
1
vote
1answer
203 views

IIS Applications created on App servers and WFE Servers

I am running SharePoint Foundation 2010. In my testing environment I've got 1 app server and 1 WFE. When I create a new web application, it is creating entries in both the APP and WFE IIS. Is this ...
0
votes
1answer
835 views

Single web application or mulitple?

I am very new compare to experts here. I have read several articles and discuss forums. However I am worry there are some potential risk I cannot foresee. Could you give me some suggestion on the wb ...
1
vote
0answers
75 views

How to create simple OAuth / REST application for hosted sharepoint? [closed]

We are looking for information on how to create very simple REST application for sharepoint hosted by Microsoft (Office 365) which uses OAuth. Basically, we are just started investigating this and we ...
0
votes
1answer
104 views

Sharepoint not sending mail using alternate access mapping path

I am using load balancer (WFE1 + WFE2) and my web application is configured as http://server which I defined in host header. I have also added AAM http://realsite. So when a user types AAM in URL then ...
0
votes
1answer
49 views

Creating two web applications under different host headers

I am reading a material about SharePoint 2013; “2013 A Core Solutions of Microsoft® SharePoint® Server 2013”. And on one of the examples they want to create two web applications representing two ...
1
vote
1answer
181 views

IIS 8 error page?

Just created a new (and the first) web application for a new SharePoint environment. When I try to access the main address it takes me to what appears to be an IIS 8 error page. The strange thing ...
0
votes
1answer
3k views

How do you move or remove the App Catalog site from a web app?

I created an App Catalog site under the root of my web app (/), and I would like to move it to another path (e.g. /sites/appcatalog). Does anyone know how to remove an existing App Catalog site, or ...
2
votes
1answer
469 views

SharePoint creating web application on APP instead of WFE

I have one APP and one WFE server. Microsoft SharePoint Foundation Web Application service is stopped on APP but is running on WFE. When I go to CA to create a new Web Application, in the URL ...
1
vote
1answer
91 views

Stuck in Sharepoint. How do I grow as a web developer when I'm stuck in Sharepoint?

I apologize if this is out of scope but I've seen other career type questions. I can't just switch jobs because the only reason I'm a quasi developer in the first place is because my company let me ...
2
votes
3answers
1k views

Two different versions of RSViewerPage.aspx on same farm?

I have a SharePoint 2013 farm with SSRS. On this farm, I have two web-apps (A and B). When we created web-app "A", we made some branding customizations to the RSViewerPage.aspx page. The problem is ...
1
vote
3answers
689 views

SharePoint2010 - install WFE & App Servers

My question is probably very stupid, but .... I have installed 2 servers with SharePoint 2010, i have created one web application. My question is: how to know if my server is a WFE or an application ...
1
vote
0answers
360 views

Timeout while creating applications from Central Admin

For the last few days I have been unable to create a new application through central administration. The creation times out. I have searched high and low through the internet. Every other site says ...
0
votes
0answers
634 views

page cannot be displayed for newly created web sites

I just installed SP 2013 on a brand new VM with Server 2012 and Sql Server 2012. After running SharePoint product configuration wizard, I created a new web application on machineName and a root site ...
3
votes
2answers
704 views

Creating My Site web application destroys application running on port 80

This is happening for the past 2 days. I have a web application running on port 80. When I create a new web application for My Site on port 8080, my port 80 web app stops working and shows "500 ...
1
vote
1answer
719 views

Implementing SSL for SharePoint High trust Apps

I have been struggling to configure an SSL Certificate based environment for hight trust apps in SharePoint 2013. I have on-premises installation of SharePoint 2013 (Enterprise). Following google and ...
0
votes
2answers
803 views

Creating a WebApp via PowerShell is mapping the site to wrong AppPool

I have a weird issue with creating WebApps using the below script. Seemingly when I create my WebApp everything is working and looking fine. I can look in IIS and see that it is correctly configured, ...
1
vote
0answers
32 views

Web App only allows workflow creation on one server in farm, all others fail

I have a 3 tier farm, with a clusterd db, 2 app servers and 4 WFE. The WFE are being load balanced on a netscaler. We have 3 web apps deployed to the farm. We are able to create workflows fine on ...
1
vote
1answer
107 views

Is it normal that web application URL is always of app server rather than WFE?

I have 1 App server and 2 WFEs. Web Application service is stopped on App server while it is started on WFEs. I created a new web application and I noticed the URL is of App server for e.g. ...
0
votes
0answers
192 views

Top Level Site page not found

I'm trying to make a site collection. When I create one and give it a host header, the URL for the top site it gives me after creating the site collection never works. When I visit the URL, it says ...
0
votes
1answer
349 views

How to remove port 80 from the application URL

i want to create a new web application on port 80. but i need to allow the user to login to this web application without typing the port number. currently under the administration section i have the ...
0
votes
1answer
61 views

New wen appliction button is disabled for a farm user

i am uisng SP 2013, but when i login to the central admin suing a farm user ,, the new web application button was disabled.. can anyone advice what is causing this ?/
0
votes
1answer
431 views

Create a Web Application using Powershell

I want to create a web application using powershell. Below is a list of commands I execute to achieve this and all works fine. Web application exists everywhere. But I cannot access it by it's url. I ...
0
votes
2answers
407 views

HTTP Error 503. “The service is unavailable.”

One of my Web Applications shows error: HTTP Error 503. The service is unavailable I checked in IIS Application pool and started the respective services but the error still persist How can I ...
0
votes
2answers
2k views

SharePoint 2010 --> New Web Application --> New Site Collection: IE can't display it

Morning all, Here's my scenario: - I've made a new web application within SharePoint 2010 via the GUI. This went ahead with no problems. From here, I've created the root site, which also reported ...
0
votes
2answers
2k views

Programmatically checking if a site collection already exists before creating a new one.

I have created a visual webpart that creates site collections programmatically. It works through SelfServiceCreateSite and does its job flawlessly but for one thing. I need to check if the site ...
1
vote
1answer
295 views

Execute URL File in Sharepoint (Mime Type?)

I have unblocked the ".URL" file extension in SharePoint that allows them to upload a link/shortcut, however SharePoint's strict Browser File Handling seemingly won't render the file - but requires ...
4
votes
3answers
2k views

Is one Web Application Architecture preferred over several Web Applications?

In almost all of the SharePoint projects I’ve participated in, the general architecture is three different web applications for intranet, cooperation and mysite. This has been the standard setup in ...
0
votes
1answer
123 views

using host headers with sharepoint

I need to make a development machine, so I have made a web application on port 80, gave it host header: google.sharepoint.com, I just wanted to play with names and see how it will be, so I added a ...
2
votes
2answers
3k views

How to get all the web application of SharePoint.

How do I get url of all the web application created in SharePoint 2010 with client object model using C#.
0
votes
0answers
158 views

Just set up Item Level Auditing in SP2010, can see months of audit data

I'm fairly new to SharePoint administration... Up until this point, I've been mostly a front-end guy (custom lists, dashboards, all that jazz) and while I've had occasion to go into Central Admin or ...
1
vote
1answer
169 views

Deploying a VS SharePoint solution to the “Web Application”

When deploying a VS SharePoint solution to the "Web Application", where does the actual assembly go? I mistakenly switched the Assembly Deployment Target of several of my projects to "Web ...
0
votes
1answer
55 views

New Web Application only works using default settings

I've been trying to create a web application and site collection using intranet.contoso.com. However after the webapp and site collections have been successfully created, the site won't display. I've ...
0
votes
3answers
5k views

Can't display new site collection

I'm going through the steps to create a site collection but after I created it, I can't access it via "intranet.contoso.com". I keep getting the error "Internet Explorer cannot display the webpage". ...
2
votes
1answer
3k views

Remove-SPWebApplication not working if SPAdminV4 service is run by Local System?

I have sucessfully removed my Web Application with the following script: PS C:\Users\SP2013Farm> Remove-SPWebApplication http://portal.com -Confirm -Dele teIISSite -RemoveContentDatabases Confirm ...
0
votes
1answer
31 views

Webpart display in all web application

I have created webpart and deploy it on web application level. It is displaying in all web application. How can i restrict to display on specific site. Regards,
1
vote
1answer
333 views

SharePoint Site App Pools restarting outside of scheduled time

in our production environment (we are running SP 2010 Enterprise) I have noticed that we are starting to see the App Pool for the main SharePoint Web Application restart during the day. These are ...
2
votes
1answer
608 views

Accessing data from another web application throws an SQLInvalidException

The scenario is: A MySiteHost site collection (example name: MY SITE). Web application's application pool account is spmysite. A TeamSite site collection (example name: TEAM SITE). Web application's ...
0
votes
2answers
353 views

403 Forbidden error on creation of new webapplication in SP2010

I am getting an error 403 forbidden on creating new weapplication or extending web application although I have signed in as System Account. I am able to create new sitecollection from central admin. ...
0
votes
2answers
1k views

Sharepoint Web analytics configuration wrong web application

I've tried to configure Sharepoint web analytics on the web application on my development machine but without success. I've followed various guides on the internet including runing some timer jobs and ...
1
vote
1answer
999 views

Programmatically get port 80 Web Application Default URL for Farm?

How would I programmatically get the port 80 Web Application Default URL for the Farm?
1
vote
2answers
2k views

How to remove the Central Admin web app?

How to remove the Central Admin web app from IIS? I am using SharePoint 2010 on Windows Server 2012. I know I can remove an app with the SharePoint 2010 Management Shell by issuing: ...