Tagged Questions

In SharePoint, a web application is a site in IIS. It is where an administrator defines what the root URL of the site will be, type of authentication that will be used, and other site-wide settings.

learn more… | top users | synonyms

1
vote
1answer
86 views

Is it normal that web application URL is always of app server rather than WFE?

I have 1 App server and 2 WFEs. Web Application service is stopped on App server while it is started on WFEs. I created a new web application and I noticed the URL is of App server for e.g. ...
0
votes
0answers
103 views

Top Level Site page not found

I'm trying to make a site collection. When I create one and give it a host header, the URL for the top site it gives me after creating the site collection never works. When I visit the URL, it says ...
0
votes
1answer
178 views

How to remove port 80 from the application URL

i want to create a new web application on port 80. but i need to allow the user to login to this web application without typing the port number. currently under the administration section i have the ...
0
votes
1answer
58 views

New wen appliction button is disabled for a farm user

i am uisng SP 2013, but when i login to the central admin suing a farm user ,, the new web application button was disabled.. can anyone advice what is causing this ?/
0
votes
1answer
176 views

Create a Web Application using Powershell

I want to create a web application using powershell. Below is a list of commands I execute to achieve this and all works fine. Web application exists everywhere. But I cannot access it by it's url. I ...
0
votes
2answers
225 views

HTTP Error 503. “The service is unavailable.”

One of my Web Applications shows error: HTTP Error 503. The service is unavailable I checked in IIS Application pool and started the respective services but the error still persist How can I ...
0
votes
2answers
1k views

SharePoint 2010 --> New Web Application --> New Site Collection: IE can't display it

Morning all, Here's my scenario: - I've made a new web application within SharePoint 2010 via the GUI. This went ahead with no problems. From here, I've created the root site, which also reported ...
0
votes
2answers
1k views

Programmatically checking if a site collection already exists before creating a new one.

I have created a visual webpart that creates site collections programmatically. It works through SelfServiceCreateSite and does its job flawlessly but for one thing. I need to check if the site ...
1
vote
1answer
153 views

Execute URL File in Sharepoint (Mime Type?)

I have unblocked the ".URL" file extension in SharePoint that allows them to upload a link/shortcut, however SharePoint's strict Browser File Handling seemingly won't render the file - but requires ...
3
votes
3answers
962 views

Is one Web Application Architecture preferred over several Web Applications?

In almost all of the SharePoint projects I’ve participated in, the general architecture is three different web applications for intranet, cooperation and mysite. This has been the standard setup in ...
0
votes
1answer
82 views

using host headers with sharepoint

I need to make a development machine, so I have made a web application on port 80, gave it host header: google.sharepoint.com, I just wanted to play with names and see how it will be, so I added a ...
2
votes
2answers
2k views

How to get all the web application of SharePoint.

How do I get url of all the web application created in SharePoint 2010 with client object model using C#.
0
votes
0answers
108 views

Just set up Item Level Auditing in SP2010, can see months of audit data

I'm fairly new to SharePoint administration... Up until this point, I've been mostly a front-end guy (custom lists, dashboards, all that jazz) and while I've had occasion to go into Central Admin or ...
1
vote
1answer
68 views

Deploying a VS SharePoint solution to the “Web Application”

When deploying a VS SharePoint solution to the "Web Application", where does the actual assembly go? I mistakenly switched the Assembly Deployment Target of several of my projects to "Web ...
0
votes
1answer
38 views

New Web Application only works using default settings

I've been trying to create a web application and site collection using intranet.contoso.com. However after the webapp and site collections have been successfully created, the site won't display. I've ...
0
votes
3answers
2k views

Can't display new site collection

I'm going through the steps to create a site collection but after I created it, I can't access it via "intranet.contoso.com". I keep getting the error "Internet Explorer cannot display the webpage". ...
2
votes
1answer
1k views

Remove-SPWebApplication not working if SPAdminV4 service is run by Local System?

I have sucessfully removed my Web Application with the following script: PS C:\Users\SP2013Farm> Remove-SPWebApplication http://portal.com -Confirm -Dele teIISSite -RemoveContentDatabases Confirm ...
0
votes
1answer
28 views

Webpart display in all web application

I have created webpart and deploy it on web application level. It is displaying in all web application. How can i restrict to display on specific site. Regards,
1
vote
1answer
219 views

SharePoint Site App Pools restarting outside of scheduled time

in our production environment (we are running SP 2010 Enterprise) I have noticed that we are starting to see the App Pool for the main SharePoint Web Application restart during the day. These are ...
2
votes
1answer
246 views

Accessing data from another web application throws an SQLInvalidException

The scenario is: A MySiteHost site collection (example name: MY SITE). Web application's application pool account is spmysite. A TeamSite site collection (example name: TEAM SITE). Web application's ...
0
votes
2answers
197 views

403 Forbidden error on creation of new webapplication in SP2010

I am getting an error 403 forbidden on creating new weapplication or extending web application although I have signed in as System Account. I am able to create new sitecollection from central admin. ...
0
votes
2answers
930 views

Sharepoint Web analytics configuration wrong web application

I've tried to configure Sharepoint web analytics on the web application on my development machine but without success. I've followed various guides on the internet including runing some timer jobs and ...
1
vote
1answer
740 views

Programmatically get port 80 Web Application Default URL for Farm?

How would I programmatically get the port 80 Web Application Default URL for the Farm?
1
vote
2answers
755 views

How to remove the Central Admin web app?

How to remove the Central Admin web app from IIS? I am using SharePoint 2010 on Windows Server 2012. I know I can remove an app with the SharePoint 2010 Management Shell by issuing: ...
1
vote
1answer
419 views

Application pool not visible in IIS, SharePoint or PowerShell

I have a PowerShell script that creates a web application using New-SPWebApplication. It crashed for some reason a while back and now it keeps telling me the application pool exists. I've looked in ...
0
votes
2answers
394 views

Root Site on New Web Application Can't be browsed to

Testing box is SharePoint 2010 Standard, single box install, local SQL. Default Web Application works fine. I've created a new web app, create a root site collection for it and no joy. I've tried / ...
0
votes
1answer
25 views

SP2010 Default Application not available after new Web Application was made / deleted

I have a SharePoint 2010 test environment was working perfectly with it's default Web Application and root site. This is a single server install, with its own local copy of SQL. I've made and ...
4
votes
1answer
300 views

Enumerate every solution for each WebApplication

I'm performing an inventory and I need to get list of sharepoint solutions (*.wsp) deployed to every individual web-application and ideally, it would also be great to list what Application pool on ...
0
votes
1answer
527 views

How to place My Sites inside another site's URL but still keep them logically isolated?

I'm setting up SharePoint 2013 as a company intranet site, and we want to implement My Sites; I know the best practices call for placing them in their own web application and content DB, but we'd ...
0
votes
0answers
238 views

Web Page Security Validation (Taxonomy AJAX Bug vs Silverlight Bug)

The situation began like this: We upgraded our SharePoint 2010 (using the Project Server 2010 February 2013 Cumulative Update) We found a bug where on the 'Project Page' layout the 'Managed ...
0
votes
1answer
175 views

Creating SPSiteCollection, top level site programmatically

I have been given a task to create an event that dynamically creates new site collections on our sharepoint webApp. Thing is using Central Admin I can create "http://testsite.com/sites/newSite_1" and ...
2
votes
1answer
949 views

App issue with SharePoint 2013 Developer Site

In SharePoint 2013 Developer Site: I am installing an app to my site and it worked fine with default stuff. I added some custom .js file in this app which will set the master page of site coll and ...
0
votes
1answer
47 views

Authentication problem in SP web application 2010

I have created a web application and then site collection by using my custom template site definition. Its created successfully. But when I access my application I get authentication dialog box for ...
0
votes
2answers
5k views

Web Application/Site collection can't displaying Problem

I created a new web application. I try to restore a site collection from a backup. It finished succesfully but when I type the url This page can't be displayed occurs. I think the problem is about ...
0
votes
1answer
81 views

how to install app in sharepoint 2013 Publishing site?

I am trying to create one App for sharepoint 2013 publishing site. I can not see Apps catalog from where I can upload an app to the publishing site. On the other hand, if I see in developer site, I ...
3
votes
1answer
885 views

Access denied after creating site collection by using Powershell

I am using SP2013 single server dev environment. I use following scripts for creating web application and site collection. but when I browse to it, it says this site has not been shared with you. I am ...
0
votes
3answers
594 views

Error on recreating web application

I've written a powershell script to create a web application, add libraries and pages, etc. As I work through the script and fix bugs and issues, I delete the web application through central ...
2
votes
2answers
182 views

Is it possible to restrict web application per WFE?

We have 2 web front ends in our single sharepoint 2010 Farm named WFE1 and WFE2. We create 2 web applications, one for my Intranet and one for extranet solution. Is it possible to force our intranet ...
2
votes
1answer
1k views

Powershell to set a Web Application's Trusted Identity Provider to an STS and NTLM?

I've created a custom STS and have setup trust with SharePoint via New-SPTrustedIdentityTokenIssuer. I can use Central Admin to configure a Web Application to use both NTLM and the STS, however I ...
1
vote
1answer
738 views

creating web application in sharepoint 2013

I have created a web application in sharepoint 2013 using central admin, that is successfully created. its successfully created app pool in IIS as well. In host file I have also added entry like this: ...
4
votes
3answers
943 views

When should we separate a site collection into a different web application

we are planning a sharepoint topology and wondering if we should separate each department in a different web application or just a dedicated site collection. What's the guide or best practice to ...
0
votes
0answers
209 views

HTTPModule Init method calling multiple times in sharepoint

I want to execute a piece of code on application start. As application_start not available in share point, so i have written my own custom HTTPModule and in Init method i have written the code. But ...
2
votes
1answer
95 views

Backup > Restore to New Farm > My site does not resolve

I have a Dev farm and I restored (SP restore) my site web application. After this, I went to use profile service and reconfigured "My site host". When I type the dev url for mysite it does not ...
2
votes
0answers
58 views

new web app on 1 of 2 wfe servers

I have two WFE servers. By default the CA web app gets installed to only one WFE. Is it possible to create a new web app that only gets installed to one WFE? If not, does it make sense to create the ...
0
votes
1answer
37 views

Store cross site collection data

Is there a way to store data (strings, maybe xml) in SharePoint that can be accessible to all the site collections in a web application?
1
vote
1answer
1k views

Can't find WebApplication scoped feature

I've deployed a wsp that has 2 features. The one scoped at a web level is listed where I'd expect to see it and activates without a problem. The feature scoped at a web application can't be found ...
0
votes
2answers
610 views

Sharepoint https and host header

Not a long time ago I was requested to create a new sharepoint web app to host our new portal. Because this portal would be (at the time) our only web app running in this farm and because the boss ...
1
vote
2answers
560 views

How to get all SharePoint Web Applications in the Central Administration Page from code behind

How can I have the list of all existing SharePoint Web Applications and their site collections from code behind .
3
votes
1answer
25 views

Find all workflows with a certain permission setting

I have a workflow which just got broken by a network administrator changing some active directory settings for a certain group. I was able to fix the workflow once the problem had been found but there ...
0
votes
0answers
808 views

Error while attaching content db to a different server

I got back up of content db from a demo server and trying to attach it to a newly created web application in my personal copy of same demo server but not up to date. however I am getting this error, ...