In SharePoint, a web application is a site in IIS. It is where an administrator defines what the root URL of the site will be, type of authentication that will be used, and other site-wide settings.

learn more… | top users | synonyms

1
vote
1answer
66 views

Deploying a VS SharePoint solution to the “Web Application”

When deploying a VS SharePoint solution to the "Web Application", where does the actual assembly go? I mistakenly switched the Assembly Deployment Target of several of my projects to "Web ...
0
votes
1answer
32 views

New Web Application only works using default settings

I've been trying to create a web application and site collection using intranet.contoso.com. However after the webapp and site collections have been successfully created, the site won't display. I've ...
0
votes
3answers
1k views

Can't display new site collection

I'm going through the steps to create a site collection but after I created it, I can't access it via "intranet.contoso.com". I keep getting the error "Internet Explorer cannot display the webpage". ...
2
votes
1answer
841 views

Remove-SPWebApplication not working if SPAdminV4 service is run by Local System?

I have sucessfully removed my Web Application with the following script: PS C:\Users\SP2013Farm> Remove-SPWebApplication http://portal.com -Confirm -Dele teIISSite -RemoveContentDatabases Confirm ...
0
votes
1answer
28 views

Webpart display in all web application

I have created webpart and deploy it on web application level. It is displaying in all web application. How can i restrict to display on specific site. Regards,
1
vote
1answer
175 views

SharePoint Site App Pools restarting outside of scheduled time

in our production environment (we are running SP 2010 Enterprise) I have noticed that we are starting to see the App Pool for the main SharePoint Web Application restart during the day. These are ...
2
votes
1answer
198 views

Accessing data from another web application throws an SQLInvalidException

The scenario is: A MySiteHost site collection (example name: MY SITE). Web application's application pool account is spmysite. A TeamSite site collection (example name: TEAM SITE). Web application's ...
0
votes
2answers
170 views

403 Forbidden error on creation of new webapplication in SP2010

I am getting an error 403 forbidden on creating new weapplication or extending web application although I have signed in as System Account. I am able to create new sitecollection from central admin. ...
0
votes
2answers
798 views

Sharepoint Web analytics configuration wrong web application

I've tried to configure Sharepoint web analytics on the web application on my development machine but without success. I've followed various guides on the internet including runing some timer jobs and ...
1
vote
1answer
623 views

Programmatically get port 80 Web Application Default URL for Farm?

How would I programmatically get the port 80 Web Application Default URL for the Farm?
1
vote
2answers
555 views

How to remove the Central Admin web app?

How to remove the Central Admin web app from IIS? I am using SharePoint 2010 on Windows Server 2012. I know I can remove an app with the SharePoint 2010 Management Shell by issuing: ...
1
vote
1answer
299 views

Application pool not visible in IIS, SharePoint or PowerShell

I have a PowerShell script that creates a web application using New-SPWebApplication. It crashed for some reason a while back and now it keeps telling me the application pool exists. I've looked in ...
0
votes
2answers
323 views

Root Site on New Web Application Can't be browsed to

Testing box is SharePoint 2010 Standard, single box install, local SQL. Default Web Application works fine. I've created a new web app, create a root site collection for it and no joy. I've tried / ...
0
votes
1answer
25 views

SP2010 Default Application not available after new Web Application was made / deleted

I have a SharePoint 2010 test environment was working perfectly with it's default Web Application and root site. This is a single server install, with its own local copy of SQL. I've made and ...
4
votes
1answer
235 views

Enumerate every solution for each WebApplication

I'm performing an inventory and I need to get list of sharepoint solutions (*.wsp) deployed to every individual web-application and ideally, it would also be great to list what Application pool on ...
0
votes
1answer
488 views

How to place My Sites inside another site's URL but still keep them logically isolated?

I'm setting up SharePoint 2013 as a company intranet site, and we want to implement My Sites; I know the best practices call for placing them in their own web application and content DB, but we'd ...
0
votes
0answers
213 views

Web Page Security Validation (Taxonomy AJAX Bug vs Silverlight Bug)

The situation began like this: We upgraded our SharePoint 2010 (using the Project Server 2010 February 2013 Cumulative Update) We found a bug where on the 'Project Page' layout the 'Managed ...
0
votes
1answer
157 views

Creating SPSiteCollection, top level site programmatically

I have been given a task to create an event that dynamically creates new site collections on our sharepoint webApp. Thing is using Central Admin I can create "http://testsite.com/sites/newSite_1" and ...
2
votes
1answer
857 views

App issue with SharePoint 2013 Developer Site

In SharePoint 2013 Developer Site: I am installing an app to my site and it worked fine with default stuff. I added some custom .js file in this app which will set the master page of site coll and ...
0
votes
1answer
46 views

Authentication problem in SP web application 2010

I have created a web application and then site collection by using my custom template site definition. Its created successfully. But when I access my application I get authentication dialog box for ...
0
votes
2answers
4k views

Web Application/Site collection can't displaying Problem

I created a new web application. I try to restore a site collection from a backup. It finished succesfully but when I type the url This page can't be displayed occurs. I think the problem is about ...
0
votes
1answer
80 views

how to install app in sharepoint 2013 Publishing site?

I am trying to create one App for sharepoint 2013 publishing site. I can not see Apps catalog from where I can upload an app to the publishing site. On the other hand, if I see in developer site, I ...
3
votes
1answer
602 views

Access denied after creating site collection by using Powershell

I am using SP2013 single server dev environment. I use following scripts for creating web application and site collection. but when I browse to it, it says this site has not been shared with you. I am ...
0
votes
3answers
457 views

Error on recreating web application

I've written a powershell script to create a web application, add libraries and pages, etc. As I work through the script and fix bugs and issues, I delete the web application through central ...
2
votes
2answers
162 views

Is it possible to restrict web application per WFE?

We have 2 web front ends in our single sharepoint 2010 Farm named WFE1 and WFE2. We create 2 web applications, one for my Intranet and one for extranet solution. Is it possible to force our intranet ...
1
vote
1answer
849 views

Powershell to set a Web Application's Trusted Identity Provider to an STS and NTLM?

I've created a custom STS and have setup trust with SharePoint via New-SPTrustedIdentityTokenIssuer. I can use Central Admin to configure a Web Application to use both NTLM and the STS, however I ...
1
vote
1answer
644 views

creating web application in sharepoint 2013

I have created a web application in sharepoint 2013 using central admin, that is successfully created. its successfully created app pool in IIS as well. In host file I have also added entry like this: ...
4
votes
3answers
721 views

When should we separate a site collection into a different web application

we are planning a sharepoint topology and wondering if we should separate each department in a different web application or just a dedicated site collection. What's the guide or best practice to ...
0
votes
0answers
177 views

HTTPModule Init method calling multiple times in sharepoint

I want to execute a piece of code on application start. As application_start not available in share point, so i have written my own custom HTTPModule and in Init method i have written the code. But ...
2
votes
1answer
87 views

Backup > Restore to New Farm > My site does not resolve

I have a Dev farm and I restored (SP restore) my site web application. After this, I went to use profile service and reconfigured "My site host". When I type the dev url for mysite it does not ...
1
vote
0answers
54 views

new web app on 1 of 2 wfe servers

I have two WFE servers. By default the CA web app gets installed to only one WFE. Is it possible to create a new web app that only gets installed to one WFE? If not, does it make sense to create the ...
0
votes
1answer
35 views

Store cross site collection data

Is there a way to store data (strings, maybe xml) in SharePoint that can be accessible to all the site collections in a web application?
1
vote
1answer
835 views

Can't find WebApplication scoped feature

I've deployed a wsp that has 2 features. The one scoped at a web level is listed where I'd expect to see it and activates without a problem. The feature scoped at a web application can't be found ...
0
votes
2answers
561 views

Sharepoint https and host header

Not a long time ago I was requested to create a new sharepoint web app to host our new portal. Because this portal would be (at the time) our only web app running in this farm and because the boss ...
1
vote
2answers
522 views

How to get all SharePoint Web Applications in the Central Administration Page from code behind

How can I have the list of all existing SharePoint Web Applications and their site collections from code behind .
3
votes
1answer
25 views

Find all workflows with a certain permission setting

I have a workflow which just got broken by a network administrator changing some active directory settings for a certain group. I was able to fix the workflow once the problem had been found but there ...
0
votes
0answers
689 views

Error while attaching content db to a different server

I got back up of content db from a demo server and trying to attach it to a newly created web application in my personal copy of same demo server but not up to date. however I am getting this error, ...
1
vote
1answer
161 views

Moving a Web Application from One server farm to another server farm

We have a Virtual Machine "vDemo" which is acting like our development server, then me as a developer has a copy of it on my PC, however my copy is very old and development server does have other ...
1
vote
1answer
343 views

Host-Named Site Collections configuration

I am configuring SharePoint Server 2013 for Host-Named Site Collections & creating Initial Site Collections. Created a new Web Application to handle Host-Named Site Collections (HNSC): ...
0
votes
2answers
780 views

Extranet / Intranet - Site Collection or Web application

I'm new to SharePoint and I have a question. If you already have an existing intranet or extranet infrastructure and you want to create(/expose) another one, should I create a new site collection, a ...
1
vote
2answers
1k views

Content Database Is Not Listing In SQL Management Studio

I have created a new SP web application and the content database name which I have given is WSS_Content_Test. Application created successfully(I checked out and found IIS Website and App pool is ...
0
votes
1answer
316 views

Remove site prefix when creating new site collection

Can I remove the site prefix from the URL when I create a new site collection? For example if the URL of the web application is http://servername and I want to create a new site collection I need to ...
0
votes
2answers
2k views

whats the difference between IIS web application and SharePoint web application

I have been working on SharePoint for a long time but still confused with the concept of webapplications in SharePoint and IIS, I would also like to know the relationship between them. I just studied ...
0
votes
0answers
115 views

HTTP-500 after creating new web applications

When I create a new web application, all existing web applications stop responding. They start giving HTTP-500 errors but I can't see a single entry in ULS logs about the error. So I can't know where ...
0
votes
3answers
197 views

Deploying to style library / site pages from a web application scoped feature

I am writing a web application-scoped feature which will provision a site collection and a small number of sites. The problem is that I have my own style files (.js, .css, images) and even some ...
0
votes
1answer
677 views

Best way to force traffic to Web Front End?

I have a SP 2010 farm with a 3-tier structure consisting of 1 DB server, 1 App Server and 1 Web Front End. When I create a Web New Web Application called "Search_WebApp", I notice that it creates the ...
1
vote
2answers
419 views

How to programmatically determine if anonymous access is enabled for a SharePoint 2010 Web Application using C#?

In Central Administration\Manage Web Applications, there is the ability to enable anonymous access on a web application through the authentication providers. Is there a way to programmatically ...
2
votes
2answers
3k views

How to Restore Same Site Backup in Same Content DB to create another site collection in the same web application?

I have a site backup and i want to create two site collection from that backup in one web application.when i try to restore second site collection on same web application it restrict me to do so.As ...
0
votes
2answers
384 views

Deploy folder/files to Web Application Root

How to deploy folder to a SharePoint 2010 Web Application Root folder (inside inetpub\wwwroot\wss\VirtualDirectories\80) in the solution package(wsp)? Which kind of item I should use in the visual ...
0
votes
0answers
180 views

All timer jobs are missing from a Web Application

A timer job solution has been written and installed to our farm. It appeared to install correctly. However when you go to Central Admin under timer jobs and look at ...