Visual Web Part is a Web Part built using a User Control (.ascx)

learn more… | top users | synonyms

1
vote
4answers
1k views

How to enable site collection feature by default when deploying a visual webpart from visual studio?

I am making a visual web part in SP 2010 using visual studio 2010. I want it so that when I add and deploy my wsp file, it should by default keep the site collection feature activated for the web ...
1
vote
2answers
688 views

Couldn't find any way of displaying a message box in Visual Webpart 2007 (User Control)

I almost tried everything I could to display a nice message box in user control (.ascx) or code behind, but I failed miserably, Can anyone find me a tutorial in context to what I need and will 100% ...
0
votes
2answers
7k views

How to add jQuery script to a custom visual webpart?

Similar to some previous questions, I'm trying to use jQuery in a visual web part but I keep getting that jQuery is undefined. I've added the jQuery script to SiteAssets as well as a script folder ...
5
votes
2answers
9k views

Difference between WebPart & Visual Web Part

I'm not sure how Visual Web Part is different from the actual Web Part in SharePoint 2010. Thanks!
3
votes
5answers
2k views

Visual web part and custom web control - can't register

I have created visual web part and copied custom web control which I'd like to use. My control looks as below: namespace AppsListWebPart { [ToolboxData("<{0}:CustomImageButton ...
2
votes
2answers
718 views

sharepoint webpart property disappear after a day (C#)

I developed a custom webpart with a webpart property with some textboxes and it works partially. If I deploy the project, the written text in the property is away. This is ok. But my MAIN Problem ...
1
vote
1answer
620 views

How to make taxonomy picker required when used in visual web part?

I have created a visual web part in which user has to specify a field's value from taxonomy picker control. I want to make that value mandatory. The control is placed successfully but when I use the ...
2
votes
2answers
971 views

How to set visual webparts to load one after - another sharepoint 2010

I have a webpart page which have 2 custom visual webparts. When i set the debugger point on both the page loads of the webpart the 2nd visual webpart debugger is hit...that makes me think the 2nd ...
1
vote
1answer
586 views

Check box in gridview should update the splistitem check box

I am a newbie in visual studio. I have a Sharepoint list which contains the following fields group name, user, section and active(which is a check box) . I have a grid view visual web part which will ...
1
vote
2answers
2k views

How to separate Title and Url from hyperlink field?

I have created a column which is of type Hyperlink or Picture. I want to display the list of links in web part, in such a manner that title should appear as text and the Url should be bound in that ...
0
votes
1answer
321 views

2007 templates broken in 2013

We're upgrading to SP2013 from 2007 and using 2010 as a stepping stone for the DB upgrade. (This is all out of production, we're building a plan to do production) The problem we're having is that many ...
0
votes
3answers
2k views

How can I access Controls in VisualWebPart1.cs from UserControl.ascx

I make a Webpart and want to use the controls from the VisualWebpart1UserControl.ascx in the VisualWebpart1.cs. Is this possible? I wrote following code in the VisualWebpart1.cs: ...
0
votes
2answers
341 views

Does web part property validation only work for visual web parts?

Suppose I define a web part property like this: private string _myString = "default value"; [WebBrowsable(true), WebDisplayName("My string"), WebDescription("A simple bit of text to ...
0
votes
1answer
313 views

How do I retrieve the “Title (linked to edit)” column from event list to display in my custom web part.

I am creating a visual web part to display the calendar events in the form of an events list with custom css. The web part will be on the home page of my site. Here is what I have right now and it is ...
0
votes
3answers
8k views

Cannot connect to the Sharepoint Site from Visual Studio 2010

I'm new to Sharepoint. I'm trying to create a simple webpart using Visual Studio 2010 but when I try to validate my Sharepoint Server (both VS 2010 and Sharepoint are present in two different system - ...
0
votes
4answers
2k views

JQuery in a Visual WebPart won't load on the page with the webpart

Hey I have a bunch of JavaScript/Jquery code that works really well when I use a Content-Editor webpart, but does not execute when I add the same code to the VisualWebPart mark up. I am referencing ...
0
votes
1answer
493 views

Sharepoint 2010 Visual WebPart and LinqDataSource

How do I use Linq DataSource in a SharePoint 2010 Visual Web-part. When I type <asp:LinqDataSource there are nothing in the Visual Studio auto-complete. When I run the code I would get this error ...