1
vote
2answers
49 views

Debugging sandboxed solution?

I know this is a novice question, but my sandboxed solution works on one site and not the other. How/where can I actually see the errors generated by some sort of report? Debugging simply takes me to ...
0
votes
0answers
70 views

SharePoint WebParts. Attaching to ProteusDebugEngine debugger failed

I'm using Visual Studio 2010 Ultimate and SharePoint Foundation 2010. When I debug my VisualWebParts I have some errors: "Attaching to ProteusDebugEngine debugger failed. Invalid pointer." "Cannot ...
2
votes
1answer
77 views

Visual Studio debugger for SharePoint AutoHosted App

I'm using VS2013 for developping Sharepoint Hosted App against a 365 developpment site. The VS debugger tool doesn't hit anymore my breakpoints. It used to the day before. I have made many tests, - ...
1
vote
2answers
248 views

Workflow debugging prerequisites failed to complete - VS2013 Autohosted App

I am creating an auto-hosted app on VS2013. I am working with SharePoint Online and not locally. The problem is that when I try to enable the workflow debugging on my project I receive the error: ...
2
votes
1answer
331 views

Visual Studio 2013 - Workflow debugging prerequisites failed to complete

I am experiencing an issue with debugging SharePoint 2013 Workflows in a SharePoint App solution: Has anyone encountered this error?
2
votes
2answers
274 views

How to debug sharepoint webservice?

I've followed Walkthrough: Creating a Custom ASP.NET Web Service and everything works fine. I just want to know how to enable debugging for this web service over network. Could you help me?
0
votes
0answers
550 views

How Sharepoint pages life cycle works?

I built a HttpModule for sharepoint. But when I begin to debug the page request, I notice that the debugging has an strange cycle: 1 - context_PreRequestHandlerExecute() 2- page_PreInit() 3 - ...
0
votes
0answers
74 views

How can Solve problems while debugging sharepoint web application?

Everytime I try to run my sharepoint application in debug mode, I get the error bellow:
0
votes
0answers
125 views

Sharepoint Solution showing old server url while debugging in visual studio 2010

I have a SharePoint solution which I developed in a server named HostA, and was deployed in the same server at the url, http://HostA:2100/ASD Later I moved the entire solution to a new server HostB, ...
0
votes
1answer
136 views

Visual Studio 2010 opens “Create New Site” page in browser when I run “Start Debugging” instead of the site I am trying to debug

I am an Office 365 user and fairly new to Sharepoint. I am trying to write a sandboxed solution for SharePoint online. To do this, I have setup a local developer environment and am currently trying ...
1
vote
2answers
1k views

Can't debug/deploy solution from VS 2010

I have encountered strange problem on my dev VM. Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking ...
2
votes
1answer
84 views

File transformations before packaging WSP

I need to modify the content of some files in my SP 2010 project before packaging, something like Web.Config transformations. I need a file to have different content based on the environment: Debug, ...
0
votes
1answer
376 views

Changing Deployment Url for Webpart in VS 2008

I am trying to debug a webpart in SharePoint 2007 using Visual Studio 2008. When I click debug, it deploys the solution to http://localhost:8080. The url I want to deploy to is on a different port. ...
1
vote
2answers
5k views

Event Receiver Not Firing

I have an event receiver using the VS2010 template for SharePoint 2010 and I have coded it the same way I have done many times. This time, though, it is not firing at all. It is attached to the list ...
15
votes
5answers
2k views

Are there any tweaks, tips to make debugging SharePoint 2010 faster?

I am using Visual Studio 2010 Ultimate and SharePoint 2010. The debugging process itself is okay but the startup takes really long. Are there any options or hidden-hints to make this faster? Edit: ...
0
votes
0answers
824 views

Unable to debug in an event receiver sharepoint 2010

When i debug in the event reciever(item adding) as soon as it reached the if condition i get the following error unable to automatically step into the server.The remote procedure could not be ...
15
votes
2answers
1k views

Can't start debugging after install VS11

After I installed VS11 Dev Preview, VS2010 cannot start debugging the Sharepoint 2010 server (developer install on Windows 7). I get a nice error dialog stating: Unable to start debugging on the ...
2
votes
2answers
602 views

How do I debug a code-behind page in the Central Administration site

I built a custom timer job and created a configuration page (.aspx) for it. Going through the Central Administration site, I can get the to configuration page. When I enter values and click "OK" to ...
2
votes
0answers
1k views

Debugging XSLT in Visual Studio 2010 [closed]

I'm trying to debug XSLT for CQWP. I followed this guide. So I'm able to retrieve the XML, and link the files temporarily together using xsl:import. But then Visual Studio can't find the schema for ...