The User Profile Service in SharePoint is responsible for synchronising user data to and from SharePoint to identity stores such as Active Directory, LDAP and many others.

learn more… | top users | synonyms

2
votes
0answers
295 views

“About Me” missing - SharePoint onPremise

I am using SP Server onPremise, I have a site collection with some sites. I do not see the "About me" menu. I would like to allow user to change profile picture and update some information about the ...
2
votes
0answers
69 views

Synchronisation Service doesn't update Job Title

A user's Job Title field isn't updating in the User Profile (and therefore an old value is showing-up in the People Search). Interestingly, I can see the Job Title property changing when I view it ...
2
votes
0answers
916 views

Move-SPUser : pixels

Migrating users from one domain to another, I get this error on a couple of users. The migration still seems to occur. Move-SPUser : pixels At D:\UserMigration\MigrateUsers.ps1:10 char:28 + ...
2
votes
0answers
301 views

No results when searching with special characters in custom metadata property

We have an issue with SharePoint 2010 Search. Currently, we have a property in Active Directory, for each user, that specify their initials. We have a scheduled task that runs every hour to sync these ...
1
vote
0answers
40 views

Has SharePoint O365 stopped support of /_vti_bin/UserProfileService.asmx endpoint recently?

Until now, the legacy /_vti_bin/UserProfileService.asmx was the only possible API to update SharePoint o365 user profile properties. Unfortunately, recently it started to return Server was unable to ...
1
vote
0answers
25 views

Manager not displayed when manager is in a different active directory domain than the user

Users whose accounts reside in the EU or AP domains but whose managers accounts reside in AM or some other domain in the forest are not displaying their managers at all. Additionally these users are ...
1
vote
0answers
37 views

Sharepoint 2013 with SQL Authentication

I'm trying to get Sharepoint 2013 to install correctly with SQL Authentication. The domain environment I am running this under, service accounts are not easy to come by and have to be renewed every ...
1
vote
0answers
45 views

Removing user from people picker/UIL

Background Information: Company is the process of moving to a new domain called domain A, from domain B. at one point there was going to be a domain, called domain C that had a few users setup and ...
1
vote
0answers
66 views

What's the connection between the User Profile Service and the People And Groups hidden list? SharePoint 2013

I'm looking to understand the connection between the User Profile Service and the hidden User Information List. Here's what I'm experiencing. New SharePoint 2013 farm with a migrated UPS from a ...
1
vote
0answers
124 views

How to get User Profile Service information on user OTHER THAN current user?

So much information on how to autopopulate information for the current user or the logged in user in InfoPath. But what about other users? What if there's a field that's 99/100 times going to be the ...
1
vote
0answers
48 views

Updated external content type but connection not updated in central admin

I have an external content type for a sql server view, all working well. I add a new field to the view and save (SPD), in central admin I go to BDC and click on the content type - I can see the added ...
1
vote
0answers
67 views

Search_Service_Application_DB permissions

All of the sudden no one can get to their profiles in our SharePoint 2010 Enterprise environment. A lovely unexpected error message pops up. Comparing the correlation ID with the ULS logs, it appears ...
1
vote
0answers
195 views

Valid sharepoint user that doesn't have a user profile causing workflow errors

I have created a work flow that retrieves some details, such as the manager and some address details, about users on our SharePoint. The information is retrieved for after the fact analysis we do on ...
1
vote
0answers
183 views

SharePoint 2013 User Profile Service - Attributes Not Being Imported

My SP 2013 User Profile Service is configured to import all active users within 2 domains; external.company.com (external domain) and company.org (internal domain). The UPS is setup on the external ...
1
vote
0answers
21 views

User not appearing when I start typing name in Group

There are 3 users in AD and they are synced with UPS. I can see their profile and if I do people search then they also appear in results. Let's call them user1, user2, user3. Problem is I am trying to ...
1
vote
0answers
303 views

SharePoint User Profiles Deleted

I had an strange issue 3 weeks before and i was wondering if you guys can help me with that . We have setup my sites in our environment and we have about 5000 profiles and everyday at 1.00 am an ...
1
vote
0answers
142 views

Sync DB Tables not being created when creating a User Profile Service Application?

Been having difficult getting the User profile synchronization service started. Deleted and recreated the service multiple times. Now I notice after creating the UPS application the profile db, social ...
1
vote
0answers
277 views

Edit UserProfileProperties in Sharepoint 2010 using PowerShell

As I mentioned above I want to modify given UserProfileProperties. http://www.c-sharpcorner.com/uploadfile/anavijai/modify-user-profile-properties-in-sharepoint-2010-using-powershell/ This is what I ...
1
vote
0answers
104 views

Separate sub-sites into their own application pools?

I'm in the middle of an upgrade of a SharePoint 2007 farm. In this old farm, they have My Sites set up to share a database and application pool with everything else in the farm. As we move ahead ...
1
vote
0answers
430 views

Retrieve the Large Thumbnail Profile Image in Sharepoint 2010 My Site Profile Page

I am trying to retrieve the profile image with the _LThumb URL, in my people search result. But since my container is 30x30px, SharePoint is automatically retrieving the profile image with _MThumb on ...
1
vote
0answers
267 views

SharePoint 2010 people search results recent content showing no results

What are the dependencies for having the "By username" actually work and show recent content within the people search results? I'm assuming the recent content is not just my site content but ALL ...
1
vote
0answers
496 views

User Profile Sync not running

Under the User Profile Service Application, I noticed that the Profile Synchronization Status was set to "Synchronizing Stop". Which is weird, as it was noon, and the incrementals are supposed to ...
1
vote
0answers
210 views

Does a trusted My Site location actually have to point to a My Site Host?

I'm trying to evaluate my strategy for doing some custom User Profile related pages. I'd like to reuse my main master page and use a combination of web parts, users controls and page layouts to get ...
1
vote
0answers
5k views

User Profile Application service was inaccessible - ProfilePropertyService.svc has exceeded the allotted timeout

Yesterday, we suffered with the Global outage on our SharePoint 2010 farm as the "User Profile Service Application" was inaccessible during those hours. Exception: 01/13/2012 08:41:20.16 OWSTIMER.EXE ...
1
vote
0answers
288 views

Approval workflow: “Assigned to” field gets different user name in list and autogenerated e-mail

I've added an Approval workflow on my development server and manually copied the workflow in the production environment (since no efficient deployment tool for configured workflows seems to exist). ...
1
vote
0answers
413 views

How does Membership show in Mysite - SharePoint 2010 - Part-2?

User's membership is not getting populated in the Membership tab on Mysite in our SharePoint 2010 environment. It was working fine until we provisioned a new UPA (used the existing profile and social ...
1
vote
0answers
355 views

Problem syncing user profile information to Site Collection

SharePoint 2010 Server - I've got a Site Collection where the user profiles aren't getting updated from the farm profile store. Especially I noticed that photos I've uploaded to the user profiles are ...
0
votes
0answers
10 views

Why does this security group have two names?

We are having a strange issue with user access. Three users were recently added to an Active Directory security group. Two users have the access they require to a SharePoint list, but the third does ...
0
votes
0answers
5 views

User Profile Picture not synchronized in SharePoint 2007

We currently have SharePoint 2007 sites synchronized with AD in our intranet. Each Staff or user's images are stored in a network Drive using their full name . For example ...
0
votes
0answers
14 views

Looking for Specific User Profile Property for Workflow but Don't Have Access User Profile Web Service

I've put together a workflow using SharePoint 2013 and SP Designer 2013 that fires off emails based certain user events in a SP library. I'm capturing these user events through the Account Name field ...
0
votes
0answers
69 views

SiteUserInfoList not updating

I am running a workflow that Calls user information from http://site/_api/Web/SiteUserInfoList/Items(<UserID>) The workflow is pulling the information just fine however I noticed that not all ...
0
votes
0answers
7 views

Adding Colleague to All Users

I am not sure the SharePoint 2010 social features are designed to work this way, but I would like to setup AD accounts that are tied to various departments within our company (HR, IT, Accounting, ...
0
votes
0answers
18 views

Get specific user based on a custom user profile field - REST

I've got a custom user profile field ex: CompanyID If CompanyID=444 then return "microsoft" Something like this: ...
0
votes
0answers
85 views

Restore Errors on Sharepoint

I got up backup a server. And I want to restore the backup to nother server. But I got this error and my restore job is failed. Object Excel Service Application failed in event OnRestore. For ...
0
votes
0answers
17 views

Issue with Active Directory Import

I have two issues with this mode in SharePoint 2013 (or I think are issues). I have different domains so I should create different AD connections (for domain CONTOSOA, CONTOSOB, etc) but I think is ...
0
votes
0answers
86 views

Delete users from Profile Missing from Import view

I need to delete users from user profile in the view Profile Missing from Import. I tried to run the My Site Cleanup Timer job but they are still there. How can I do?
0
votes
0answers
51 views

CSOM. Get user profile info return “503 Service Unavailable” from code

We have an SharePoint-hosted App, that receives a lot of information from SharePoint user profiles. Client code looks like this: var context = new SP.ClientContext.get_current(); var peopleManager = ...
0
votes
0answers
122 views

I cannot create Audiences in my SP2013 user profile service

I am on SP 2013 Enterprise server and I am trying to create some Audiences in my User Profile Service. When I attempt to add a rule I get the following error: "Rule context is not detected. This ...
0
votes
0answers
71 views

Can I delete 1 user from the UPS “Profiles missing from import” in powershell?

I am using sp2010. I would like to delete 1 user from the User Profile Service Application in the section "Profiles missing from import". How can I do this in powershell? I know there is a powershell ...
0
votes
0answers
90 views

Managed property is not being set, coming from a User Profile custom property

I have a custom user profile property that is mapped to 2 different managed properties. For some reason, it is only appearing in 1 one of the managed properties. I can confirm the managed properties ...
0
votes
0answers
20 views

Exclude certain accounts in SharePoint Profile Import

We are trying to exclude certain account from SharePoint Imports. Basically we have service accounts that we need to exclude from the import and was wondering if this can be done via editing ...
0
votes
0answers
28 views

Is it possible to use UserProfileService to return all current Birthdays?

I am new to the UserProfileService web service, the url based service accessed through /_vti_bin/userprofileservice.asmx In reference to writing a JavaScript CSOM web part, I am wondering if it's ...
0
votes
0answers
28 views

Change user's account name

I sync all my users from AD and I have a few that were synced before I turned the Netbios names option on on the User Profile Service. This means that 98% of my users have the proper ...
0
votes
0answers
92 views

Active Directory Import “No containers to display”

I am trying to configure Active Directory Import in SP2013, the problem is that on Add new synchronization connection screen I am getting "No containers to display" error after clicking "Populate ...
0
votes
0answers
155 views

SharePoint 2010 UserProfileService GetUserProfileByName - different results for similar input syntax

I have a problem where a call from a browser enabled InfoPath form to the UserProfileService in SP 2010 returns at 500 error: "Warning The following query failed: GetUserProfileByName (User: ...
0
votes
0answers
297 views

SharePoint 2013 Event ID 3760 SQL Database ' ' on SQl Server Instance ' ' not found

I am running into following error message into my Event Viewer in the Sp2013 Web Server. Site is stable and no issues realted to db. But repeatedly it is throwing following errors: Log Name: ...
0
votes
0answers
22 views

Update the UPS Synchronization to a BDC model

Is there a way to update the available fields within a UPS synchronization connection when the underlying BDC model changes (addded/deleted fields) and without recreating the connection?
0
votes
0answers
37 views

Delete values from multi value user profile property

How can I remove a property value from a user profile multi valued property. I have a custom multi valued(string) property where I can add items.But does anyone know if how to remove any value ...
0
votes
0answers
71 views

Profile Picture from URL not showing in 2010

I am trying to import profile pictures using PictureURL. We have a full url stored in extensionAttribute3(http://pictureserver/photo/GetPhoto.aspx?id=xyz)(could it be because my url isn't linking ...
0
votes
0answers
88 views

UPS Connectors with Flow Updates not mapping

I'm syncing data from various sources to user profiles. I have a few multi-value fields and all of them but one work. For example a field called Education gets data from an external content type and ...