Upgrading from a previous version of SharePoint.

learn more… | top users | synonyms

2
votes
2answers
657 views

Feature upgrade incomplete for Feature 'PublishingWeb' - Could not find file

I'm upgrading SharePoint 2007 to 2010 using attach and upgrade method. When running database upgrade a series of similar errors are shown in upgrade log (could not find some temp file with an ...
3
votes
1answer
320 views

Why do I get an error updating a custom field type from 2007 to 2010?

I'm upgrading a publishing site from 2007 to 2010, the upgrade completes with errors in the upgrade log, all of which relate to a particular custom field type. An example of one the errors is here: ...
0
votes
1answer
747 views

2010 SP1 Upgrade throws XPathException: Expression must evaluate to a node-set

I'm stuck with an exception during upgrading SharePoint 2010 to SP1. It happens during provisioning of the central administration web app. I initially ran the configuration wizard and got the ...
1
vote
2answers
2k views

Database Attache Upgrade Fail?

I ran the mount-spcontentdatabase and it failed. The test-SPContent Database didn't produce anything in the log that would fail the upgrade. Also, the error report didn't have anything that would ...
1
vote
1answer
239 views

Upgrading from Sharepoint Foundation 2010 to Sharepoint Server 2010

Is it possible to upgrade from Sharepoint Foundation to the full version (SharePoint Server 2010)? We've half way implemented a site in Foundation and are running into issues. Can we just install ...
1
vote
0answers
42 views

Which Web Parts should get installed in SP2010 Update?

Per Dave Wise's answer(http://sharepoint.stackexchange.com/questions/13110/get-web-part-name-from-guid): Thanks, that worked great. However, even though my SQL Query returned 9000 results, about 18 of ...
6
votes
1answer
3k views

Choice field changed - How to propagate the change down to all lists that used it?

I have a feature (Web scoped) with a content type which contains a field (Type="Choice"). Values were A, B and C. I've created a list based on this content type and added some elements in it. I ...
1
vote
1answer
559 views

Errors migrating from custom list with SharePoint 2010 upgrade

In MOSS we exposed a custom list definition to users instead of the Shared Documents library. Now, we are trying to convert all those list instances to use the out of the box list. It seems that ...
0
votes
1answer
100 views

Seamless upgrading of content query web parts

Is there a tool or check list for upgrading content query web parts in 2007 to 2010?
1
vote
2answers
441 views

Best practices for updating list template schema files in SharePoint

I have a requirement to update the schema files of a list template which modifies the options available to the fields. But, when I am updating the schema file the options for the already defined ...
0
votes
1answer
161 views

Find out feature version for list's content type

I have a feature which contains a custom content type. I've created a list based on this content type then proceeded into changing the feature version and performing an upgrade. I have ...
1
vote
1answer
831 views

Upgrade from 2007 to 2010 error on custom web parts

We have several SharePoint 2007 farms with several site collections in certain databases. The desire is to be able to migrate these 2007 site collections to our new 2010 farm envirionment. The best ...
1
vote
2answers
411 views

SharePoint 2007 - SharePoint2010 Migration — Giving Issues

I am getting issues while migrating SP2007 - SP2010. Below are the steps I have followed as part of SharePoint data migration: I used two different systems and installed MSSQL 2005 & SharePoint ...
2
votes
1answer
229 views

Strange behavior opening items from view after upgrade SP1 2010

After installation of SP1 for SP2010, the items in libraries no longer displayed in a dialog. On the list is indicated that the items should be displayed in a dialog. After research I found out when ...
1
vote
2answers
2k views

How can I solve “A SharePoint database named [xxx] already exists” when upgrading from SharePoint 2003 to 2007?

I am trying to upgrade a SharePoint 2003 web application to MOSS 2007 through the database attach method. I am following these steps as outlined by Microsoft: Create web application in MOSS 2007 ...
2
votes
1answer
1k views

Fab 40 Test-SPContentDatabase Upgrade Missing Assembly Error

I'm getting a Fab 40 related MissingAssembly error in the output of Test-SPContentDatabase. The strange part is that the version number of the assembly referenced in the output is incorrect. ...
0
votes
3answers
386 views

Post-Service Pack 1, Broken Web Applications (User Profile Sync)

I had a clean environment prior to installing service pack 1 and the June CUs. User Profile Sync is up and running, and synchronizing, but all web applications are throwing a SharePoint error. Digging ...
1
vote
0answers
103 views

Application Page 404 - Upgrade from 2007 to 2010

In a 2007 Publishing site developed for a client I deployed some custom pages to URL /CustomPages/Programmes.aspx (rather than application pages going in _Layout). The site custom master page was used ...
1
vote
2answers
1k views

Masterpage upgrade from 2007 to 2010 while still supporting 2007

I'm currently upgrading a SharePoint site with a custom master page from 2007 to 2010. We want to be able to let the user decide when to migrate their site from 2007 L&F to 2010 L&F using the ...
0
votes
1answer
359 views

SSP Database Upgraded from 2007 to 2010, My Links automatically deleted shortly after

I follow the steps here to upgrade a 2007 SSP database to 2010: http://technet.microsoft.com/en-us/library/cc263299.aspx#SSP After the upgrade everything appears successful and users can see their ...
1
vote
1answer
187 views

After upgrade from 2007 to 2010 - Field Duplicate when trying to add feature

I upgraded a sharepoint from 2007 to 2010 with attaching the content database. After that i developed a new solution with the same content type i used in 2007. Adding the solution works fine but ...
0
votes
3answers
712 views

“A previous installation has been detected with a license type does not match the install in progress” Error when upgrading to SP2010

I am trying to upgrade Sharepoint server 2007 (Enterprise CALs) to SP2010. I'm using the SP2010 evaluation package from Microsoft along with the included license keys. When the upgrade process ...
0
votes
1answer
3k views

Why am I getting “Server error: http://go.microsoft.com/fwlink?LinkID=177673” after doing a database-attach upgrade

I have a massive MOSS content database that I'm trying to upgrade to 2010 via a database attach. After the process is complete, I get "Server error: http://go.microsoft.com/fwlink?LinkID=177673" when ...
0
votes
1answer
169 views

Can I make calendar items link to data view page?

We currently upgraded from 2007 to 2010 and I'm having problems with the calendar. In 2007 I was able to change that the calendar items would link to a custom data view I created. Here is our 2007 ...
1
vote
2answers
108 views

SharePoint 2010 Opinions and Alternatives

My company has been using SharePoint WSS 3.0 for 2-3 years and we've recently upgraded to SharePoint Foundation 2010. Our use of SharePoint started in IT and has gradually moved into other areas of ...
1
vote
2answers
1k views

Test-spcontentdatabase returns The server instance of the database could not be found

I am trying to run Test-spcontentdatabase on a MOSS database on a SQL server (2008 R2). When I run it I get "The server instance of the database could not be found." The ULS has no more information ...
6
votes
11answers
26k views

Sharepoint Server 2010 SP1 PSConfig issue

I've download (KB 2460045) and install the sp1 for SPS2010, so far so good. To complete the process -SQL upgrade- I must run the SP2010 Products Configuration Wizard (psconfig), but in the last step a ...
1
vote
1answer
124 views

WSS 3 on SBS 2003

I just recently identified that upgrading WSS 2 to WSS 3 on SBS 2003 is not supported. I need to plan the best approach to get a client using WSS 3 with the current SBS 2003 environment. It is a ...
1
vote
6answers
2k views

Missing 1033 Directory in SharePoint 2010 URLs

I seem to be missing a '1033' directory for my SharePoint 2010 installation. Here's the full details: We upgraded from SP2007 to SP2010 using the database attach method. Some resources have a 1033 ...
0
votes
2answers
233 views

Users denied access after solution redeployment

My old solution has been running in my intranet farm for a long time. The solution contains a feature which deploys a webpart. The webpart shows the users of a group, together with information from ...
5
votes
3answers
2k views

Failed 2010 SP1 Upgrade

Anyone have an idea? I am trying to upgrade on Win7 Development box 06/30/2011 11:11:20 8 ERR Task upgrade has failed with a PostSetupConfigurationTaskException An exception of type ...
0
votes
2answers
139 views

Missing Sharepoint Definition

I am having trouble deleting a rogue site definition found after running stsadm preupdatecheck. I have run stsadm -o enumallwebs and have found where the template is used. The trouble is that URL ...
2
votes
1answer
394 views

Why do I have folders called “1” in my document library after an upgrade to 2010?

We upgraded our MOSS2007 to MSS2010 (database attach upgrade method). We have multiple document libraries on a site. default.aspx contains web parts with the files from document libraries. The files ...
1
vote
0answers
374 views

Weird top link bar after upgrading WSS2 to WSS3

Installed WSS2 on server 2003, not customized or changed, upgraded to WSS3 and the top link bar (home, documentation etc..) is vertical and appears to be broken. This looked the same before I changed ...
2
votes
1answer
2k views

Workflows lost on SharePoint 2010 migration

I have been migrating SharePoint 2007 to a SharePoint 2010 installation. The upgrade completes successfully but the association between workflows and lists is lost. In the SharePoint 2007 there are ...
3
votes
2answers
628 views

Remove or ignore Project Server 2007 on SharePoint 2007

Environment is a single SharePoint 2007 server (MOSS) and a SQL db server farm. Once upon a time a previous SP admin installed Project Server on the SP server, but it was never used. Some action was ...
0
votes
1answer
2k views

Upgrade moss 2007 to 2010 List problems

I've taken my moss 2007 db backup and used attach method to upgrade on sharepoint 2010. Upgrade went successful and users can see the sites and can navigate also. Interface is same as moss 2007. I am ...
2
votes
2answers
1k views

Site with custom master page reverts to v4.master on upgrade

I have a web application in 2007 that contains a bunch of sites that all used a custom site definition and a custom master page (deployed using a feature). All is well. I've upgraded the code for ...
1
vote
1answer
2k views

moss 2007 content db migration to sharepoint 2010

I am in a middle of content database migration of MOSS 2007 built on SQLServer 2005 to SharePoint 2010 with SQLServer 2008 R2. This is what I've done. Installed SP 2010 Standard Edition ...
3
votes
1answer
541 views

Preupgrade check reveals webpart issues which are not installed on farm, how to identify the name, assembly of the referenced webparts

I have run a preupgrade check on a SP2007 database to identify issues prior to upgrading to SP2010. The report shows a lot of messages for missing webparts. The strange thing is that I cannot identify ...
1
vote
1answer
257 views

Creating Site Templates - Master Page Not Being Handled Right After Upgrade

In our old MOSS 2007 farm we had a branding feature deployed that swapped out CSS Files, Master Pages, etc for our sites to keep a consistent branding across our Site Collections. We are currently in ...
2
votes
1answer
598 views

Why can't I access a site I've just imported when central admin says I'm a site collection administrator?

This is a slightly unusual situation. I have a MOSS 2007 farm. I do a database backup and restore to our dev farm and then do a database attach to our 2010 farm. I'm secondary site collection ...
2
votes
2answers
2k views

Site gets 404 error after upgrade to 2010

I have a site collection with multiple sites. When I upgrade the site collection the sites all get 404. If i use Designer I can see the default.aspx file fine. If I rename it to default1.aspx then ...
2
votes
3answers
5k views

Get Web Part name from GUID

We're migrating from SP2007 to SP2010 and are seeing some error messages about missing web parts during the upgrade, but the error messages only list the GUID and not the web part name. Is there a way ...
5
votes
2answers
264 views

How do I handle custom webpart property type update during re-deployment

I have a custom webpart that was defined with a property like [Personalizable(PersonalizationScope.Shared), WebBrowsable(true), WebDisplayName("Chart Type"), Category("Chart - Required")] ...
3
votes
3answers
2k views

No 'edit' button on sharepoint 2010 after upgrade from 2007

I've upgraded a SharePoint 2007 (12.0.0.6421) database to SharePoint 2010 (no SP's or anything yet) and I noticed that there is no edit button that brings up the ribbon to edit a page in the upgraded ...
2
votes
2answers
183 views

How do I migrate my SharePoint 2007 environment to SharePoint 2010?

I'm looking for a book or website which will lay out the complete process of upgrading from SharePoint 2007 to 2010. I've come across a couple of products which will do this for me, such as Xavor and ...
0
votes
1answer
541 views

Corrupted OOTB Workflows Feature from SP2007 to SP2010 Upgrade

We recently performed a database detach upgrade method and the out of the box workflows: Approval, Collect Feedback and Collect Signatures are all missing from the Workflow Templates when trying to ...
2
votes
1answer
565 views

SPD Workflows upgrade from 2007 to 2010 fix

Our company has several large SharePoint farms that are migrating over time. As a result of the upgrade, our URL's will change. Our technology group has said that any workflows created in Designer ...
1
vote
3answers
2k views

failed upgrade to 2010 - some site not upgraded, but site works. Continue?

are doing an database attach upgrade and the upgrade failed while performing the Mount-SPContentDatabase and got the errors "Feature upgrade failed for Feature " and "Exception: Object reference ...