Upgrading from a previous version of SharePoint.

learn more… | top users | synonyms

0
votes
3answers
686 views

wss 3.0 to Sharepoint 2010 Foundation Upgrade Problem

Just did a Database attach Upgrade from wss 3.0 to sharepoint 2010 Foundation. I detached the content database from wss 3.0 Webapplication with internal database running in Windows Server 2008 R2. I ...
3
votes
3answers
381 views

Deploying SharePoint 2010 WSP to MOSS 2007

Please help me on this. Is it possible to deploy a WSP solution developed in SharePoint 2010 to SharePoint 2007. I know this is very akward question, but right now I am asked this very same question ...
1
vote
1answer
144 views

Default SP2007 Workflows Upgrade Issues to SP2010

We recently completed an upgrade (database attach hybrid) from SharePoint 2007 to SharePoint 2010. We have come across an issue in which one of our sites used the default approval workflows, but since ...
1
vote
3answers
115 views

MOSS2007 to 2010 - What tricks have you learnt?

The company I work for is currently in the planning stages of a MOSS to 2010 migration (we have a business critical environment with >500 users to port). With this in mind I was wondering what are ...
2
votes
2answers
454 views

Migration from SharePoint 2007 to SharePoint 2010 problem

I'm working with SharePoint 2007 to 2010 migration, the problem is the Upgrade Status in CA stated it was succeeded, however when I browse the new Web Application for the first time, it load for ...
2
votes
1answer
489 views

Pricing an upgrade from 2007 to 2010 for a customer?

How would I go about pricing a 2007 > 2010 upgrade for a small business client? What cost elements/variables/metrics to consider? What is the typical price range? What elements can be worked with ...
0
votes
1answer
658 views

CU October 2011 Invalid object name 'Webs'

I've runed the CU October 2011 and Sharepoint Configuration Wizard failed after executing, however the farm build version changed to: 14.0.6112.5000 as expected. In ULS i've seen error: Invalid name ...
2
votes
1answer
1k views

SharePoint 2010 Service Packs and Cumulative Updates

If I would install a new SharePoint Server 2010 farm now, in order to get my Farm fully up to date, which of the following patches would I have to apply? Does any of these automatically install any of ...
2
votes
1answer
2k views

Events showing in List view and not Calendar view

I've upgraded a WSS 2.0 site to MOSS 2007 to Foundation 2010 using the content database attach method, and I have a vacation calendar where I can see all the events in the list view, but the events do ...
2
votes
1answer
519 views

Web and its child webs not showing in default navigation after 2007 > 2010 upgrade

I have a single site collection that was previously a MOSS 2007 site. This site collection has about 15 webs, and some of those have a number of subwebs underneath them. The top navigation bar is set ...
2
votes
0answers
175 views

Field types error when ribbon is shown

We upgraded our MOSS 2007 to SharePoint 2010 yesterday. Everything seemed fine until I chose Show Ribbon from the site menu. Now I get an error like this: "One or more field types are not installed ...
0
votes
2answers
522 views

MOSS 2007 : stsadm -o preupgradecheck found missing feature files for features still active in deployment

This is the last thing I have left to fix to pass the pre upgrade check. There are a three features that are referenced by the content but not installed on the server (not sure how this happened). Two ...
2
votes
1answer
169 views

Visual Upgrade and CQWP

We have upgraded two similar farms (one development and one test). The branding/design is identical and both farms are using Visual Upgrade. The farms have different versions of ...
1
vote
1answer
827 views

Removing references to old Solution Workflow files

As part of an upgrade to Sharepoint 2010 from 2007, I've been removing old FAB40 templates by using the following process for each FAB40 solution; Delete any sites which use the solution, and ensure ...
1
vote
0answers
20 views

False notifications being sent for tasks

I have notifications being sent for tasks that are complete. The tasks were part of an approval workflow. The tasks and workflow have been complete for 3 to 6 months. The issue started after an ...
1
vote
2answers
228 views

List Features that are part of a Solution Package

As part of a migration from SharePoint 2007 to 2010, I am cleaning up old features that are no longer used and/or would have compatibility issues with the upgrade - mainly the old FAB40 templates. To ...
2
votes
2answers
544 views

Feature upgrade incomplete for Feature 'PublishingWeb' - Could not find file

I'm upgrading SharePoint 2007 to 2010 using attach and upgrade method. When running database upgrade a series of similar errors are shown in upgrade log (could not find some temp file with an ...
3
votes
1answer
300 views

Why do I get an error updating a custom field type from 2007 to 2010?

I'm upgrading a publishing site from 2007 to 2010, the upgrade completes with errors in the upgrade log, all of which relate to a particular custom field type. An example of one the errors is here: ...
0
votes
1answer
670 views

2010 SP1 Upgrade throws XPathException: Expression must evaluate to a node-set

I'm stuck with an exception during upgrading SharePoint 2010 to SP1. It happens during provisioning of the central administration web app. I initially ran the configuration wizard and got the ...
1
vote
2answers
2k views

Database Attache Upgrade Fail?

I ran the mount-spcontentdatabase and it failed. The test-SPContent Database didn't produce anything in the log that would fail the upgrade. Also, the error report didn't have anything that would ...
1
vote
1answer
214 views

Upgrading from Sharepoint Foundation 2010 to Sharepoint Server 2010

Is it possible to upgrade from Sharepoint Foundation to the full version (SharePoint Server 2010)? We've half way implemented a site in Foundation and are running into issues. Can we just install ...
1
vote
0answers
41 views

Which Web Parts should get installed in SP2010 Update?

Per Dave Wise's answer(http://sharepoint.stackexchange.com/questions/13110/get-web-part-name-from-guid): Thanks, that worked great. However, even though my SQL Query returned 9000 results, about 18 of ...
5
votes
1answer
3k views

Choice field changed - How to propagate the change down to all lists that used it?

I have a feature (Web scoped) with a content type which contains a field (Type="Choice"). Values were A, B and C. I've created a list based on this content type and added some elements in it. I ...
1
vote
1answer
525 views

Errors migrating from custom list with SharePoint 2010 upgrade

In MOSS we exposed a custom list definition to users instead of the Shared Documents library. Now, we are trying to convert all those list instances to use the out of the box list. It seems that ...
0
votes
1answer
99 views

Seamless upgrading of content query web parts

Is there a tool or check list for upgrading content query web parts in 2007 to 2010?
1
vote
2answers
420 views

Best practices for updating list template schema files in SharePoint

I have a requirement to update the schema files of a list template which modifies the options available to the fields. But, when I am updating the schema file the options for the already defined ...
0
votes
1answer
152 views

Find out feature version for list's content type

I have a feature which contains a custom content type. I've created a list based on this content type then proceeded into changing the feature version and performing an upgrade. I have ...
1
vote
1answer
744 views

Upgrade from 2007 to 2010 error on custom web parts

We have several SharePoint 2007 farms with several site collections in certain databases. The desire is to be able to migrate these 2007 site collections to our new 2010 farm envirionment. The best ...
1
vote
2answers
389 views

SharePoint 2007 - SharePoint2010 Migration — Giving Issues

I am getting issues while migrating SP2007 - SP2010. Below are the steps I have followed as part of SharePoint data migration: I used two different systems and installed MSSQL 2005 & SharePoint ...
2
votes
1answer
218 views

Strange behavior opening items from view after upgrade SP1 2010

After installation of SP1 for SP2010, the items in libraries no longer displayed in a dialog. On the list is indicated that the items should be displayed in a dialog. After research I found out when ...
1
vote
2answers
2k views

How can I solve “A SharePoint database named [xxx] already exists” when upgrading from SharePoint 2003 to 2007?

I am trying to upgrade a SharePoint 2003 web application to MOSS 2007 through the database attach method. I am following these steps as outlined by Microsoft: Create web application in MOSS 2007 ...
2
votes
1answer
1k views

Fab 40 Test-SPContentDatabase Upgrade Missing Assembly Error

I'm getting a Fab 40 related MissingAssembly error in the output of Test-SPContentDatabase. The strange part is that the version number of the assembly referenced in the output is incorrect. ...
0
votes
3answers
372 views

Post-Service Pack 1, Broken Web Applications (User Profile Sync)

I had a clean environment prior to installing service pack 1 and the June CUs. User Profile Sync is up and running, and synchronizing, but all web applications are throwing a SharePoint error. Digging ...
1
vote
0answers
102 views

Application Page 404 - Upgrade from 2007 to 2010

In a 2007 Publishing site developed for a client I deployed some custom pages to URL /CustomPages/Programmes.aspx (rather than application pages going in _Layout). The site custom master page was used ...
1
vote
2answers
1k views

Masterpage upgrade from 2007 to 2010 while still supporting 2007

I'm currently upgrading a SharePoint site with a custom master page from 2007 to 2010. We want to be able to let the user decide when to migrate their site from 2007 L&F to 2010 L&F using the ...
0
votes
1answer
331 views

SSP Database Upgraded from 2007 to 2010, My Links automatically deleted shortly after

I follow the steps here to upgrade a 2007 SSP database to 2010: http://technet.microsoft.com/en-us/library/cc263299.aspx#SSP After the upgrade everything appears successful and users can see their ...
1
vote
1answer
186 views

After upgrade from 2007 to 2010 - Field Duplicate when trying to add feature

I upgraded a sharepoint from 2007 to 2010 with attaching the content database. After that i developed a new solution with the same content type i used in 2007. Adding the solution works fine but ...
0
votes
3answers
667 views

“A previous installation has been detected with a license type does not match the install in progress” Error when upgrading to SP2010

I am trying to upgrade Sharepoint server 2007 (Enterprise CALs) to SP2010. I'm using the SP2010 evaluation package from Microsoft along with the included license keys. When the upgrade process ...
0
votes
1answer
2k views

Why am I getting “Server error: http://go.microsoft.com/fwlink?LinkID=177673” after doing a database-attach upgrade

I have a massive MOSS content database that I'm trying to upgrade to 2010 via a database attach. After the process is complete, I get "Server error: http://go.microsoft.com/fwlink?LinkID=177673" when ...
0
votes
1answer
156 views

Can I make calendar items link to data view page?

We currently upgraded from 2007 to 2010 and I'm having problems with the calendar. In 2007 I was able to change that the calendar items would link to a custom data view I created. Here is our 2007 ...
1
vote
2answers
106 views

SharePoint 2010 Opinions and Alternatives

My company has been using SharePoint WSS 3.0 for 2-3 years and we've recently upgraded to SharePoint Foundation 2010. Our use of SharePoint started in IT and has gradually moved into other areas of ...
1
vote
2answers
1k views

Test-spcontentdatabase returns The server instance of the database could not be found

I am trying to run Test-spcontentdatabase on a MOSS database on a SQL server (2008 R2). When I run it I get "The server instance of the database could not be found." The ULS has no more information ...
5
votes
11answers
23k views

Sharepoint Server 2010 SP1 PSConfig issue

I've download (KB 2460045) and install the sp1 for SPS2010, so far so good. To complete the process -SQL upgrade- I must run the SP2010 Products Configuration Wizard (psconfig), but in the last step a ...
1
vote
1answer
119 views

WSS 3 on SBS 2003

I just recently identified that upgrading WSS 2 to WSS 3 on SBS 2003 is not supported. I need to plan the best approach to get a client using WSS 3 with the current SBS 2003 environment. It is a ...
1
vote
6answers
1k views

Missing 1033 Directory in SharePoint 2010 URLs

I seem to be missing a '1033' directory for my SharePoint 2010 installation. Here's the full details: We upgraded from SP2007 to SP2010 using the database attach method. Some resources have a 1033 ...
0
votes
2answers
232 views

Users denied access after solution redeployment

My old solution has been running in my intranet farm for a long time. The solution contains a feature which deploys a webpart. The webpart shows the users of a group, together with information from ...
5
votes
3answers
2k views

Failed 2010 SP1 Upgrade

Anyone have an idea? I am trying to upgrade on Win7 Development box 06/30/2011 11:11:20 8 ERR Task upgrade has failed with a PostSetupConfigurationTaskException An exception of type ...
0
votes
2answers
138 views

Missing Sharepoint Definition

I am having trouble deleting a rogue site definition found after running stsadm preupdatecheck. I have run stsadm -o enumallwebs and have found where the template is used. The trouble is that URL ...
2
votes
1answer
363 views

Why do I have folders called “1” in my document library after an upgrade to 2010?

We upgraded our MOSS2007 to MSS2010 (database attach upgrade method). We have multiple document libraries on a site. default.aspx contains web parts with the files from document libraries. The files ...
1
vote
0answers
363 views

Weird top link bar after upgrading WSS2 to WSS3

Installed WSS2 on server 2003, not customized or changed, upgraded to WSS3 and the top link bar (home, documentation etc..) is vertical and appears to be broken. This looked the same before I changed ...