Transport Layer Security (TLS) and its predecessor, Secure Sockets Layer (SSL), are cryptographic protocols that provide communication security over the Internet.[

learn more… | top users | synonyms

5
votes
1answer
405 views

SoapException: Possible SOAP version mismatch, accessing SSL enabled site

When I execute the following code: var context = new ClientContext("https://somehost/somesite"); FormsAuthenticationLoginInfo login = new FormsAuthenticationLoginInfo("jesuslogin", "mypassword"); ...
4
votes
2answers
5k views

Configuring SSL certificate for SharePoint 2013 on Windows Server 2008

I'm trying to configure my SSL certificate for my SharePoint site. I'm using this site : http://blogs.msdn.com/b/fabdulwahab/archive/2013/01/21/configure-ssl-for-sharepoint-2013.aspx I'm stuck on step ...
4
votes
1answer
305 views

Claims Auth, ADFS & Subject Alternate names

I currently have a wildcard cert *name.com with several subject alternate names. Inside the subject alternate names, there is an entry for name.net and several other variations. The URL of my ...
3
votes
4answers
7k views

Multiple web applications using SSL on one IP

Setting up my test farm I have a scratch server that i've set up everything on except office web apps, i have that running on another server. I was finally able yesterday to configure a connection ...
3
votes
3answers
5k views

A certificate validation operation took milliseconds and has exceeded the execution time threshold

I have a SharePoint 2013 Farm which is behind a secure firewall and has no internet access which includes a Web Application running over SSL. We keep seeing the following error in the SharePoint ULS ...
3
votes
1answer
617 views

SSL and Forms Based Authentication in WSS 3.0

I have a FBA application and we would like to use SSL with it. By default, does setting SSL in IIS use SSL for the entire site, or just the login? We think we'd like to use SSL for the entire visit ...
3
votes
1answer
2k views

Sharepoint 2013 sharepoint-hosted app domain configuration over https

I'm trying to configure SharePoint 2013 environment for both type of apps provider- and sharepoint-hosted. I was able to do it based on http, however switching to https causes me trouble. I have fully ...
3
votes
2answers
903 views

Losing SSL Certificate in IIS every night

After configuring IIS so that our SharePoint (Topology) Web Service is bound to a SSL certificate, we have successfully tested it in a load balancing scenario. However, we are finding that the ...
2
votes
2answers
107 views

how to apply multiple SSL certificates to multiple sites

I have one web application in which I have two external sites : Mydomain.co.uk -internet zone mydomain.com-intranet zone And I have two certificates available with me which I purchased for this ...
2
votes
1answer
6k views

SharePoint 2013 and Office Web Apps - Unable to view documents

We have a Web Applications Companion (WAC) server connected to our SharePoint 2013 web application (upgraded to claims based authentication). It appears to us that the WAC server does not trust the ...
2
votes
2answers
398 views

AAM and SSL over the same Web Application

Scenario: One web application in a port 8080, extended to the zone extranet for the purpose of the activation of the SSL layer on port 8180. The default zone is for anonymous access and, once the user ...
2
votes
1answer
260 views

Search Scope and HTTPS Proxy

We have a farm that sits behind a Forefront UAG server doing SSL termination. Traffic from the farm is un-encrypted over port 80 to the UAG server. The UAG server then sends the traffic encrypted over ...
2
votes
2answers
608 views

Why am I receiving an error when trying to view a report in the report viewer webpart?

I am having trouble viewing reports in our company's SharePoint site using the report viewer webpart. Here are the version details: SSRS 2008, MOSS 2007, IE9, Win 7 32-bit. I can view the Sharepoint ...
2
votes
2answers
773 views

People Results and Thumbnail previews not working in Fast Search Server for SharePoint 2010

My site uses SSL. I am getting the following error in the Application log: An operation failed because the following certificate has validation errors: Subject Name: CN=www.mycompany.net, ...
2
votes
1answer
1k views

Problem with OneDrive and Sites links after migrating Sharepoint 2013 from HTTP to HTTPS

I created a Sharepoint test environment with HTTP originally. Now I am switching everything over to SSL. I had both a "home" web application for the main collaboration site, and a my sites web ...
2
votes
2answers
513 views

Favicon not working in Sharepoint 2013 SSL site

I'm working on a branding project and I'm unable to get a favicon to display on an internal SSL Sharepoint 2013 site. If I access the site via http://servername:xxxx the favicon displays fine so I ...
2
votes
2answers
3k views

Cannot open Office file types directly from server

I have a big problem, in my Sharepoint site when I am trying to open Excel files in document library, it shows " access the web server by default disabled. It uses basic authentication but it does not ...
2
votes
1answer
829 views

Firefox connection reset over hardware load balancing and SSL

We have set up farm with 3 WFE's. Web apps are load balanced by hardware balancer with SSL. Assuming that our web site is https://www.foo.bar, we have our applications configured as follows: HTTP ...
2
votes
0answers
130 views

Data Source file cannot be saved Soap Service Connection

I am trying to Get List Items using SharePoint Designer 2013 Soap Service Data Source. I have entered Service description as https://sitesurl/_vti_bin/lists.asmx?WSDL listName ...
2
votes
0answers
68 views

Sharepoint 2010 http webapp redirected to wrong webapp when using https

I am facing a specific probelm on a Server2008R2 & Sharepoint 2010 setup. On the System there are multiple Webapps, but only one must be configured with SSL on port 443. the others remain on port ...
2
votes
0answers
457 views

ssl certificate error when using Client object model

I wrote an app that gets information from some Sharepoint 2010 lists and displays it to the user. It works fine on my development machine.But when I copied the exe to another desktop machine i got the ...
2
votes
2answers
2k views

Event IDs 8311, 6803, 6110, and 6801 after new SSL certs installed and December CU

About a week ago I installed new SSL certificates. Few days I configured the export thumbnailPhoto attribute for the User Profile Sync. I've never actually been able to successfully export the photos ...
1
vote
1answer
2k views

SSL Offloading in 2013

For my web front end's I plan to put the two of them against a load balancer (netscaler) the admin i'm working with gave me the option to Offload SSL on the load balancer...in 2010 I would have said ...
1
vote
2answers
652 views

SSL redirect and AAM not working on a Workflow which is using the original/install URL

A year ago, I created our SharePoint site under a test name. I then added an AAM to extend it to our production name. Just a month ago, I added an SSL redirect in IIS which sends all http requests ...
1
vote
1answer
25 views

Why am I unable to crawl people over SSL / HTTPS?

If I attempt to perform a crawl of a people content source using a path like sps3://mysites I get an error such as the following: The URL of the item could not be resolved. The repository might be ...
1
vote
1answer
47 views

SSL on SharePoint

I am facing some problems on SharePoint. I've got a SharePoint site (let's say HTTP : //intranet.domain.be) We wanted to use this intranet from outside. So we decided to set an Extranet (HTTPS : ...
1
vote
1answer
2k views

Open with Explorer via SSL with SNI

I am trying to get a developer site up and running that uses SSL only with 3 web applications that use SNI. Everything except "openwith explorer" The error I get is: We're having a problem ...
1
vote
1answer
1k views

Extend SharePoint 2010 web application to use https(SSL)

I have a SharePoint 2010 web application which uses Claims based authentication with NTLM and the site is published to TMG. After completing this process a few days later we installed SSL certificates ...
1
vote
1answer
230 views

Is it possible to implement SSL/HTTPS on a SharePoint site thats not running on port 80?

I'm finding this concept a rather confusing perhaps or may be this is a very basic question. I have a sharepoint web application running on port 90 and have got a SSL certificate. Lets say : ...
1
vote
1answer
6k views

Outlook/SharePoint calendar sync 'error occurred connecting to site'

Our SharePoint site was originally setup under a test name (oldname). When brought into production, I added an AAM to extend it to our production name (prodname). About 6 months ago, I added an SSL ...
1
vote
1answer
1k views

InfoPath Form and SSL Cert Error

I have an InfoPath form that fetches the current user's name, account, manager, etc.. from AD on form load. Everything works well in the client, how ever when I publish the form to or SharePoint ...
1
vote
2answers
910 views

Sharepoint Web performance optimization

We are running on SSL on following server topology: - 1 ISA (SSL Terminate/cache/proxy+AD authentication) - 1 Sharepoint - 1 IBM DB2 Database - enterprise/corporate DB - 1 MS SQL Server - local DB ...
1
vote
1answer
46 views

Impact of not updating default AAM when changing from http to https

Usually when you first setup the SharePoint web app you do not have the SSL certificate. So, you setup the SharePoint web app using http:/foo.com Later on you get the SSL, and update the bindings in ...
1
vote
2answers
2k views

Could Not Establish trust relationship for the SSL/TLS secure channel Sharepoint Web services

I am trying to updateList items into a sharepoint list from the xml document stored in my shared drive in remote server. To make that work i wrote down a Powershell Script that utilizes Sharepoint ...
1
vote
1answer
2k views

Open in Explorer View Using SSL

In a previous post, I was exploring using the Open With Explorer button with SNI enabled, and we came to the likely conclusion that this is not a supported configuration. After researching that, I ...
1
vote
1answer
368 views

Install SSL on SharePoint

I am little confused about how SSL works in SharePoint. We have a portal site (say portal.abc.com). I need to enable SSL on this web application ...
1
vote
1answer
582 views

Documents opening in read only SharePoint/Office 2010

I recently switched SharePoint 2010 from http to https using URL rewrite and a purchased wildcard certificate. Since then, any time a user attempts to Edit Document in Application (i.e. Word, Excel, ...
1
vote
2answers
635 views

authentication between host-named site collection, https and http

Here's my situation and I'm wondering what the best way to solve it is. I have two domains and I'm trying to pass credentials between them. Maybe it's not possible, but here goes...... Domain One ...
1
vote
1answer
1k views

Cannot open document for editing in Sharepoint (MOSS 2007)

I am experiencing a frustrating issue when I try to check out a document for editing in one of our Sharepoint sites (running MOSS 2007, Office 2010, IE9, Win 7 32 bit SP1), when I try to open the ...
1
vote
1answer
151 views

SSL certificate for MOSS public site?

I have a sharepoint web application accessible online (public IP) thru windows auth on port 81 and extended to port 80 and is accessible anonymously. now i need to secure the portal using SSL. https ...
1
vote
3answers
1k views

SharePoint 2010 Central Administration over SSL

How can you change the SharePoint 2010 Central Administration site so that it works over SSL, rather than a random port over http? Other sites on the server may also use SSL, so would use a host ...
1
vote
0answers
29 views

Benefits and drawbacks of using the SNI extensions with SSL

We're in the middle of evaluating what the best way to encrypt all our web applications in SharePoint would be. We have taken into account what different types of certificates there are and their ...
1
vote
1answer
32 views

What effect would it make if the SSLv3 protocal is disabled in a SharePoint site?

I have come across a situation where I need to decide whether to disable the SSLV3 protocal in the SharePoint site. I have not come across any answers yet.
1
vote
0answers
124 views

SharePoint 2013 and SSL Offload / Termination

I'm trying to configure my SharePoint to allow SSL Offload. I have a My Sites Host web app created on port 80 (without SSL) and I have configured Alternative Access Mapping to support the SSL Offload: ...
1
vote
2answers
302 views

Renewed Server Certificate and Crawl fails

We renewed our expiring server certificates and now our search crawls are failing. The error we get is: The secure sockets layer (SSL) certificate sent by the server was invalid and this item ...
1
vote
1answer
133 views

Get the public URL of the current page when using off box ssl termination

If you're using off box SSL Termination with SharePoint how do you determine the Public URL of the current page the url the user has in the browser) e.g. Browser : httpS://sharepoint/somesite SSL ...
1
vote
0answers
81 views

How to retrieve the user account associated to a client certificate on SharePoint 2013

I’m searching for a while but I don’t find any answer to my problem. So now, i'm confused ... I hope to find an answer thanks to you. On SharePoint 2013, I configured FBA with a custom login page. ...
1
vote
0answers
346 views

Share Point 2013 url resolve after web app extend

I have deployed SP 2013 WA in intranet with http://abc.de.fg that is working fine, after that I have extended that WA to https://kl.mn.op all are working fine but pictures and some html links are ...
1
vote
0answers
680 views

UAG not redirecting SilverLight Org Chart Pic Links

We have a ForeFront UAG server publishing two SP 2010 web apps externally. The first is the portal site, and the second is My Sites. UAG is terminating SSL and is also redirecting any port 80 ...
1
vote
1answer
174 views

HNSC, SSL and Mixed Content

I have setup a Multi-Tenancy Farm and everything seems to be working fine except for the fact that I'm getting Mixed Content when viewing my Site through SSL. The SSL is being offloaded to the load ...