1
vote
1answer
25 views

Deploy wsp without logging to SP server

Can i deploy a wsp using powershell batch file without logging to the sp server ?
0
votes
1answer
18 views

What does “Synchronize” paramter of Install-SPSolution do?

Install-SPSolution command can accept an optional Synchronize parameter. MSDN says that it "synchronizes all solutions or the specified solution in the local farm". But what does this mean? What ...
0
votes
2answers
42 views

Which of the foll. powershell script is correct way to install a timer job into SharePoint?

1: install-spsolution Solution.wsp -webapplication "webapplication" -GACDeployment –force 2: install-spsolution Solution.wsp -GACDeployment –force Which of above is best practice?
1
vote
1answer
288 views

Download/Export solution from site solution gallery

I'm trying to automate the process of downloading one solution and then add/install the same solution to other site collections. The first thing to do would be to download the freshly created solution ...
0
votes
1answer
107 views

Error while deploying WSP through SP 2010 Management Shell

I am trying to deploy a wsp through SP 2010 Mgmt Shell but every time it throws an error: This is the script that I am running: Add-SPSolution -LiteralPath "E:\QD Survey 2013-01-10\QDSurvey.wsp"
1
vote
1answer
141 views

Windows PowerShell Vs. SharePoint PowerShell for Deployments

I am using Windows Server 2008 R2 with SharePoint 2010. I see two PowerShell tools on this machine: Windows PowerShell and the SharePoint 2010 Management Shell. Does anyone know the difference? Can ...
3
votes
4answers
14k views

How do I update an already existing wsp on farm? [duplicate]

Possible Duplicate: Update-SPSolution does not Deploy Solution I have a wsp that is already deployed on the farm. I made some code changes. I cannot use the Add-SPSolution command because I ...
3
votes
2answers
4k views

What's wrong with Uninstall-SPSolution and AllWebApplications parameter?

When I try to uninstall WSP with following line, everything is ok: Uninstall-SPSolution project.wsp # no error - OK When I try to add switch parameter -AllWebApplications, I get error (something ...
1
vote
4answers
4k views

Detecting Solution Deploying Status

I am Looking for a way to detect if the a solution is deploying the following code does not seem to return "Deploying" like I see in central admin. $wspID = Get-SPSolution -Identity 'mysolution.wsp'; ...
0
votes
2answers
4k views

Solution Deployed Successfully but Web parts not available

I'm running into a deployment problem in my sharepoint 2010 environment. I built a small 'Hello World' type web part in visual studio 2010 and then deployed to my development environment via visual ...
1
vote
2answers
1k views

This powershell runs but why is it so slow

I ran this powershell which automates wsp addition, activate, deploy web parts and it runs fine. However, it takes about 3 minutes to go through the whole process. Is this norm? = = = powershell code ...
2
votes
3answers
6k views

SharePoint 2010 - Install Site Template using Powershell script

I want to install site template in SharePoint 2010. Basically i want to know how use install-spwebtemplate wsp name : SPT_SiteTemplate.wsp Name : SPT_SiteTemplate
6
votes
1answer
2k views

Problem installing web part using Powershell

We've developed a custom Visual Web Part using Visual Studio 2010 for Sharepoint 2010 Server. The webpart gets deployed when executed from VS (F5), so we can add it wherever we want using Sharepoint ...
6
votes
2answers
959 views

How to reproduce Visual Studio “Deploy” action?

It seems like whenever I am developing a web part and I "Deploy" it from Visual Studio, everything gets deployed and works exactly as I would expect. When I take my WSP and try to install it to a ...
3
votes
2answers
5k views

Adding a WSP through the Management Shell?

I have a WSP that I am trying to install on my development SharePoint server. I used the Management Shell to do this: Add-SPSolution -LiteralPath c:\temp\mySolution.wsp and then: ...
2
votes
3answers
11k views

Install-SPSolution : This solution contains no resources scoped for a Web application and cannot be deployed to a particular Web application

I have a powershell script that deploys about 12 web parts. They have all been created in the manner through visual studio 2010 and are being deployed to sharepoint 2010. I am getting the following ...