0
votes
2answers
28 views

Upgrading solution 2007 from the 2010 package

I have a small issue or a big one ... So I have a SharePoint 2007 where a solution build in visual studio 2008 is deployed. Recently i've started to develop in 2010, i converted the solution to the ...
0
votes
2answers
105 views

How do you deploy a custom web service within a WSP file?

I can deploy my assembly in a wsp to our MOSS 2007 server but I can't seem to find any information about how to automatically deploy my .asmx, disco.aspx and wdsl.aspx files at the same time. Is this ...
2
votes
1answer
38 views

Adding and Deploying Multiple solutions in SharePoint 2007

I have got around 10's of webpart solutions that I need to add and then deploy to all web applications, I would prefer if someone can share easiest way of doing it.
0
votes
1answer
110 views

WSP Builder copies dlls to solution regardless of “Copy Local” property set to False or not

I have a Custom timer job that references few custom dlls, now if I set copy local property of these dlls to false, it stills adds them and when I deploy solution it forces them into Gac. Is there ...
0
votes
1answer
59 views

I have a site Template , I want to create another site template based on this template but using different Master Page

I have a Site Template A .wsp file, I want to create another Site Template B based on Site Template A but I want it have a different Master Page. I know how to do it in a site definition but I dont ...
1
vote
1answer
390 views

How to create a WSP file without using wspbuilder for Site Definition

I have a folder with following structure, I wonder how can I create a wsp file for it, and it deploy the site definition for me, structure - XML - -> ONET.xml - default.aspx - ...
2
votes
2answers
4k views

Making a cab file with ddf (to create a wsp solution package)

I am trying to Create a ddf file for my custom list feature using tutorial given in this link Create a wsp using ddf but in this link there isn't enough Information like what is the directory ...
1
vote
1answer
400 views

Error Deploying Solution - returns The feature path 'myfeaturename' must be of the form 'directory/feature.xml'

Let me start out by saying I'm sure WSP builder or STSdev is the way to go, but I can't use those where I work, so I'm having to do this all manually. So here's where I am. I have created a simple ...
0
votes
1answer
233 views

SharePoint 2007, WSP solution is not deploying to Global Assembly Cache

I have a standard WSP package with a single assembly that is deployed to the GAC. We have 2 versions of packages, both with the same assembly version and assembly file version. Version 1 installs ...
1
vote
2answers
586 views

Multiple workflows in a sharepoint feature

Really simple - I'm wondering if it's possible to pack multiple custom workflows in a single wsp-solution/feature. I thought I could just create the workflows, and then add multiple instances of ...
1
vote
1answer
156 views

SharePoint list template repackaged, forms now unavailable (“cannot get ghost document”)

I had a SharePoint solution with a number of features packaged inside. I can't list them here, but it looked something like this: Features (Scope): (Site) MyDocument Content Type (Site) Log List ...
1
vote
2answers
526 views

DWP file is not updated in the web part gallery by the stsadm upgradesolution command

I am trying to update a DWP file in the web part gallery by using stsadm upgradesolution. Here is what I am doing: Created a web part, put it in feature, packaged it in solution by WSPBuilder, ...
1
vote
2answers
96 views

How to deploy a LOT of solutions between SharePoint 2007 and 2010 Farms

Right now we're moving from a SharePoint 2007 and SharePoint 2010 farm, my current list of solutions implemented in the 2007 farm numbers somewhere in the 100's. A few ideas I had for moving them ...
0
votes
1answer
1k views

WebPart not registered as safe

I have a webpart that is part of a larger solution, deployed as a WSP using WSPBuilder. I can see the SafeControl entry in the web.config and can see that the assembly has deployed to the GAC. The ...
2
votes
2answers
868 views

Problems with WSP Deployment

We have a server farm that is having issues deploying WSPs. The odd thing is that the server goes through all the motions of deploying the WSPs with no errors. That is, the job is scheduled ...
1
vote
3answers
227 views

What is best practice for deploying third party SharePoint 2007 solutions?

I want to know what to look for and what to do (both from a developer and IT admin point of view) before installing a third party solution into a SharePoint 2007 farm? Is there a checklist that I ...
1
vote
3answers
963 views

InfoPath form status stuck on “Installing”

I have followed many of the recommended practices to install an InfoPath form that needs Administrative approval (see this link). However, I am still unable to see the form finally complete it's ...
4
votes
2answers
270 views

How can I compare WFEs to ensure a WSP was deployed succesfully?

I'm a sharepoint 2007 administrator. We are running with two WFE and deployed a wsp package recently, we suspect that the deployment was not completely successful. we would like to compare the WSPs ...
3
votes
2answers
660 views

Deploying all components of an InfoPath form plus managed code as a solution

Has anyone successfully packaged up an InfoPath form solution with the following features? Custom site columns for properties promoted from form Custom content types to be associated with form ...