is deployment of a wsp-package to a SharePoint farm or one of its servers.

learn more… | top users | synonyms

1
vote
1answer
17 views

Muilti deploy DLLs from external Projects into single WSP

I'm trying to build a single .WSP that should contains multiple DLLs from External projects. I've been following that this tutorial: Link I've followed all steps but on deploy , DLLS doesn't appear ...
1
vote
1answer
101 views

Problem with SP2013 solution scope: WebApplication vs GAC

I have a SP2013 solution that contains a custom WCF service, custom Timer Job and a Feature Event Reciever. Because of these the solution Assembly Deploying Target is set to GlobalAssemblyCache. The ...
1
vote
1answer
39 views

How many ways we can deploy any solution in moss?

What all different ways available to deploy any custom solution in moss. Which is the best practice to follow while deploying solution?
1
vote
1answer
328 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
0
votes
1answer
24 views

SP2013 Custom Workflow Deployment issues

I have a custom sequential workflow that works fine when deployed from Visual Studio in my development environment. To deploy to the test environment I follow the following procedure Deactivate ...
0
votes
1answer
25 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
0
votes
1answer
99 views

Deployment Issue with Custom FIeld Types

SHORT DESCRIPTION Custom Field Types are not being correctly deployed/activated on all but one Virtual Machine. I have several VMs with identical SharePoint environments. I have a Visual Studio ...
0
votes
1answer
97 views

How to find images & javascripts of SandBox solution deployment?

I have deployed SandBox Solution to my SharePoint Server. After deployment When I open the site in browser, it displays the images of the Site but not working of JavaScript file. (I have given the ...
0
votes
1answer
117 views

Site is not available through the browser, inetpub folder is empty

Visual Studio generated an error saying that the file web.config is not found when I deploy solution. After that the folder inetpub\wwwroot\wss\VirtualDirectories\80 was empty at all. Also the site is ...
0
votes
1answer
82 views

How to create single SharePoint Installer using SharePoint 2010 Solution Installer?

I have 1 Visual Studio Solution which contains 3 different Projects. 1 for EventReceiver and 2 for UI(WebParts) projects. I want to create single Setup file for all sothat I can deploy it on any ...
2
votes
0answers
41 views

Moving multiple WSP solutions in to one WSP solution

We have tree solutions that we are deploying by retract deploy approach. One problem is that two of the solutions deploys as global solutions, on is web application scoped. This recycles all the web ...
2
votes
0answers
49 views

Change logic for event receivers in an already deployed solution

I have a sandbox solution that has list schemas, visual web parts, custom pages and actions, workflows and a couple event receivers. Yes, one big mess of a thing, but I needed to pack everything up in ...
2
votes
0answers
152 views

Error on Custom Sitemap Provider

I've come across an odd scenario and I'm drawing a blank. Perhaps one of my peers here will have an idea. We have a custom navigation solution which consumes and builds on the OOTB navigation ...
1
vote
0answers
9 views

TypeLoadException in ULS log on retract and deploy

When I retract or deploy a SP2010 solution, I get the following message in the ULS: TypeLoadException: Could not load file or assembly 'Microsoft.SharePoint.ApplicationPages, Version=14.0.0.0, ...
1
vote
0answers
96 views

Missing “Deploy”-Button Visual Studio 2012

Yesterday I have installed Visual Studio 2012 Premium on my SharePoint 2013 Development Machine. I also installed the Office Developer Tools to get the SP2013 Project templates. Opening my SP 2010 ...
1
vote
0answers
75 views

2010 - Update-SPSolution required after solution installed?

I created a new feature and performed a Uninstall/Remove/Add/Install-SPSolution using PowerShell to deploy it. The solution deployed correctly and the feature was added to the 14 hive, but did not ...
1
vote
0answers
27 views

What is SPXmlDocCache & SPXmlDocCacheRefreshSentinel

I am getting UpdatedConcurrencyException: The object SPXmlDocCacheRefreshSentinel was updated by another user. in ULS during a web application scoped feature uninstall (as part of a solution ...
1
vote
0answers
41 views

'-LOCAL' solution deployment across multi server farm

I've deployed numerous solutions before but I'm trying to do a 'zero downtime' deployment on a 4 server farm. My question is about what happens in the background when deploying with the -local ...
1
vote
0answers
207 views

how to maintain workflow task list data when retracting or removing workflow association

whenever i try to remove workflow association or retract workflow solution (.wsp) all associated task list data also gets deleted. i want to prevent this behavior as task list data is important for ...
1
vote
0answers
97 views

Help understand ContentType/List upgrade

Everywhere i read on the web it says that Content Types and List once deployed through Xml files they cannot be updated anymore. I have created a VS 2010 solution, created a SharePoint List ...
1
vote
0answers
65 views

Everytime I try to add an existing or new project to my SharePoint 2010 Solution it says “File not Found”

Everytime I try to add a class library to my SharePoint 2010 solution (which consists of about 4 other projects), I get the error: Could not load file or assembly 'AF.XMLMapping, Version=1.0.0.0, ...
0
votes
0answers
13 views

Error while deploying List Definition and List Instance in SharePoint 2013

I have two features, first feature deploys custom columns and custom content types. Second feature deploys list instance and list definition. But I got following error when I retract solution first ...
0
votes
0answers
29 views

Sharepoint - Visual Studio 2012 Deploy problem

I'm having a problem, when I deploy my solution through VS2012 it looks like it wont update what I already have deployed, the changes I make on code wont take effect. I have the following scenario: 1 ...
0
votes
0answers
30 views

Deploy works from Visual Studio, get security exception from Site Collection Features. SP 2010

I have a solution that creates a new send to connection for a web application. When deploying from visual studio the feature get activated with no errors and creates the connection. When I try to ...
0
votes
0answers
36 views

Prevent removing ItemStyle.xsl when retracting solution

I'm working on a solution which requires me to override the default ItemStyle.xsl as well as the ContentQueryMain.xsl files. What I'm interested in knowing is; is there a way to prevent the files ...
0
votes
0answers
19 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
0
votes
0answers
21 views

SharePoint Feature Packaging and Projects in Visual Studio

I have two projects (project 1 and project 2) in a SharePoint solution in Visual Studio. I would like to use the project 1 to create a wsp package to include the site-level features in both projects. ...
0
votes
0answers
63 views

Custom Feature Compatibility from SP2010 to SP2013 Question

I have a question concerning the compatibility of my SP2010 custom features in SP2013. Here is my setup: I have a wide range of Farm, Site, and Web features that all interact with each other in a ...
0
votes
0answers
42 views

When running solution deployment through a remote shell, solution deployment hangs

I have a remote shell (using PowerShell) running a solution deployment on SharePoint 2010. It hangs on the deployment and never finishes deploying. When I do this locally from the box, there are no ...
0
votes
0answers
26 views

Issues in Deployment of Custom timer service job in share point 2010

I have created a custom timer service job in share point 2010. I have wrapped it inside a wsp with scope 'Site'.It works fine on development server, but I am facing problems in deployment on ...
0
votes
0answers
314 views

Failed to connect to an IPC Port: Access is denied. How to resolve?

When attempting to upgrade a sharepoint 2007 solution I am getting the following error: Timer job successfully created. E:\wsps>stsadm -o execadmsvcjobs Executing .Executing ...
0
votes
0answers
258 views

Why am I getting this error? “Incompatible Web Part markup detected. Use *.dwp Web Part XML instead of *.webpart Web Part XML.”

I created a WebPart in Visual Studio 2010 and made the necessary changes to make it work in MOSS 2007. The webpart was working just fine, but I had to remove a couple webparts from the project, so I ...
0
votes
0answers
79 views

WSP deployment repeats last characters of a file

I have a weird issue with deployment of a WSP file. A little background info: The Visual Studio solutions consists of 28 projects (don't ask... I inherited it :-)) of which 26 files generate a WSP ...
0
votes
0answers
68 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...