is deployment of a wsp-package to a SharePoint farm or one of its servers.

learn more… | top users | synonyms

0
votes
0answers
45 views

Deploying .wsp packages

Here is my problem, after I update the .wsp packages, the status became "error". This happened to me before, and the quick fix that I did is to remove the solution, then add and deploy it again. I ...
0
votes
1answer
818 views

Fail to activate SharePoint.Foundation.Publishing.2013.wsp on my collection site

I downloaded a hand-made equivalent to the SharePoint Server 2013 Publishing Feature here SharePoint Foundation 2013 Publishing Infrastructure. i'm on a single farm, running a SP Foundation 2013 with ...
5
votes
0answers
43 views

Multiple app parts re-deployment issue in SharePoint 2013

I am working in SharePoint 2013 and i have my solution with 20 app parts. I have also configured several pages (filled with data) using these app parts. The issue is when i redeploy it after making ...
0
votes
1answer
749 views

how to build wsp in visual studio 2012 without actually deploying the project

I am trying to create a wsp for my project in visual studio 2012. when i build my project it is not creating a wsp only when i deploy my project it is creating a wsp in my bin/debug folder. Is there ...
0
votes
3answers
976 views

SharePoint 2010 solution package not deploying to all servers

Having an issue with deploying a WSP to our farm (2 WFEs, 2 App servers). When I try to run Install-SPSolution <packagename> -WebApplication <appurl> -GACDeployment -Force, the timer jobs ...
0
votes
1answer
25 views

Upgrading Site Templates in the Solution Gallery

How do I use the Upgrade button in the solutions gallery for a site template I've created? The word "upgrade" is forever associated with migration from 2010 to 2013, but unable to find prompt ...
0
votes
1answer
167 views

workflow inactive - after deployment?

my workflow is deployed through the following script in SharePoint 2010: # Set CurrentDirectory $callingDir = Split-Path -Parent $MyInvocation.MyCommand.Path [Environment]::CurrentDirectory = $...
0
votes
2answers
67 views

Error occurred in deployment step 'Add Solution' Sharepoint 2013

My machine shutdown when I was taking the solution backup. Then I started, I coudn't deploy the solution code from visual studio saying Error occurred in deployment step 'Add Solution': <nativehr&...
0
votes
0answers
25 views

Error deploying in production ONLY

I have a SharePoint solution, consisted of 2 features. The first feature is consisted of 5 SharePoint 2010 workflows, and some web pages. The second one is empty and has a feature event receiver that ...
0
votes
1answer
40 views

Moving Custom solutions in SP 2010 to new SP 2013 Farm

How can we successfully deploy/move all custom solutions (custom visual web parts, event receivers, custom workflows, Administrative Full-Trust InfoPath forms, etc.) developed for SharePoint 2010 to ...
0
votes
0answers
29 views

WSP on O365 activation

I prepared test WSP sandbox solution in Visual Studio 2012. Contains 1 web part "Hello", [ToolboxItemAttribute(false)] public class WP_Hello : WebPart { Literal lt; Button ...
0
votes
1answer
79 views

install-spsolution really stuck on “deploying”

Im trying to deploy a wsp on a Sp2013-farm. Ive tried restarting all sptimer-services on all machines, restarted admin service on all machines, restarted all machines, recycled service (iis) app pool, ...
0
votes
0answers
77 views

Sharepoint 2013 app deployment error - The operation has timed out

I have developed SharePoint 2013 apps(Office 365). All the app parts were working properly, but suddenly i am getting the following error, if i am trying to deploy it: Error 147 Error occurred in ...
1
vote
2answers
1k views

ActivityNotFoundException during feature activation

I have a workflow 2013 included in Full trust solution (WSP). When I add a variable of type DynamicValue to the workflow and try to deploy the solution using VS 2012 I get the error during feature ...
0
votes
1answer
17 views

Error occurred in deployment step 'Add Solution': Data at the root level is invalid. Line 1, position 1070

i'm trying to develop App using visual studio on but when i try to deploy the app this error pop out in visual studio error. i was reading for the last few hours trying to find a solution but no joy ...
1
vote
2answers
2k views

Download/Export solution from site solution gallery

I'm trying to automate the process of downloading one solution and then add/install the same solution to other site collections. The first thing to do would be to download the freshly created solution ...
23
votes
5answers
32k views

Feature has already been installed. Use the force attribute to explicitly re-install the feature

We have several SharePoint 2010 solutions which we want to deploy to SharePoint 2013 with Visual Studio 2012 running on Windows Server 2012. Site solutions work. But farm solutions just don't. I get ...
1
vote
1answer
61 views

Deploy a WSP that is built on Teamsite to Publishing Site

SharePoint 2013, We have developed WSP for a TeamSite but due to requirement change client want to have publishing site. I wonder what I need to do to deploy the same WSP on Publishing Site in client'...
4
votes
1answer
65 views

Confused about SharePoint Solutions

I'm confused about SharePoint Solutions. Could you verify if my understanding is correct? There are only 2 kinds of SharePoint Solutions: Sandboxed Solutions: When a solution package is deployed to ...
1
vote
1answer
230 views

SharePoint Event Receiver does not fire after deployment

I have created a simple SharePoint 2013 solution and added event receiver. When I am in visual studio, i hit F5, solution is deployed and event receiver works. However, when I publish the solution (....
1
vote
1answer
46 views

What influences the deployment speed on SP2013?

I have an Hyper-V machine running Sharepoint 2013 connected to an hosted server with 16GB ram, where the database is installed for that Sharepoint server. I wanted to improve the local deployment ...
0
votes
1answer
200 views

error “Operation is not valid due to the current state of the object.” during deploy solution from visual studio

I create one share point solution and two class library within that project,every library signed in properly, but, while I deploy that on to share point site,various ways I tried like through power-...
0
votes
1answer
61 views

Get SharePoint Web App Url programatilly from WindowsFormTool

I developing a simple Windows Forms Application that using a PowerShell script to add WSP solutions to multiple SharePoint front ends automatically. I am not a SharePoint developer but it's required ...
0
votes
0answers
20 views

How to find solution location of application deployed on Sharepoint2013

Need your help in finding the solution location deployed on a production environment.This is because the past developer deployed different solutions on UAT on Production.And handed over to me a ...
0
votes
1answer
49 views

How the user is authenticated in SharePoint using Active Directory?

I am having a requirement when admin sets an account to "Force Password change at next login", the user will be redirected to password reset page. But I don't know what happens at the back after user ...
0
votes
2answers
207 views

Error while deploying custom solution with itextsharp dll

I need to use an external .dll file with itextsharp in my solution. Under development environment everything is fine. But same code in production server is giving an error. when checked in the log ...
1
vote
1answer
41 views

After deploying the Visual studio workflow in SP2013 breaking instances of in progress workflows

I have been working on developing visual studio workflows for SP2013. This workflow is associated with a document library. I have noticed that each time i deploy the workflow it is breaking the ...
1
vote
1answer
136 views

SharePoint 2013 Visual Studio Solution - Adding / Importing site pages into an existing solution

I have an existing Visual Studio solution containing web parts etc. I want to add a set of site pages to the solution, that will be deployed to the 'SitePages' folder of a site collection, when the ...
9
votes
2answers
8k views

How to stop solution deployment

I started some solutions deployment with batch file and one of them was hanging. So I stopped the script and tried to retract that one solution to deploy it once again stsadm -o retractsolution -name ...
0
votes
1answer
538 views

SharePoint 2010 Adding Web Part Error: Object reference not set to an instance of an object

I created a Farm Solution visual web part in a development environment (VM). I've run into issue while attempting to deploy this Visual Web Part in a test environment. I added (Add-SPSolution), ...
0
votes
1answer
902 views

Can I deploy a sandboxed solution from Visual Studio to SharePoint online?

Apps are great for many things but hosting a service for a one-off customization of a host web seem a little overkill. I want to use a sandboxed solution for things like branding and data structure ...
0
votes
0answers
37 views

Import Visio Workflow in SharePoint 2013 using powershell

I received a .vwi file, which is a Visio workflow and now I would like to add it to the SharePoint workflow of a site collection. So far I have found that it can only be imported using SharePoint ...
6
votes
2answers
12k views

Deployed web parts don't show up in Web Part Gallery

I have created several custom web parts in a Visual Studio solution which deploys to my development environment site perfectly directly through Visual Studio. However, I also want to be able to ...
2
votes
2answers
1k views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
3
votes
4answers
642 views

File in _layouts not updated on deployment

We have this situation: there was an error in teh solution, which occured in one of JS files deployed into _layouts. Bug was kind of a critical, and decision was made to push chaned JS file by hand ...
1
vote
0answers
23 views

How to bulk upload a site template (solution) to multiple site collections

We've multiple site collections with customized site templates (or solutions). Is it possible to change all the solution (in all the site collections) at once when the template has been updated? ...
0
votes
1answer
67 views

Deploying an updated solution seems to redeploy the previous version

I'm testing a new feature I'm developing. I have ULS logging in the feature. I deployed it to a production server after testing in the dev environment was complete and users then requested a few ...
0
votes
1answer
245 views

Not able to activate the site template in solutions gallery : SharePoint 2010

I have created a site from Decision Meeting work-space template, made some modifications(added 2 Extra columns of date time datatype into Agenda list, added a new list for comments). I have saved ...
0
votes
0answers
89 views

Error when deploying solution webparts - Cant figure out why its failing

I'm trying to deploy this webpart I can get it to work on Dev with no issues. But I have problem when deploying it to production. First of all I can't get to see anything in the site collection ...
1
vote
0answers
23 views

2013 Solution Migration

I upgraded a site with custom aspx pages from 2010 to 2013 and tried to save it as a template to move it to another SP13 farm but I keep getting an error. The content type name ' $Resources:...
1
vote
1answer
61 views

Convert User field to UserMulti field

I have a content type which has a field called "Owner" which currently is of type User. The code has been deployed to production and has been so for ~1 year so they have a lot of data in the ...
4
votes
1answer
2k views

SharePoint feature deployment and scope via PowerShell

We use SP2013 and PowerShell to deploy wsps. When installing the wsp via PowerShell: CASE 1: Add-SPSolution -LiteralPath $path install-spsolution -Identity $solution -GACDeployment Above ...
33
votes
3answers
30k views

Explain it to me: SharePoint deployment scope, solution and features

There are different levels of scope for deployment, but I have not been able to find a definitive explaination of when each applies and what the restrictions are that require loosening (or tightening) ...
2
votes
2answers
40 views

Deploy multiple WSPs to specific web application or globally in MOSS 2007 environment

Install-SPSolution -Identity $solutionName -WebApplication $webApp -GacDeployment -Force But I get cmdlet not found error. Please can anyone help me out.
1
vote
0answers
327 views

how to maintain workflow task list data when retracting or removing workflow association

whenever i try to remove workflow association or retract workflow solution (.wsp) all associated task list data also gets deleted. i want to prevent this behavior as task list data is important for ...
7
votes
3answers
6k views

Problem with SP2013 solution scope: WebApplication vs GAC

I have a SP2013 solution that contains a custom WCF service, custom Timer Job and a Feature Event Reciever. Because of these the solution Assembly Deploying Target is set to GlobalAssemblyCache. The ...
0
votes
1answer
84 views

SharePoint mixing list schema

I've a solution for SharePoint 2013 where I created several list and added them to a feature. When I deploy the solution to my dev environment every list has the same schema (the same columns). They ...
1
vote
1answer
355 views

Some of the files failed to copy during deployment of the solution

I tried to deploy a solution to our server, but it seems that there are two WFE servers (I am not sure about this if they are both WFE or WFE and application server. How can I see the difference?). ...
1
vote
2answers
348 views

Only Site Collect Admin can deploy SharePoint?

I am trying to deploy a SharePoint 2010 project onto an SP server. When I hit F5 after building the solution, the output says that "Only a site collection administrator can activate or upgrade ...
0
votes
2answers
314 views

Why my solution is getting deployed to only one(App Server) server out of 2 WebFrontEnd and 1 App Server?

I have a solution containing a Visual WebPart and an Application(_Layouts) page. I have used VS 2013 for developing this solution and its for our 2013 farm. The farm has one Application Server and 2 ...