is deployment of a wsp-package to a SharePoint farm or one of its servers.

learn more… | top users | synonyms

0
votes
0answers
13 views

Deploying an updated solution seems to redeploy the previous version

I'm testing a new feature I'm developing. I have ULS logging in the feature. I deployed it to a production server after testing in the dev environment was complete and users then requested a few ...
3
votes
2answers
707 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
0
votes
1answer
27 views

Not able to activate the site template in solutions gallery : SharePoint 2010

I have created a site from Decision Meeting work-space template, made some modifications(added 2 Extra columns of date time datatype into Agenda list, added a new list for comments). I have saved ...
0
votes
0answers
37 views

Error when deploying solution webparts - Cant figure out why its failing

I'm trying to deploy this webpart I can get it to work on Dev with no issues. But I have problem when deploying it to production. First of all I can't get to see anything in the site collection ...
0
votes
0answers
3 views

Re-deploy MSVS webpart independently

We are having MSVS solution from old developer and manage to update one of the web part. To safeguard production server we want to deploy the web part which we made update. Is there a way doing it? ...
1
vote
0answers
19 views

2013 Solution Migration

I upgraded a site with custom aspx pages from 2010 to 2013 and tried to save it as a template to move it to another SP13 farm but I keep getting an error. The content type name ' ...
1
vote
1answer
23 views

Convert User field to UserMulti field

I have a content type which has a field called "Owner" which currently is of type User. The code has been deployed to production and has been so for ~1 year so they have a lot of data in the ...
4
votes
1answer
1k views

SharePoint feature deployment and scope via PowerShell

We use SP2013 and PowerShell to deploy wsps. When installing the wsp via PowerShell: CASE 1: Add-SPSolution -LiteralPath $path install-spsolution -Identity $solution -GACDeployment Above ...
18
votes
3answers
22k views

Explain it to me: SharePoint deployment scope, solution and features

There are different levels of scope for deployment, but I have not been able to find a definitive explaination of when each applies and what the restrictions are that require loosening (or tightening) ...
2
votes
2answers
26 views

Deploy multiple WSPs to specific web application or globally in MOSS 2007 environment

Install-SPSolution -Identity $solutionName -WebApplication $webApp -GacDeployment -Force But I get cmdlet not found error. Please can anyone help me out.
1
vote
0answers
279 views

how to maintain workflow task list data when retracting or removing workflow association

whenever i try to remove workflow association or retract workflow solution (.wsp) all associated task list data also gets deleted. i want to prevent this behavior as task list data is important for ...
6
votes
3answers
3k views

Problem with SP2013 solution scope: WebApplication vs GAC

I have a SP2013 solution that contains a custom WCF service, custom Timer Job and a Feature Event Reciever. Because of these the solution Assembly Deploying Target is set to GlobalAssemblyCache. The ...
0
votes
1answer
29 views

SharePoint mixing list schema

I've a solution for SharePoint 2013 where I created several list and added them to a feature. When I deploy the solution to my dev environment every list has the same schema (the same columns). They ...
1
vote
1answer
50 views

Some of the files failed to copy during deployment of the solution

I tried to deploy a solution to our server, but it seems that there are two WFE servers (I am not sure about this if they are both WFE or WFE and application server. How can I see the difference?). ...
1
vote
2answers
163 views

Only Site Collect Admin can deploy SharePoint?

I am trying to deploy a SharePoint 2010 project onto an SP server. When I hit F5 after building the solution, the output says that "Only a site collection administrator can activate or upgrade ...
0
votes
2answers
39 views

Why my solution is getting deployed to only one(App Server) server out of 2 WebFrontEnd and 1 App Server?

I have a solution containing a Visual WebPart and an Application(_Layouts) page. I have used VS 2013 for developing this solution and its for our 2013 farm. The farm has one Application Server and 2 ...
1
vote
3answers
78 views

Deploying WSP to a specific web application

I have created a SP 2013 solution, and I want to deploy this in my farm. But the requirement is that I don't want this wsp to be available in all the web applications. It should target only to my web ...
1
vote
1answer
39 views

Solution not deploying after Farm Restart

I launched powershell script for restart the entire Farm. After that, I notice that every time I try to deploy a solution it doesn't finish deploying process. Even if launching Install-SPSolution from ...
0
votes
0answers
11 views

Failed Deploy the sharepoint Project on sharepoint 2010 environment

I am getting following Error when I try to deploy My project on SharePoint 2010 : The required version of SharePoint Foundation 2013 or SharePoint Server 2013 is not installed on this system. ...
1
vote
3answers
2k views

Deploying the same WSP file with a different name

I have created wsp file using Visual Studio 2010 that servers an application pages in site. My solution file name is "Portal.wsp". I have already deploy this solution file on my server it running ...
0
votes
1answer
25 views

Solution Upgrade, Activating feature as well

I have deployed a solution on my test server with 1 features that creates an AppConfig list and add 3 list items, I used visual studio to create list items. <Data> <Rows> ...
0
votes
1answer
28 views

how to build wsp in visual studio 2012 without actually deploying the project

I am trying to create a wsp for my project in visual studio 2012. when i build my project it is not creating a wsp only when i deploy my project it is creating a wsp in my bin/debug folder. Is there ...
1
vote
2answers
2k views

Add multiple farm solutions using power shell (Not Deploy)

I am trying to migrate around 200 wsps from one SharePoint 2010 farm to another. I have already copied the wsp files to a folder in the new farm. I need a powershell script that can take the path of ...
0
votes
0answers
34 views

LightSwitch app on SharePoint Server 2013

So here's the problem: I have a simple Lightswitch app made with VS 2013. I am DB-admin and SharePoint has the default settings. When I click deploy, VS is installing exactly 38 minutes and then it ...
0
votes
0answers
6 views

Microsoft products 2010 installation

I wants to deploy a custom solution for our team portal. But I don't find any Microsoft products list in my system how to install it?
0
votes
1answer
50 views

Deploy solution across all the site collection in a web app

I have an environment in which we have 1000's of site collection. We also create new site collection. I want to deploy an event receiver which is available across all the site collections i.e web ...
1
vote
1answer
946 views

Download/Export solution from site solution gallery

I'm trying to automate the process of downloading one solution and then add/install the same solution to other site collections. The first thing to do would be to download the freshly created solution ...
1
vote
1answer
27 views

Deploy solution only at root sites in site collections

There are more than 100 site collections and I need to deploy a solution which should only be available to all site collections but not to sub-sites. Please suggest a way forward.
4
votes
3answers
245 views

How to programmatically detect if a solution is deployed?

Situation: There's a sharepoint farm with ~60 solutions. On some not specified time someone can deploy a new /update an existing solution to this farm. Everytime a deployment is successfull I need to ...
0
votes
2answers
143 views

Add Custom Web Part to newly created page programmatically

I created a custom web part for SharePoint 2013 and I would like it to be added to a blank page that is created for it. I looked it up and found out, that the I can add an Event Receiver to the ...
1
vote
0answers
32 views

SharePoint 2013 Visual Studio Solution - Adding / Importing site pages into an existing solution

I have an existing Visual Studio solution containing web parts etc. I want to add a set of site pages to the solution, that will be deployed to the 'SitePages' folder of a site collection, when the ...
1
vote
0answers
77 views

Sandbox Solution failing to load

Okay I think I'm missing something when I'm trying to build an Event Receiver. I'm new to this so please excuse my ignorance. But when I try to deploy an Event Receiver I always get a Could not load ...
2
votes
1answer
66 views

No permission to retract/uninstall from CA, but from PowerShell

I have a weird permission-related problem. My account is entered as a local administrator, just to be on the safe side. If I want to retract or remove solutions within the CA I am getting either an ...
0
votes
0answers
25 views

FeatureActivated event not firing Visual Web Part

I have a Sharepoint 2013 visual web part(farm) and I want it to be added programmatically to a created page. I found some code snipplets online that let me do that, and I found out I have to put them ...
0
votes
1answer
167 views

Page Not Found Error After Deploying The Solution Using PowerShell

I am a novice in sharepoint 2013. I have created a Sharepoint 2013 Solution using "Empty Project" as my template and added two aspx pages. When deploying the solution using VS2012 the solution ...
0
votes
1answer
32 views

Can I test a SharePoint solution on a remote server?

I want to develop a SharePoint Solution event receiver (not SharePoint app) on a computer with visual studio 2013 but without SharePoint. SharePoint will run on a different computer on the same LAN. ...
13
votes
5answers
19k views

Feature has already been installed. Use the force attribute to explicitly re-install the feature

We have several SharePoint 2010 solutions which we want to deploy to SharePoint 2013 with Visual Studio 2012 running on Windows Server 2012. Site solutions work. But farm solutions just don't. I get ...
3
votes
1answer
668 views

SharePoint Project does not deploy

I upgraded SP 2010 Solution created using VS 2010 to SP 2013 solution in VS 2012. The Solution has one SharePoint project which references another SharePoint project in the same solution. There are ...
0
votes
2answers
100 views

SharePoint .wsp retraction error

I am deploying a solution by Visual Studio. I get the error during Retraction: The solution does not have a WSP file associated with it. I tried to do IISRESET and also to restart the server.
1
vote
1answer
120 views

SharePoint 2010 Farm Solution Deployment Error Using Non-admin Accounts

I am trying to deploy a farm solution using Visual Studio 2012 on SharePoint 2010. I receive the following error when I try to build or deploy using any admin group accounts other than the Farm Admin ...
2
votes
1answer
18 views

Is multiple user account required to deploy in office 365 production environments?

Let’s say there are 5 users working with different apps in one SharePoint 2013 Office 365 development environment. Naturally they are working with different user ids (a/c). Now if they want to deploy ...
0
votes
0answers
10 views

Deployment strategy for Office 365 SharePoint 2013 apps to production site? [duplicate]

Let's say A SharePoint 2013 OFFICE 365 development site has all provider hosted app parts which needs to be migrated to the OFFICE 365 UAT environments. Basically, I have to take the stuff from ...
1
vote
1answer
235 views

ActivityNotFoundException during feature activation

I have a workflow 2013 included in Full trust solution (WSP). When I add a variable of type DynamicValue to the workflow and try to deploy the solution using VS 2012 I get the error during feature ...
3
votes
1answer
5k views

Deployed web parts don't show up in Web Part Gallery

I have created several custom web parts in a Visual Studio solution which deploys to my development environment site perfectly directly through Visual Studio. However, I also want to be able to ...
3
votes
2answers
129 views

Custom Form of SharePoint-List: Prevent default DataFormWebpart to be added

I'm working on a SharePoint 2013-Solution which deploys a custom list with custom site columns and a custom form. In the list's Schema.xml I added following lines: <Forms> <Form ...
0
votes
1answer
133 views

Recaptcha.dll not found after webpart deployment

I'm developing a webpart that contains a form for register data and send it to a list. I know a little about Sharepoint webpart development but again, implementation of external resources in ...
1
vote
0answers
25 views

Deploy Solution in SharePoint 2013

I am deploying a SharePoint solution in SharePoint 2013 and I am getting the error: "a web config modification is already running" Environment is multiple servers (4), and multiple web application ...
0
votes
1answer
282 views

Fail to activate SharePoint.Foundation.Publishing.2013.wsp on my collection site

I downloaded a hand-made equivalent to the SharePoint Server 2013 Publishing Feature here SharePoint Foundation 2013 Publishing Infrastructure. i'm on a single farm, running a SP Foundation 2013 with ...
1
vote
1answer
94 views

SharePoint 2013 - MasterPage Installation Problem

When I republish my MasterPage through Visual Studio 2012, I have an issue with the old master page not being able to be deleted. I get a error message saying that a conflict could not be resolved, ...
2
votes
1answer
47 views

Specify custom parameters in WSP deploy / feature activation?

I have a Feature Receiver where I access the Term Store to get / set something. My problem is, the code needs to connect to 'specific' term store.. but what if the Term store name changes when I ...