is deployment of a wsp-package to a SharePoint farm or one of its servers.

learn more… | top users | synonyms

0
votes
1answer
150 views

How to find images & javascripts of SandBox solution deployment?

I have deployed SandBox Solution to my SharePoint Server. After deployment When I open the site in browser, it displays the images of the Site but not working of JavaScript file. (I have given the ...
1
vote
1answer
1k views

How to deploy SandBox solution with images on the Server?

How can I deploy SandBox Solution from Visual Studio with images on the Server ? When I trying to deploy it, I am getting the following errors. 1). The Project Item "Images" cannot be deployed ...
0
votes
0answers
452 views

Why am I getting this error? “Incompatible Web Part markup detected. Use *.dwp Web Part XML instead of *.webpart Web Part XML.”

I created a WebPart in Visual Studio 2010 and made the necessary changes to make it work in MOSS 2007. The webpart was working just fine, but I had to remove a couple webparts from the project, so I ...
0
votes
1answer
228 views

Site is not available through the browser, inetpub folder is empty

Visual Studio generated an error saying that the file web.config is not found when I deploy solution. After that the folder inetpub\wwwroot\wss\VirtualDirectories\80 was empty at all. Also the site is ...
9
votes
2answers
9k views

Error occurred in deployment step 'Install app for SharePoint': Apps are disabled on this site

We have installed SharePoint Server 2013 on a Windows Server 2008 machine. In our development environment we have installed Visual Studio 2012 on a Windows 7 machine and have installed Office ...
2
votes
2answers
2k views

SharePoint 2010 User Code Host service stops

When I try to deploy any SandBox Solution I receive following error: Error occurred in deployment step 'Retract Solution': Timeout occurred while running the SharePoint Sandboxed Code service. ...
3
votes
2answers
621 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
5
votes
3answers
134 views

SharePoint Admin and Developer Roles [closed]

Currently in our organization we have a three man SharePoint development team where we do everything other than SharePoint admin. Our organization has development, test, and production servers. We, ...
0
votes
0answers
100 views

WSP deployment repeats last characters of a file

I have a weird issue with deployment of a WSP file. A little background info: The Visual Studio solutions consists of 28 projects (don't ask... I inherited it :-)) of which 26 files generate a WSP ...
1
vote
0answers
42 views

'-LOCAL' solution deployment across multi server farm

I've deployed numerous solutions before but I'm trying to do a 'zero downtime' deployment on a 4 server farm. My question is about what happens in the background when deploying with the -local ...
0
votes
2answers
966 views

How to Deploy the Feature with Scope=Site & Scope=Web for WebParts & EventReceiver respectively?

I have only 1 Visual Studio Project. It contains 1 EventReceiver(for DocumentLibrary) and multiple-WebParts. I have defined the Scope=Site of Feature.xml file of Project. I have created 1 custom ...
0
votes
0answers
77 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
0
votes
1answer
100 views

How to create single SharePoint Installer using SharePoint 2010 Solution Installer?

I have 1 Visual Studio Solution which contains 3 different Projects. 1 for EventReceiver and 2 for UI(WebParts) projects. I want to create single Setup file for all sothat I can deploy it on any ...
0
votes
2answers
477 views

How to make SharePoint Online to update files inside modules

We have deployed solution to SharePoint Online with following elements.xml file: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> ...
0
votes
2answers
519 views

Deploy folder/files to Web Application Root

How to deploy folder to a SharePoint 2010 Web Application Root folder (inside inetpub\wwwroot\wss\VirtualDirectories\80) in the solution package(wsp)? Which kind of item I should use in the visual ...
1
vote
3answers
2k views

Deploying the same WSP file with a different name

I have created wsp file using Visual Studio 2010 that servers an application pages in site. My solution file name is "Portal.wsp". I have already deploy this solution file on my server it running ...
0
votes
2answers
776 views

Permissions required for deploying wsp files and debugging workflows

I am having issues at a client with regards to permissions that I need to request for my account to be able to deploy wsps (using WSPBuilder) to the development environment, and to debug workflows in ...
0
votes
2answers
543 views

Thoughts about deployment via Site Collection backup-restore

I wonder sharepoint experts ideas about deployment of sharepoint projects/portals via site collection backup & restore, instead of visual studio solutions? Especially for the projects that will ...
0
votes
1answer
2k views

Unable to deploy my solution in SharePoint 2013

Hi I am using SP2013 stand-alone version. I am trying to deploy a solution in SharePoint 2013, I have successfully added the solution to solution store, but whenever I try to deploy the solution, ...
0
votes
2answers
1k views

“Thread abort exception” in event receiver after adding a solution?

I am developing an event receiver for the web provisioned event. It does quite a few things, culminating to add and deploying a solution and activating a feature from it. When I do the following: ...
0
votes
2answers
700 views

OpenXML and WebPart Solution Deploying to Live Server

I have the OpenXML SDK installed on my development machine, and I have written a webpart solution that basically creates an excel file using the OpenXML dll. This solution is a full farm solution not ...
1
vote
1answer
640 views

Add solution from within event receiver - how to sort out “access denied” errors?

I'm handling the WebProvisioned event in order to add and deploy a solution that's relevant to the site being created. The solution is being created dynamically based on parameters of the site but for ...
0
votes
1answer
340 views

How do I get an InfoPath 2010 form deployed with a WSP to work in a sub-site collection?

What I currently have is a SharePoint 2010 project that I have successfully deploying an InfoPath Browser Form (Full Trust) content type and associating it with library instances. This is working ...
1
vote
0answers
263 views

how to maintain workflow task list data when retracting or removing workflow association

whenever i try to remove workflow association or retract workflow solution (.wsp) all associated task list data also gets deleted. i want to prevent this behavior as task list data is important for ...
0
votes
2answers
2k views

What is the Correct Way to Deploy Solutions in Foundation 2010 Via C# API

I am on a team developing a "portal" for SharePoint Foundation 2010. I am responsible for making the installer which sets up a new instance of SharePoint. It handles more than just the installation ...
0
votes
1answer
148 views

workflow inactive - after deployment?

my workflow is deployed through the following script in SharePoint 2010: # Set CurrentDirectory $callingDir = Split-Path -Parent $MyInvocation.MyCommand.Path [Environment]::CurrentDirectory = ...
1
vote
1answer
436 views

Powershell script taking too long to finish

i wrote a power shell script to deploy my wsp to to SP 2010 server. It first checks if the solutions is already there and deployed if yes then retracts and redeploy again. It deploys to a specific web ...
2
votes
2answers
2k views

SharePoint solution deployment issue

I am trying to deploy a WSP solution in SP2010 using a PowerShell script and it's showing the status in CA as "Deploying" for a long time. I have tried: stsadm -o execadmsvcjobs stsadm -o ...
1
vote
0answers
101 views

Help understand ContentType/List upgrade

Everywhere i read on the web it says that Content Types and List once deployed through Xml files they cannot be updated anymore. I have created a VS 2010 solution, created a SharePoint List ...
0
votes
1answer
350 views

Powershell Script for Deployment and Activating Features SharePoint 2010

I am writing Powershell script for adding my solution,activating solution and at last activation features on my SP2010 server. There are no issues in adding solution and deploying the solution. Issues ...
0
votes
3answers
398 views

Deploying Solution to Remote SharePoint Site

I have a SP2010 wsp. I want to deploy it to some remote SharePoint site. I don't have access to root site on the remote server but to a sub site, where I want my solution. How can I directly deploy my ...
3
votes
2answers
6k views

What's wrong with Uninstall-SPSolution and AllWebApplications parameter?

When I try to uninstall WSP with following line, everything is ok: Uninstall-SPSolution project.wsp # no error - OK When I try to add switch parameter -AllWebApplications, I get error (something ...
0
votes
2answers
257 views

Will be next SharePoint 13/15 have new deploy features?

Over the past couple of years I've been making solutions for SharePoint Server and always most important problem was the availability of the web-site. Deployment not-sandboxed solution is pain at ...
1
vote
2answers
2k views

Can't debug/deploy solution from VS 2010

I have encountered strange problem on my dev VM. Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking ...
0
votes
2answers
825 views

Powershell deployment with nant - problem with script arguments

I have a powershell script updating my solution: Add-PSSnapin Microsoft.SharePoint.PowerShell write-host $args[0] Update-SPSolution -Identity PkbInfo.SP.wsp -literalpath $args[0] -GACDeployment ...
1
vote
1answer
2k views

SandBox Solutions Deployment of WSP to Solution Gallery : Beginner Questions

I am a beginner to SP Dev, and I have been reading a few things about Sandbox Solutions and the limitations there. Also it seems that to deploy a solution, I can simply upload a wsp to the solution ...
6
votes
1answer
577 views

Site Definition vs Web Template for product site

I'm getting ready to create a product for SharePoint, and I'd like it to be as easy as possible for people to deploy and use. I was planning on using a Site Definition, since this seems like a great ...
1
vote
1answer
455 views

Visual Studio Retract - Install features script

when Visual Studio launch a Sharepoint Project does some steps, when debug ends does a retract to restore the system status. Now I'm developing an application based on content type.. When I deploy ...
3
votes
3answers
1k views

Update Feature automatically

I have developed an update for a SharePoint 2010 solution. This update defines some upgrades for some of the included features (the upgrade are managed via the new FeatureUpgraded receiver event). I ...
1
vote
2answers
2k views

Add multiple farm solutions using power shell (Not Deploy)

I am trying to migrate around 200 wsps from one SharePoint 2010 farm to another. I have already copied the wsp files to a folder in the new farm. I need a powershell script that can take the path of ...
0
votes
1answer
141 views

Enterprise built .wsp deployable to Standard Edition?

Is it possible to build/package a .wsp on a machine with Sharepoint 2010 Enterprise Edition (DEV machine) and deploy it to a machine with Sharepoint 2010 Standard Edition (PROD machine) installed?
1
vote
3answers
4k views

Update a existing deployed farm solution

I've deployed a farm solution to a test environment by following the Technet Deploy solution packages page - works well. But development continues, and I need to redeploy. When I follow the process ...
3
votes
1answer
911 views

Timeout while deploying VS2010 solution to SP2010

When deploy a solution (no sandbox solution) with many projects, I always get the following error: Error occurred in deployment step 'Recycle IIS Application Pool': The open operation did not ...
1
vote
2answers
1k views

SharePoint 2010 - Best practices: how to handle assemblies [Discussion]

There is a discussion which has been going on for serveral years when programming for SharePoint. In Visual Studio you can add a SharePoint solution, which will be converted to a .wsp file to deploy. ...
6
votes
1answer
5k views

How to stop solution deployment

I started some solutions deployment with batch file and one of them was hanging. So I stopped the script and tried to retract that one solution to deploy it once again stsadm -o retractsolution -name ...
1
vote
1answer
176 views

Sharepoint proxy page not accessible when not logged in

I created a proxy aspx page following this guide: http://www.sharepointjohn.com/sharepoint-2010-cross-domain-proxy-page-for-client-side-scripts/ I deployed the solution to the farm using the two ...
1
vote
1answer
109 views

Lost navigation when testing on one Web Front-End server taken off Load balancing?

Last week we experienced a phenomenon which didn't make sense (to me). We have an environment with one SQL Server and two Web Front-End servers in the Farm. Upon deploy one WFE were removed from Load ...
3
votes
1answer
1k views

How to register an ashx handler through sharepoint 2010 farm solution

I have a 3rd party control that i want to add to the web part. That 3rd party control uses a generic ASHX handler. I can always add the registration to the actual WFE web.config but it's a bit ...
1
vote
1answer
550 views

Deployment of masterpage goes wrong if .wsp is used

i have a custom master page layout. The problem is that it works great if i install it with the Web-interface or with SPD.. Unfortunately everytime i try to deploy it using VS either direct deployment ...
0
votes
1answer
615 views

Error on Activate Features on deploying SharePoint Skin

Error occurred in deployment step 'Activate Features': Object reference not set to an instance of an object. I just can't figure out where the error is occuring. Found some blog posts concerning the ...