is deployment of a wsp-package to a SharePoint farm or one of its servers.

learn more… | top users | synonyms

5
votes
1answer
468 views

Site Definition vs Web Template for product site

I'm getting ready to create a product for SharePoint, and I'd like it to be as easy as possible for people to deploy and use. I was planning on using a Site Definition, since this seems like a great ...
1
vote
1answer
1k views

Add multiple farm solutions using power shell (Not Deploy)

I am trying to migrate around 200 wsps from one SharePoint 2010 farm to another. I have already copied the wsp files to a folder in the new farm. I need a powershell script that can take the path of ...
1
vote
1answer
382 views

Visual Studio Retract - Install features script

when Visual Studio launch a Sharepoint Project does some steps, when debug ends does a retract to restore the system status. Now I'm developing an application based on content type.. When I deploy ...
0
votes
1answer
121 views

Enterprise built .wsp deployable to Standard Edition?

Is it possible to build/package a .wsp on a machine with Sharepoint 2010 Enterprise Edition (DEV machine) and deploy it to a machine with Sharepoint 2010 Standard Edition (PROD machine) installed?
0
votes
3answers
2k views

Update a existing deployed farm solution

I've deployed a farm solution to a test environment by following the Technet Deploy solution packages page - works well. But development continues, and I need to redeploy. When I follow the process ...
1
vote
2answers
900 views

SharePoint 2010 - Best practices: how to handle assemblies [Discussion]

There is a discussion which has been going on for serveral years when programming for SharePoint. In Visual Studio you can add a SharePoint solution, which will be converted to a .wsp file to deploy. ...
1
vote
1answer
158 views

Sharepoint proxy page not accessible when not logged in

I created a proxy aspx page following this guide: http://www.sharepointjohn.com/sharepoint-2010-cross-domain-proxy-page-for-client-side-scripts/ I deployed the solution to the farm using the two ...
1
vote
1answer
90 views

Lost navigation when testing on one Web Front-End server taken off Load balancing?

Last week we experienced a phenomenon which didn't make sense (to me). We have an environment with one SQL Server and two Web Front-End servers in the Farm. Upon deploy one WFE were removed from Load ...
2
votes
1answer
726 views

How to register an ashx handler through sharepoint 2010 farm solution

I have a 3rd party control that i want to add to the web part. That 3rd party control uses a generic ASHX handler. I can always add the registration to the actual WFE web.config but it's a bit ...
0
votes
2answers
670 views

How deploy Application Page - Missing WSP file

I have made a project in VS 2010 and added an application page to the project. When i build the project i get no WSP file. There is also no items in feature . If i add a WebPart item, then i get a ...
1
vote
1answer
441 views

Deployment of masterpage goes wrong if .wsp is used

i have a custom master page layout. The problem is that it works great if i install it with the Web-interface or with SPD.. Unfortunately everytime i try to deploy it using VS either direct deployment ...
0
votes
1answer
590 views

Error on Activate Features on deploying SharePoint Skin

Error occurred in deployment step 'Activate Features': Object reference not set to an instance of an object. I just can't figure out where the error is occuring. Found some blog posts concerning the ...
1
vote
2answers
762 views

Error deploying SharePoint 2010 solution with InfoPath form (The path is not of a legal form.)

I am new to SharePoint and .Net development, sorry if answer for my question is obvious. I've created SharePoint solution, which uses InfoPath form. When I deploy it from Visual Studio, all work ...
0
votes
1answer
409 views

Can't find workflow deployed as WSP solution

I am new to SharePoint, sorry if answer to my question is obvious. I am trying to deploy my very simple workflow as WSP package, it deploys without errors, I activate it, but I can't find my workflow ...
1
vote
1answer
136 views

What to do on feature deletion/deactivation

as I am trying to wrap my head around silverlight and sharepoint there's one thing I find most irritating: Provisioned xap-Files and/or web-Parts remain fully active upon deactivation/uninstallation ...
1
vote
0answers
65 views

Everytime I try to add an existing or new project to my SharePoint 2010 Solution it says “File not Found”

Everytime I try to add a class library to my SharePoint 2010 solution (which consists of about 4 other projects), I get the error: Could not load file or assembly 'AF.XMLMapping, Version=1.0.0.0, ...
2
votes
1answer
90 views

How to develop in the following environment

Production has 10 servers, 8 app servers, 2 front end. Its own active directory Testing has almost the same. Its own active directory The problem is that at the moment, in the current company ...
3
votes
2answers
221 views

How to programmatically detect if a solution is deployed?

Situation: There's a sharepoint farm with ~60 solutions. On some not specified time someone can deploy a new /update an existing solution to this farm. Everytime a deployment is successfull I need to ...
2
votes
3answers
1k views

Problem Activating Custom Timer Job

Right now I'm trying to create a SharePoint 2010 Custom Timer Job in Visual Basic 2010, which doesn't want to register itself in the SharePoint Timer (it appears to add ok and everything, but doesn't ...