0
votes
1answer
42 views

GacDeployment does not show any results

following scenario. I have a structure that looks as follows: WebApplication (App) --> SiteCollection (SiteCol) --> Site (Site) --> WebSite (Web) --> List I developed an eventreceiver which should ...
0
votes
1answer
35 views

Deployment time of wsp in Sharepoint

I like to enter the deployment time of wsp into registry when we had installed on particular server. How to get it in code?
0
votes
1answer
31 views

Error deploying custom web parts

I deployed my WSP to the SP server and activated my solution. When I attempted to add my web parts to a page I get the message: A Web Part of Web Form Control on this Page cannot be displayed or ...
3
votes
1answer
69 views

Iterative deployments using WSP in SharePoint2010

I am looking for best practices for deploying frequent custom code changes to SharePoint 2010 server, my changes include all kind of changes like web parts, content types, workflows, feature ...
1
vote
1answer
40 views

Muilti deploy DLLs from external Projects into single WSP

I'm trying to build a single .WSP that should contains multiple DLLs from External projects. I've been following that this tutorial: Link I've followed all steps but on deploy , DLLS doesn't appear ...
1
vote
1answer
295 views

Download/Export solution from site solution gallery

I'm trying to automate the process of downloading one solution and then add/install the same solution to other site collections. The first thing to do would be to download the freshly created solution ...
0
votes
1answer
29 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
0
votes
1answer
177 views

Process cannot access the file “project.dll” because it is being used by another process

I need to deploy a wsp file in VS, but I am not able to do that because I am getting the error in my question's title, I tried doing IIS reset, restarting my development machine. Any ideas?
0
votes
0answers
60 views

How to create a WSP package for a SharePoint 2010 site? [duplicate]

I previously asked this Question: How to create WSP Package of a SharePoint 2010 site without VS 2010 (with SP Designer)?. But didn't get a proper answer. I am developing a SharePoint 2010 website. ...
2
votes
1answer
412 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
0
votes
0answers
85 views

WSP deployment repeats last characters of a file

I have a weird issue with deployment of a WSP file. A little background info: The Visual Studio solutions consists of 28 projects (don't ask... I inherited it :-)) of which 26 files generate a WSP ...
0
votes
0answers
73 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
0
votes
2answers
382 views

Deploy folder/files to Web Application Root

How to deploy folder to a SharePoint 2010 Web Application Root folder (inside inetpub\wwwroot\wss\VirtualDirectories\80) in the solution package(wsp)? Which kind of item I should use in the visual ...
1
vote
3answers
982 views

Deploying the same WSP file with a different name

I have created wsp file using Visual Studio 2010 that servers an application pages in site. My solution file name is "Portal.wsp". I have already deploy this solution file on my server it running ...
0
votes
2answers
465 views

Thoughts about deployment via Site Collection backup-restore

I wonder sharepoint experts ideas about deployment of sharepoint projects/portals via site collection backup & restore, instead of visual studio solutions? Especially for the projects that will ...
0
votes
2answers
758 views

“Thread abort exception” in event receiver after adding a solution?

I am developing an event receiver for the web provisioned event. It does quite a few things, culminating to add and deploying a solution and activating a feature from it. When I do the following: ...
3
votes
2answers
4k views

What's wrong with Uninstall-SPSolution and AllWebApplications parameter?

When I try to uninstall WSP with following line, everything is ok: Uninstall-SPSolution project.wsp # no error - OK When I try to add switch parameter -AllWebApplications, I get error (something ...
1
vote
1answer
2k views

SandBox Solutions Deployment of WSP to Solution Gallery : Beginner Questions

I am a beginner to SP Dev, and I have been reading a few things about Sandbox Solutions and the limitations there. Also it seems that to deploy a solution, I can simply upload a wsp to the solution ...
1
vote
1answer
401 views

Visual Studio Retract - Install features script

when Visual Studio launch a Sharepoint Project does some steps, when debug ends does a retract to restore the system status. Now I'm developing an application based on content type.. When I deploy ...
0
votes
1answer
126 views

Enterprise built .wsp deployable to Standard Edition?

Is it possible to build/package a .wsp on a machine with Sharepoint 2010 Enterprise Edition (DEV machine) and deploy it to a machine with Sharepoint 2010 Standard Edition (PROD machine) installed?
1
vote
3answers
3k views

Update a existing deployed farm solution

I've deployed a farm solution to a test environment by following the Technet Deploy solution packages page - works well. But development continues, and I need to redeploy. When I follow the process ...
0
votes
1answer
598 views

Error on Activate Features on deploying SharePoint Skin

Error occurred in deployment step 'Activate Features': Object reference not set to an instance of an object. I just can't figure out where the error is occuring. Found some blog posts concerning the ...
0
votes
1answer
438 views

Can't find workflow deployed as WSP solution

I am new to SharePoint, sorry if answer to my question is obvious. I am trying to deploy my very simple workflow as WSP package, it deploys without errors, I activate it, but I can't find my workflow ...
7
votes
3answers
14k views

Explain it to me: SharePoint deployment scope, solution and features

There are different levels of scope for deployment, but I have not been able to find a definitive explaination of when each applies and what the restrictions are that require loosening (or tightening) ...