is deployment of a wsp-package to a SharePoint farm or one of its servers.

learn more… | top users | synonyms

0
votes
0answers
46 views

Deploying .wsp packages

Here is my problem, after I update the .wsp packages, the status became "error". This happened to me before, and the quick fix that I did is to remove the solution, then add and deploy it again. I ...
5
votes
0answers
44 views

Multiple app parts re-deployment issue in SharePoint 2013

I am working in SharePoint 2013 and i have my solution with 20 app parts. I have also configured several pages (filled with data) using these app parts. The issue is when i redeploy it after making ...
0
votes
1answer
26 views

Upgrading Site Templates in the Solution Gallery

How do I use the Upgrade button in the solutions gallery for a site template I've created? The word "upgrade" is forever associated with migration from 2010 to 2013, but unable to find prompt ...
0
votes
2answers
77 views

Error occurred in deployment step 'Add Solution' Sharepoint 2013

My machine shutdown when I was taking the solution backup. Then I started, I coudn't deploy the solution code from visual studio saying Error occurred in deployment step 'Add Solution': <nativehr&...
0
votes
0answers
25 views

Error deploying in production ONLY

I have a SharePoint solution, consisted of 2 features. The first feature is consisted of 5 SharePoint 2010 workflows, and some web pages. The second one is empty and has a feature event receiver that ...
0
votes
1answer
40 views

Moving Custom solutions in SP 2010 to new SP 2013 Farm

How can we successfully deploy/move all custom solutions (custom visual web parts, event receivers, custom workflows, Administrative Full-Trust InfoPath forms, etc.) developed for SharePoint 2010 to ...
0
votes
0answers
30 views

WSP on O365 activation

I prepared test WSP sandbox solution in Visual Studio 2012. Contains 1 web part "Hello", [ToolboxItemAttribute(false)] public class WP_Hello : WebPart { Literal lt; Button ...
0
votes
1answer
82 views

install-spsolution really stuck on “deploying”

Im trying to deploy a wsp on a Sp2013-farm. Ive tried restarting all sptimer-services on all machines, restarted admin service on all machines, restarted all machines, recycled service (iis) app pool, ...
0
votes
0answers
78 views

Sharepoint 2013 app deployment error - The operation has timed out

I have developed SharePoint 2013 apps(Office 365). All the app parts were working properly, but suddenly i am getting the following error, if i am trying to deploy it: Error 147 Error occurred in ...
0
votes
1answer
17 views

Error occurred in deployment step 'Add Solution': Data at the root level is invalid. Line 1, position 1070

i'm trying to develop App using visual studio on but when i try to deploy the app this error pop out in visual studio error. i was reading for the last few hours trying to find a solution but no joy ...
1
vote
1answer
63 views

Deploy a WSP that is built on Teamsite to Publishing Site

SharePoint 2013, We have developed WSP for a TeamSite but due to requirement change client want to have publishing site. I wonder what I need to do to deploy the same WSP on Publishing Site in client'...
4
votes
1answer
65 views

Confused about SharePoint Solutions

I'm confused about SharePoint Solutions. Could you verify if my understanding is correct? There are only 2 kinds of SharePoint Solutions: Sandboxed Solutions: When a solution package is deployed to ...
1
vote
1answer
237 views

SharePoint Event Receiver does not fire after deployment

I have created a simple SharePoint 2013 solution and added event receiver. When I am in visual studio, i hit F5, solution is deployed and event receiver works. However, when I publish the solution (....
1
vote
1answer
46 views

What influences the deployment speed on SP2013?

I have an Hyper-V machine running Sharepoint 2013 connected to an hosted server with 16GB ram, where the database is installed for that Sharepoint server. I wanted to improve the local deployment ...
0
votes
1answer
203 views

error “Operation is not valid due to the current state of the object.” during deploy solution from visual studio

I create one share point solution and two class library within that project,every library signed in properly, but, while I deploy that on to share point site,various ways I tried like through power-...
0
votes
1answer
61 views

Get SharePoint Web App Url programatilly from WindowsFormTool

I developing a simple Windows Forms Application that using a PowerShell script to add WSP solutions to multiple SharePoint front ends automatically. I am not a SharePoint developer but it's required ...
0
votes
0answers
20 views

How to find solution location of application deployed on Sharepoint2013

Need your help in finding the solution location deployed on a production environment.This is because the past developer deployed different solutions on UAT on Production.And handed over to me a ...
0
votes
1answer
49 views

How the user is authenticated in SharePoint using Active Directory?

I am having a requirement when admin sets an account to "Force Password change at next login", the user will be redirected to password reset page. But I don't know what happens at the back after user ...
0
votes
1answer
546 views

SharePoint 2010 Adding Web Part Error: Object reference not set to an instance of an object

I created a Farm Solution visual web part in a development environment (VM). I've run into issue while attempting to deploy this Visual Web Part in a test environment. I added (Add-SPSolution), ...
0
votes
2answers
209 views

Error while deploying custom solution with itextsharp dll

I need to use an external .dll file with itextsharp in my solution. Under development environment everything is fine. But same code in production server is giving an error. when checked in the log ...
0
votes
0answers
37 views

Import Visio Workflow in SharePoint 2013 using powershell

I received a .vwi file, which is a Visio workflow and now I would like to add it to the SharePoint workflow of a site collection. So far I have found that it can only be imported using SharePoint ...
1
vote
1answer
41 views

After deploying the Visual studio workflow in SP2013 breaking instances of in progress workflows

I have been working on developing visual studio workflows for SP2013. This workflow is associated with a document library. I have noticed that each time i deploy the workflow it is breaking the ...
1
vote
0answers
24 views

How to bulk upload a site template (solution) to multiple site collections

We've multiple site collections with customized site templates (or solutions). Is it possible to change all the solution (in all the site collections) at once when the template has been updated? ...
0
votes
1answer
68 views

Deploying an updated solution seems to redeploy the previous version

I'm testing a new feature I'm developing. I have ULS logging in the feature. I deployed it to a production server after testing in the dev environment was complete and users then requested a few ...
0
votes
1answer
247 views

Not able to activate the site template in solutions gallery : SharePoint 2010

I have created a site from Decision Meeting work-space template, made some modifications(added 2 Extra columns of date time datatype into Agenda list, added a new list for comments). I have saved ...
0
votes
0answers
91 views

Error when deploying solution webparts - Cant figure out why its failing

I'm trying to deploy this webpart I can get it to work on Dev with no issues. But I have problem when deploying it to production. First of all I can't get to see anything in the site collection ...
1
vote
0answers
23 views

2013 Solution Migration

I upgraded a site with custom aspx pages from 2010 to 2013 and tried to save it as a template to move it to another SP13 farm but I keep getting an error. The content type name ' $Resources:...
1
vote
1answer
61 views

Convert User field to UserMulti field

I have a content type which has a field called "Owner" which currently is of type User. The code has been deployed to production and has been so for ~1 year so they have a lot of data in the ...
2
votes
2answers
40 views

Deploy multiple WSPs to specific web application or globally in MOSS 2007 environment

Install-SPSolution -Identity $solutionName -WebApplication $webApp -GacDeployment -Force But I get cmdlet not found error. Please can anyone help me out.
0
votes
1answer
84 views

SharePoint mixing list schema

I've a solution for SharePoint 2013 where I created several list and added them to a feature. When I deploy the solution to my dev environment every list has the same schema (the same columns). They ...
1
vote
1answer
360 views

Some of the files failed to copy during deployment of the solution

I tried to deploy a solution to our server, but it seems that there are two WFE servers (I am not sure about this if they are both WFE or WFE and application server. How can I see the difference?). ...
1
vote
1answer
102 views

Solution not deploying after Farm Restart

I launched powershell script for restart the entire Farm. After that, I notice that every time I try to deploy a solution it doesn't finish deploying process. Even if launching Install-SPSolution from ...
1
vote
3answers
557 views

Deploying WSP to a specific web application

I have created a SP 2013 solution, and I want to deploy this in my farm. But the requirement is that I don't want this wsp to be available in all the web applications. It should target only to my web ...
0
votes
1answer
25 views

Solution Upgrade, Activating feature as well

I have deployed a solution on my test server with 1 features that creates an AppConfig list and add 3 list items, I used visual studio to create list items. <Data> <Rows> ...
0
votes
1answer
762 views

how to build wsp in visual studio 2012 without actually deploying the project

I am trying to create a wsp for my project in visual studio 2012. when i build my project it is not creating a wsp only when i deploy my project it is creating a wsp in my bin/debug folder. Is there ...
0
votes
0answers
6 views

Microsoft products 2010 installation

I wants to deploy a custom solution for our team portal. But I don't find any Microsoft products list in my system how to install it?
0
votes
1answer
262 views

Deploy solution across all the site collection in a web app

I have an environment in which we have 1000's of site collection. We also create new site collection. I want to deploy an event receiver which is available across all the site collections i.e web ...
0
votes
1answer
51 views

Deploy solution only at root sites in site collections

There are more than 100 site collections and I need to deploy a solution which should only be available to all site collections but not to sub-sites. Please suggest a way forward.
1
vote
1answer
136 views

SharePoint 2013 Visual Studio Solution - Adding / Importing site pages into an existing solution

I have an existing Visual Studio solution containing web parts etc. I want to add a set of site pages to the solution, that will be deployed to the 'SitePages' folder of a site collection, when the ...
2
votes
0answers
269 views

Sandbox Solution failing to load

Okay I think I'm missing something when I'm trying to build an Event Receiver. I'm new to this so please excuse my ignorance. But when I try to deploy an Event Receiver I always get a Could not load ...
0
votes
2answers
326 views

Why my solution is getting deployed to only one(App Server) server out of 2 WebFrontEnd and 1 App Server?

I have a solution containing a Visual WebPart and an Application(_Layouts) page. I have used VS 2013 for developing this solution and its for our 2013 farm. The farm has one Application Server and 2 ...
2
votes
1answer
388 views

No permission to retract/uninstall from CA, but from PowerShell

I have a weird permission-related problem. My account is entered as a local administrator, just to be on the safe side. If I want to retract or remove solutions within the CA I am getting either an ...
0
votes
2answers
386 views

Add Custom Web Part to newly created page programmatically

I created a custom web part for SharePoint 2013 and I would like it to be added to a blank page that is created for it. I looked it up and found out, that the I can add an Event Receiver to the ...
0
votes
1answer
570 views

Page Not Found Error After Deploying The Solution Using PowerShell

I am a novice in sharepoint 2013. I have created a Sharepoint 2013 Solution using "Empty Project" as my template and added two aspx pages. When deploying the solution using VS2012 the solution ...
0
votes
1answer
103 views

Can I test a SharePoint solution on a remote server?

I want to develop a SharePoint Solution event receiver (not SharePoint app) on a computer with visual studio 2013 but without SharePoint. SharePoint will run on a different computer on the same LAN. ...
0
votes
2answers
465 views

SharePoint .wsp retraction error

I am deploying a solution by Visual Studio. I get the error during Retraction: The solution does not have a WSP file associated with it. I tried to do IISRESET and also to restart the server.
2
votes
1answer
23 views

Is multiple user account required to deploy in office 365 production environments?

Let’s say there are 5 users working with different apps in one SharePoint 2013 Office 365 development environment. Naturally they are working with different user ids (a/c). Now if they want to deploy ...
1
vote
2answers
1k views

ActivityNotFoundException during feature activation

I have a workflow 2013 included in Full trust solution (WSP). When I add a variable of type DynamicValue to the workflow and try to deploy the solution using VS 2012 I get the error during feature ...
3
votes
2answers
346 views

Custom Form of SharePoint-List: Prevent default DataFormWebpart to be added

I'm working on a SharePoint 2013-Solution which deploys a custom list with custom site columns and a custom form. In the list's Schema.xml I added following lines: <Forms> <Form Type="...
0
votes
1answer
281 views

Recaptcha.dll not found after webpart deployment

I'm developing a webpart that contains a form for register data and send it to a list. I know a little about Sharepoint webpart development but again, implementation of external resources in ...