2
votes
0answers
31 views

to go with save site as a template, web template or site definition

I have to create a generic site template which has few tabs in the home page and on click of these links/tabs in this site template it will navigate to the sub sites created under that[this generic ...
0
votes
0answers
44 views

How can I create a editable site page based on a custom page layout that is deployed via site definition

I have a site definition (SP2013) with some features. The feature deployes a custom page layout thats using the "Article Page" content type. Once deployed I can create new pages fine based on my new ...
1
vote
2answers
1k views

SharePoint 2013 Site Definition Template Missing

I am using Visual Studio 2012 Ultimate RC, and I did install the Sharepoint 2013 tools. But cant find the site definition templates. Any thoughts??
0
votes
2answers
85 views

Steps to deploy a Site Definition having a custom Master page

we have custom site definition with a custom master page, I copied it from Control Templates, made changes to "ONET.XML" and master page they are using. I also renamed site definition folder name and ...
0
votes
1answer
42 views

Is it possible to have a Site without Site Definition

I am working on a portal and have a site/web and I am trying to find out what site definition its using, I tried this code to find out, it does give me a site template ID and Master page URL, but it ...
0
votes
2answers
107 views

How to Find out Site definition being used by a Site

I always struggle to find out that how to know what site definition or site template a "Web" or a "Site" is using. We do have a lot of custom site definitions and site templates, we are using in our ...
2
votes
3answers
4k views

“Cannot find this file” error when deploying from Visual Studio 2010

I'm getting an error in Visual Studio 2010 after pressing F5 to Debug: Error occurred in deployment step 'Add Solution': Error: Cannot find this file specified in the manifest file: ...
0
votes
2answers
1k views

WSP for Site Definition does not show up when creating a new site

WSP for Site Definition does not show up when creating a new site. I uploaded a new wsp under the solution gallery of the site collection. I went to a sub site and click on Create from "all content" ...