0
votes
0answers
55 views

spadminV4 which could not be contacted in deployment

I have Sharepoint 2013 and Powershell deployment. I execute muy ps1 script in SPS01 machine. Farm servers are SPS01, SPS02, SPS03, SPS04. User for deploy is UserInstallerMoss , it's Farm ...
0
votes
1answer
55 views

Access denied in powerschell script for Add SPSolution

I have a Windows Server 2012 Standard, named DC. This server is a Domain Controller. I have Sharepoint 2013. The domain is DEVRSG.COM. I log on in DC machine using DEVRSG\Administrator, is Domain ...
0
votes
1answer
24 views

What does “Synchronize” paramter of Install-SPSolution do?

Install-SPSolution command can accept an optional Synchronize parameter. MSDN says that it "synchronizes all solutions or the specified solution in the local farm". But what does this mean? What ...
0
votes
1answer
38 views

What happens if feature is already activated and you install new wsp?

Suppose we have deployed a wsp (say webpart) with a feature at site collection level and it is activated. Then, we change code of the webpart, create a new wsp. Then, go to central admin->manage ...
0
votes
1answer
17 views

Webpart not appearing in site

We have deployed webpart using powershell but cannot find it under the Edit page-> add webpart -> custom, there is no folder called 'custom'. This folder otherwise comes up when deployed via VS. ...
3
votes
2answers
541 views

Problem with SP2013 solution scope: WebApplication vs GAC

I have a SP2013 solution that contains a custom WCF service, custom Timer Job and a Feature Event Reciever. Because of these the solution Assembly Deploying Target is set to GlobalAssemblyCache. The ...
0
votes
1answer
1k views

Deploy a single feature using SharePoint Management Shell with SharePoint 2013

I have been working in a development environment and deploying my custom web part features from Visual Studio directly by just hitting F5. I now need a way to deploy features separately to a test ...
0
votes
2answers
34 views

Full deploy with customization

I have installed 2 VM's (DC/SQL box and a SP2010app/VS2012 box). I have created a web app with its initial root site collection (based on Blank Site). My goal is to prepare the dev environment so ...
1
vote
1answer
199 views

Solution deployment fails with error “Violation of PRIMARY KEY constraint 'PK_Classes'”

In our install script, which installs several solutions together, we found that solutions were occasionally failing to deploy with the following error in the ULS log: ...
1
vote
1answer
526 views

How to create a PowerShell script that accepts one or more SPWebApplication and use it in an expression?

I'm trying to create a custom function that can uninstall and reinstall any SharePoint solution. Some solutions requires the -GACDeployment switch, some requires the -AllWebApplications and some ...
0
votes
0answers
114 views

Problem with adding webparts with limitedWebManager.ImportWebPart PowerShell

When creating a web in Visual Studio it generates a web part where the namespace and the class name is the same. I'm thinking that this is giving me a problem with the limitedWebManager.ImportWebPart ...
0
votes
1answer
345 views

Deploy with PowerShell issue

When I deploy my project from visual studio everything is fine, I have a module with some pictures in it and a stylesheet that get replaced on deployment, from the output window: Retracting ...
0
votes
1answer
192 views

Error while executing Powershell Script SharePoint 2010

I am writing a PS script to add,deploy solution and deploy the features. The sequence is as follows Check if solution already exists, if yes then Disable -SPFeature (Runs for around 10 features) ...
2
votes
5answers
2k views

Adding new webparts to an already deployed solution

I have a webpart project built in visual studio 2010 and it has been deployed successfully to my production environment. I recently had to make some changes to the webpart and also needed to add a ...
2
votes
3answers
199 views

How to check if there is any active solution deployment running on the server?

Is there a way to know if there is any active solution deployment running on SharePoint server? I'm wondering how to do this using a PowerShell script?
8
votes
4answers
4k views

Problem with HTTP Handler deployed on Sharepoint 2010

I've developed a Visual Web Part for Sharepoint 2010. I've used VS2010 to do that and tested the Webpart in a testing server using VS to do the deployment. But to deploy it on the production server I ...
2
votes
5answers
10k views

Enable-SPFeature not working

I am using PowerShell script to deploy and activate a feature in the same script. Everything works fine and I can see my feature in the Sharepoint Root folder (14 hive). I run it using Farm Admin. ...
2
votes
3answers
3k views

How to apply new page layout to all existing pages in a site?

I really need your help. I've created a new page layout in SharePoint Designer 2010 and I want to apply it to all existing pages in a site. Another thing to note, some subsites and pages use ...
1
vote
3answers
2k views

Powershell Deployment - Enable-SPFeature Error

I get the following problem activating a feature in powershell: Enable-SPFeature : The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: ...
2
votes
2answers
2k views

How can I use Powershell to move a list from a development to a production Sharepoint 2010 box?

I'd like to copy a list (and its contents) onto our production server. I've been trying to use the Export-SPWeb cmdlet, using this article as a reference, but I can't seem to get it to cooperate. I've ...
2
votes
2answers
386 views

Is there a way to assign a search server to a content database using PowerShell?

Is there a way to assign a SharePoint Foundation search server to a content database using PowerShell, either while creating an Sp-WebApplication using New-SpWebApplication or by updating an ...
2
votes
1answer
4k views

Activating a WebApplication Scoped Feature for a particular WebApplication

I developed a SharePoint 2010 WSP that contains a custom HTTP Module for performing short-url redirects. The WSP also contains a WebApplication scoped feature that consists of a feature receiver that ...
3
votes
1answer
2k views

Set SPWeb title on a SharePoint site using PowerShell

I'm having problems setting the title of a root web in a site collection when creating it in an other language then English. When i run the script under using 1033, it works fine the site title is set ...
4
votes
3answers
2k views

Deploying a site template and instantiate it in the same PowerShell script?

I want to create a PowerShell script that : add a farm solution that only contains a site template deploy the solution globally wait for the deploy job to finish create a site collection based on ...
6
votes
1answer
2k views

Problem installing web part using Powershell

We've developed a custom Visual Web Part using Visual Studio 2010 for Sharepoint 2010 Server. The webpart gets deployed when executed from VS (F5), so we can add it wherever we want using Sharepoint ...
6
votes
2answers
986 views

How to reproduce Visual Studio “Deploy” action?

It seems like whenever I am developing a web part and I "Deploy" it from Visual Studio, everything gets deployed and works exactly as I would expect. When I take my WSP and try to install it to a ...
3
votes
1answer
2k views

Creating the secure store service master key fails

I have some powershell to create a farm including the secure store service. The code is pretty straight forward: Update-SPSecureStoreMasterKey -ServiceApplicationProxy $id -Passphrase $passphrase ...
6
votes
2answers
166 views

What is a good way to build/install/provision a full web application?

I have a fairly simple SharePoint web application, with a publishing front end, an extranet for customers and an intranet portal. I want this web app to be easily redeployable -- pretty much a ...
0
votes
1answer
277 views

AddListItem to list by using powershell

Is it possible to add list items to a list by using powershell commands.