Internet Information Server (IIS) – is a web server application to host web applications.

learn more… | top users | synonyms

2
votes
1answer
81 views

Set Default Web Site to Stopped

Can you set the Default Web Site's status to Stopped in IIS on the WFE servers, and still have access to your SharePoint 2013 site? We are attempting to do this for security reasons.
2
votes
1answer
362 views

Steps to deny anonymous access to _vti_pvt directory iis7

The service.cnf file found in the _vti_pvt directory has the default permission settings which may lead to an unauthorized access to the file What are the steps to deny anonymous access to _vti_pvt ...
1
vote
1answer
38 views

2 web sites running on same port and without host header

I have created a web application on port 443 https and configured to use windows authentication and without any host headers, providing no host header is requirement for Apps development, I have ...
1
vote
1answer
63 views

The server could not complete your request : Opening a site in SharePoint 2013 designer

I work in SharePoint Designer 2013. I want to open my site I received the following error. Then I clicked "Details". But details are empty. I researched same issue on the net and I found this ...
1
vote
1answer
62 views

Error accesing configure service account page in central admin

recently i migrated sharepoint farm from one domain to another. i manually changed application pool identity in IIS which is bad practice which i later realized. now that i read some articles and get ...
1
vote
1answer
277 views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
1
vote
1answer
225 views

Error while publishing Provider-Hosted MVC App to catalog site

I am tying to publish SharePoint 2013 Provider-Hosted MVC App to my site. I am getting this error message: Parser Error Message: Could not load type 'Microsoft.SharePoint.WebControls.ListMenu'. ...
1
vote
1answer
96 views

Custom Web Part's Active Directory connection only working from server

I have a custom web part that utilizes a dropdown combobox with items populated from AD. While it used to work, now I am unable to see anything populated in the dropdown unless I view the web part ...
1
vote
1answer
384 views

IIS Log files are not getting generated for the “SharePoint Web Services” webapplication in SharePoint - 2010?

IIS Log files are not getting generated for the "SharePoint Web Services" webapplication in SharePoint - 2010, even though Logging is enabled at the IIS level. Is that an expected behavior? or this ...
0
votes
1answer
35 views

500 Internal error - Timeout expired

I am getting "500 Internal Server" error while accessing my webapplication in SharePoint 2010. After some tracing I found that the actual error is : "Timeout expired. The timeout period elapsed ...
0
votes
1answer
18 views

Conceptual - How does a custom feature maps to the web application / site?

When we deploy a custom code such as a List Definition with custom forms, we are attaching it into the feature so that upon activation, the list and forms are created. Going behind the scenes, the ...
0
votes
1answer
29 views

Mapping “http://intranet” to a web application

A customer of mine wants a user to be able to type "http://intranet" into their url and have their web application load. typing their web applications is rediculous because the url is nonsensical, I ...
0
votes
1answer
64 views

SharePoint 2010 Users cannot edit/open documents

Users with correct permissions are suddenly unable to to edit documents. When a document is clicked it is opened in Read-Only mode stating that the document is checked out to literally "Another User". ...
0
votes
1answer
52 views

Map HTTP Handler to allow .dll

I am trying to upload files to SharePoint 2013 Document Library programatically using C# and WebClient class. When the request to upload the data to certain path is made, and the file is e.g. a *.txt ...
0
votes
1answer
88 views

“Cannot connect to the configuration database” after changing app pool identity in SharePoint 2010?

The main web application on port 80 was running on sysadmin account in application. I changed identity to Domain user account. Added that user to config and admin databases as db owner and ...
0
votes
1answer
64 views

Central Administration Application pool Stopping

My SharePoint 2010 Central administration Application pool in IIS7 only works with my domain Administartor account. The Service Account I created crashed the application pool
0
votes
1answer
29 views

Web application creation trouble SharePoint 2013

I just have created a host header webApp in SharePoint 2013 (very normal operation) and added an A or AAA entry to the forward lookup zones in my dns and i created a site colelction which i cannot ...
0
votes
1answer
65 views

The SharePoint website cannot be displayed

Dunno what happened, just walked away from my server, came back and suddnely SharePoint website cannot be displayed. However, I can Access CA and it shows that the content is still there. I restarded ...
2
votes
0answers
26 views

Requirments for running my web application under https

I have created a new web application that uses https. After that I added a new site collection to it, but my question is "will SharePoint web application and the site collection works under HTTPS out ...
1
vote
0answers
26 views

Benefits and drawbacks of using the SNI extensions with SSL

We're in the middle of evaluating what the best way to encrypt all our web applications in SharePoint would be. We have taken into account what different types of certificates there are and their ...
1
vote
0answers
205 views

Error 401 SharePoint Provider Hosted App

I'm trying to work with high trust apps on SharePoint 2013. I'm using Visual Studio 2013 Update 3, SharePoint 2013 Enterprise SP1. I've followed this 2 links : Create a basic provider hosted app ...
1
vote
0answers
81 views

Sharepoint designer won't connect to localhost

I use IIS 6 with windows7 I installed Sharepoint Designer 2007. http://localhost is functioning allright. Now my problem: When in SharePoint Designer I try to open http://localhost I get the error ...
1
vote
0answers
269 views

Config error: The requested service could not be activated

I am trying to deploy and use a web part developed in SP2010 that requires connecting from a SP2010 server to a SQL server. I get the following error (greatly abbreviated): The requested service, ...
1
vote
0answers
57 views

Deploying Sharepoint 2010 solutions to sharepoint 2013 giving me error

does anyone have any suggestions where to look for guides when deploying sp 2010 solutions to 2013, I've tried everything and keep gettin the error : Error occurred in deployment step 'Recycle IIS ...
1
vote
0answers
236 views

Why WCF service does not work in sharepoint web part?

I have created a web service using WCF which gets the data from SQL into sharepoint. I have hosted it in IIS. It works fine when I call the service in the browser. I can see the wsdl. I used an ...
1
vote
0answers
53 views

Sluggish Sharepoint Application

I have Sharepoint 2010 application that runs smoothly during certain times of day however, whenever it feels like: the CPU usage hits 100%; the ASP Request Execution Time indicator flashes a warning; ...
1
vote
0answers
211 views

IIS Error - Invalid Path

I am new to IIS and trying to set up a site on it. I am trying to set up Microsft.Hosting.SharePoint2010.Services. I keep getting the following error. Here are my Basic Settings. The physical path ...
0
votes
0answers
19 views

Create webservice, host and call in sharepoint hosted apps

I have one requirement to connect to database and get the details and do some operations in sharepoint (I dont want BCS solution). For these things i have create one simple webservice(for testing) and ...
0
votes
0answers
22 views

Sharepoint 2013 app 404 error

I'm trying to deploy an app I got from the Windows Store in a new Sharepoint 2013 server. I have a separate domain in DNS and can ping and resolve the app url. However when I try to start the app ...
0
votes
0answers
16 views

css files for 1 site collection are being served as application/octet-stream Content-type instead of text/css

I got 2 SP2010 (win 2008R2) farms and 2 web-applications running on them: Farm1 (prd) -> app-prd Farm2 (tst) -> app-tst (app-prd and app-tst are FQDN http links) on those web-applications we've ...
0
votes
0answers
49 views

InfoPath error, “The Soap message cannot be parsed”. Risks editing the execution timeout?

So i just ran into the problem with an InfoPath form for a list with over 60 columns and over 3000+ list items that can't be deployed to the server because "The Soap message cannot be parsed". I've ...
0
votes
0answers
26 views

SharePoint 2013 Apps with HTTPS & VM in Azure (Problem with SNI in IIS)

I have a VM in Azure with SharePoint 2013 (and one NIC) and this machine has a site to site vpn with my customer. In this farm i have applied the app model with https in a different web application ...
0
votes
0answers
18 views

Limiting access to internet facing SharePoint site

I've recently started using the Url-Rewrite tool to achieve a couple of redirecting needs. My current need is to limit access to a customer's internet facing site based on SharePoint so that ...
0
votes
0answers
86 views

MS Office documents won't open

I'm using SharePoint 2010 and MS Office 2013 up until recently I was having no issues with this combination. Starting over the last week all MS Office documents will not open. The MS Office ...
0
votes
0answers
157 views

Lists.asmx returns 404 Page Not Found in Sharepoint 2013

I am trying to add a web reference. So trying to reach http://server/_vti_bin/Lists.asmx from my browser. I can see the list services listed down but when I select the Service Description (or ...
0
votes
0answers
40 views

SP2013 - 2 WebApps on same IP with SSL for HNSC

First a couple things about my environment: - I'm using SP2013 Enterprise on Windows 2012R2 with IIS8 SNI isn't an option since I need to support IE on WinXP (plus I believe it needs to be part of ...
0
votes
0answers
11 views

Server asks for credentails but doesn't show default.aspx

I've installed Sharepoint 2013 Server on Windows Server 2012. But I've problems login into Administration Control Panel. I have installed development environment. After a lot of waiting Sharepoint ...
0
votes
0answers
13 views

Setting up apps on a SSL-based VM

Sorry if this has been posted or well-documented somewhere -- I can't seem to find any good documentation on this anywhere. Closest I found was this related post, but it didn't work for me. I ...
0
votes
0answers
76 views

Provider Hosted MVC application hosted outside Sharepoint IIS, find current Sharepoint User

I want to host a MVC application outside Sharepoint - 80 IIS website. Everything works just fine, but I can not find the current sharepoint user, because SPContext.Current is null. My entire MVC ...
0
votes
0answers
69 views

unable to provision a new Central Administration web application

I was facing a problem when accessing the Central administration web application that it keeps raisng “File not found” inside my SharePoint server 2013 , although the web application is running inside ...
0
votes
0answers
21 views

SPContext in SharePoint virtual directory

Reference to this question Adding ASP.NET Web Application to SharePoint Virtual Directory (for SPContext) , I'm facing the same issue; I have created an asp.net website. I've copied the source folder ...
0
votes
0answers
39 views

Multiple HTTP redirects

We have multiple cnames pointing to the SP server that we want to redirect to specific sites, i.e. if someone types http://finance in the browser they are redirected to something like ...
0
votes
0answers
40 views

Sharepoint cookies

My problem is same as the one asked in the question @ Make all sharepoint specific cookies non-persistent? The problem is "Make all sharepoint cookies non-persistent" I have implemented the solution ...
0
votes
0answers
95 views

IIS website not prompting for authentication, and page is blank

My SharePoint site has suddenly stopped working. It is not prompting for login. The page simply stops at blank. I tried creating a new website, and it is working fine. So, it seems there is ...
0
votes
0answers
18 views

What am I looking for when I already have 1 “intranet” as a default when a newly acquired “intranet” is supposed to be “absorbed”?

I have two "intranets" listed as the URL. The recently acquired "intranet" should be "absorbed" into the existing "intranet". Both are SharePoint 2010 Foundation, Server 2008. How do I plan for the ...
0
votes
0answers
119 views

Can't resolve 500 - Internal server error

I am running SharePoint Foundation 2010. I have 1 APP and 2 WFE server. I did setup (in IIS) bindings to a subdomain and IP). I have setup my application and it was working fine. I ran the SharePoint ...
0
votes
0answers
404 views

Server Error in '/' Application after system reboot

I'm using Sharepoint Foundation 2013. I've installed some Windows Update on my Win Server 2008 R2 and then rebooted my server. After that my Sharepoint website returns: "Server Error in '/' ...
0
votes
0answers
248 views

Sharepoint Site configuration Error when deploying Provider hosted App

I have SharePoint 2013 on premises. My App catalog is on the same server as SharePoint (it is on the same domain). Whenever I deploy my simple Provider-Hosted app to any site, the site's web.config ...
0
votes
0answers
929 views

How Sharepoint pages life cycle works?

I built a HttpModule for sharepoint. But when I begin to debug the page request, I notice that the debugging has an strange cycle: 1 - context_PreRequestHandlerExecute() 2- page_PreInit() 3 - ...
0
votes
0answers
221 views

Website cannot be found

I have installed SP 2007 where nine domains are being hosted. Everything has been working correct until now. Right now, some of the domains cannot be displayed. I tried to edit the site in designer ...