Internet Information Server (IIS) – is a web server application to host web applications.

learn more… | top users | synonyms

0
votes
0answers
15 views

Provider Hosted MVC application hosted outside Sharepoint IIS, find current Sharepoint User

I want to host a MVC application outside Sharepoint - 80 IIS website. Everything works just fine, but I can not find the current sharepoint user, because SPContext.Current is null. My entire MVC ...
0
votes
1answer
452 views

What kind of IIS 6.0 configuation is needed with a MOSS SharePoint 2007 system

I admin a MOSS SP2007 service pack 3 (32 bit) farm of 1 sql server (shared) and 1 machine that runs all of sp2007 (windows 2003, 32 bit). The VM has allocated to it 2 CPUs and 8 GB of memory. Recent ...
0
votes
1answer
549 views

X-Frame-Options ignored in Chrome / Firefox. IE works

I have a simple PageViewer Webpart loading mysites. This displays in an iFrame within IE but doesn't display in Chrome or Firefox. I have tried adding the following to my MasterPage: <meta ...
0
votes
2answers
22 views

Solution Layouts/BigLettersFolder, in ScriptLink ends as layouts/bigletterfolder, and return 404

In some VS Sharepoint 2013 solution I have set up as follow: In mapped Layouts I have folder jQueryTest, and jquery.js in it. I have Scirpt Element with Elements.xml with: <?xml version="1.0" ...
0
votes
1answer
616 views

Enable Anonymous Access to Subfolder Containing Handlers

I have a folder in an application that I would like available to the public. For example: /_layouts/Handlers/Public/MyHandler.ashx I found this question that says I should enable anonymous access ...
0
votes
1answer
16 views

Central Administration Application pool Stopping

My SharePoint 2010 Central administration Application pool in IIS7 only works with my domain Administartor account. The Service Account I created crashed the application pool
0
votes
1answer
458 views

Cryptographic Exception

I have been having this error in SharePoint show up often: An unhandled exception occurred and the process was terminated. Application ID: /LM/W3SVC/1640420947/ROOT Process ID: 5788 ...
0
votes
0answers
10 views

unable to provision a new Central Administration web application

I was facing a problem when accessing the Central administration web application that it keeps raisng “File not found” inside my SharePoint server 2013 , although the web application is running inside ...
0
votes
0answers
12 views

SPContext in SharePoint virtual directory

Reference to this question Adding ASP.NET Web Application to SharePoint Virtual Directory (for SPContext) , I'm facing the same issue; I have created an asp.net website. I've copied the source folder ...
0
votes
0answers
25 views

Remove Sharepoint from IIS website retracts solution

I have a question on unextending a web app. When I unextend a web app, I find that all my files in the wpresources folder are removed even if other web apps are using these files. This is strange. ...
1
vote
1answer
148 views

Error while publishing Provider-Hosted MVC App to catalog site

I am tying to publish SharePoint 2013 Provider-Hosted MVC App to my site. I am getting this error message: Parser Error Message: Could not load type 'Microsoft.SharePoint.WebControls.ListMenu'. ...
0
votes
1answer
56 views

Redirect to http after certificate removal?

I'm trying to use AAM do redirect a webapplication that was used the run over HTTPS but now is just gonna run over basic HTTP. I notice that using AAM for this is not working. I have removed the ...
0
votes
0answers
45 views

Error 401 SharePoint Provider Hosted App

I'm trying to work with high trust apps on SharePoint 2013. I'm using Visual Studio 2013 Update 3, SharePoint 2013 Enterprise SP1. I've followed this 2 links : Create a basic provider hosted app ...
0
votes
2answers
612 views

Automatically logged in as “System Account” after changing service accounts

Note: The steps listed below should resolve this issue in most cases. My situation involved my browser cache... Whenever I access my SharePoint 2010 foundation page I am automatically logged in as ...
0
votes
1answer
46 views

How to refresh after edits to fldtypes.xsl?

After I make an edit to my custom \LAYOUTS\XSL\fldtypes.xsl file, such as these, how do I make the system immediately load the new file? I know I can get it loaded immediately with an iisreset. I ...
0
votes
0answers
22 views

Multiple HTTP redirects

We have multiple cnames pointing to the SP server that we want to redirect to specific sites, i.e. if someone types http://finance in the browser they are redirected to something like ...
5
votes
9answers
27k views

Application Pool is auto stopped when browse web application in IIS7

When I browse to Central Administration I get repeated authentication requests and am unable to view the page. I get the following error: Service Unavailable HTTP Error 503. The service is ...
1
vote
1answer
29 views

The server could not complete your request : Opening a site in SharePoint 2013 designer

I work in SharePoint Designer 2013. I want to open my site I received the following error. Then I clicked "Details". But details are empty. I researched same issue on the net and I found this ...
1
vote
0answers
24 views

Sharepoint designer won't connect to localhost

I use IIS 6 with windows7 I installed Sharepoint Designer 2007. http://localhost is functioning allright. Now my problem: When in SharePoint Designer I try to open http://localhost I get the error ...
2
votes
5answers
2k views

Workflow Manager Configuration Wizard blocked ports

I am running the Workflow Manager Configuration Wizard for Sharepoint 2013 workflows, but I am getting the flowing errors, I can't find anything on Google so I am hoping that someone here knows what ...
0
votes
1answer
124 views

Unable to create new Web Application - Corrupted Site in IIS and SecureToken Service errors

I'm not able to create new Web Application, after do that the page in CA when I was creating Web App shows error that "Internet Explorer cannot displayed the websitebe" In IIS Site has a few less ...
0
votes
1answer
141 views

My site collection is not accessible using IE & Chrome , while I can access it uing Firefox

I have a Team site collection at the root of my server, and can be accessed using the following URL:- http://servername now i can access it using firefox by entering the username/password and ...
0
votes
1answer
80 views

when i changed the IIS application pool's and sharepoint services's Service Account i start receving the following error “403 FORBIDDEN”

For security reasons we wanted to chnage the service accounts username for all the IIS application pools and SharePoint service , so we created a new user named "Staging.user", and i define it as a ...
2
votes
2answers
36 views

Host IIS sites alongside SharePoint

I know the premise around SharePoint and IIS, where SharePoint takes on Port 80 as the default, which is fine. Question is, is there a way to host IIS web sites, along side SharePoint on the same ...
1
vote
1answer
15 views

Error accesing configure service account page in central admin

recently i migrated sharepoint farm from one domain to another. i manually changed application pool identity in IIS which is bad practice which i later realized. now that i read some articles and get ...
0
votes
0answers
23 views

Sharepoint cookies

My problem is same as the one asked in the question @ Make all sharepoint specific cookies non-persistent? The problem is "Make all sharepoint cookies non-persistent" I have implemented the solution ...
2
votes
4answers
11k views

The Security Token Service is unavailable

I have to problems left on my dev machine. 1. The Security Token Service is unavailable 2. Get the user profile sync serve started. I am getting the following error every 5 minutes in my event log ...
3
votes
2answers
457 views

Users Getting IIS Home Screen Instead of Home page

I have one user which is getting the IIS home landing page instead of our SharePoint home page. When I log onto her from a different machine everything seems to be working fine. If she types in ...
0
votes
2answers
379 views

Page Load Extremely Slow (30 minutes) After IIS Reset

I have seen people reporting unacceptable 90 second page load times after an IIS reset. Every time we deploy a new solution and fire an IIS reset, it takes about 30 minutes for the first page to load. ...
0
votes
0answers
38 views

IIS website not prompting for authentication, and page is blank

My SharePoint site has suddenly stopped working. It is not prompting for login. The page simply stops at blank. I tried creating a new website, and it is working fine. So, it seems there is ...
0
votes
1answer
702 views

How do I add a user control from a separate assembly onto a Sharepoint application page?

Note: This question was originally posted in Stackoverflow and I was recommended to ask it here instead. There is probably a very simple solution to this problem but since I do not know Sharepoint at ...
1
vote
0answers
163 views

Config error: The requested service could not be activated

I am trying to deploy and use a web part developed in SP2010 that requires connecting from a SP2010 server to a SQL server. I get the following error (greatly abbreviated): The requested service, ...
0
votes
3answers
64 views

SharePoint warmup script implementation

I've implemented the SPWarmup script from Codeplex on development and production environment. This script (that can be found here https://spbestwarmup.codeplex.com/) is working well, when I run it ...
0
votes
2answers
1k views

Can not display a site collection after creating it

i have created a new site collection of type team site inside SharePoint 2013. it took around 50 minutes till it creates the site collection and i got the folloiwng page:- Central Administration : ...
1
vote
1answer
68 views

Sharepoint 2010 fails to run elevated code as IIS pool identity account

I changed the IIS pool identity service account for my SharePoint 2010 web application thus replacing the default "Network Service" account (using SharePoint Administrator.) The pool service account ...
1
vote
1answer
150 views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
0
votes
1answer
25 views

Web application creation trouble SharePoint 2013

I just have created a host header webApp in SharePoint 2013 (very normal operation) and added an A or AAA entry to the forward lookup zones in my dns and i created a site colelction which i cannot ...
0
votes
1answer
39 views

The SharePoint website cannot be displayed

Dunno what happened, just walked away from my server, came back and suddnely SharePoint website cannot be displayed. However, I can Access CA and it shows that the content is still there. I restarded ...
0
votes
1answer
176 views

SharePoint 2013. why Anonymous user Identity need to be 'IUSR'?

Environment: SharePoint 2013, IIS 8. No images and CSS displayed in the Central Admin. In firebug, its authentication failure. I checked in the IIS, the Anonymous user Identity was set to ...
0
votes
0answers
14 views

What am I looking for when I already have 1 “intranet” as a default when a newly acquired “intranet” is supposed to be “absorbed”?

I have two "intranets" listed as the URL. The recently acquired "intranet" should be "absorbed" into the existing "intranet". Both are SharePoint 2010 Foundation, Server 2008. How do I plan for the ...
1
vote
1answer
209 views

SharePoint 404 not found after IIS hardening

Environment: Windows Server 2012 SharePoint 2013 IIS 8 I have deployed the Sharepoint 2013 site in the App server(Windows 2012). We have seperate DB server. My site was working fine. Until I ran ...
0
votes
1answer
41 views

Redirect a PDF referencing old 2007 site

We have a SharePoint 2010 site that has numerous documents migrated over from our old SharePoint 2007 site. These documents that were migrated to 2010 (PDFs) have links in them that reference old ...
0
votes
2answers
1k views

Could not load file or assembly 'DLL' or one of its dependencies. Access is denied

Hi im having an issue migrating our .NET 2.0,1.0 and 0.0 WebForms application in our new SharePoint 2013 where it always prompt in every applications. Could not load file or assembly 'App_Code' or ...
0
votes
0answers
19 views

Compare SPAuditQuery and IIS log to get IPs

I'm using SP audit, but MachineIP is always null by design. I know that IIS loggs this info. So i dunno how can I compare it with IIS logs to get IPs. Now i'm just using a simple query to get all ...
0
votes
0answers
60 views

How to use Logparser to SharePoint

I am trying to follow this Blog http://altfo.wordpress.com/2013/04/07/how-to-find-concurrent-users-for-sharepoint-and-asp-net-using-iis-logs/ When I try to run the following command as stated in the ...
0
votes
1answer
1k views

SharePoint web services web site error Service Unavailable HTTP Error 503. The service is unavailable

I am working on SharePoint 2013 , and inside the IIS i have noted a question mark icon beside the "SharePoint Web Services" website, and when i browse the http & https , from IIS->select the ...
0
votes
1answer
59 views

SharePoint Web Services Site Gone in IIS 8.0 (SP2013)

In my SharePoint environment the site "SharePoint Web Service" site is missing from IIS Sites list, is there a way to recreate it? I have seen a guide on here but it seems to be for SharePoint 2010. ...
0
votes
0answers
133 views

Add VERBS in IIS(GET,POST,OPTIONS)

I am not able to publish infopath form in a sharepoint site (http://sites.com/region/Department) after several research, i got an update that need to add verbs in IIS. iam receving the below error in ...
0
votes
2answers
25 views

IIS site stopped SP is working, while IIS site started SP is not working

I can't understand at all why thing goes wrong like that. I have a SP2013. Evertyhing's ok. My website returns a Service Unavailable error. I stopped the IIS site, and my site is up ... and if I ...
0
votes
0answers
86 views

Can't resolve 500 - Internal server error

I am running SharePoint Foundation 2010. I have 1 APP and 2 WFE server. I did setup (in IIS) bindings to a subdomain and IP). I have setup my application and it was working fine. I ran the SharePoint ...