Internet Information Server (IIS) – is a web server application to host web applications.

learn more… | top users | synonyms

0
votes
2answers
29 views

On IIS cannot find existing application pool showed in CA

We are using SP2010 on-premise Enterprise edition. It is a single server containing SQL2008 (not express) and SharePoint Recently we found the User Profile Service application is not working. In the ...
1
vote
1answer
649 views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
0
votes
1answer
31 views

Redirect the Mysites request to another site in SharePoint 2013

In SharePoint 2013, I am facing an issue when clicking on the User id, it redirects to MySite url: https://mysites.example.com Currently Mysites is not working and users are getting error message. ...
0
votes
2answers
34 views

What's the SharePoint applications pool limit depend on?

I am working on SharePoint 2013, with a number of the application pool is 10. I gonna to create a new service application that requires new application pool , I read that the limit is 10, Can I ...
0
votes
1answer
44 views

How to create a Rest wcf service on SharePoint?

I'm trying to make a WCF Rest service inside SharePoint. but it doesn't work and I get 404 :( I set the svc file like that <%@ ServiceHost Language="C#" Debug="true" Service="MyNamespace....
0
votes
0answers
13 views

Homepage logged as 200 in IIS logs

Looking at the IIS logs I am seeing status code 200 for pages that are redirected. e.g. the landing page on a site redirects to /pages/default.aspx So we have an entry for / and an entry for /...
4
votes
1answer
80 views

Cannot Login to SP Site from application Server - Login prompt continually

After Creating new Site Collection root(SPWEB) with Host Header every request made from server (internal) is denied (Popup login Window continually). If requests come from FE (same USER), access is ...
1
vote
0answers
2k views

Topology error: A failure was reported when trying to invoke a service application

I am getting frequent topology errors on my SP servers: A failure was reported when trying to invoke a service application: EndpointFailure Affected Endpoint: http://app01:32843/...
1
vote
1answer
1k views

Enable Anonymous Access to Subfolder Containing Handlers

I have a folder in an application that I would like available to the public. For example: /_layouts/Handlers/Public/MyHandler.ashx I found this question that says I should enable anonymous access ...
0
votes
0answers
15 views

can not access web application from Load balancer after restart foundation web application service

Strange issue i have in our environment this is old farm and i am trying to add cumulative updates, it works for me when i stop sharepoint foundation web application service and run the configuration ...
0
votes
0answers
36 views

SharePoint URL Change

I am testing SharePoint 2013 local. First, I can't create new web application without server name. Eg.(servername:port). Second, I can't change URL(not subsite). I also tested by creating zones(in ...
0
votes
0answers
26 views

Oracle Access Manager and Sharepoint 2013 integration

I'm using SharePoint server 2013 running on Windows Server 2012R2 and IIS 8.5. I want to integrate SharePoint 2013 with OAM(Oracle Access Manager) for single sign on purpose. I followed some guides ...
0
votes
1answer
31 views

How can I display the current SharePoint user from a c# Web Form hosted on IIS

I'm stuck on my project. I have Web Forms published in IIS that are shown in SharePoint 2010 site. From that Web Form, I want to show the current user in SharePoint. My solution is from [http://www....
5
votes
11answers
43k views

Application Pool is auto stopped when browse web application in IIS7

When I browse to Central Administration I get repeated authentication requests and am unable to view the page. I get the following error: Service Unavailable HTTP Error 503. The service is ...
0
votes
0answers
69 views

Register-SPWorkflowService errors, possible IIS authentication misconfiguration? Cmdlet returns 401 code from Workflow Management Site

I cannot seem to find a solution to this issue. I've been trying to get workflow working now for 3 days with little success. Up until today, I was getting various errors on the Register-...
0
votes
0answers
63 views

404 FILE NOT FOUND: After Restoring Content DB

I have taken backup of content DB of one web application from production database server and restored to my development database server. content DB restored successfully. Content DBs have exactly same ...
0
votes
1answer
19 views

SharePoint 2010 WFEs (2) in same farm require different compatability modes

I have a SP 2010 Farm with 2 WFEs. The WFEs are load balanced and users, when they get switched (round robin, usage based polling on load balancer) they have to go in and deselect the compatibility ...
0
votes
1answer
75 views

Remove IIS Binding For SharePoint 2013 Site

I have a SharePoint 2013 site that has two port 80 bindings in IIS: one with a host name, one without (IP addresses are unassigned in both bindings). I would like to remove the port 80 binding that ...
0
votes
0answers
31 views

SharePoint 2010 iis virtual directory reverse proxy

I'm having some problems setting up a virtual directory to act as part of reverse proxy in IIS under our organisations SharePoint website. Basically I want to have a directory (e.g. htp://...
0
votes
0answers
13 views

User friendly page redirect using IIS

I have a page in sharepoint, I want to make the page url user friendly for example the page url is http://sp-site/pages/friendlypage I want to make it like this http://sp-site/friendlypage can ...
0
votes
1answer
22 views

Redirect from https://a.site.com to https://a.site.com/sub

I have a root site collection at https://a.site.com Underneath this root site collection I have another site collection (host named) at https://a.site.com/sub My users are interested in the site at ...
3
votes
1answer
42 views

SharePoint 2010 site is not opening with Alternate access mappings

My SharePoint site is not opening with any of public urls configured in Alternate access mapping. Steps i followed, I have added one public url for intranet zone eg: "http://www.example.com" I have ...
1
vote
1answer
364 views

SharePoint 2010 - disable SSLv3 and TLS 1.0

I'm tasked to figure out how to disable SSLv3 and TLS 1.0 on SharePoint 2010 farm. After some reading, I came to the following conclusions: It is safe to disable SSLv3 on SharePoint servers, It is ...
0
votes
0answers
549 views

Lists.asmx returns 404 Page Not Found in Sharepoint 2013

I am trying to add a web reference. So trying to reach http://server/_vti_bin/Lists.asmx from my browser. I can see the list services listed down but when I select the Service Description (or http://...
0
votes
1answer
69 views

Best practise for change the IP address of web front end server [duplicate]

change the IP of existing sharepoint web front end server and best practise for change the iP of sharepoint server, is any issues to web applicatons and sharepont farm
0
votes
1answer
99 views

SharePoint site Keep Asking for password After IISRESET

Even Many Question Regarding SharePoint Prompting for password again and again but,Even I can't find Exact solution When IIS reset to cache clear, site working fine ,but after some time same ...
0
votes
1answer
24 views

how can i change the sharepoint web application name and it also apply in IIS?

In sharepoint 2010 , when i create new web applications i given the name of sharepoint web applications like sharepoint-81,sharepoint-82... and after application created, in IIS also name of the ...
0
votes
0answers
30 views

SharePoint 2010 not Accessible

My complete SharePoint 2010 site is not accessible. However, the admin site is. The database is still OK. Error: Cannot open database "WSS_Site_Content" requested by the login. The login failed. ...
0
votes
1answer
930 views

MS Office documents won't open

I'm using SharePoint 2010 and MS Office 2013 up until recently I was having no issues with this combination. Starting over the last week all MS Office documents will not open. The MS Office ...
4
votes
2answers
9k views

When do we need an IISreset after deployment?

Is there any good articles out there to explain when we need to do an IISreset after deployment? We are using SharePoint as an internet facing site, and try to not do an IISreset if it is not ...
0
votes
0answers
37 views

Sharepoint Application Initialization and Preload

I'm curious if anyone is successful with using the IIS Application Initialization and Preloading features of IIS with Sharepoint. Here are some of the questions i had regarding getting it working ...
1
vote
0answers
96 views

Server issues Start-SPServiceInstance not working, but .Provision() Seems to be

We are having some pretty severe and bizarre issues. Luckily this is our quality environment. Three server farm. The issue is on the Web-Front-End. Sharepoint 2013 Enterprise. Some of the oddities (...
0
votes
0answers
23 views

How can I have two urls redirect to the same site?

We are getting rid of an old site http://sharepoint/sites/oldSite and would like to automatically redirect users to the new site http://sharepoint/sites/newSite if they try to hit the old site url. ...
2
votes
1answer
23 views

MMS service app pool name is incorrect

I've created a managed metadata service with PowerShell: New-SPServiceApplicationPool -Name "SPService" -Account CONTOSO\Admin New-SPMetadataServiceApplication -Name "MetadataServiceApp" -...
4
votes
2answers
104 views

Unable to install Application Server Role

When I try to install Sharepoint 2013 on a new Windows 2012 R2 server, I encounter the following error with the Product Preparation Tool: Unable to install Application Server Role I followed a ...
3
votes
1answer
227 views

PowerShell Script to restart the Application Pools of WFEs

Need to create a PowerShell script to recycle the Application Pool of my WFE - Dev,Staging & Production servers of my SP 2013 Farm. I tried code mentioned here But somehow as mentioned in ...
0
votes
1answer
914 views

How do I add a user control from a separate assembly onto a Sharepoint application page?

Note: This question was originally posted in Stackoverflow and I was recommended to ask it here instead. There is probably a very simple solution to this problem but since I don't know Sharepoint at ...
1
vote
2answers
289 views

403 Forbidden Error when accessing _layouts folder

I have inherited an application in which the Developer created a bunch of application pages (ASPX) which get deployed to the _layouts folder. The user is directed to these pages throughout the ...
0
votes
1answer
652 views

Redirect from xxx.com to full FQDN URL

In SharePoint 2013 I have created a web application and published it to Internet with avalid https certificate AAM: Default: https://www.xxxx.com IIS bindings: Hostname: www.xxxxx.com My ...
0
votes
0answers
16 views

Designer - Error when trying to connect to web service “the server can not complete your request”

I'm trying to connect to sites with sharepoint designer , but I get the error below: Translation: "the server can not complete your request." When click on "Details " displays an empty box. When ...
0
votes
2answers
1k views

Move-SPSite vs Copy-SPSite

In my environment I need to perform a Move-SPSite and a Copy-SPSite. Why do Move-SPSite need a IISreset and Copy-SPSite do not? Can I just use a Copy-SPSite (and delete one db) to avoid IISReset?
0
votes
0answers
65 views

Duplicate HSTS header

This is an odd one. Like I do on other IIS sites, I set a custom header, Strict-Transport-Security: max-age=2592000. It works great. But on my SharePoint 2013 server, it always comes back to the ...
0
votes
0answers
17 views

Workflow with custom async webservices Skip some Requests

I've built a custom workflow activity for Sp 2010. this one does nothing else than calling an Custom Web Services asynchronously private void codeActivity1_ExecuteCode(object sender, EventArgs e) ...
0
votes
1answer
45 views

Configuring AAM to use HTTPS caused many services

I have configured the AAM to use HTTPS. Actual steps I used are: Create Binding in IIS site to use https and selected a wildcard certificate. From Central Administrator, AAM is configured as- ...
0
votes
2answers
1k views

Cryptographic Exception

I have been having this error in SharePoint show up often: An unhandled exception occurred and the process was terminated. Application ID: /LM/W3SVC/1640420947/ROOT Process ID: 5788 ...
0
votes
1answer
33 views

SharePoint 2013 AAM Issue

My SharePoint 2013 instance was originally deployed into production as local intranet access only (i.e. http:SPABC01:12351) and later when I finished I configured the internet zone (i.e. http://...
1
vote
1answer
158 views

Redirect HTTP to HTTPS using IIS is not working

I have a Web Application. Its AAM is as follows- Zone Public URL for Zone Default http://sharepoint:46543 Internet http://abc.something.com Custom https://abc.something.com ...
0
votes
0answers
76 views

Microsoft <product> cannot access file - NTLM Authentication Issue

Last week out of nowhere our Sharepoint Foundation 2010 server stopped allowing random computers in the company the ability to open any office document via Internet Explorer. It only affected a few ...
0
votes
1answer
421 views

IIS Sites not created in all servers in Farm SharePoint 2013

I have SharePoint 2013 Farm with 2 WFE and 3 App Server: I have 3 Web Applications aside from Central Admin. In IIS i have all sites created properly except on WFE2. I only see 2 Web Applications ...
0
votes
1answer
105 views

why one application pool has 4 worker processes in IIS

why one application pool has 4 worker processes in IIS this application pool for Performancepoint service running in sharepoint application server