Internet Information Server (IIS) – is a web server application to host web applications.

learn more… | top users | synonyms

0
votes
0answers
22 views

SPContext in SharePoint virtual directory

Reference to this question Adding ASP.NET Web Application to SharePoint Virtual Directory (for SPContext) , I'm facing the same issue; I have created an asp.net website. I've copied the source folder ...
1
vote
0answers
223 views

Error 401 SharePoint Provider Hosted App

I'm trying to work with high trust apps on SharePoint 2013. I'm using Visual Studio 2013 Update 3, SharePoint 2013 Enterprise SP1. I've followed this 2 links : Create a basic provider hosted app ...
0
votes
1answer
86 views

How to refresh after edits to fldtypes.xsl?

After I make an edit to my custom \LAYOUTS\XSL\fldtypes.xsl file, such as these, how do I make the system immediately load the new file? I know I can get it loaded immediately with an iisreset. I ...
0
votes
1answer
86 views

Redirect to http after certificate removal?

I'm trying to use AAM do redirect a webapplication that was used the run over HTTPS but now is just gonna run over basic HTTP. I notice that using AAM for this is not working. I have removed the ...
0
votes
0answers
40 views

Multiple HTTP redirects

We have multiple cnames pointing to the SP server that we want to redirect to specific sites, i.e. if someone types http://finance in the browser they are redirected to something like ...
1
vote
1answer
72 views

The server could not complete your request : Opening a site in SharePoint 2013 designer

I work in SharePoint Designer 2013. I want to open my site I received the following error. Then I clicked "Details". But details are empty. I researched same issue on the net and I found this ...
1
vote
0answers
88 views

Sharepoint designer won't connect to localhost

I use IIS 6 with windows7 I installed Sharepoint Designer 2007. http://localhost is functioning allright. Now my problem: When in SharePoint Designer I try to open http://localhost I get the error ...
0
votes
1answer
1k views

Unable to create new Web Application - Corrupted Site in IIS and SecureToken Service errors

I'm not able to create new Web Application, after do that the page in CA when I was creating Web App shows error that "Internet Explorer cannot displayed the websitebe" In IIS Site has a few less ...
0
votes
1answer
598 views

My site collection is not accessible using IE & Chrome , while I can access it uing Firefox

I have a Team site collection at the root of my server, and can be accessed using the following URL:- http://servername now i can access it using firefox by entering the username/password and ...
0
votes
1answer
333 views

when i changed the IIS application pool's and sharepoint services's Service Account i start receving the following error “403 FORBIDDEN”

For security reasons we wanted to chnage the service accounts username for all the IIS application pools and SharePoint service , so we created a new user named "Staging.user", and i define it as a ...
2
votes
2answers
188 views

Host IIS sites alongside SharePoint

I know the premise around SharePoint and IIS, where SharePoint takes on Port 80 as the default, which is fine. Question is, is there a way to host IIS web sites, along side SharePoint on the same ...
1
vote
1answer
80 views

Error accesing configure service account page in central admin

recently i migrated sharepoint farm from one domain to another. i manually changed application pool identity in IIS which is bad practice which i later realized. now that i read some articles and get ...
0
votes
0answers
44 views

Sharepoint cookies

My problem is same as the one asked in the question @ Make all sharepoint specific cookies non-persistent? The problem is "Make all sharepoint cookies non-persistent" I have implemented the solution ...
0
votes
0answers
99 views

IIS website not prompting for authentication, and page is blank

My SharePoint site has suddenly stopped working. It is not prompting for login. The page simply stops at blank. I tried creating a new website, and it is working fine. So, it seems there is ...
1
vote
0answers
279 views

Config error: The requested service could not be activated

I am trying to deploy and use a web part developed in SP2010 that requires connecting from a SP2010 server to a SQL server. I get the following error (greatly abbreviated): The requested service, ...
0
votes
3answers
170 views

SharePoint warmup script implementation

I've implemented the SPWarmup script from Codeplex on development and production environment. This script (that can be found here https://spbestwarmup.codeplex.com/) is working well, when I run it ...
1
vote
1answer
139 views

Sharepoint 2010 fails to run elevated code as IIS pool identity account

I changed the IIS pool identity service account for my SharePoint 2010 web application thus replacing the default "Network Service" account (using SharePoint Administrator.) The pool service account ...
1
vote
1answer
308 views

IIS hangs when debugging with Visual Studio

I keep having this ridiculous issue that's driving me mad. I happen to debug some code with Visual Studio (attached to all w3wp) and let's say I get an exception and VS is set to catch all exceptions. ...
0
votes
1answer
29 views

Web application creation trouble SharePoint 2013

I just have created a host header webApp in SharePoint 2013 (very normal operation) and added an A or AAA entry to the forward lookup zones in my dns and i created a site colelction which i cannot ...
0
votes
1answer
66 views

The SharePoint website cannot be displayed

Dunno what happened, just walked away from my server, came back and suddnely SharePoint website cannot be displayed. However, I can Access CA and it shows that the content is still there. I restarded ...
0
votes
1answer
602 views

SharePoint 2013. why Anonymous user Identity need to be 'IUSR'?

Environment: SharePoint 2013, IIS 8. No images and CSS displayed in the Central Admin. In firebug, its authentication failure. I checked in the IIS, the Anonymous user Identity was set to ...
0
votes
0answers
18 views

What am I looking for when I already have 1 “intranet” as a default when a newly acquired “intranet” is supposed to be “absorbed”?

I have two "intranets" listed as the URL. The recently acquired "intranet" should be "absorbed" into the existing "intranet". Both are SharePoint 2010 Foundation, Server 2008. How do I plan for the ...
0
votes
1answer
62 views

Redirect a PDF referencing old 2007 site

We have a SharePoint 2010 site that has numerous documents migrated over from our old SharePoint 2007 site. These documents that were migrated to 2010 (PDFs) have links in them that reference old ...
1
vote
1answer
949 views

SharePoint 404 not found after IIS hardening

Environment: Windows Server 2012 SharePoint 2013 IIS 8 I have deployed the Sharepoint 2013 site in the App server(Windows 2012). We have seperate DB server. My site was working fine. Until I ran ...
0
votes
2answers
4k views

Could not load file or assembly 'DLL' or one of its dependencies. Access is denied

Hi im having an issue migrating our .NET 2.0,1.0 and 0.0 WebForms application in our new SharePoint 2013 where it always prompt in every applications. Could not load file or assembly 'App_Code' or ...
0
votes
1answer
2k views

X-Frame-Options ignored in Chrome / Firefox. IE works

I have a simple PageViewer Webpart loading mysites. This displays in an iFrame within IE but doesn't display in Chrome or Firefox. I have tried adding the following to my MasterPage: <meta ...
1
vote
1answer
3k views

SharePoint web services web site error Service Unavailable HTTP Error 503. The service is unavailable

I am working on SharePoint 2013 , and inside the IIS i have noted a question mark icon beside the "SharePoint Web Services" website, and when i browse the http & https , from IIS->select the ...
0
votes
1answer
141 views

SharePoint Web Services Site Gone in IIS 8.0 (SP2013)

In my SharePoint environment the site "SharePoint Web Service" site is missing from IIS Sites list, is there a way to recreate it? I have seen a guide on here but it seems to be for SharePoint 2010. ...
0
votes
2answers
27 views

IIS site stopped SP is working, while IIS site started SP is not working

I can't understand at all why thing goes wrong like that. I have a SP2013. Evertyhing's ok. My website returns a Service Unavailable error. I stopped the IIS site, and my site is up ... and if I ...
0
votes
0answers
120 views

Can't resolve 500 - Internal server error

I am running SharePoint Foundation 2010. I have 1 APP and 2 WFE server. I did setup (in IIS) bindings to a subdomain and IP). I have setup my application and it was working fine. I ran the SharePoint ...
1
vote
2answers
351 views

Resetting IIS takes website down even though load balancer is being used

I have 2 load balanced WFEs. When I take one of them offline then website still works which means load balancer is working. But when I do IIS reset on one of those machines then the website doesn't ...
0
votes
1answer
280 views

What should be the interval for warmup script scheduled?

There are lots of Sharepoint wake up/warm up script available. But what should be the scheduled interval? I think it is based on particular environment. It is my understanding: Set IISReset at 4am ...
0
votes
0answers
414 views

Server Error in '/' Application after system reboot

I'm using Sharepoint Foundation 2013. I've installed some Windows Update on my Win Server 2008 R2 and then rebooted my server. After that my Sharepoint website returns: "Server Error in '/' ...
0
votes
1answer
129 views

IIS Applications created on App servers and WFE Servers

I am running SharePoint Foundation 2010. In my testing environment I've got 1 app server and 1 WFE. When I create a new web application, it is creating entries in both the APP and WFE IIS. Is this ...
0
votes
2answers
632 views

Page Load Extremely Slow (30 minutes) After IIS Reset

I have seen people reporting unacceptable 90 second page load times after an IIS reset. Every time we deploy a new solution and fire an IIS reset, it takes about 30 minutes for the first page to load. ...
1
vote
1answer
144 views

IIS 8 error page?

Just created a new (and the first) web application for a new SharePoint environment. When I try to access the main address it takes me to what appears to be an IIS 8 error page. The strange thing ...
0
votes
2answers
1k views

Creating SharePoint 2013 Application does not create IIS Site

I am trying to restore a backup of my SharePoint 2013 Farm to a new Server configuration. Everything works fine and I do not get any error messages in any of the logs that I am able to connect to the ...
0
votes
1answer
28 views

Is the IIS role necessary on a dedicated SQL server?

I haven't been able to find anything on this. I'm looking into only the bare necessities for a dedicated SQL server being used by a SharePoint farm. Is the Web Server (IIS) role necessary for a ...
0
votes
1answer
255 views

Experience downtime after recycle app pool. Is this normal?

This question may have been answered already but why is there downtime when I recycle an app pool? Is it because recycling restarts the app pool? I know that when recycling occurs, the worker process ...
8
votes
2answers
2k views

What is the correct way to block all HTTP Headers (ASP.Net and SharePoint) from a particular web application extension?

I have been involved in two projects recently which have required the removal of all HTTP Headers which can identify the site as either an ASP.Net site or as a SharePoint site. This is normally as a ...
0
votes
2answers
347 views

IIS roles in sharepoint server 2010

I need to give a presentation on IIS roles in SharePoint Server 2010. Can anyone help me out?
2
votes
1answer
60 views

Change the name of a SharePoint 2007 app server machine

I have an Microsoft SharePoint / Project 2007 environment set up on two VM servers: APP01 Windows Server 2008 R2 / IIS 7 / SharePoint Server2007 SP3 / Project 2007 SP3 DB01 Windows Server 2008 R2 / ...
1
vote
1answer
168 views

How do I add an already existing web application to Sharepoint?

I created a virtual directory for the Default Site in IIS that referred to the directory where my web site was located. Everything was working well, since the Default Site listened to Port 80, the ...
0
votes
1answer
704 views

index.html in sharepoint iis site's root

Has anyone tried to put a regular file to the root directory of a sharepoint web application's IIS site. It does not work. For example create an index.html file in the root directory of your web ...
0
votes
2answers
3k views

Automatically logged in as “System Account” after changing service accounts

Note: The steps listed below should resolve this issue in most cases. My situation involved my browser cache... Whenever I access my SharePoint 2010 foundation page I am automatically logged in as ...
3
votes
2answers
7k views

When do we need an IISreset after deployment?

Is there any good articles out there to explain when we need to do an IISreset after deployment? We are using SharePoint as an internet facing site, and try to not do an IISreset if it is not ...
2
votes
4answers
20k views

The Security Token Service is unavailable

I have to problems left on my dev machine. 1. The Security Token Service is unavailable 2. Get the user profile sync serve started. I am getting the following error every 5 minutes in my event log ...
0
votes
0answers
255 views

Sharepoint Site configuration Error when deploying Provider hosted App

I have SharePoint 2013 on premises. My App catalog is on the same server as SharePoint (it is on the same domain). Whenever I deploy my simple Provider-Hosted app to any site, the site's web.config ...
1
vote
1answer
247 views

Error while publishing Provider-Hosted MVC App to catalog site

I am tying to publish SharePoint 2013 Provider-Hosted MVC App to my site. I am getting this error message: Parser Error Message: Could not load type 'Microsoft.SharePoint.WebControls.ListMenu'. ...
2
votes
2answers
417 views

Login with facebook in SharePoint

How to login in SharePoint site with facebook login. i follow the steps from this site. http://ovaismehboob.wordpress.com/2011/09/07/configuring-facebook-authentication-in-sharepoint-2010/ but there ...