Health Analyzer is a feature in Microsoft SharePoint that enables administrators to schedule regular, automatic checks for potential configuration, performance, and usage problems in the server farm.

learn more… | top users | synonyms

0
votes
3answers
225 views

How to identify Orphaned Site Collection in SharePoint 2013 Content Database

We have recently discovered following error in SharePoint Health Analyzer report page: "Content databases contain orphaned items." We have identified the faulty content DB, database status of content ...
0
votes
3answers
32 views

MissingFeature - Issue

I am trying to get rid of the health error: [MissingFeature] Database [WSS_ContentDB] has reference(s) to a missing feature: Id = [id] I followed this link Removing features from a content ...
1
vote
1answer
27 views

MissingSetupFile issue - file does not exist

I am trying to get rid of the health error [MissingSetupFile]. I followed some guide to get (querying the contentDB) the Id of the file (and of the Site and Web). The issue is that the file does not ...
0
votes
1answer
49 views

TFS 2013 Update 2 installed in hive 14 instead of hive15

We've been testing TFS for SharePoint 2013 on our staging server. After the install health analyzer started giving missing server side dependency errors. TFS features were installed in the '14' hive ...
0
votes
0answers
29 views

Missing Server Side Dependencies in Health Analyzer belongs to App server not Front ends

I've problem trying to cleaning up my content databases of missing server side dependencies. The thing is that I think it's showing up dependencies that belongs to APP server not Front-end server. ...
0
votes
1answer
292 views

Microsoft SharePoint Foundation Usage service application not found. error

I'm receiving this error on our SharePoint server in event viewer. When I check the Configure usage and health data collection I see WSS_Logging_fd8d31dd9b964a649407b44127593673 as the database name. ...
0
votes
1answer
54 views

When it is safe to delete entries from contentDB?

I have a file that is getting caught by the health analyzer ReportViewer.dwp as a missing setup file referenced [1] times in the database. I've tracked the file down to the web part gallery and ...
1
vote
1answer
97 views

MissingSetupFile Removed webpart in gallery still receive error

I looked up a webpart and the only reference was to the web part gallery of the site. I removed the webpart from the list and recycle bin, but when I do a health check the error still persists. The ...
1
vote
0answers
78 views

Missing Server Side Dependencies MissingWebPart

I have a site that has a "missing server-side dependencies" rule hit, but the webpart that the script is listing doesn't seem to match any errors. They are all legit webparts that run. Tried ...
1
vote
0answers
359 views

One or more services have started or stopped unexpectedly error

Hello I am having the following error , and even after checking on forums and googling about it I haven't been able to find the solution to this error. The health report has the option Repair ...
1
vote
0answers
203 views

Missing server side dependencies and MissingSetupFile error with missing Site

A while ago I deployed a feature to my site that included a JavaScript file. I have since removed the file from the feature. I have also deleted and recreated sites within the mysite webapp. I have ...
0
votes
1answer
211 views

Server removed from farm but still shows up in Health Analyzer

I disconnected the server from the farm using SharePoint Config Wizard. Once that was finished I went into central admin and removed the server, On the SharePoint Central Administration Web site, in ...
0
votes
0answers
131 views

Getting Access Denied error when I try to edit a Health Analyzer Rule

Not sure what changed on my site, but I've tried logging into our Web Front End as several different domain accounts that are all listed in the Farm Administrators group. Whenever I try to Edit a ...
2
votes
1answer
4k views

How to repair “The server farm account should not be used for other services. ”

I'm looking for a solution to this in my 2013 farm. TITLE The server farm account should not be used for other services. EXPLAINATION spadmin, the account used for the SharePoint timer service and ...
0
votes
1answer
68 views

MissingWebPart Health Analyzer Errors

I have a whole bunch of these MissingWebPart errors in my health analyzer, all referring to a web part with GUID baf5274e-a800-8dc3-96d0-0003d9405663. The internet tells me this has to do with a web ...
1
vote
1answer
1k views

Dedicated Web application and separate URL domain

** Validate the My Site Host and individual My Sites are on a dedicated Web application and separate URL domain. ** How to resolve ??
1
vote
1answer
22 views

Disable the Health-analyzer rule [InfoPath form library forms cannot be filled out in a Web browser]

In my SP2010 Server farm I have this rule violation warning in Health Analyzer. I don't need this feature to be enabled [filling out InfoPath form library forms in a Web browser] I know that ...
1
vote
0answers
68 views

Configuration error: Create Project Web App Instances

On a new SP 2010 installation, the health analyzer notifies of an error Going inside, it declares of a configuration error in PsiService Error detailed as: Following service applications do ...
2
votes
2answers
242 views

Cannot find pages that have instances of missing webpart

I am trying to fix some missing server side dependencies on an SP2010 farm and am having trouble with missing webparts. There are two problems specifically. 1) Of the pages I can find (two pages ...
3
votes
1answer
73 views

Deploying a custom health rule fails on Add Solution

I've created a custom health rule for checking which mode solutions were built in (following this guide) but am having trouble deploying it. When deploying from VS2010, I get Error occurred in ...
0
votes
1answer
306 views

Error : Web Applications using Claims authentication require an update from health analyzer

After installing a sharepoint instance(Sp Server standard 2010 Sp1 and Windows 2008 r2 server) i get some errors being detected by the health analyzer ; Web Applications using Claims authentication ...
2
votes
2answers
1k views

Missing Server Side Dependencies Errors on Search Service Administration WebParts

I am trying to resolve some [MissingWebPart] errors from the CA Health Analyzer, from a site migrated from 2007 to 2010 with a database detach/reattach. The set of errors all refer to the WebParts on ...
1
vote
1answer
2k views

No health reports available though features enabled

How do you enable health reports on a SharePoint 2010 server? Under Central Admin, I go to Monitoring, click View Health Reports, and it says: A health report is not available for this site. Usage ...
6
votes
3answers
9k views

How do I fix “People search relevance is not optimized when the Active Directory has errors in the manager reporting structure”?

SharePoint Health Analyzer has detected the following error: People search relevance is not optimized when the Active Directory has errors in the manager reporting structure. Title : People search ...
1
vote
1answer
285 views

Finding the location of the SharePoint Configuration Database in API

I'm building a .NET Health Analyzer Custom Rule which checks a few vital signs of another custom application I have built, however if the application is also deployed on a server that is also hosting ...
2
votes
2answers
6k views

MissingSiteDefinition >> How do I go by fixing this issue?

[MissingSiteDefinition] 1 Sites in database [Colgate_WSS05] has reference(s) to a missing site definition, Id = [16781], Lcid = [1033]. The site definitions with Id 16781 is referenced in the ...
5
votes
7answers
20k views

How to fix “Missing server side dependencies”

In SharePoint 2010 the Health Analyzer shows an 'Missing Server Side Dependencies' error message. In the past a SharePoint solution was deployed, but currently it don't exist in the farm anymore. But ...
1
vote
4answers
7k views

How can I remove an orphaned event receiver?

This began when we noticed the health analyzer reporting the following: [MissingAssembly] Assembly [ProjectSubsiteMaker, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f8132574c3fbdd6f] is ...