set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

3
votes
2answers
564 views

Documents opening in Office Web Applications (when they're not installed)

I have a farm where for every new site collection the "Open Documents in Client Applications by Default" feature is disabled. So when ever a user opens an excel or word file it will try and open it in ...
0
votes
2answers
28 views

Removing missing features which are not referenced

I have an issue, basically I have one missing feature which was found by the pre upgrade tool and i would like to delete it, but no tools help me with that, it is also said that this feature is ...
0
votes
2answers
106 views

Creating a site column using a feature and setting its WebId property

I need to create a site column that will be added to children sites, this column is a lookup referencing a list in the rootWeb, so I need to provide de WebId property in order to make it available on ...
1
vote
1answer
40 views

Dependency of feature deployment with List and webpart

We have a project containing a webpart and a list instance (rootwebonly). The webpart and the list instance are activated via a single feature. Now problem is that, everytime a change is requested, ...
1
vote
1answer
61 views

Cannot activate SharePoint Publishing Feature

despite placing the following code in my onet.xml, the publishing feature is not activated. <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA"> <!-- PublishingPrerequisites --> ...
1
vote
1answer
470 views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
1
vote
1answer
61 views

Apply element manifest without re-activating feature

I have a feature module which consists of an XML file which adds ConsoleNodes to the Site Actions menu. To test it, it seems I must compile the package, deploy it, activate it, etc. Since this is ...
1
vote
1answer
176 views

How to DeActivate feature of my site?

How to DeActivate feature of my SharePoint site remotely ? I have created .wsp package file and uploaded SandBox solution to my SharePoint site. But in my elements.xml file it has 1 mistake of ...
1
vote
1answer
2k views

SharePoint 2010 solution not deploying correctly (features not available)

I have been working on a SharePoint 2010 solution on a server using Visual Studio. Unfortunately the server decided to die on me. Fortunately I have the solution backed up using source control and had ...
1
vote
1answer
73 views

Which publishing feature creates a search site?

I have created some custom WebTemplates for SP2010 and activated a load of publishing features which have in turn created a search site. Does anyone know which feature is likely to create this subsite ...
0
votes
1answer
42 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...
0
votes
1answer
70 views

“The system cannot find the file specified” message while deploying new feature

I'm trying to deploy a new feature on sharepoint 2010 with scope web. The deploy seems to run successfully, but the feature is not prensent in feature manager. While visual Studio deploys the ...
0
votes
1answer
25 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
0
votes
1answer
64 views

Object reference not set to an object error while moving an object to feature list

I have created a feature in which I want to put the list instance to be created when the feature is activated. I created new feature from visual studio and trying to add the list instance file to the ...
0
votes
1answer
18 views

How to find feature including a specific element

this migth be a really easy question, but I could not find any solution for that. I'm using VS 2012 and want to find which features are using a specific element. Since I got lots of Features in my ...
0
votes
1answer
60 views

Remove a list from all site collections when a feature is uninstalled

I have a site scoped Feature which specifies a list as such: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> ...
0
votes
1answer
93 views

Add custom code for solution upgrade

I have a solution for SP2010. Let's call it s.wsp. I had version 1 of s.wsp and now I have version 2 of s.wsp. Versions 1 and 2 share three common features: A, B and C. Version 2 adds a new feature D. ...
0
votes
1answer
243 views

Disable auto activate feature

I have a really strange behaviour, I'm working with SharePoint 2007 and I have a feature web application scoped, and i don't want it automatically being activated on deploying the solution, but it ...
0
votes
1answer
250 views

delete feature using event receiver on a farm feature

there is a farm feature and there is a web-scoped feature. web feature does stuff on multiple sites. If ever i want to get rid of the feature on all sites, I have a farm feature that has on ...
0
votes
1answer
48 views

how to check custom property of added Item

There is a boolean column I added to a custom list, but I also have a feature on this custom list so that when a Item is added i have to check if this column exists or not and then its value. now i ...
0
votes
1answer
1k views

How do I configure styles and layout of a Summary Link Web Part using code?

I have successfully added a Summary Link Web Part as a feature and want to configure the styles and layout of it, including: The default style for new links The group header style The number of ...
2
votes
0answers
738 views

How can I specify the ID of a XsltViewWebPart?

In a module, I'm deploying a webpart page where I put a view to a list : <View WebPartZoneID="Body" WebPartOrder="3" List="related" BaseViewID="4" ...
2
votes
0answers
512 views

Setting an audience from declarative WebPart?

I have a module that deploys some page. I'm adding webparts to these page, using a <AllUsersWebPart> node within a <View>: <View WebPartZoneID="Body" WebPartOrder="5" ...
2
votes
0answers
106 views

Attaching file in data node of a list instance?

I have a custom list definition and a custom list instance in a feature. If I want to populate some data in the list at its creation, I can use the data node. How can I add an attachment to this ...
2
votes
0answers
242 views

Why does WSP Deployment Type 'ApplicationServer' require features to be manually installed?

When I create a WSP with Deployment Type set to WebFrontEnd and deploy, all of the features contained within are automatically installed. Features that are set up as ActivateOnDefault="TRUE" (Farm or ...
1
vote
0answers
7 views

SP2010 - ToolbarTemplate property not working in Custom Feature

I have a requirement to hide the "Respond to Survey" link on all surveys for a SP2010 site if the user has already responded. I followed the process using this link ...
1
vote
0answers
75 views

Embed iframe when inserting a post

I developed a Ribbon button that show's up in the Media tab. This displays a Modal Dialog to the user, listing some external content, and when clicking on an item it pastes the iframe html code on the ...
1
vote
0answers
75 views

2010 - Update-SPSolution required after solution installed?

I created a new feature and performed a Uninstall/Remove/Add/Install-SPSolution using PowerShell to deploy it. The solution deployed correctly and the feature was added to the 14 hive, but did not ...
1
vote
0answers
103 views

Lists not being added to quicklaunch

I'm having a problem with some lists that are included in a feature (Scope: web), which is created via a site definition. These lists have the display on quicklaunch set to true, although, the only ...
1
vote
0answers
118 views

Missing Features and Existing Lists

I have a site that was hosted on a Microsoft Project Server instance. One of the sub-sites was based on the Project Workspace Template in order to get access to the "special" lists like Risks and ...
1
vote
0answers
469 views

Can't deploy a xslt webpart as expected

In one of my custom list schema, I have defined a custom view : <View Type="HTML" DisplayName="My wonderful view" BaseViewID="2" ...
1
vote
0answers
231 views

Is there a way to create user-configurable Custom Retention Formulas, possibly through Custom Properties?

I am wanting to create a "user" - configurable Custom Retention Formula? Something like a simple version of the rules that Excel and other applications have which displays something like: ...
1
vote
0answers
20 views

In SharePoint 2007 what feature or solution added the WebPart Page Doc library templates?

In SharePoint 2007 what feature or solution added the WebPart Page Doc library template? We have it on one Farm, but not another. Is it part of the Fab 40? A site feature or a Site collection ...
0
votes
0answers
40 views

The element of type field fo feature 'feature' threw an exception during activation: a duplicate field name 'fieldName' was found

I am taking over a SharePoint environment. The previous developer created a custom Workflow with Custom Activities, etc. One of the steps in the Workflow is to create a web using a custom Site ...
0
votes
0answers
52 views

“Feature has conflicting event reciever settings” error

I am new to SharePoint so I apologize if this is not phrased properly, but I created a BDC to a SQL database in Visual Studio 2012. I am trying to have the list created programmatically through an ...
0
votes
0answers
29 views

Custom Search to External Service

I am trying to add a custom search on the top static bar in SharePoint 2010. I created a delegate control to perform this task. I have tried multiple ways of creating a form text box and button and ...
0
votes
0answers
19 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
0
votes
0answers
44 views

How can I create a editable site page based on a custom page layout that is deployed via site definition

I have a site definition (SP2013) with some features. The feature deployes a custom page layout thats using the "Article Page" content type. Once deployed I can create new pages fine based on my new ...
0
votes
0answers
21 views

sharepoint 2010 Ghosted / UnGhosted Page Layout query

I've deployed a Feature to my SharePoint 2010 Farm which deploys each of my custom page layouts as 'ghosted' (uncustomized) aspx files into the Page Layouts folder especially since I have to update ...
0
votes
0answers
63 views

Custom Feature Compatibility from SP2010 to SP2013 Question

I have a question concerning the compatibility of my SP2010 custom features in SP2013. Here is my setup: I have a wide range of Farm, Site, and Web features that all interact with each other in a ...
0
votes
0answers
196 views

Calling Enable-SPFeature in SP2013 with CompatibilityLevel isn't working

In an SP2013 environment running in SP2010 mode has anyone successfully called the Powershell command -- Enable-SPFeature while specifying the compatibility level? Example: Enable-SPFeature -identity ...
0
votes
0answers
166 views

Feature ‘XXX’ for list template ‘YYY’ is not installed in this farm. The operation could not be completed

So I'm very new to SharePoint. And I'm supposed to debug a website SharePoint 2013. So when I open this page a web service is supposed to get me data from a distant database and display it in a ...
0
votes
0answers
25 views

Feature is not deploying

I have created a new BDCS model in Visual Studio. VS created a new feature for this item. Several times this feature worked fine.. But it didn`t deployed twice. First time I deleted feature and bdcs ...
0
votes
0answers
50 views

Features in Sharepoint 2010

I created an empty Project and used the default Feature1 thats created with the project to then create the following: public override void FeatureActivated(SPFeatureReceiverProperties properties) ...
0
votes
0answers
50 views

Add element to more than one feature

This is the case: We have an existing site collection with Feature A with 6 elements: E1, E2, E3, E4, E5, E6 (5 list instances and 1 web event receiver). I want to create a feature which only exists ...
0
votes
0answers
106 views

List of Site Features using Client Object model - SharePoint 2010

I am working on a Windows Forms application to list the features available for a SharePoint site. But I find no way, to retrieve the list of Site Features using Client Object Model. ...
0
votes
0answers
68 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
0
votes
0answers
29 views

Custom delegate is applied even if the feature is deactivated

I have a question regarding a feature. Situation: I have a feature that is farm scoped, with this feature I deploy a delegate control (xml file), this file refers to cs code. So I've added that file ...
0
votes
0answers
461 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with ...