set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

4
votes
2answers
5k views

When I create a folder programmatically get the error “Invalid item data — missing FileRef”

I am trying to add programmatically the desired Folder. I do the following foreach (SPListItem reparto in reparti.Items) { var folder = dl.Items.Add(dl.RootFolder.ServerRelativeUrl, ...
2
votes
1answer
381 views

cant find webapplication scoped feature anywhere

I developed a Custom Timer Job Feature using WSP Builder but for some reason I am not able to find it so that I can activate it. I know I can activate it using stsadm but why cant I find it in Site ...
0
votes
1answer
517 views

Adding column to a SPList

Normally I create a New List if I want to add an additional column to a List that already exists in a web. Wondering what would be the best option, should I create a new list with additional column ...
0
votes
1answer
84 views

compare values in list and change if necessary

So guys, I have a sharepoint list with and fields like "webID, url, rating" and a c# list with more or less the same fields. My task is to compare the lists by webID and if the row's "rating" field is ...
2
votes
2answers
1k views

Delete custom master page error on feature deactivation

I have a feature that deploys custom master pages to all sites in a site collection on activation, and want to delete all traces of the custom master pages on deactivation. On deactivation, after ...
5
votes
0answers
1k views

How can I specify the ID of a XsltViewWebPart?

In a module, I'm deploying a webpart page where I put a view to a list : <View WebPartZoneID="Body" WebPartOrder="3" List="related" BaseViewID="4" ...
0
votes
0answers
479 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with ...
0
votes
2answers
199 views

SharePoint 2010 Dev Machine Deploy to Stage Machine

Machine 1: Virtual Development box with Visual Studio 2010, SharePoint 2010 Foundations, Designer 2010. Machine 2: SharePoint 2010 Enterprise (Staging Environment) Question: Does Machine 2 need to ...
2
votes
1answer
3k views

SharePoint 2010 solution not deploying correctly (features not available)

I have been working on a SharePoint 2010 solution on a server using Visual Studio. Unfortunately the server decided to die on me. Fortunately I have the solution backed up using source control and had ...
5
votes
1answer
1k views

Setting an audience from declarative WebPart?

I have a module that deploys some page. I'm adding webparts to these page, using a <AllUsersWebPart> node within a <View>: <View WebPartZoneID="Body" WebPartOrder="5" ...
0
votes
0answers
26 views

SPContext is null on Feature Activation [duplicate]

Possible Duplicate: Error : Object reference not set to an instance of an object on feature deployment I am writing a feature receiver. Here is my code sample on feature_activated code. ...
1
vote
1answer
194 views

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server?

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server if so how?
1
vote
0answers
592 views

Can't deploy a xslt webpart as expected

In one of my custom list schema, I have defined a custom view : <View Type="HTML" DisplayName="My wonderful view" BaseViewID="2" ...
1
vote
1answer
73 views

Including a WorkFlow in a WSP

I am creating a feature that I want to install a couple of workflows when activated and bind them to a list. Is there a way you can use SPD and then export your workflow to include them in your visaul ...
1
vote
1answer
297 views

Look & Feel - Pagelayouts and Site Templates

I recently ran into a rather unfortunate assignment. It regards the selection of pagelayouts and sitetemplates which subsites should be able to use. As I'm supposed to change this for 20+ site ...
3
votes
0answers
135 views

Attaching file in data node of a list instance?

I have a custom list definition and a custom list instance in a feature. If I want to populate some data in the list at its creation, I can use the data node. How can I add an attachment to this ...
7
votes
1answer
6k views

Can't hide the title column in a custom content type

I'm building a custom content type. I've set a bunch of site columns I add to the content type. The content type is used in a custom list definition within a ContentTypeRef node. I'm also willing to ...
2
votes
1answer
444 views

Overriding search control, contextual scope as default

I have a strange problem regarding the overriding of search delegate control in SharePoint 2007. The purpose of why i override it is to set drop down mode to show contextual scopes as default aka ...
2
votes
1answer
2k views

Specifying advanced webpart properties on a view in a custom module?

I'm deploying a web part page from a feature. In the module/file node, I defines a view to a specific list in the site : <Module Name="SitePages" Url="SitePages" ...
1
vote
1answer
780 views

Access Document ID from a different Site Collection

I have the Document ID Service feature enabled in a Site Collection. I have a Records Center site provisioned in a different Site Collection - within the same web application. If I create a document ...
1
vote
2answers
462 views

How to add an workflow association to a list

I have a feature where I have create several items including lists and workflow. I want to add an workflow association to one of my lists. However I would like to refrain from using a code solution. ...
0
votes
1answer
51 views

Creating a Copy of Site Definition with a different Name

I have a site definition folder with following structure, XML default.aspx MasterPageabc.master masterpageabcajax.master In XML folder I have "ONET.XML" and I looked into this file, and realized ...
0
votes
1answer
487 views

Debugging a Timer Job

I was not able to do something a little more elaborate with my timer job so I decided to check if something basic works. So I tried the code below - but it keeps giving me this error - why? UPDATE ...
1
vote
3answers
1k views

Cant´t activate a custom feature with PowerShell but with the GUI

I want to activate a custom feature with PowerShell on a few sites in my environment. When I´m doing this job over the GUI, everything is perfect. But when I´, doing it with my script, the feature ...
1
vote
1answer
122 views

How do I move lists from a site into a feature?

I created some custom lists (with content) on a site I'm using for prototyping. I want to make a feature (via Visual Studio) that automatically adds these lists (plus content) to any site the feature ...
33
votes
1answer
10k views

What is “feature stapling”?

I've seen the term "feature stapling" used around this site and some blogs. What exactly does this mean? My best guess is that it has something to do with dynamically activating features from other ...
2
votes
3answers
1k views

Сan't programmaticaly activate the Publishing Feature for the Blog site

I'm developed a solution for stapling features. in my solution are located two projects, one project contains a module which consist the id features, what I want to attach to the sites collections and ...
1
vote
1answer
76 views

Which publishing feature creates a search site?

I have created some custom WebTemplates for SP2010 and activated a load of publishing features which have in turn created a search site. Does anyone know which feature is likely to create this subsite ...
2
votes
1answer
202 views

Sharepoint Report center

Is the Report Center option available for sub-site creation? I would like to utilize it for Director reporting and scorecards/dashboards
2
votes
2answers
1k views

Activate Feature in Powershell and specify custom properties

I want to activate a feature with custom properties. It is easy to do in onet.xml by providing Properties: <Feature ID=“78277796-98D9-4276-B7D2-E3374AAC43D8“> <Properties> ...
0
votes
2answers
1k views

Errors when attempting to install a sharepoint 2010 feature

I'm attempting to install and activate a feature containing a Timer Job. When I execute the install-spfeature cmdlet I get the following error. What is the source of my error? PS ...
1
vote
2answers
4k views

Column 'Document Id' not added to Library even after activating 'Document ID Service'

To enable document id feature in SP10, I followed the steps mentioned in the following posts: Document ID in SharePoint Server 2010 SharePoint 2010 – Activating the Document ID Feature Why after I ...
0
votes
1answer
33 views

How to replace a Default List “Events” with a new custom list for all the sites

I am trying to find a script that will replace Sharepoint Events List with one of Custom List i created + Copy all the data of Events list to my newly created list. I know how to Delete a list and ...
1
vote
1answer
969 views

removing a sharepoint solution duplicates entry in web.config?

My intentions is to be able to add and remove web.config changes when a solution is installed or uninstalled. The code below and the powershell below works ALMOST as expected. When I add sp ...
0
votes
1answer
3k views

Provision listview webpart on page layout using feature

I've deployed a custom page layout using a module in a feature, like this: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> <Module ...
1
vote
2answers
54 views

Customizing a feature: Site Options? Config List? Something else?

I'm developing a feature that renders a link on the user's screen, and I need that link's destination URL to be configurable by site collection administrators (SCAs) who are not developers. Where ...
3
votes
2answers
7k views

Making a cab file with ddf (to create a wsp solution package)

I am trying to Create a ddf file for my custom list feature using tutorial given in this link Create a wsp using ddf but in this link there isn't enough Information like what is the directory ...
1
vote
2answers
720 views

Schema.XML not found in 12/Template/Features/myfeature

I am trying to create a custom list feature, what I did is created feature and then i build a solution out of it using this tutorial Creating a Solution file for Feature when it creates a .wsp ...
1
vote
4answers
3k views

Custom Claim Provider - What is the fix for “Error loading the claim provider assembly”?

I have implemented a custom SPClaimProvider that is doing claims augmentation in the FillClaimsForEntity method. I have packaged this as a SharePoint feature and deploy it in a WSP. I am trying to ...
0
votes
1answer
131 views

Using configuration of base web template in custom web template

I'm creating a custom web template, and I'd like for my configuration only to add the things I need above and beyond what's in the base web template (in my case, CMSPUBLISHING#0). My template works ...
0
votes
1answer
2k views

How to dynamically set Module URL property in Elements.xml file

I have created a module that creates a site page inside a pages library. Is there a way we can dynamically set Url property of the Module node in the XML file? I would like to set the Url property ...
0
votes
1answer
879 views

Column 'ListId' does not belong to underlying table ''

I am trying to run the following code I found somewhere here, but I got this exception on this line DataView dv = new DataView(dtResults); using (SPWeb web = properties.GetWeb()) { ...
1
vote
2answers
3k views

Event receiver not working properly?

I created an Event Receiver for a feature, my problem is when I deploy the solution, the feature is deployed as active but never goes through my FeatureActivated() inside my Event Receiver. It also ...
0
votes
1answer
68 views

Strange exceptions ocurring

I am having very big trouble with features, my feature has the following site columns content type list tempalte list instance After fighting a lot, I removed the feature and created them again in ...
0
votes
1answer
695 views

Error on activating Publishing Feature SharePoint 2010

I am working with SharePoint 2010. I need to activate SharePoint Publishing Infrastructure Feature under Site Administration>Site Collection features. But when I try to activate this feature I get the ...
1
vote
2answers
640 views

How to upgrade a specific aspx or ascx file in an existing solution

In the current project, the solution is already existing, the solution has like 5 features and each feature deploys different things. The current development never used feature versions. So I ...
0
votes
1answer
153 views

Custom list Feature problems

I created a custom list definition, which works well. When i deploy, the list definition is added, when i retract, the list definition retracts properly. I also created a list instance from said ...
1
vote
3answers
1k views

How can I provision a page using a page layout from another feature?

I have a generic feature, feature #1, that will be deployed to multiple site collections and will include some standard page layouts include one called OneColumn.aspx. I have another feature, feature ...
1
vote
1answer
492 views

Error Deploying Solution - returns The feature path 'myfeaturename' must be of the form 'directory/feature.xml'

Let me start out by saying I'm sure WSP builder or STSdev is the way to go, but I can't use those where I work, so I'm having to do this all manually. So here's where I am. I have created a simple ...
2
votes
2answers
577 views

Caml defined Custom Action, UrlAction and the multi language interface

When defining a custom action via the CAML schema definition, the UrlAction parameter specifies the "site or site collection relative URL of the page, for example, ~site/_layouts/sampleurl.aspx or ...