set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

0
votes
1answer
340 views

Adding column to a SPList

Normally I create a New List if I want to add an additional column to a List that already exists in a web. Wondering what would be the best option, should I create a new list with additional column ...
0
votes
1answer
79 views

compare values in list and change if necessary

So guys, I have a sharepoint list with and fields like "webID, url, rating" and a c# list with more or less the same fields. My task is to compare the lists by webID and if the row's "rating" field is ...
2
votes
0answers
904 views

How can I specify the ID of a XsltViewWebPart?

In a module, I'm deploying a webpart page where I put a view to a list : <View WebPartZoneID="Body" WebPartOrder="3" List="related" BaseViewID="4" ...
0
votes
0answers
465 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with ...
0
votes
2answers
189 views

SharePoint 2010 Dev Machine Deploy to Stage Machine

Machine 1: Virtual Development box with Visual Studio 2010, SharePoint 2010 Foundations, Designer 2010. Machine 2: SharePoint 2010 Enterprise (Staging Environment) Question: Does Machine 2 need to ...
2
votes
2answers
1k views

Can't activate Publishing Feature

On some sites I get the following error when trying to activate the publishing feature. Event log message was: 'Failed to initialize some site properties for Web at Url: 'http://intranet/social'. ...
2
votes
0answers
681 views

Setting an audience from declarative WebPart?

I have a module that deploys some page. I'm adding webparts to these page, using a <AllUsersWebPart> node within a <View>: <View WebPartZoneID="Body" WebPartOrder="5" ...
0
votes
0answers
26 views

SPContext is null on Feature Activation [duplicate]

Possible Duplicate: Error : Object reference not set to an instance of an object on feature deployment I am writing a feature receiver. Here is my code sample on feature_activated code. ...
1
vote
1answer
161 views

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server?

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server if so how?
1
vote
0answers
519 views

Can't deploy a xslt webpart as expected

In one of my custom list schema, I have defined a custom view : <View Type="HTML" DisplayName="My wonderful view" BaseViewID="2" ...
1
vote
1answer
70 views

Including a WorkFlow in a WSP

I am creating a feature that I want to install a couple of workflows when activated and bind them to a list. Is there a way you can use SPD and then export your workflow to include them in your visaul ...
0
votes
0answers
11 views

why sitecolumn title is blank after feature activation [duplicate]

Possible Duplicate: Problem with defining Site Columns in a feature After installing using stsadmin, and activating using site UI "Site Collection Feature" these columns shows up but no ...
2
votes
3answers
883 views

Сan't programmaticaly activate the Publishing Feature for the Blog site

I'm developed a solution for stapling features. in my solution are located two projects, one project contains a module which consist the id features, what I want to attach to the sites collections and ...
1
vote
1answer
271 views

Look & Feel - Pagelayouts and Site Templates

I recently ran into a rather unfortunate assignment. It regards the selection of pagelayouts and sitetemplates which subsites should be able to use. As I'm supposed to change this for 20+ site ...
2
votes
0answers
120 views

Attaching file in data node of a list instance?

I have a custom list definition and a custom list instance in a feature. If I want to populate some data in the list at its creation, I can use the data node. How can I add an attachment to this ...
7
votes
1answer
4k views

Can't hide the title column in a custom content type

I'm building a custom content type. I've set a bunch of site columns I add to the content type. The content type is used in a custom list definition within a ContentTypeRef node. I'm also willing to ...
2
votes
1answer
1k views

Specifying advanced webpart properties on a view in a custom module?

I'm deploying a web part page from a feature. In the module/file node, I defines a view to a specific list in the site : <Module Name="SitePages" Url="SitePages" ...
2
votes
1answer
367 views

Overriding search control, contextual scope as default

I have a strange problem regarding the overriding of search delegate control in SharePoint 2007. The purpose of why i override it is to set drop down mode to show contextual scopes as default aka ...
5
votes
4answers
2k views

Is feature activation code allowed in Web Template Project?

I created a empty project added module copy onet.xml and default.aspx from layout/template/sts directory to my project and added to my project Ran F-5 to debug and it seems to be working Now I need ...
1
vote
1answer
556 views

Access Document ID from a different Site Collection

I have the Document ID Service feature enabled in a Site Collection. I have a Records Center site provisioned in a different Site Collection - within the same web application. If I create a document ...
1
vote
2answers
375 views

How to add an workflow association to a list

I have a feature where I have create several items including lists and workflow. I want to add an workflow association to one of my lists. However I would like to refrain from using a code solution. ...
1
vote
1answer
76 views

Which publishing feature creates a search site?

I have created some custom WebTemplates for SP2010 and activated a load of publishing features which have in turn created a search site. Does anyone know which feature is likely to create this subsite ...
0
votes
1answer
438 views

Debugging a Timer Job

I was not able to do something a little more elaborate with my timer job so I decided to check if something basic works. So I tried the code below - but it keeps giving me this error - why? UPDATE ...
0
votes
1answer
590 views

Error on activating Publishing Feature SharePoint 2010

I am working with SharePoint 2010. I need to activate SharePoint Publishing Infrastructure Feature under Site Administration>Site Collection features. But when I try to activate this feature I get the ...
1
vote
1answer
119 views

How do I move lists from a site into a feature?

I created some custom lists (with content) on a site I'm using for prototyping. I want to make a feature (via Visual Studio) that automatically adds these lists (plus content) to any site the feature ...
0
votes
1answer
31 views

How to replace a Default List “Events” with a new custom list for all the sites

I am trying to find a script that will replace Sharepoint Events List with one of Custom List i created + Copy all the data of Events list to my newly created list. I know how to Delete a list and ...
18
votes
1answer
6k views

What is “feature stapling”?

I've seen the term "feature stapling" used around this site and some blogs. What exactly does this mean? My best guess is that it has something to do with dynamically activating features from other ...
2
votes
1answer
181 views

Sharepoint Report center

Is the Report Center option available for sub-site creation? I would like to utilize it for Director reporting and scorecards/dashboards
1
vote
2answers
1k views

Activate Feature in Powershell and specify custom properties

I want to activate a feature with custom properties. It is easy to do in onet.xml by providing Properties: <Feature ID=“78277796-98D9-4276-B7D2-E3374AAC43D8“> <Properties> ...
0
votes
2answers
773 views

Errors when attempting to install a sharepoint 2010 feature

I'm attempting to install and activate a feature containing a Timer Job. When I execute the install-spfeature cmdlet I get the following error. What is the source of my error? PS ...
1
vote
4answers
887 views

How to embed a CQWP into a master page or DelegateControl

I'm looking for a way to embed a pre-configured Content Query Web Part into a master page. In short, I have a SharePoint:DelegateControl on the master page and I want to plug the web part into it by ...
1
vote
1answer
788 views

removing a sharepoint solution duplicates entry in web.config?

My intentions is to be able to add and remove web.config changes when a solution is installed or uninstalled. The code below and the powershell below works ALMOST as expected. When I add sp ...
0
votes
1answer
2k views

Provision listview webpart on page layout using feature

I've deployed a custom page layout using a module in a feature, like this: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> <Module ...
1
vote
2answers
51 views

Customizing a feature: Site Options? Config List? Something else?

I'm developing a feature that renders a link on the user's screen, and I need that link's destination URL to be configurable by site collection administrators (SCAs) who are not developers. Where ...
2
votes
2answers
4k views

Making a cab file with ddf (to create a wsp solution package)

I am trying to Create a ddf file for my custom list feature using tutorial given in this link Create a wsp using ddf but in this link there isn't enough Information like what is the directory ...
1
vote
2answers
612 views

Schema.XML not found in 12/Template/Features/myfeature

I am trying to create a custom list feature, what I did is created feature and then i build a solution out of it using this tutorial Creating a Solution file for Feature when it creates a .wsp ...
1
vote
3answers
141 views

editing sharepoint file in the feature folder

I'm having an issue. I want to make a quick change to an aspx file that I recently deployed to a sharepoint server. Due to some circumstances, it is not worth the time to edit and recompile the ...
0
votes
1answer
125 views

Using configuration of base web template in custom web template

I'm creating a custom web template, and I'd like for my configuration only to add the things I need above and beyond what's in the base web template (in my case, CMSPUBLISHING#0). My template works ...
0
votes
1answer
1k views

How to dynamically set Module URL property in Elements.xml file

I have created a module that creates a site page inside a pages library. Is there a way we can dynamically set Url property of the Module node in the XML file? I would like to set the Url property ...
0
votes
1answer
624 views

Column 'ListId' does not belong to underlying table ''

I am trying to run the following code I found somewhere here, but I got this exception on this line DataView dv = new DataView(dtResults); using (SPWeb web = properties.GetWeb()) { ...
0
votes
1answer
66 views

Strange exceptions ocurring

I am having very big trouble with features, my feature has the following site columns content type list tempalte list instance After fighting a lot, I removed the feature and created them again in ...
1
vote
2answers
413 views

How to upgrade a specific aspx or ascx file in an existing solution

In the current project, the solution is already existing, the solution has like 5 features and each feature deploys different things. The current development never used feature versions. So I ...
0
votes
1answer
146 views

Custom list Feature problems

I created a custom list definition, which works well. When i deploy, the list definition is added, when i retract, the list definition retracts properly. I also created a list instance from said ...
1
vote
3answers
699 views

How can I provision a page using a page layout from another feature?

I have a generic feature, feature #1, that will be deployed to multiple site collections and will include some standard page layouts include one called OneColumn.aspx. I have another feature, feature ...
1
vote
1answer
431 views

Error Deploying Solution - returns The feature path 'myfeaturename' must be of the form 'directory/feature.xml'

Let me start out by saying I'm sure WSP builder or STSdev is the way to go, but I can't use those where I work, so I'm having to do this all manually. So here's where I am. I have created a simple ...
0
votes
3answers
4k views

How to add SP2010 module elements with “published” state?

I use a feature to deploy a master page to a SharePoint 2010 publishing site. I use VS 2010 SharePoint projects. The feature deploys the .master , some CSS files and some images. Everything works OK ...
0
votes
1answer
61 views

Deploying an individual feature

I am using sharepoint software factory and have a number of features within it. How can I deploy an individual feature to my local dev farm, as opposed to the whole lot? Thanks
0
votes
1answer
148 views

XML Dictionary - how to provision with feature and read it?

I have an visual webpart and I need to populate drop down with content extracted from xml file. How can I provision that XML file with feature and then how can I access it from my codebehind to be ...
1
vote
2answers
468 views

Managing WebParts with dependencies on Web scoped Features

I have a Web scoped Feature which provisions a number of Content Types, List Templates & Instances, Custom Actions etc that enables a discrete set of functionality. I also have a number of ...
3
votes
1answer
750 views

Sandbox Web Part without Site Collection Administrator permissions?

Is there a way to get a Sandboxed Web Part deployed without Site Collection Administrator permissions? Here is the situation: I have Full Control permissions of the Site Collection's Root Web, ...