set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

2
votes
1answer
8k views

Error occurred in deployment step 'Activate Features' - When feature stapling to My Sites

I am trying to deploy a feature to My Sites in SharePoint 2010 and nothing seems to be working. I did this perfectly fine on the test environment but can't seem to get it working on the production ...
1
vote
1answer
537 views

Publishing field type names for feature

I'm creating a SharePoint 2010 feature in VS 2010 to add some custom site columns to a site collection via an elements.xml file. I can't seem to find the Type attribute values for the publishing ...
0
votes
2answers
2k views

Finding all activated Site Features & Site Collection Features in a Site Collection Script

I wonder if someone knows any C# script that will provide me all Site Features in a site collection as well as all Site collection features in a site collection. I only required Activated features ...
0
votes
1answer
15 views

Site Features in Sub Webs Confusion

Very Basic but confusing question. I see we have three types of features, Web Application Features Site Collection Features Site Features Now I know that Web application features belong to web ...
3
votes
1answer
198 views

Site Scope Feature dependent on a Web Scope Feature

On the root web for my site collection I need to make sure a web scope feature is turned on. In the feature EventReceiver I can turn on the feature progamtically. How can I stop the user turning the ...
1
vote
2answers
397 views

Elements.xml Id substitution

I have a site column defined in an Elements.xml file in Visual Studio. The SharePoint project this is in does all sorts of initial configuration on the website. I need to set the UserSelectionScope to ...
2
votes
1answer
3k views

When I create a folder porgrammatically get the error “Invalid item data — missing FileRef”

I trying to add programmatically the detested Folder. I do the following foreach (SPListItem reparto in reparti.Items) { var folder = dl.Items.Add(dl.RootFolder.ServerRelativeUrl, ...
2
votes
1answer
321 views

cant find webapplication scoped feature anywhere

I developed a Custom Timer Job Feature using WSP Builder but for some reason I am not able to find it so that I can activate it. I know I can activate it using stsadm but why cant I find it in Site ...
0
votes
1answer
270 views

Adding column to a SPList

Normally I create a New List if I want to add an additional column to a List that already exists in a web. Wondering what would be the best option, should I create a new list with additional column ...
0
votes
1answer
77 views

compare values in list and change if necessary

So guys, I have a sharepoint list with and fields like "webID, url, rating" and a c# list with more or less the same fields. My task is to compare the lists by webID and if the row's "rating" field is ...
2
votes
2answers
1k views

Delete custom master page error on feature deactivation

I have a feature that deploys custom master pages to all sites in a site collection on activation, and want to delete all traces of the custom master pages on deactivation. On deactivation, after ...
2
votes
0answers
834 views

How can I specify the ID of a XsltViewWebPart?

In a module, I'm deploying a webpart page where I put a view to a list : <View WebPartZoneID="Body" WebPartOrder="3" List="related" BaseViewID="4" ...
0
votes
0answers
463 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with ...
0
votes
2answers
185 views

SharePoint 2010 Dev Machine Deploy to Stage Machine

Machine 1: Virtual Development box with Visual Studio 2010, SharePoint 2010 Foundations, Designer 2010. Machine 2: SharePoint 2010 Enterprise (Staging Environment) Question: Does Machine 2 need to ...
1
vote
1answer
2k views

SharePoint 2010 solution not deploying correctly (features not available)

I have been working on a SharePoint 2010 solution on a server using Visual Studio. Unfortunately the server decided to die on me. Fortunately I have the solution backed up using source control and had ...
2
votes
0answers
598 views

Setting an audience from declarative WebPart?

I have a module that deploys some page. I'm adding webparts to these page, using a <AllUsersWebPart> node within a <View>: <View WebPartZoneID="Body" WebPartOrder="5" ...
0
votes
0answers
25 views

SPContext is null on Feature Activation [duplicate]

Possible Duplicate: Error : Object reference not set to an instance of an object on feature deployment I am writing a feature receiver. Here is my code sample on feature_activated code. ...
1
vote
1answer
150 views

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server?

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server if so how?
1
vote
0answers
498 views

Can't deploy a xslt webpart as expected

In one of my custom list schema, I have defined a custom view : <View Type="HTML" DisplayName="My wonderful view" BaseViewID="2" ...
1
vote
1answer
68 views

Including a WorkFlow in a WSP

I am creating a feature that I want to install a couple of workflows when activated and bind them to a list. Is there a way you can use SPD and then export your workflow to include them in your visaul ...
1
vote
1answer
262 views

Look & Feel - Pagelayouts and Site Templates

I recently ran into a rather unfortunate assignment. It regards the selection of pagelayouts and sitetemplates which subsites should be able to use. As I'm supposed to change this for 20+ site ...
2
votes
0answers
115 views

Attaching file in data node of a list instance?

I have a custom list definition and a custom list instance in a feature. If I want to populate some data in the list at its creation, I can use the data node. How can I add an attachment to this ...
7
votes
1answer
4k views

Can't hide the title column in a custom content type

I'm building a custom content type. I've set a bunch of site columns I add to the content type. The content type is used in a custom list definition within a ContentTypeRef node. I'm also willing to ...
2
votes
1answer
342 views

Overriding search control, contextual scope as default

I have a strange problem regarding the overriding of search delegate control in SharePoint 2007. The purpose of why i override it is to set drop down mode to show contextual scopes as default aka ...
2
votes
1answer
1k views

Specifying advanced webpart properties on a view in a custom module?

I'm deploying a web part page from a feature. In the module/file node, I defines a view to a specific list in the site : <Module Name="SitePages" Url="SitePages" ...
1
vote
1answer
495 views

Access Document ID from a different Site Collection

I have the Document ID Service feature enabled in a Site Collection. I have a Records Center site provisioned in a different Site Collection - within the same web application. If I create a document ...
1
vote
2answers
356 views

How to add an workflow association to a list

I have a feature where I have create several items including lists and workflow. I want to add an workflow association to one of my lists. However I would like to refrain from using a code solution. ...
0
votes
1answer
51 views

Creating a Copy of Site Definition with a different Name

I have a site definition folder with following structure, XML default.aspx MasterPageabc.master masterpageabcajax.master In XML folder I have "ONET.XML" and I looked into this file, and realized ...
0
votes
1answer
415 views

Debugging a Timer Job

I was not able to do something a little more elaborate with my timer job so I decided to check if something basic works. So I tried the code below - but it keeps giving me this error - why? UPDATE ...
1
vote
3answers
1k views

Cant´t activate a custom feature with PowerShell but with the GUI

I want to activate a custom feature with PowerShell on a few sites in my environment. When I´m doing this job over the GUI, everything is perfect. But when I´, doing it with my script, the feature ...
1
vote
1answer
115 views

How do I move lists from a site into a feature?

I created some custom lists (with content) on a site I'm using for prototyping. I want to make a feature (via Visual Studio) that automatically adds these lists (plus content) to any site the feature ...
18
votes
1answer
5k views

What is “feature stapling”?

I've seen the term "feature stapling" used around this site and some blogs. What exactly does this mean? My best guess is that it has something to do with dynamically activating features from other ...
2
votes
3answers
809 views

Сan't programmaticaly activate the Publishing Feature for the Blog site

I'm developed a solution for stapling features. in my solution are located two projects, one project contains a module which consist the id features, what I want to attach to the sites collections and ...
1
vote
1answer
75 views

Which publishing feature creates a search site?

I have created some custom WebTemplates for SP2010 and activated a load of publishing features which have in turn created a search site. Does anyone know which feature is likely to create this subsite ...
2
votes
1answer
175 views

Sharepoint Report center

Is the Report Center option available for sub-site creation? I would like to utilize it for Director reporting and scorecards/dashboards
1
vote
2answers
1k views

Activate Feature in Powershell and specify custom properties

I want to activate a feature with custom properties. It is easy to do in onet.xml by providing Properties: <Feature ID=“78277796-98D9-4276-B7D2-E3374AAC43D8“> <Properties> ...
0
votes
2answers
719 views

Errors when attempting to install a sharepoint 2010 feature

I'm attempting to install and activate a feature containing a Timer Job. When I execute the install-spfeature cmdlet I get the following error. What is the source of my error? PS ...
1
vote
2answers
2k views

Column 'Document Id' not added to Library even after activating 'Document ID Service'

To enable document id feature in SP10, I followed the steps mentioned in the following posts: http://blogs.msdn.com/b/ecm/archive/2011/10/12/document-id-in-sharepoint-server-2010.aspx ...
0
votes
1answer
31 views

How to replace a Default List “Events” with a new custom list for all the sites

I am trying to find a script that will replace Sharepoint Events List with one of Custom List i created + Copy all the data of Events list to my newly created list. I know how to Delete a list and ...
1
vote
1answer
716 views

removing a sharepoint solution duplicates entry in web.config?

My intentions is to be able to add and remove web.config changes when a solution is installed or uninstalled. The code below and the powershell below works ALMOST as expected. When I add sp ...
0
votes
1answer
2k views

Provision listview webpart on page layout using feature

I've deployed a custom page layout using a module in a feature, like this: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> <Module ...
1
vote
2answers
51 views

Customizing a feature: Site Options? Config List? Something else?

I'm developing a feature that renders a link on the user's screen, and I need that link's destination URL to be configurable by site collection administrators (SCAs) who are not developers. Where ...
2
votes
2answers
4k views

Making a cab file with ddf (to create a wsp solution package)

I am trying to Create a ddf file for my custom list feature using tutorial given in this link Create a wsp using ddf but in this link there isn't enough Information like what is the directory ...
1
vote
2answers
572 views

Schema.XML not found in 12/Template/Features/myfeature

I am trying to create a custom list feature, what I did is created feature and then i build a solution out of it using this tutorial Creating a Solution file for Feature when it creates a .wsp ...
0
votes
4answers
2k views

Custom Claim Provider - What is the fix for “Error loading the claim provider assembly”?

I have implemented a custom SPClaimProvider that is doing claims augmentation in the FillClaimsForEntity method. I have packaged this as a SharePoint feature and deploy it in a WSP. I am trying to ...
0
votes
1answer
125 views

Using configuration of base web template in custom web template

I'm creating a custom web template, and I'd like for my configuration only to add the things I need above and beyond what's in the base web template (in my case, CMSPUBLISHING#0). My template works ...
0
votes
1answer
1k views

How to dynamically set Module URL property in Elements.xml file

I have created a module that creates a site page inside a pages library. Is there a way we can dynamically set Url property of the Module node in the XML file? I would like to set the Url property ...
0
votes
1answer
567 views

Column 'ListId' does not belong to underlying table ''

I am trying to run the following code I found somewhere here, but I got this exception on this line DataView dv = new DataView(dtResults); using (SPWeb web = properties.GetWeb()) { ...
1
vote
2answers
2k views

Event receiver not working properly?

I created an Event Receiver for a feature, my problem is when I deploy the solution, the feature is deployed as active but never goes through my FeatureActivated() inside my Event Receiver. It also ...
0
votes
1answer
66 views

Strange exceptions ocurring

I am having very big trouble with features, my feature has the following site columns content type list tempalte list instance After fighting a lot, I removed the feature and created them again in ...