set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

0
votes
2answers
436 views

How to Deploy the Feature with Scope=Site & Scope=Web for WebParts & EventReceiver respectively?

I have only 1 Visual Studio Project. It contains 1 EventReceiver(for DocumentLibrary) and multiple-WebParts. I have defined the Scope=Site of Feature.xml file of Project. I have created 1 custom ...
0
votes
1answer
125 views

Unable to get list “Calendar” list in feature while creating site

I want to create custom calendar list programatically. SPListTemplate template = web.ListTemplates["Calendar"]; var newListID = web.Lists.Add(fromTitle, description, template); But i cannot do ...
0
votes
4answers
1k views

How to programmatically get Feature ID?

In order to programmatically activate a feature, you need its Feature ID (some type of GUID) that is set in the .feature file. Is there a pretty way of retrieving this value programmatically, so that ...
0
votes
0answers
68 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
0
votes
1answer
220 views

Adding style sheet to feature

I have created a feature in sharepoint 2010. The feature has a visual web part (sandboxed), the web part has controls etc. I have added some styles to the web part. How do i upload the stylesheet ...
0
votes
1answer
635 views

Page not appearing in site pages library

I want to deploy a page to the sitepages library. When i deploy this code it does not appear. However when i go to the url manually e.g. contoso.com/SitePages/mytestpage.html, i get the 'save as' ...
0
votes
2answers
822 views

How do i activate a Feature when a subsite is created

I have a web template that users can create sub sites from. I want to activate a feature when the subsite is created e.g. create list, columns etc for that sub site only. How would i approach doing ...
0
votes
2answers
97 views

How do i create a feature in web template?

I have created a web template in visual studio, it includes the standard element file and onet file, it also has a feature which is scoped to site level. All this works fine, i can deploy it and can ...
0
votes
1answer
43 views

Sharepoint Feature Creation Approach

I want to create a feature, once the feature is activated by the administrator a number of lists, items and workflows will be created. What would be the best approach to implementing this? The ...
0
votes
3answers
79 views

How to build a complex feature to collect and store user options that drive a delegate control

A long title but hopefully will be enough! Basically, I want to create a feture in Visual Studio that will do the following: When activated, places an option/link in the site collection options in ...
2
votes
1answer
143 views

Using solutions and features in creation/branding of SharePoint websites

I am new to SharePoint website creation and branding and I need your advice. For my first SharePoint site I have done the following: 1- Created/edited a master page. 2- Added CSS and JavaScript ...
0
votes
1answer
985 views

Where to Place XML File to be Read by Web Part?

In another question, I finally found a way to deploy the XML file to be read via a Feature, to the _layouts folder: Feature Elements File Should I be deploying it there at all? I wasn't able to ...
0
votes
1answer
849 views

Feature Elements File

I'm having some difficulty creating a Feature which contains a Web Part and a links.xml which is processed by the WP code-behind. My difficulty is in understanding the Feature XML config files and ...
1
vote
1answer
364 views

Web Part Feature

I'm working on a (non-visual) Web Part and wish to read from an xml file placed in the "C:\inetpub\wwwroot\wss\VirtualDirectories\80\wpresources" folder: Code-Behind: string sUri = ...
0
votes
2answers
418 views

Web-scoped Feature falsely activated during Visual Studio deployment

In Visual Studio I have a solution containing two features with their Scope set to "Web". These two features work as expected but the only thing that is going "wrong" is that they are activated when I ...
0
votes
1answer
425 views

Modify the content of the home page programmatically in SharePoint 2010

First of all, I'm pretty new to SharePoint so don't shoot me if this is a noobish question or if I don't provide all the right information at once... :) I have a team-site in SharePoint with ...
2
votes
2answers
1k views

How to delete features?

I have been uploading managed code xsn through central admin in development. It's the same infopath project. But I think SharePoint has a bug and it does not delete the old features when uploading a ...
0
votes
1answer
250 views

delete feature using event receiver on a farm feature

there is a farm feature and there is a web-scoped feature. web feature does stuff on multiple sites. If ever i want to get rid of the feature on all sites, I have a farm feature that has on ...
1
vote
1answer
202 views

Staple onto MyContent

I made my farm level stapler and my site level staple features, for SPSPER#0 it fires on MySite creation, so I presumed SPSMSITEHOST#0 would be MyContent, but nothing gets fires at all. I set the ...
0
votes
1answer
601 views

Hide a feature in Site Collection Administration => Features area

I have a feature with webparts that needs to be activated using powershell. I need a way to either hide the feature on the Site Collection Administration => Features (under Site Settings) or to ...
0
votes
2answers
876 views

What's the connection between “Recently modified in Quick Launch” and the “SharePoint Server Publishing”-Feature?

First I had a plain Team Site without the Feauture "SharePoint Server Publishing" activated. I created several Site Pages, all rendered automatically without the annoying "Recently Modified". When I ...
0
votes
2answers
96 views

How would a Web Application feature knows on activation that which web app its supposed to run on

Scenario can be read on My other Question Further to that question, why would a web application has timer job definition that it hasn't been deployed to. this is the code I am using for feature ...
1
vote
2answers
361 views

How to include an anchor tag in a Feature description

Is there a way to include an anchor tag in the description of a feature; my reason for this is to take the user to a page that has the configuration instructions for the feature. Currently what is ...
0
votes
2answers
664 views

List ribbon button disappeared

I have a problem with a List ribbon button that disappears. The only thing that has happend that I know of is that the wsp was redeployed and the site-feature (which creates the list) was reactivated. ...
0
votes
1answer
48 views

how to check custom property of added Item

There is a boolean column I added to a custom list, but I also have a feature on this custom list so that when a Item is added i have to check if this column exists or not and then its value. now i ...
0
votes
2answers
2k views

Adding multiple controls to AdditionalPageHead

My question is regarding the delegate control AdditionalPageHead, as we know it allows multple controls to be loaded. My questions are: How to add multiple controls? I want that the different ...
0
votes
2answers
220 views

ContentType.FieldLinks.Add() issue with hidden and required

I have a feature that does the following in the feature activation Code : Creates a new SiteColumn (Type=Text, Hidden=False and Required =True) Set the french version of the Name (using ...
0
votes
0answers
29 views

Custom delegate is applied even if the feature is deactivated

I have a question regarding a feature. Situation: I have a feature that is farm scoped, with this feature I deploy a delegate control (xml file), this file refers to cs code. So I've added that file ...
0
votes
1answer
1k views

How do I configure styles and layout of a Summary Link Web Part using code?

I have successfully added a Summary Link Web Part as a feature and want to configure the styles and layout of it, including: The default style for new links The group header style The number of ...
2
votes
1answer
7k views

Error occurred in deployment step 'Activate Features' - When feature stapling to My Sites

I am trying to deploy a feature to My Sites in SharePoint 2010 and nothing seems to be working. I did this perfectly fine on the test environment but can't seem to get it working on the production ...
1
vote
1answer
426 views

Publishing field type names for feature

I'm creating a SharePoint 2010 feature in VS 2010 to add some custom site columns to a site collection via an elements.xml file. I can't seem to find the Type attribute values for the publishing ...
0
votes
2answers
1k views

Finding all activated Site Features & Site Collection Features in a Site Collection Script

I wonder if someone knows any C# script that will provide me all Site Features in a site collection as well as all Site collection features in a site collection. I only required Activated features ...
0
votes
1answer
15 views

Site Features in Sub Webs Confusion

Very Basic but confusing question. I see we have three types of features, Web Application Features Site Collection Features Site Features Now I know that Web application features belong to web ...
3
votes
1answer
192 views

Site Scope Feature dependent on a Web Scope Feature

On the root web for my site collection I need to make sure a web scope feature is turned on. In the feature EventReceiver I can turn on the feature progamtically. How can I stop the user turning the ...
1
vote
2answers
354 views

Elements.xml Id substitution

I have a site column defined in an Elements.xml file in Visual Studio. The SharePoint project this is in does all sorts of initial configuration on the website. I need to set the UserSelectionScope to ...
2
votes
1answer
2k views

When I create a folder porgrammatically get the error “Invalid item data — missing FileRef”

I trying to add programmatically the detested Folder. I do the following foreach (SPListItem reparto in reparti.Items) { var folder = dl.Items.Add(dl.RootFolder.ServerRelativeUrl, ...
2
votes
1answer
307 views

cant find webapplication scoped feature anywhere

I developed a Custom Timer Job Feature using WSP Builder but for some reason I am not able to find it so that I can activate it. I know I can activate it using stsadm but why cant I find it in Site ...
0
votes
1answer
219 views

Adding column to a SPList

Normally I create a New List if I want to add an additional column to a List that already exists in a web. Wondering what would be the best option, should I create a new list with additional column ...
0
votes
1answer
75 views

compare values in list and change if necessary

So guys, I have a sharepoint list with and fields like "webID, url, rating" and a c# list with more or less the same fields. My task is to compare the lists by webID and if the row's "rating" field is ...
2
votes
2answers
861 views

Delete custom master page error on feature deactivation

I have a feature that deploys custom master pages to all sites in a site collection on activation, and want to delete all traces of the custom master pages on deactivation. On deactivation, after ...
2
votes
0answers
738 views

How can I specify the ID of a XsltViewWebPart?

In a module, I'm deploying a webpart page where I put a view to a list : <View WebPartZoneID="Body" WebPartOrder="3" List="related" BaseViewID="4" ...
0
votes
0answers
461 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with ...
0
votes
2answers
178 views

SharePoint 2010 Dev Machine Deploy to Stage Machine

Machine 1: Virtual Development box with Visual Studio 2010, SharePoint 2010 Foundations, Designer 2010. Machine 2: SharePoint 2010 Enterprise (Staging Environment) Question: Does Machine 2 need to ...
1
vote
1answer
2k views

SharePoint 2010 solution not deploying correctly (features not available)

I have been working on a SharePoint 2010 solution on a server using Visual Studio. Unfortunately the server decided to die on me. Fortunately I have the solution backed up using source control and had ...
2
votes
0answers
512 views

Setting an audience from declarative WebPart?

I have a module that deploys some page. I'm adding webparts to these page, using a <AllUsersWebPart> node within a <View>: <View WebPartZoneID="Body" WebPartOrder="5" ...
0
votes
0answers
25 views

SPContext is null on Feature Activation [duplicate]

Possible Duplicate: Error : Object reference not set to an instance of an object on feature deployment I am writing a feature receiver. Here is my code sample on feature_activated code. ...
1
vote
1answer
141 views

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server?

Is it possible to the change filenames of feature.xml and elements.xml on a sharepoint server if so how?
1
vote
0answers
469 views

Can't deploy a xslt webpart as expected

In one of my custom list schema, I have defined a custom view : <View Type="HTML" DisplayName="My wonderful view" BaseViewID="2" ...
1
vote
1answer
68 views

Including a WorkFlow in a WSP

I am creating a feature that I want to install a couple of workflows when activated and bind them to a list. Is there a way you can use SPD and then export your workflow to include them in your visaul ...
1
vote
1answer
245 views

Look & Feel - Pagelayouts and Site Templates

I recently ran into a rather unfortunate assignment. It regards the selection of pagelayouts and sitetemplates which subsites should be able to use. As I'm supposed to change this for 20+ site ...