set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

0
votes
3answers
206 views

MissingFeature - Issue

I am trying to get rid of the health error: [MissingFeature] Database [WSS_ContentDB] has reference(s) to a missing feature: Id = [id] I followed this link Removing features from a content ...
1
vote
2answers
149 views

Why does a Site-Scoped Feature need to be installed on farm-level?

"Feature with Id '#########################' is not installed in this farm and cannot be added to scope" I received this error when trying to deploy a SharePoint 2010 solution in VS 2010. The problem ...
0
votes
2answers
19 views

How can I manipulate List-Data on a certain SiteCollection using a TimerJob?

I need to periodically execute code that reads and writes ListData within a certain SiteCollection. My first thought was a TimerJob. Can I create a TimerJob using a SiteCollection-Feature? How can I ...
0
votes
1answer
13 views

How to open and manipulating an already developed and deployed SharePoint feature using visual studio

After SharePoint migration from 2010 to 2013, I have imported a solution, using power shell, which was developed for the SharePoint 2010. Now the feature is deployed and is available but does not ...
0
votes
1answer
48 views

How to find out per PowerShell Script if a Solution is activated and where it is activated

i have a Solution with the name My.Solutionname as the result of it i have a WSP with the name My.Solutionname.wsp It includes one Site and one Web scoped Feature. I have a SharePoint 2013 Farm ...
0
votes
1answer
49 views

Order of Items in a single feature

Can we set order for items in a single feature? I was trying to create a site column of type lookup for which the lookup-list should be created first after that only we can create the column. In my ...
0
votes
1answer
19 views

Improper feature Id attribute error

Hi I am getting Improper feature Id attribute error. I try to deploy a feature to a site using visual studio 2013. google cant help me so i ask here. this is my feature.xml: <?xml version="1.0" ...
0
votes
1answer
24 views

Feature not activating, til 2nd attempt, no error

I have a custom feature that, when activated, alters a document library (adds content types, sets up views, attaches a workflow). For some reason, the first time I activate the feature nothing seems ...
0
votes
1answer
17 views

Object Reference Error when trying to check for activated features using windows forms app

var feature = spSite.Features.SingleOrDefault(sf => sf.Definition.DisplayName.ToLower().Equals(strFeatureName));//Error block if (feature != null)//if feature is activated { ...
0
votes
1answer
314 views

“The associated workflow has been deprecated.” error

I've got 2013 workflows, deployed from WSP package. After last Deploy from VS2013 I've got workflows behaving the way that first execution on item created is ended after starting with the "The ...
0
votes
1answer
664 views

Cannot active SharePoint Server Publishing - missing another feature

I'm trying to active this part from the site features: **SharePoint Server Publishing Create a Web page library as well as supporting libraries to create and publish pages based on page layouts.** ...
0
votes
1answer
161 views

Unable to see timer job

I have created a custom timer job, which contains a feature. I have successfully activated the feature on my web application, but it does not show up under the job definitions. Feature.xml is as ...
0
votes
1answer
63 views

Stop remove to SitePages from site on feature deactivation

I have create on module which is add in SitePages and add the webpart page and set that page as a home page of site on feature activation. and on feature deactivation I have wrote a code which will ...
0
votes
1answer
36 views

Can't find MissingFeature

I have a question, basically when i run Test-SPContentDatabase I get an error "MissingFeature" with an ID. I used the Feature Admin, this one doesn't give any faulty features or whatever, i checked ...
0
votes
1answer
149 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...
0
votes
1answer
38 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
0
votes
1answer
142 views

Object reference not set to an object error while moving an object to feature list

I have created a feature in which I want to put the list instance to be created when the feature is activated. I created new feature from visual studio and trying to add the list instance file to the ...
0
votes
1answer
23 views

How to find feature including a specific element

this migth be a really easy question, but I could not find any solution for that. I'm using VS 2012 and want to find which features are using a specific element. Since I got lots of Features in my ...
0
votes
1answer
76 views

Remove a list from all site collections when a feature is uninstalled

I have a site scoped Feature which specifies a list as such: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> ...
0
votes
1answer
125 views

Add custom code for solution upgrade

I have a solution for SP2010. Let's call it s.wsp. I had version 1 of s.wsp and now I have version 2 of s.wsp. Versions 1 and 2 share three common features: A, B and C. Version 2 adds a new feature D. ...
0
votes
1answer
712 views

Disable auto activate feature

I have a really strange behaviour, I'm working with SharePoint 2007 and I have a feature web application scoped, and i don't want it automatically being activated on deploying the solution, but it ...
-1
votes
1answer
52 views

Can't see feature on my webApplication

I did a solution for a SPJobDefinition. Feature scope is WebApplication as required. I have event FeatureActivated but when i deploy solution. When i go to CA -> Manage WebApplication -> select one ...