set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

1
vote
1answer
87 views

Do you see “Shared with me” and “Undo Change” feature at your SP2013 (std and enterprise)

Sorry it maybe a stupid question but in my test environment the titled features are missed. According to MSDN: ...
1
vote
0answers
17 views

SP2010 - ToolbarTemplate property not working in Custom Feature

I have a requirement to hide the "Respond to Survey" link on all surveys for a SP2010 site if the user has already responded. I followed the process using this link ...
0
votes
2answers
105 views

How can I make my custom webpart visible to the whole farm?

I am quite new to SharePoint. I am trying to update an Integration of SharePoint 2010 to SharePoint 2013. I can add my custom webpart under the default site collection. But when I create a new site ...
0
votes
1answer
89 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...
0
votes
1answer
31 views

Site provision cycle

I have some site definitions in which I have added multiple lists into the <Lists> tag and then I've added a stapling feature which will trigger a series of web-scoped features when sites are ...
0
votes
0answers
103 views

The element of type field fo feature 'feature' threw an exception during activation: a duplicate field name 'fieldName' was found

I am taking over a SharePoint environment. The previous developer created a custom Workflow with Custom Activities, etc. One of the steps in the Workflow is to create a web using a custom Site ...
4
votes
1answer
118 views

Adding new site column to existing content type on multi language sites

I'm using the declarative SharePoint feature upgrade approach to : 1. Add a new custom column to site columns gallery 2. Add the new custom column to an existing content type There are two variation ...
0
votes
1answer
637 views

Adding Folders to a SharePoint 2010 Custom Document Library Template

Although I know it is bad practice, my business requirements dictate to create a default folder structure within a custom document library template. I created the feature in VS including site columns ...
0
votes
1answer
236 views

“Feature has conflicting event reciever settings” error

I am new to SharePoint so I apologize if this is not phrased properly, but I created a BDC to a SQL database in Visual Studio 2012. I am trying to have the list created programmatically through an ...
0
votes
0answers
32 views

Custom Search to External Service

I am trying to add a custom search on the top static bar in SharePoint 2010. I created a delegate control to perform this task. I have tried multiple ways of creating a form text box and button and ...
2
votes
2answers
28 views

Controlling which feature a project element is added to

How does visual studio decide which feature to add an element to? My features have a specific order which they need to be enabled (and its set using Feature Dependencies) but I need a simpler method ...
2
votes
1answer
183 views

PowerShell Script To Find Where SharePoint 2010 Features Are Activated

I want a PowerShell script to find where Features are activated in a site collection and its sites/subsites Like for example feature "Enterprise feature"
4
votes
1answer
415 views

Farm scope Event Receiver

For some security reasons on one of our farm level solutions, we need to limit some actions using Event Receiver-FileMoving event. However, as known, event receivers can be deployed only by Site or ...
1
vote
1answer
256 views

Cannot activate SharePoint Publishing Feature

despite placing the following code in my onet.xml, the publishing feature is not activated. <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA"> <!-- PublishingPrerequisites --> ...
1
vote
2answers
116 views

What user data or customizations will I lose if I deactivate and reactivate a site collection feature

I am having problems with my embedded SSRS reports (print button missing) and it claims that my Report Viewer web part is not configured correctly, or something along those lines. I was thinking of ...
2
votes
4answers
243 views

feature stapling in site definition

I want to create site definition using VS2010, also when any site get created it should activate few feature automatically. How to use feature stapling exactly , please anyone let me know step by step ...
1
vote
1answer
97 views

Easiest way to add a list instance with column in Feature

What is the easiest way to add a list instance (to the existing Custom/generic list) with one new column declaratively? Is there a way to do this without specifying anything extra (like specifying any ...
1
vote
1answer
175 views

Sharepoint 2007 to Sharepoint 2010 Migration Issues

I recently migrated SharePoint 2007 portal to SharePoint 2010 using content database attach/detach method. After mounting the database in SharePoint 2010, site collection got created. When I browse ...
1
vote
1answer
27 views

2 exact the same features in different packages

I have a question, basically in a solution i have 2 packages which should be independent, but also should work properly together. So I have a feature which basically is required in both packages. I ...
9
votes
4answers
12k views

Feature has already been installed. Use the force attribute to explicitly re-install the feature

We have several SharePoint 2010 solutions which we want to deploy to SharePoint 2013 with Visual Studio 2012 running on Windows Server 2012. Site solutions work. But farm solutions just don't. I get ...
0
votes
1answer
288 views

“The system cannot find the file specified” message while deploying new feature

I'm trying to deploy a new feature on sharepoint 2010 with scope web. The deploy seems to run successfully, but the feature is not prensent in feature manager. While visual Studio deploys the ...
0
votes
1answer
431 views

Features.feature in SharePoint app

I added a new SharePoint app project into an existing web project solution. When I tried to deploy it am getting an error: Error occurred in deployment step 'Install app for SharePoint': Failed to ...
0
votes
0answers
20 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
1
vote
1answer
291 views

What are the considerations with removing groups and permission levels added by SharePoint Server Publishing Infrastructure

I'm trying to decide how to handle requirements I have for removing security groups and permission levels that are added by activating the SharePoint Server Publishing Infrastructure (SSPI) feature ...
0
votes
3answers
542 views

Email group when documents reaches expiry date

I have a requirement where a document column ‘Expiry’ = today to send an email to the document owner / group. Then the owner will need to modify the document and update the Expiry Date ready for the ...
1
vote
2answers
199 views

Delete content type during feature dectivation

I want to delete content type programmatically on feature deactivation. I've wrote the code to perform deletion: SPSecurity.RunWithElevatedPrivileges(delegate() { using ...
1
vote
3answers
129 views

How to remove safe a feature in SharePoint 2013?

I have a visual studio 2012 solution with some features. This is deployed on the production environment. Now I have removed one of the features from the VS solution. I created a new wsp file and ...
2
votes
2answers
140 views

Copy user accounts across site collections

I am writing an archival Feature for a SharePoint 2010 list using C#. I have it copying the list items and all version history over to the new site collection but the Modified By and Created By fields ...
0
votes
1answer
30 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
0
votes
1answer
79 views

Allow multiple people to work on different web parts at the same time

I've scoured the internet and tried asking different questions but still can't come up with a nice solution to this problem. Consider a situation where I have 2 web parts, each of which is being ...
0
votes
1answer
106 views

Object reference not set to an object error while moving an object to feature list

I have created a feature in which I want to put the list instance to be created when the feature is activated. I created new feature from visual studio and trying to add the list instance file to the ...
1
vote
2answers
4k views

Feature with Id 'guid' is not installed in this farm, and cannot be added to this scope

I have a WinForms project that acts as a Sharepoint 2013 Solution installer. It basically do some checking, create a sql database, adds and install a SP Solution and finally activates the feature. ...
0
votes
0answers
500 views

Calling Enable-SPFeature in SP2013 with CompatibilityLevel isn't working

In an SP2013 environment running in SP2010 mode has anyone successfully called the Powershell command -- Enable-SPFeature while specifying the compatibility level? Example: Enable-SPFeature -identity ...
0
votes
0answers
244 views

Feature ‘XXX’ for list template ‘YYY’ is not installed in this farm. The operation could not be completed

So I'm very new to SharePoint. And I'm supposed to debug a website SharePoint 2013. So when I open this page a web service is supposed to get me data from a distant database and display it in a ...
1
vote
0answers
106 views

Embed iframe when inserting a post

I developed a Ribbon button that show's up in the Media tab. This displays a Modal Dialog to the user, listing some external content, and when clicking on an item it pastes the iframe html code on the ...
1
vote
1answer
195 views

Activate Content Organizer feature from code

how to activate content organizer feature from c# code or by powershell script. I want to activate this feature on my subsite from my code ?
1
vote
4answers
2k views

How to enable site collection feature by default when deploying a visual webpart from visual studio?

I am making a visual web part in SP 2010 using visual studio 2010. I want it so that when I add and deploy my wsp file, it should by default keep the site collection feature activated for the web ...
1
vote
0answers
105 views

2010 - Update-SPSolution required after solution installed?

I created a new feature and performed a Uninstall/Remove/Add/Install-SPSolution using PowerShell to deploy it. The solution deployed correctly and the feature was added to the 14 hive, but did not ...
0
votes
2answers
1k views

Sharepoint package installation - Feature is not visible in Site collection -> settings

I am not very experienced with Sharepoint 2010 and I am having trouble installing a package. I downloaded a package from "iLove SharePoint" as I need to call web service from a workflow. The package ...
0
votes
1answer
400 views

Custom Master Page Feature on Parent Site automatically getting activated on activating child's master page feature

I've created and deployed a custom master page and kept its scope to be Web because I want to apply to specific sites not the complete site collection. But when I activate feature at a specific site, ...
1
vote
2answers
2k views

Sharepoint 2010 - feature not appearing in UI

Does anyone here know what could cause a new feature to not show up in the SharePoint UI? The solution it is part of has been correctly deployed to the GAC and shows up in the central administration ...
0
votes
1answer
19 views

How to find feature including a specific element

this migth be a really easy question, but I could not find any solution for that. I'm using VS 2012 and want to find which features are using a specific element. Since I got lots of Features in my ...
1
vote
1answer
57 views

Dynamically deploying branding (SharePoint 2010)

I'm developing a portal for clients in SP2010. Each client will have their own copy of the portal (a site collection) branding for them. Currently I provision all the branding artifacts to the style ...
2
votes
1answer
35 views

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory?

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory? What I'm trying to do is re-provision data every time my feature is activated without deleting the SPList. The idea is to ...
2
votes
2answers
1k views

Web Application scoped features not visible in Central Admin after installing solution with WebApplication scoped resources

In an effort to use WebConfigModifications less, I am trying to move some binding redirects and safe control entries into the solution manifest. The DeploymentTarget of the assembies is ...
0
votes
2answers
276 views

Creating a site column using a feature and setting its WebId property

I need to create a site column that will be added to children sites, this column is a lookup referencing a list in the rootWeb, so I need to provide de WebId property in order to make it available on ...
2
votes
1answer
1k views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
0
votes
1answer
727 views

Hide “Customize Form” Button on List Ribbon

I am trying to hide the "Customize Form" button on the List ribbon: I have created a feature that deploys an Elements.xml file that looks like this: <?xml version="1.0" encoding="utf-8"?> ...
1
vote
0answers
172 views

Lists not being added to quicklaunch

I'm having a problem with some lists that are included in a feature (Scope: web), which is created via a site definition. These lists have the display on quicklaunch set to true, although, the only ...
0
votes
2answers
614 views

How to add a calculated column to list view programmatically?

I have created a SharePoint feature where I have added a list named "Employees". I have added a Content Type "Employee" and added to it some columns like "Vacation Days Taken", "Vacation Days ...