set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

1
vote
4answers
1k views

How to enable site collection feature by default when deploying a visual webpart from visual studio?

I am making a visual web part in SP 2010 using visual studio 2010. I want it so that when I add and deploy my wsp file, it should by default keep the site collection feature activated for the web ...
0
votes
2answers
80 views

How can I make my custom webpart visible to the whole farm?

I am quite new to SharePoint. I am trying to update an Integration of SharePoint 2010 to SharePoint 2013. I can add my custom webpart under the default site collection. But when I create a new site ...
4
votes
1answer
96 views

Adding new site column to existing content type on multi language sites

I'm using the declarative SharePoint feature upgrade approach to : 1. Add a new custom column to site columns gallery 2. Add the new custom column to an existing content type There are two variation ...
1
vote
3answers
2k views

Powershell Deployment - Enable-SPFeature Error

I get the following problem activating a feature in powershell: Enable-SPFeature : The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: ...
0
votes
1answer
73 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...
0
votes
1answer
30 views

Site provision cycle

I have some site definitions in which I have added multiple lists into the <Lists> tag and then I've added a stapling feature which will trigger a series of web-scoped features when sites are ...
2
votes
4answers
154 views

feature stapling in site definition

I want to create site definition using VS2010, also when any site get created it should activate few feature automatically. How to use feature stapling exactly , please anyone let me know step by step ...
1
vote
3answers
240 views

Add user control or web part to every page in a site

I want to have a feature which causes the following to happen everytime any page in a site loads. I need to have a web part or user control which adds information about the current user to the page. ...
0
votes
4answers
2k views

Custom Claim Provider - What is the fix for “Error loading the claim provider assembly”?

I have implemented a custom SPClaimProvider that is doing claims augmentation in the FillClaimsForEntity method. I have packaged this as a SharePoint feature and deploy it in a WSP. I am trying to ...
0
votes
0answers
69 views

The element of type field fo feature 'feature' threw an exception during activation: a duplicate field name 'fieldName' was found

I am taking over a SharePoint environment. The previous developer created a custom Workflow with Custom Activities, etc. One of the steps in the Workflow is to create a web using a custom Site ...
0
votes
1answer
417 views

Adding Folders to a SharePoint 2010 Custom Document Library Template

Although I know it is bad practice, my business requirements dictate to create a default folder structure within a custom document library template. I created the feature in VS including site columns ...
0
votes
2answers
701 views

Feature deactivation and webpart not being removed

I have a question regarding a feature and the webparts. Basically recently i noticed that when i deploy a webpart with my solution and it is bound to a feature on site collection scope, when it is ...
0
votes
0answers
31 views

Custom Search to External Service

I am trying to add a custom search on the top static bar in SharePoint 2010. I created a delegate control to perform this task. I have tried multiple ways of creating a form text box and button and ...
2
votes
2answers
25 views

Controlling which feature a project element is added to

How does visual studio decide which feature to add an element to? My features have a specific order which they need to be enabled (and its set using Feature Dependencies) but I need a simpler method ...
2
votes
1answer
107 views

PowerShell Script To Find Where SharePoint 2010 Features Are Activated

I want a PowerShell script to find where Features are activated in a site collection and its sites/subsites Like for example feature "Enterprise feature"
4
votes
1answer
273 views

Farm scope Event Receiver

For some security reasons on one of our farm level solutions, we need to limit some actions using Event Receiver-FileMoving event. However, as known, event receivers can be deployed only by Site or ...
1
vote
2answers
83 views

What user data or customizations will I lose if I deactivate and reactivate a site collection feature

I am having problems with my embedded SSRS reports (print button missing) and it claims that my Report Viewer web part is not configured correctly, or something along those lines. I was thinking of ...
1
vote
1answer
154 views

Cannot activate SharePoint Publishing Feature

despite placing the following code in my onet.xml, the publishing feature is not activated. <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA"> <!-- PublishingPrerequisites --> ...
1
vote
1answer
63 views

Easiest way to add a list instance with column in Feature

What is the easiest way to add a list instance (to the existing Custom/generic list) with one new column declaratively? Is there a way to do this without specifying anything extra (like specifying any ...
1
vote
1answer
75 views

Sharepoint 2007 to Sharepoint 2010 Migration Issues

I recently migrated SharePoint 2007 portal to SharePoint 2010 using content database attach/detach method. After mounting the database in SharePoint 2010, site collection got created. When I browse ...
0
votes
1answer
320 views

Feature Activation through stapling

I am developing a sharepoint feature which takes a backup of the site at sitecollection level and at site level whenever a user tries to delete the site. The feature is working fine without issues for ...
2
votes
2answers
2k views

Error occurred in deployment step 'Activate Features': The parent content type specified by content type identifier 0x0101 does not exist

I have created 80 content types. some of them are inherited from some other content types. I have placed all the content types in feature in such an order that parent content types are at top. But ...
1
vote
1answer
27 views

2 exact the same features in different packages

I have a question, basically in a solution i have 2 packages which should be independent, but also should work properly together. So I have a feature which basically is required in both packages. I ...
2
votes
1answer
903 views

Web Application scoped features not visible in Central Admin after installing solution with WebApplication scoped resources

In an effort to use WebConfigModifications less, I am trying to move some binding redirects and safe control entries into the solution manifest. The DeploymentTarget of the assembies is ...
3
votes
3answers
1k views

Moving BDC models from server to server

I have created a BDC model and deploy it through a feature. The feature has to have a SiteUrl as specified in the feature xml below. However when I move the feature from say the development to test, ...
0
votes
1answer
191 views

“The system cannot find the file specified” message while deploying new feature

I'm trying to deploy a new feature on sharepoint 2010 with scope web. The deploy seems to run successfully, but the feature is not prensent in feature manager. While visual Studio deploys the ...
0
votes
1answer
269 views

Features.feature in SharePoint app

I added a new SharePoint app project into an existing web project solution. When I tried to deploy it am getting an error: Error occurred in deployment step 'Install app for SharePoint': Failed to ...
0
votes
1answer
70 views

Allow multiple people to work on different web parts at the same time

I've scoured the internet and tried asking different questions but still can't come up with a nice solution to this problem. Consider a situation where I have 2 web parts, each of which is being ...
0
votes
1answer
729 views

Site Collection Feature won't go away

I have a custom Feature, with Site Collection scope, that won't go away even after I delete the Web Application, the Content Database, the IIS Web Site. I have uninstalled the Solution that ...
0
votes
0answers
20 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
1
vote
1answer
174 views

What are the considerations with removing groups and permission levels added by SharePoint Server Publishing Infrastructure

I'm trying to decide how to handle requirements I have for removing security groups and permission levels that are added by activating the SharePoint Server Publishing Infrastructure (SSPI) feature ...
0
votes
3answers
346 views

Email group when documents reaches expiry date

I have a requirement where a document column ‘Expiry’ = today to send an email to the document owner / group. Then the owner will need to modify the document and update the Expiry Date ready for the ...
0
votes
0answers
54 views

How can I create a editable site page based on a custom page layout that is deployed via site definition

I have a site definition (SP2013) with some features. The feature deployes a custom page layout thats using the "Article Page" content type. Once deployed I can create new pages fine based on my new ...
0
votes
2answers
113 views

Delete content type during feature dectivation

I want to delete content type programmatically on feature deactivation. I've wrote the code to perform deletion: SPSecurity.RunWithElevatedPrivileges(delegate() { using ...
1
vote
3answers
119 views

How to remove safe a feature in SharePoint 2013?

I have a visual studio 2012 solution with some features. This is deployed on the production environment. Now I have removed one of the features from the VS solution. I created a new wsp file and ...
2
votes
1answer
32 views

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory?

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory? What I'm trying to do is re-provision data every time my feature is activated without deleting the SPList. The idea is to ...
0
votes
1answer
29 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
2
votes
2answers
111 views

Copy user accounts across site collections

I am writing an archival Feature for a SharePoint 2010 list using C#. I have it copying the list items and all version history over to the new site collection but the Modified By and Created By fields ...
0
votes
0answers
30 views

sharepoint 2010 Ghosted / UnGhosted Page Layout query

I've deployed a Feature to my SharePoint 2010 Farm which deploys each of my custom page layouts as 'ghosted' (uncustomized) aspx files into the Page Layouts folder especially since I have to update ...
0
votes
0answers
74 views

Custom Feature Compatibility from SP2010 to SP2013 Question

I have a question concerning the compatibility of my SP2010 custom features in SP2013. Here is my setup: I have a wide range of Farm, Site, and Web features that all interact with each other in a ...
0
votes
1answer
96 views

Object reference not set to an object error while moving an object to feature list

I have created a feature in which I want to put the list instance to be created when the feature is activated. I created new feature from visual studio and trying to add the list instance file to the ...
1
vote
2answers
3k views

Feature with Id 'guid' is not installed in this farm, and cannot be added to this scope

I have a WinForms project that acts as a Sharepoint 2013 Solution installer. It basically do some checking, create a sql database, adds and install a SP Solution and finally activates the feature. ...
12
votes
3answers
7k views

How do I find in which (sub)sites a WebPart/Feature is used?

I need to find out on which (sub)sites a certain webpart is used. In a data sharing environment with many subsites and pages, I want to check if and where certain (third party) webparts are used. Is ...
0
votes
0answers
363 views

Calling Enable-SPFeature in SP2013 with CompatibilityLevel isn't working

In an SP2013 environment running in SP2010 mode has anyone successfully called the Powershell command -- Enable-SPFeature while specifying the compatibility level? Example: Enable-SPFeature -identity ...
0
votes
0answers
184 views

Feature ‘XXX’ for list template ‘YYY’ is not installed in this farm. The operation could not be completed

So I'm very new to SharePoint. And I'm supposed to debug a website SharePoint 2013. So when I open this page a web service is supposed to get me data from a distant database and display it in a ...
1
vote
0answers
93 views

Embed iframe when inserting a post

I developed a Ribbon button that show's up in the Media tab. This displays a Modal Dialog to the user, listing some external content, and when clicking on an item it pastes the iframe html code on the ...
1
vote
1answer
147 views

Activate Content Organizer feature from code

how to activate content organizer feature from c# code or by powershell script. I want to activate this feature on my subsite from my code ?
1
vote
2answers
1k views

Sharepoint 2010 - feature not appearing in UI

Does anyone here know what could cause a new feature to not show up in the SharePoint UI? The solution it is part of has been correctly deployed to the GAC and shows up in the central administration ...
1
vote
0answers
96 views

2010 - Update-SPSolution required after solution installed?

I created a new feature and performed a Uninstall/Remove/Add/Install-SPSolution using PowerShell to deploy it. The solution deployed correctly and the feature was added to the 14 hive, but did not ...
0
votes
1answer
294 views

Custom Master Page Feature on Parent Site automatically getting activated on activating child's master page feature

I've created and deployed a custom master page and kept its scope to be Web because I want to apply to specific sites not the complete site collection. But when I activate feature at a specific site, ...