set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

2
votes
1answer
182 views

No Display Templates for Popular Items web part from Search-Driven Content category

I have a Popular Items web part on my site and in the Display Templates these things are selected: I have saved this site as template, via Save Site as Template option, and created a new site from ...
2
votes
1answer
1k views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
1
vote
1answer
19 views

Edit person.aspx?

We have more than 1000 user profiles that need a customized person.aspx. We need to make quite big changes to person.aspx. What is best practice here ? Do we edit person.aspx via SharePoint designer ...
1
vote
1answer
14 views

Features on a list

How can I see the features attached to a list? (ex: which feature create an item custom action)
1
vote
1answer
31 views

Hide feature based on user sharepoint

Is there any way to manipulate feature.xml file to control its visibility from a specific group? Thanks.
1
vote
1answer
54 views

Dependency of feature deployment with List and webpart

We have a project containing a webpart and a list instance (rootwebonly). The webpart and the list instance are activated via a single feature. Now problem is that, everytime a change is requested, ...
1
vote
1answer
278 views

Cannot activate SharePoint Publishing Feature

despite placing the following code in my onet.xml, the publishing feature is not activated. <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA"> <!-- PublishingPrerequisites --> ...
1
vote
1answer
102 views

Apply element manifest without re-activating feature

I have a feature module which consists of an XML file which adds ConsoleNodes to the Site Actions menu. To test it, it seems I must compile the package, deploy it, activate it, etc. Since this is ...
1
vote
1answer
310 views

How to DeActivate feature of my site?

How to DeActivate feature of my SharePoint site remotely ? I have created .wsp package file and uploaded SandBox solution to my SharePoint site. But in my elements.xml file it has 1 mistake of ...
1
vote
1answer
76 views

Which publishing feature creates a search site?

I have created some custom WebTemplates for SP2010 and activated a load of publishing features which have in turn created a search site. Does anyone know which feature is likely to create this subsite ...
0
votes
1answer
16 views

Cannot active SharePoint Server Publishing - missing another feature

I'm trying to active this part from the site features: **SharePoint Server Publishing Create a Web page library as well as supporting libraries to create and publish pages based on page layouts.** ...
0
votes
1answer
98 views

Unable to see timer job

I have created a custom timer job, which contains a feature. I have successfully activated the feature on my web application, but it does not show up under the job definitions. Feature.xml is as ...
0
votes
1answer
44 views

Stop remove to SitePages from site on feature deactivation

I have create on module which is add in SitePages and add the webpart page and set that page as a home page of site on feature activation. and on feature deactivation I have wrote a code which will ...
0
votes
1answer
26 views

Can't find MissingFeature

I have a question, basically when i run Test-SPContentDatabase I get an error "MissingFeature" with an ID. I used the Feature Admin, this one doesn't give any faulty features or whatever, i checked ...
0
votes
1answer
93 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...
0
votes
1answer
297 views

“The system cannot find the file specified” message while deploying new feature

I'm trying to deploy a new feature on sharepoint 2010 with scope web. The deploy seems to run successfully, but the feature is not prensent in feature manager. While visual Studio deploys the ...
0
votes
1answer
31 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
2
votes
0answers
932 views

How can I specify the ID of a XsltViewWebPart?

In a module, I'm deploying a webpart page where I put a view to a list : <View WebPartZoneID="Body" WebPartOrder="3" List="related" BaseViewID="4" ...
2
votes
0answers
724 views

Setting an audience from declarative WebPart?

I have a module that deploys some page. I'm adding webparts to these page, using a <AllUsersWebPart> node within a <View>: <View WebPartZoneID="Body" WebPartOrder="5" ...
2
votes
0answers
120 views

Attaching file in data node of a list instance?

I have a custom list definition and a custom list instance in a feature. If I want to populate some data in the list at its creation, I can use the data node. How can I add an attachment to this ...
2
votes
0answers
333 views

Why does WSP Deployment Type 'ApplicationServer' require features to be manually installed?

When I create a WSP with Deployment Type set to WebFrontEnd and deploy, all of the features contained within are automatically installed. Features that are set up as ActivateOnDefault="TRUE" (Farm or ...
1
vote
0answers
12 views

Access Denied on installing WSP having Web Application scoped Feature

As the title says. I am trying to deploy a solution through central admin which has a Web Application scoped feature. As soon as I try to install it, it goes to access denied page. Strangely, when I ...
1
vote
0answers
18 views

SP2010 - ToolbarTemplate property not working in Custom Feature

I have a requirement to hide the "Respond to Survey" link on all surveys for a SP2010 site if the user has already responded. I followed the process using this link ...
1
vote
0answers
108 views

Embed iframe when inserting a post

I developed a Ribbon button that show's up in the Media tab. This displays a Modal Dialog to the user, listing some external content, and when clicking on an item it pastes the iframe html code on the ...
1
vote
0answers
105 views

2010 - Update-SPSolution required after solution installed?

I created a new feature and performed a Uninstall/Remove/Add/Install-SPSolution using PowerShell to deploy it. The solution deployed correctly and the feature was added to the 14 hive, but did not ...
1
vote
0answers
179 views

Lists not being added to quicklaunch

I'm having a problem with some lists that are included in a feature (Scope: web), which is created via a site definition. These lists have the display on quicklaunch set to true, although, the only ...
1
vote
0answers
154 views

Missing Features and Existing Lists

I have a site that was hosted on a Microsoft Project Server instance. One of the sub-sites was based on the Project Workspace Template in order to get access to the "special" lists like Risks and ...
1
vote
0answers
532 views

Can't deploy a xslt webpart as expected

In one of my custom list schema, I have defined a custom view : <View Type="HTML" DisplayName="My wonderful view" BaseViewID="2" ...
1
vote
0answers
293 views

Is there a way to create user-configurable Custom Retention Formulas, possibly through Custom Properties?

I am wanting to create a "user" - configurable Custom Retention Formula? Something like a simple version of the rules that Excel and other applications have which displays something like: ...
1
vote
0answers
20 views

In SharePoint 2007 what feature or solution added the WebPart Page Doc library templates?

In SharePoint 2007 what feature or solution added the WebPart Page Doc library template? We have it on one Farm, but not another. Is it part of the Fab 40? A site feature or a Site collection ...
0
votes
0answers
7 views

Create a web template via visual studio

I have a little problem , I'm trying to create a simple web template from Visual Studio using this technique: ...
0
votes
0answers
11 views

SharePoint Online master page not being added to subsite

In SharePoint Online I have created a new Site Collection with a custom master page, and the master page styles are displaying fine. Now when I create a subsite they do not get the master page ...
0
votes
0answers
15 views

What does the site collection feature “Reporting” provision / enable?

The site collection scoped feature "Reporting" has description "Creates reports about information in Microsoft SharePoint Foundation." What does this feature actually provision and/or enable? Does ...
0
votes
0answers
32 views

Current navigation and AreaNavigationSetting error with publishing feature

I'm working with SharePoint 2013 and I have a problem with current navigation and the AreaNavigationSettings.aspx page. Publishing features are enabled on the site collection and the website but the ...
0
votes
0answers
65 views

Uninstalling farm solutions, will not remove the related site collection features

I am facing a problem which I cannot understand how to fix it. Now I have installed third party tools inside my SharePoint 2013 server. Then I wanted to remove them, so i went to "Central ...
0
votes
0answers
42 views

MySite Feature Activated Document Library

I would like to modify the Document Library for each users mysite during creation to include a custom content type. I figured a feature would solve this problem. However, when activating the features ...
0
votes
0answers
10 views

Retain Items and item history on feature re-deployment

Using SharePoint feature/solution I have created a list instance with 4 fields and is currently in production. I got a request to add another 3 fields to existing list instance so making it 7 fields ...
0
votes
0answers
15 views

List Synchronization in Sharepoint

I'm running Visual Studio 2010 with SP 2010. I was tasked with creating a setting page (within Site Action dropdowns). On that page I will select 2 different lists and allow them to synchronize with ...
0
votes
0answers
29 views

HarePoint Knowledge Base and DevExpress won't leave me alone!

I installed the HarePoint Knowledge Base for SharePoint. I have since removed it. Periodically, despite the fact that I have removed every trace of the application I can find, all of my web.config ...
0
votes
0answers
38 views

Error occurred in deployment step 'Activate Features': The file Image Library/KeynoteBackdrop1.png has been modified by i:0#.w|xyz\harsh.dave

I have created a following module - <Module Name="Images" Url="Image Library" RootWebOnly="TRUE" > <File Path="SliderFiles\KeynoteBackdrop1.png" Url="KeynoteBackdrop1.png" ...
0
votes
0answers
26 views

Custom Features in SharePoint 2013 Online

I am developing an application for SharePoint Online. Everything is working fine but I would like to create a feature so that it can be activated/deactivated. Depending on the activation state, I ...
0
votes
0answers
26 views

put all list instances in the same feature or each feature contains one list instance

I have in my project 9 custom lists. I put each list definition in a feature. Is it better to put each list instance in a feature ( the feature of list instance has as dependency the feature of the ...
0
votes
0answers
110 views

The element of type field fo feature 'feature' threw an exception during activation: a duplicate field name 'fieldName' was found

I am taking over a SharePoint environment. The previous developer created a custom Workflow with Custom Activities, etc. One of the steps in the Workflow is to create a web using a custom Site ...
0
votes
0answers
20 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
0
votes
0answers
522 views

Calling Enable-SPFeature in SP2013 with CompatibilityLevel isn't working

In an SP2013 environment running in SP2010 mode has anyone successfully called the Powershell command -- Enable-SPFeature while specifying the compatibility level? Example: Enable-SPFeature -identity ...
0
votes
0answers
283 views

Feature ‘XXX’ for list template ‘YYY’ is not installed in this farm. The operation could not be completed

So I'm very new to SharePoint. And I'm supposed to debug a website SharePoint 2013. So when I open this page a web service is supposed to get me data from a distant database and display it in a ...
0
votes
0answers
63 views

Features in Sharepoint 2010

I created an empty Project and used the default Feature1 thats created with the project to then create the following: public override void FeatureActivated(SPFeatureReceiverProperties properties) ...
0
votes
0answers
76 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
0
votes
0answers
32 views

Custom delegate is applied even if the feature is deactivated

I have a question regarding a feature. Situation: I have a feature that is farm scoped, with this feature I deploy a delegate control (xml file), this file refers to cs code. So I've added that file ...
0
votes
0answers
467 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with ...