set of functionality that can be turned on at a particular scope level

learn more… | top users | synonyms

1
vote
1answer
24 views

Hide feature based on user sharepoint

Is there any way to manipulate feature.xml file to control its visibility from a specific group? Thanks.
1
vote
1answer
48 views

Dependency of feature deployment with List and webpart

We have a project containing a webpart and a list instance (rootwebonly). The webpart and the list instance are activated via a single feature. Now problem is that, everytime a change is requested, ...
1
vote
1answer
134 views

Cannot activate SharePoint Publishing Feature

despite placing the following code in my onet.xml, the publishing feature is not activated. <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA"> <!-- PublishingPrerequisites --> ...
1
vote
1answer
675 views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
1
vote
1answer
81 views

Apply element manifest without re-activating feature

I have a feature module which consists of an XML file which adds ConsoleNodes to the Site Actions menu. To test it, it seems I must compile the package, deploy it, activate it, etc. Since this is ...
1
vote
1answer
212 views

How to DeActivate feature of my site?

How to DeActivate feature of my SharePoint site remotely ? I have created .wsp package file and uploaded SandBox solution to my SharePoint site. But in my elements.xml file it has 1 mistake of ...
1
vote
1answer
2k views

SharePoint 2010 solution not deploying correctly (features not available)

I have been working on a SharePoint 2010 solution on a server using Visual Studio. Unfortunately the server decided to die on me. Fortunately I have the solution backed up using source control and had ...
1
vote
1answer
74 views

Which publishing feature creates a search site?

I have created some custom WebTemplates for SP2010 and activated a load of publishing features which have in turn created a search site. Does anyone know which feature is likely to create this subsite ...
0
votes
1answer
33 views

Unable to see timer job

I have created a custom timer job, which contains a feature. I have successfully activated the feature on my web application, but it does not show up under the job definitions. Feature.xml is as ...
0
votes
1answer
29 views

Stop remove to SitePages from site on feature deactivation

I have create on module which is add in SitePages and add the webpart page and set that page as a home page of site on feature activation. and on feature deactivation I have wrote a code which will ...
0
votes
1answer
23 views

Can't find MissingFeature

I have a question, basically when i run Test-SPContentDatabase I get an error "MissingFeature" with an ID. I used the Feature Admin, this one doesn't give any faulty features or whatever, i checked ...
0
votes
1answer
68 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...
0
votes
1answer
157 views

“The system cannot find the file specified” message while deploying new feature

I'm trying to deploy a new feature on sharepoint 2010 with scope web. The deploy seems to run successfully, but the feature is not prensent in feature manager. While visual Studio deploys the ...
0
votes
1answer
29 views

List-driven solution needs to be deployed to two different web applications. What do I do?

Here is the summary of the problem I am facing: I created a feature, scoped to site collection. The solution installed by the feature uses data from lists created by the feature on install. This is ...
0
votes
1answer
91 views

Object reference not set to an object error while moving an object to feature list

I have created a feature in which I want to put the list instance to be created when the feature is activated. I created new feature from visual studio and trying to add the list instance file to the ...
0
votes
1answer
19 views

How to find feature including a specific element

this migth be a really easy question, but I could not find any solution for that. I'm using VS 2012 and want to find which features are using a specific element. Since I got lots of Features in my ...
0
votes
1answer
61 views

Remove a list from all site collections when a feature is uninstalled

I have a site scoped Feature which specifies a list as such: <?xml version="1.0" encoding="utf-8"?> <Elements xmlns="http://schemas.microsoft.com/sharepoint/"> ...
0
votes
1answer
95 views

Add custom code for solution upgrade

I have a solution for SP2010. Let's call it s.wsp. I had version 1 of s.wsp and now I have version 2 of s.wsp. Versions 1 and 2 share three common features: A, B and C. Version 2 adds a new feature D. ...
0
votes
1answer
270 views

Disable auto activate feature

I have a really strange behaviour, I'm working with SharePoint 2007 and I have a feature web application scoped, and i don't want it automatically being activated on deploying the solution, but it ...
0
votes
1answer
289 views

delete feature using event receiver on a farm feature

there is a farm feature and there is a web-scoped feature. web feature does stuff on multiple sites. If ever i want to get rid of the feature on all sites, I have a farm feature that has on ...
0
votes
1answer
48 views

how to check custom property of added Item

There is a boolean column I added to a custom list, but I also have a feature on this custom list so that when a Item is added i have to check if this column exists or not and then its value. now i ...
0
votes
1answer
1k views

How do I configure styles and layout of a Summary Link Web Part using code?

I have successfully added a Summary Link Web Part as a feature and want to configure the styles and layout of it, including: The default style for new links The group header style The number of ...
2
votes
0answers
804 views

How can I specify the ID of a XsltViewWebPart?

In a module, I'm deploying a webpart page where I put a view to a list : <View WebPartZoneID="Body" WebPartOrder="3" List="related" BaseViewID="4" ...
2
votes
0answers
575 views

Setting an audience from declarative WebPart?

I have a module that deploys some page. I'm adding webparts to these page, using a <AllUsersWebPart> node within a <View>: <View WebPartZoneID="Body" WebPartOrder="5" ...
2
votes
0answers
111 views

Attaching file in data node of a list instance?

I have a custom list definition and a custom list instance in a feature. If I want to populate some data in the list at its creation, I can use the data node. How can I add an attachment to this ...
2
votes
0answers
270 views

Why does WSP Deployment Type 'ApplicationServer' require features to be manually installed?

When I create a WSP with Deployment Type set to WebFrontEnd and deploy, all of the features contained within are automatically installed. Features that are set up as ActivateOnDefault="TRUE" (Farm or ...
1
vote
0answers
70 views

No Display Templates for Popular Items web part from Search-Driven Content category

I have a Popular Items web part on my site and in the Display Templates these things are selected: I have saved this site as template, via Save Site as Template option, and created a new site from ...
1
vote
0answers
9 views

SP2010 - ToolbarTemplate property not working in Custom Feature

I have a requirement to hide the "Respond to Survey" link on all surveys for a SP2010 site if the user has already responded. I followed the process using this link ...
1
vote
0answers
89 views

Embed iframe when inserting a post

I developed a Ribbon button that show's up in the Media tab. This displays a Modal Dialog to the user, listing some external content, and when clicking on an item it pastes the iframe html code on the ...
1
vote
0answers
91 views

2010 - Update-SPSolution required after solution installed?

I created a new feature and performed a Uninstall/Remove/Add/Install-SPSolution using PowerShell to deploy it. The solution deployed correctly and the feature was added to the 14 hive, but did not ...
1
vote
0answers
125 views

Lists not being added to quicklaunch

I'm having a problem with some lists that are included in a feature (Scope: web), which is created via a site definition. These lists have the display on quicklaunch set to true, although, the only ...
1
vote
0answers
130 views

Missing Features and Existing Lists

I have a site that was hosted on a Microsoft Project Server instance. One of the sub-sites was based on the Project Workspace Template in order to get access to the "special" lists like Risks and ...
1
vote
0answers
491 views

Can't deploy a xslt webpart as expected

In one of my custom list schema, I have defined a custom view : <View Type="HTML" DisplayName="My wonderful view" BaseViewID="2" ...
1
vote
0answers
256 views

Is there a way to create user-configurable Custom Retention Formulas, possibly through Custom Properties?

I am wanting to create a "user" - configurable Custom Retention Formula? Something like a simple version of the rules that Excel and other applications have which displays something like: ...
1
vote
0answers
20 views

In SharePoint 2007 what feature or solution added the WebPart Page Doc library templates?

In SharePoint 2007 what feature or solution added the WebPart Page Doc library template? We have it on one Farm, but not another. Is it part of the Fab 40? A site feature or a Site collection ...
0
votes
0answers
63 views

The element of type field fo feature 'feature' threw an exception during activation: a duplicate field name 'fieldName' was found

I am taking over a SharePoint environment. The previous developer created a custom Workflow with Custom Activities, etc. One of the steps in the Workflow is to create a web using a custom Site ...
0
votes
0answers
31 views

Custom Search to External Service

I am trying to add a custom search on the top static bar in SharePoint 2010. I created a delegate control to perform this task. I have tried multiple ways of creating a form text box and button and ...
0
votes
0answers
20 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
0
votes
0answers
51 views

How can I create a editable site page based on a custom page layout that is deployed via site definition

I have a site definition (SP2013) with some features. The feature deployes a custom page layout thats using the "Article Page" content type. Once deployed I can create new pages fine based on my new ...
0
votes
0answers
28 views

sharepoint 2010 Ghosted / UnGhosted Page Layout query

I've deployed a Feature to my SharePoint 2010 Farm which deploys each of my custom page layouts as 'ghosted' (uncustomized) aspx files into the Page Layouts folder especially since I have to update ...
0
votes
0answers
73 views

Custom Feature Compatibility from SP2010 to SP2013 Question

I have a question concerning the compatibility of my SP2010 custom features in SP2013. Here is my setup: I have a wide range of Farm, Site, and Web features that all interact with each other in a ...
0
votes
0answers
322 views

Calling Enable-SPFeature in SP2013 with CompatibilityLevel isn't working

In an SP2013 environment running in SP2010 mode has anyone successfully called the Powershell command -- Enable-SPFeature while specifying the compatibility level? Example: Enable-SPFeature -identity ...
0
votes
0answers
180 views

Feature ‘XXX’ for list template ‘YYY’ is not installed in this farm. The operation could not be completed

So I'm very new to SharePoint. And I'm supposed to debug a website SharePoint 2013. So when I open this page a web service is supposed to get me data from a distant database and display it in a ...
0
votes
0answers
26 views

Feature is not deploying

I have created a new BDCS model in Visual Studio. VS created a new feature for this item. Several times this feature worked fine.. But it didn`t deployed twice. First time I deleted feature and bdcs ...
0
votes
0answers
54 views

Features in Sharepoint 2010

I created an empty Project and used the default Feature1 thats created with the project to then create the following: public override void FeatureActivated(SPFeatureReceiverProperties properties) ...
0
votes
0answers
73 views

Site-scoped feature with both Modules and Visual Web Parts

I have a Feature with Modules that place files in the Master Page Gallery, and I recently added Visual Web Parts to the feature. Then I realized at some point the copying of files into the Gallery had ...
0
votes
0answers
30 views

Custom delegate is applied even if the feature is deactivated

I have a question regarding a feature. Situation: I have a feature that is farm scoped, with this feature I deploy a delegate control (xml file), this file refers to cs code. So I've added that file ...
0
votes
0answers
463 views

Deploy solution using powershell

I have a solution with 4 projects to automatically some processes in Sharepoint.these projects are: WebPartProject: Create a custom webpart CreateTemplate: Create 2 documents libraries (with ...