A feature-activation is a process which makes a feature active programatically, using power shell or through a web interface. A feature needs to be active in order to be used.

learn more… | top users | synonyms

9
votes
4answers
6k views

Replace the Default Page in a SharePoint WebSite

I have been asked to programmatically do the following in a SharePoint 2007 team site collection: Create a website using the OOTB blank site template. (Please note, for project specific reasons, we ...
7
votes
3answers
4k views

How do you “stop” activating a feature within the feature receiver?

I have a feature receiver with some long running code, hence I use SPLongOperation and delegate for better visual appearance. Basically my feature receiver looks like so: public override void ...
5
votes
1answer
137 views

How to handle web references becoming stale in a web feature activation

We have a number of web-scoped features all stapled to a site definition, so they are all activated in turn when a web is created from the definition. It seems the feature receivers all share the ...
4
votes
6answers
5k views

Identify moss features from GUID

We are using a site definition and it has 3 feature dependencies that we are struggling to identify: <ActivationDependency FeatureId="7EDD3C9C-8AC6-4ab5-A209-30B5DC422464" /> ...
4
votes
4answers
12k views

How to activate feature using powershell script?

I need to activate specific feature to all site collection which is inside the particular web application using powershell script?
4
votes
2answers
284 views

Feature Activation Logic (Prevent Activation)

I have three site collection features used to set branding throughout the site collection. I want to prevent the accidental activation of one of the features if one of the three is already activated; ...
4
votes
1answer
2k views

Activate a feature in feature installed

I have a feature for deploying masterpages that I am trying to activate upon install(deploy). The following snippets of code are in the EventReceiver.cs. I am getting a null when attempting to ...
4
votes
1answer
345 views

Farm scope Event Receiver

For some security reasons on one of our farm level solutions, we need to limit some actions using Event Receiver-FileMoving event. However, as known, event receivers can be deployed only by Site or ...
4
votes
1answer
1k views

Is it possible to export a site workflow?

If I have a Site Workflow on my development machine, what's the best way to deploy it onto the production system which is hosted on Microsoft SharePoint Online? I have found a way of doing it which ...
3
votes
2answers
1k views

Unable to delete List during solution deactivate

I have two list that I need to delete when a solution is deactivated and removed. But my code doesn't seems to be working. I am trying to delete and remove the quicklinks to the lists in ...
3
votes
2answers
742 views

Deploying .dlls to the web application bin folder using .wsp fails with feature recevier

When deploying .dlls to the bin directory using a .wsp my feature receivers seem to blow at the deploysolution stage as they cannot find the related code for my feature receivers. How can I handle ...
3
votes
2answers
2k views

Debugging SPFeatureReceiver

I have built an SPFeatureReceiver and am trying to debug it by attaching to the w3wp.exe process. No matter what I do no breakpoints are ever hit. Here are my steps Build and Package the solution ...
3
votes
1answer
156 views

Removing page from content database via feature deactivation

I deployed page via module. Module is deployed via feature (method FeatureActivated). After that process page is deployed in content database. What I need is to be able to delete (remove) page from ...
3
votes
1answer
301 views

Listadded events on My Site omits Personal and Shared Documents creation

I want to have a feature which will change some settings on every list on My Site. Problem is i cant change settings for two main list: Shared and Personal Documents. For testing I have web feature ...
3
votes
3answers
479 views

“Service too busy” exception occurrs when trying to programmatically activate a sandbox feature with an attached feature receiver

The title says it all... I am trying to programmatically activate some sandbox features (from within a feature reciver that is also part of the sandbox solution). And whilst the features without ...
3
votes
1answer
202 views

Site Scope Feature dependent on a Web Scope Feature

On the root web for my site collection I need to make sure a web scope feature is turned on. In the feature EventReceiver I can turn on the feature progamtically. How can I stop the user turning the ...
3
votes
1answer
503 views

Provisioning did not succeed. Failed to create pages library

I have a client who are trying to create new sub sites in site collections. If they use the publishing site template or if they create a team site and try activate the publishing feature it will ...
3
votes
1answer
563 views

Is SPFeatureCollection.Add method asynchronous?

I have a quite complex application that is split into several features. In order to hide this complexity, I set the IsHidden property of the feature to true, then have created a "master" feature. ...
2
votes
2answers
5k views

Getting SPWeb in feature receiver

While testing my solution I receive an error on Feature activation: Detected use of SPRequest for previously closed SPWeb object. Please close SPWeb objects when you are done with all objects ...
2
votes
2answers
131 views

SharePoint TimerJob not executing

I have a TimerJob in my feature that is not executing. I've tried restarting the timer service (below), deactivating and activating the feature, and manually executing the job using the "run now" ...
2
votes
4answers
2k views

How can I make sure the features in my solution activate in the correct order?

I'm working on a fairly large SharePoint 2010 project. We have broken up the code into a number of solutions, each containing a number of features which we deploy via powershell and activate in the ...
2
votes
5answers
11k views

Enable-SPFeature not working

I am using PowerShell script to deploy and activate a feature in the same script. Everything works fine and I can see my feature in the Sharepoint Root folder (14 hive). I run it using Farm Admin. ...
2
votes
2answers
807 views

Error activating feature

I have created a solution package for Sharepoint 2007 and have installed and deployed it on a development server. However, when I go to activate it through Site Features, I'm given a lovely page of ...
2
votes
2answers
192 views

Any downsides to feature property “Always Force Install”?

Occasionally on our deployments, we would get this error Error occurred in deployment step 'Add Solution': A feature with ID {Guid} has already been installed in this farm. Use the force attribute ...
2
votes
2answers
343 views

Difference between enabling feature from PowerShell and activating it via site collection features page?

I am trying to create a SharePoint list based on a list template via a feature. The code for creating the list is in the FeatureActivated event handler of the feature's EventReceiver.cs file. The list ...
2
votes
3answers
375 views

Error when deploying SharePoint feature: The specified list does not exists

I'm using SharePoint 2010 Foundation and Visual Studio 2010 Ultimate. I'm working on a Web Parts with two features: Feature1 - My Web Parts Feature2 - Contains two Visual Studio module with CSS and ...
2
votes
3answers
488 views

Set the JSLink property for all list forms in FeatureActivated

Is it possible to update the SPForm.JSLink property for the forms (Display, New, Edit) of an existing list in the when a feature is activated? I have tried the code below, but it seems that the ...
2
votes
2answers
147 views

How to catch the feature activate time

I am trying to write one program such that, when ever a feature is activated then it should display the activated time in the sharepoint list. for that i written following code. public class ...
2
votes
2answers
1k views

Create Site Column (lookup type)

Is there any solid (proven) method of creating Site columns (lookups) where list GUID is not known? I think this is where feature activation kicks in; getting the lookup list by its name and then ...
2
votes
2answers
258 views

Setting customErrors attribute

When activating a feature on a site I am getting a Runtime Error page that indicates to set customError mode attribute to Off in order to see the error. I have changed the web.config in my IIS folder ...
2
votes
3answers
3k views

How to deploy a web-scoped feature in visual studio SharePoint Project to a specific site in the Site collection?

I have a visual studio SharePoint site that contains a list definition and content type. I need this feature to be activated on a specific site in the site collection. I set the feature scope to ...
2
votes
2answers
2k views

List Instances not created on Feature Activation for Initial Deployment

I have two features, a Content Type feature that contains the content type and list definitions, and a List feature that creates the List Instances from the list definitions. Both features ...
2
votes
1answer
432 views

FeatureActivated not called for Site Template

We have an web-level feature that when you activate it will change the master pages used by the web to point to a .master page in the rootweb of the site collection. This feature has been activated ...
2
votes
3answers
6k views

Activating and deactivating publishing feature breaks SP2010 wikis?

I have created an Enterprise Wiki site on SharePoint 2010. I have added some pages to the wiki - that worked fine. By default, it seems that an Enterprise Wiki has publishing turned off. If I ...
2
votes
1answer
1k views

<View> (ListViewWebPart) from within publishing page in feature

This is in the context of MOSS 2007. I have a custom site definition. Currently in ONET.xml we have the following Module: <View ...
2
votes
1answer
56 views

Deleting lists upon feature deactivation

I have a FeatureReceiver class for a feature that deploy a couple of list instances. In the FeatureDeactivating event I want to remove those instances as well as other artifacts which get deployed ...
2
votes
1answer
141 views

PowerShell Script To Find Where SharePoint 2010 Features Are Activated

I want a PowerShell script to find where Features are activated in a site collection and its sites/subsites Like for example feature "Enterprise feature"
2
votes
2answers
327 views

Activate webfeatures on all SharePoint online webs

I want to activate a webfeature on all subsites of a sitecollection in Office 365 / SharePoint online. I thought i can do the actions in a SiteCollection Feature, but that's throwing a timeout error. ...
2
votes
1answer
34 views

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory?

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory? What I'm trying to do is re-provision data every time my feature is activated without deleting the SPList. The idea is to ...
2
votes
2answers
141 views

Strange issue with feature activation

I'm having a problem while activating a feature. I have a custom dll that I referenced in this new project, and I'm trying to execute some code on the feature activation. The problem is that I get the ...
2
votes
1answer
323 views

SPListCollection.EnsureSitePagesLibrary() throwing SPException (specified title already exists in this Web site)

I am attempting to call SPListCollection.EnsureSitePagesLibrary() upon FeatureActivated. The method is throwing the following exception: Microsoft.SharePoint.SPException: A list, survey, ...
2
votes
1answer
917 views

Error occurred in deployment step 'Activate Features': Feature with Id 'xxxxx-xxx' is not installed in this farm, and cannot be added to this scope

while installing a feature, VS ouput the error: Error occurred in deployment step 'Activate Features': Feature with Id 'xxxxxxx-xxxx' is not installed in this farm, and cannot be added to this scope. ...
2
votes
1answer
404 views

How does SP resolve web.config modifications?

Specifically, if my code makes a change to the web.config to enable the ScriptResource.axd HttpHandler, and then another third party app comes along and also 'adds' the config entry (it doesn't add a ...
2
votes
1answer
4k views

Activating a WebApplication Scoped Feature for a particular WebApplication

I developed a SharePoint 2010 WSP that contains a custom HTTP Module for performing short-url redirects. The WSP also contains a WebApplication scoped feature that consists of a feature receiver that ...
2
votes
1answer
4k views

How do I Activate the Signatures Workflow?

After fixing the intranet site that was deleted, I am re-establishing some pages that were lost. I have a site template that I created and when I try to use it on the top level site, I receive the ...
2
votes
0answers
22 views

Specify custom parameters in WSP deploy / feature activation?

I have a Feature Receiver where I access the Term Store to get / set something. My problem is, the code needs to connect to 'specific' term store.. but what if the Term store name changes when I ...
2
votes
0answers
365 views

Sandbox solutions - Prevent auto activation of site collection features

Question: Does anyone know a way to activate a sandbox solution in SharePoint Online without having the site collection features automatically activated? Background info: I have done a bit of ...
2
votes
0answers
133 views

Site is Provisioned but Content Type List is still empty

I have this feature that I am trying to run in order to configure a site, this feature among other things creates pages based on content types, etc. The problem I am facing is that everytime i am ...
2
votes
3answers
848 views

–°an't programmaticaly activate the Publishing Feature for the Blog site

I'm developed a solution for stapling features. in my solution are located two projects, one project contains a module which consist the id features, what I want to attach to the sites collections and ...
2
votes
1answer
2k views

Can't activate feature because of an existing column in a child site

I have a site collection without the publishing feature activated (Id: f6924d36-2fa8-4f0b-b16d-06b7250180fa). I want to activate it, but it fails : Enable-SPFeature : The field with Id ...