A feature-activation is a process which makes a feature active programatically, using power shell or through a web interface. A feature needs to be active in order to be used.

learn more… | top users | synonyms

0
votes
1answer
296 views

Disable auto activate feature

I have a really strange behaviour, I'm working with SharePoint 2007 and I have a feature web application scoped, and i don't want it automatically being activated on deploying the solution, but it ...
0
votes
0answers
9 views

webprovisioned activatedfeature save conflict

I am having an issue when creating a WebProvisioned eventreceiver that activates a feature. However I am getting the "Save conflict - Your changes conflict with those made concurrently by another ...
1
vote
2answers
119 views

Sharepoint is keeping a record of un-installed solutions

Today i ran a powershell script that lists all the features on my Sharepoint 2013 system along with their 'scope' and 'GUID'. I noticed while looking at the list that it also includes features that ...
0
votes
0answers
22 views

Feature error when deploying a master page with visual studio 2013

I am new in working with VS13 to edit master pages, when I try to deploy it gives an error: Error 30 Error occurred in deployment step 'Activate Features': Feature with Id ...
0
votes
1answer
487 views

Failed with 0x80004005 to create the view query or web parts for web

Feature 1 creates Site Columns Feature 2 creates Content Type and adds the site columns created by feature1 Feature 3 creates a List definition for mylist I have two Web tempaltes. I have added ...
2
votes
2answers
275 views

Activate webfeatures on all SharePoint online webs

I want to activate a webfeature on all subsites of a sitecollection in Office 365 / SharePoint online. I thought i can do the actions in a SiteCollection Feature, but that's throwing a timeout error. ...
1
vote
1answer
947 views

How can I activate a wsp solution uploaded to solution gallery via code in SharePoint 2013

I'm creating a site definition which provisions a subsite based to a webtemplate(wsp) file. This webtemplate file is packed in a feature containing a module.When the feature is activated the wsp file ...
1
vote
1answer
72 views

FeatureActivated() not binding two SPEventReceiverDefinitions

I have a feature which I have placed in the onet.xml in to make it active whenever the site collection is created. The feature contains two event receiver definitions for permission groups. One is for ...
0
votes
1answer
1k views

How do I configure styles and layout of a Summary Link Web Part using code?

I have successfully added a Summary Link Web Part as a feature and want to configure the styles and layout of it, including: The default style for new links The group header style The number of ...
0
votes
0answers
21 views

put all list instances in the same feature or each feature contains one list instance

I have in my project 9 custom lists. I put each list definition in a feature. Is it better to put each list instance in a feature ( the feature of list instance has as dependency the feature of the ...
2
votes
2answers
5k views

Getting SPWeb in feature receiver

While testing my solution I receive an error on Feature activation: Detected use of SPRequest for previously closed SPWeb object. Please close SPWeb objects when you are done with all objects ...
1
vote
1answer
388 views

Enable-SPFeature doesn't work, but activation via Site Settings does. Why?

I have a weird problem... I'm trying to deploy a sharepoint solution in production. This project works fine in the test environment, but in production trying to enable the feature returns this error: ...
0
votes
1answer
28 views

SP2013 Cannot create “_catalogs/masterpage”

I have created in my VS2013 solution a Masterpage module. The problem is that during feature activation I encounter a message 'Cannot create "_catalogs/masterpage', as if the feature was not being ...
1
vote
0answers
33 views

Call FeatureInstalled method on feature activation and after FeatureActivated

I like to call FeatureInstalled method of feature after the FeatureActivated method. How can I call FeatureActivated method from FeatureInstalled? I have a module in feature and it will adding the ...
1
vote
4answers
2k views

Error while activating custom feature

I have a wsp package installed as farm solution. package has event reciever on activating feature. When I go to Site Collection Features and activate this feature i get an error Error File ...
0
votes
3answers
6k views

Failed to load receiver assembly when activate feature

I have a problem when activating a Site scoped feature. Every time I try to activate the solution with STSADM or Powershell I get this error: C:\Program Files\Common Files\Microsoft Shared\Web Server ...
1
vote
2answers
480 views

Can i use SPLongOperation in FeatureActivating?

I have a feature that upgrades and updates an existing site to a new and improved version of that site. One of the tasks of the feature is to upgrade existing data in the site. For simple test/dev ...
0
votes
1answer
43 views

Edit default Pagelayout on feature activation

My site is in SharePoint 2010. I want to edit the content of PageFromDocLayout.aspx default page layout on feature activation. My feature is on site collection level. I want to change the ...
0
votes
1answer
27 views

Inheritance of Content Types in a Single Feature

I am having the same issue as seen in http://stackoverflow.com/q/9699451/240372 yet the solution does not work for me. The ID's for my Content Types are the following A ...
1
vote
1answer
31 views

Problem to modify web.config in runtime

I'm trying to modify the web.config file when the feature is activated with the code below: public override void FeatureActivated(SPFeatureReceiverProperties properties) { SPWebApplication webApp ...
1
vote
2answers
865 views

How do I fix the error “Expression must evaluate to a node-set” setting web.config entries?

I'm trying to update web.config in SharePoint when the feature is activated. I have created Event receiver. The code inside receiver is: public override void ...
0
votes
1answer
31 views

Feature activation terminated if code is running too long (SP 2010)

Is it possible that feature activation will fail or will end unexpectedly (without any exceptions in ULS) when it takes too long for code to finish the job? We have a feature which during activation ...
1
vote
3answers
349 views

Set the JSLink property for all list forms in FeatureActivated

Is it possible to update the SPForm.JSLink property for the forms (Display, New, Edit) of an existing list in the when a feature is activated? I have tried the code below, but it seems that the ...
1
vote
2answers
4k views

Microsoft SharePoint is not supported with version 4.0.30319.225 of the Microsoft .Net Runtime

So, the story is the following: I just joined a team of an existing sharepoint project, sharepoint is installed RTM on all environments, from DEV to production. But because its 2 companies working ...
0
votes
1answer
40 views

Unable to see timer job

I have created a custom timer job, which contains a feature. I have successfully activated the feature on my web application, but it does not show up under the job definitions. Feature.xml is as ...
0
votes
0answers
24 views

Getting wrong PageLayouts from site with variations

I have a site in 2013 with two variations: de-de and en-us. On feature activation, I try to get list of Available Page Layouts using following code: using (SPSite site = new SPSite(siteUrl)) ...
0
votes
1answer
46 views

Unable to activate Feature in sharepoint 2010

I created a timer job which will send a mail to all the user.It was working fine in dev server.So ,I change the "SITE URL" in SOLUTION properties to prod server url(http://*_prod) and added solution ...
0
votes
0answers
37 views

Creating sub site in feature receiver does not work always in sandbox solution

I have created a sandbox solution in which there is one feature for creating two sub-sites. In the event receiver of that feature I have created two sites programmatically. The code is as per ...
0
votes
0answers
15 views

Dynamically Add web part in sandbox solution

I've site in office 365. I want to add site page in /SitePages on feature activation. I also want to dynamically add web part in this site page. How can I do this?
0
votes
1answer
36 views

Activating web feature from event receiver doesn't do anything

I have the following code that should run to automatically disable the Minimal Download Strategy feature when a new site is being provisioned. Unfortunately nothing happens. No errors are captured in ...
1
vote
1answer
39 views

Feature Activation Routing Workflows - SharePoint 2010 (en-US)

We get an error message: "the feature with the ID {3bc0c1e1-b7d5-4e82-afd7-9f7e59b60409} must be activated." Does somebody know how to activate this feature. I can't find it in central administration ...
1
vote
1answer
29 views

Site Feature needs to be re-enabled after creation from template?

I have a Site Template which includes the SP List Item Copy Feature. This Feature was enabled on the site when I created the template. My issue is that whenever I create a new site with this ...
2
votes
2answers
141 views

Any downsides to feature property “Always Force Install”?

Occasionally on our deployments, we would get this error Error occurred in deployment step 'Add Solution': A feature with ID {Guid} has already been installed in this farm. Use the force attribute ...
0
votes
0answers
10 views

Duplication of listitems when enabling a feature [duplicate]

I currently have a Web scoped feature that creates a list via a list definition created in Visual Studio 2013. This list instance has some Rows being added in the definition itself by default. For ...
1
vote
1answer
33 views

Which is good practice to not activate the feature by default?

I have read about:- Active Deployment Configuration : No Activation Feature --> Activate on Default : False What is the difference?
2
votes
2answers
123 views

Strange issue with feature activation

I'm having a problem while activating a feature. I have a custom dll that I referenced in this new project, and I'm trying to execute some code on the feature activation. The problem is that I get the ...
2
votes
2answers
236 views

Difference between enabling feature from PowerShell and activating it via site collection features page?

I am trying to create a SharePoint list based on a list template via a feature. The code for creating the list is in the FeatureActivated event handler of the feature's EventReceiver.cs file. The list ...
2
votes
1answer
4k views

Activating a WebApplication Scoped Feature for a particular WebApplication

I developed a SharePoint 2010 WSP that contains a custom HTTP Module for performing short-url redirects. The WSP also contains a WebApplication scoped feature that consists of a feature receiver that ...
1
vote
1answer
354 views

PowerShell code to add/remove, install/uninstall and enable/deactivate feature at Web, Site Collection, Web Application and Farm scope

Please can you give me the best practice PowerShell code to:- A. Add, install and enable feature at -Web -Site Collection -Web Application -Farm scope B. Deactivate, Uninstall and Remove ...
0
votes
0answers
11 views

The right place to add / remove timer jobs [duplicate]

Still fairly new to SP. Have a question about adding timer jobs via features. A couple of weeks ago when I was even newer to SP, I followed one or two tutorials on the subject. The code in these used ...
0
votes
1answer
22 views

Why SharePoint can't activate a dependency feature, while upgrading a feature?

This question is regarding dependency feature activation, while upgrading a feature to latest version. Suppose, There is a feature called MasterFeature_0_0_0_0 and it is being upgraded to ...
0
votes
1answer
51 views

Styling a 2010 publishing site using a feature - Not enough information to determine a list for module

I've got a site collection which currently only has one web site (the root web). The styling comes in a Site level feature with a few modules to deploy the master page, the CSS, and other resources, ...
2
votes
3answers
235 views

Error when deploying SharePoint feature: The specified list does not exists

I'm using SharePoint 2010 Foundation and Visual Studio 2010 Ultimate. I'm working on a Web Parts with two features: Feature1 - My Web Parts Feature2 - Contains two Visual Studio module with CSS and ...
0
votes
0answers
34 views

Staple a feature on custom site template site creation

I have a site template on sharepoint 2007 (stp file) which has everything setup that i need on it and is the way the client wants the site to look. However if i template the site and upload that ...
0
votes
0answers
37 views

Enable-SPFeature not working in scheduled task

I have a powershell script that runs every 5 minutes it creates a subsite on a Site Collection the last part of the script activates the SiteNoteBook feature in SharePoint 2013. I added all the new ...
0
votes
2answers
1k views

Sharepoint package installation - Feature is not visible in Site collection -> settings

I am not very experienced with Sharepoint 2010 and I am having trouble installing a package. I downloaded a package from "iLove SharePoint" as I need to call web service from a workflow. The package ...
0
votes
4answers
2k views

How to programmatically get Feature ID?

In order to programmatically activate a feature, you need its Feature ID (some type of GUID) that is set in the .feature file. Is there a pretty way of retrieving this value programmatically, so that ...
1
vote
4answers
2k views

How to enable site collection feature by default when deploying a visual webpart from visual studio?

I am making a visual web part in SP 2010 using visual studio 2010. I want it so that when I add and deploy my wsp file, it should by default keep the site collection feature activated for the web ...
0
votes
1answer
201 views

Programatically publishing Content Type in Content type Hub

I have a custom content type which I am deploying to a Site collection in which content type hub is configured. To use the content types in different site collection after the content type is deployed ...
0
votes
1answer
73 views

Hide all site templates except custom and also show templates which are added after feature activation

We want to remove all site templates except custom templates under Create > 'Sites and Workspaces'. and we only want to allow custom templates... Custom template can grow over the time by saving site ...