A feature-activation is a process which makes a feature active programatically, using power shell or through a web interface. A feature needs to be active in order to be used.

learn more… | top users | synonyms

0
votes
0answers
70 views

How to set ImageUrl/ThumbnailUrl for a particular list?

I'm looking to create custom ImageUrl images for lists that I'm programmatically adding to a web via Feature Activation. However, there seem to be a few stumbling blocks: 1) ImageUrl is not updating ...
1
vote
2answers
474 views

Help with deploying a feature to Web Application level

I have a SharePoint 2013 solution project (built in VS2013) that contains a feature set to WebApplication level with an event receiver that has no code at all (just for testing purposes). When I set ...
1
vote
0answers
107 views

Try to activate a web site feature. Error: Failed to create feature receiver object from assembly

I am using sharepoint 2007. I have created some custom solution in visual studio 2008. In this solution there is an event receiver "FeatureActivated". I have deployed this wsp to my sharepoint ...
2
votes
2answers
131 views

SharePoint TimerJob not executing

I have a TimerJob in my feature that is not executing. I've tried restarting the timer service (below), deactivating and activating the feature, and manually executing the job using the "run now" ...
1
vote
1answer
76 views

FeatureActivated() not binding two SPEventReceiverDefinitions

I have a feature which I have placed in the onet.xml in to make it active whenever the site collection is created. The feature contains two event receiver definitions for permission groups. One is for ...
1
vote
1answer
199 views

Deployment Issue with Custom FIeld Types

SHORT DESCRIPTION Custom Field Types are not being correctly deployed/activated on all but one Virtual Machine. I have several VMs with identical SharePoint environments. I have a Visual Studio ...
0
votes
1answer
2k views

Deploy a single feature using SharePoint Management Shell with SharePoint 2013

I have been working in a development environment and deploying my custom web part features from Visual Studio directly by just hitting F5. I now need a way to deploy features separately to a test ...
1
vote
1answer
137 views

How do you indicate a Web Application vs Site Collection in for the -url parameter in PowerShell?

When I run the code script below: enable-spfeature "MyFeature" –url "http://myportal:5555" I get the error: This feature is not a farm level feature and is not found in a Site level defined ...
2
votes
3answers
488 views

Set the JSLink property for all list forms in FeatureActivated

Is it possible to update the SPForm.JSLink property for the forms (Display, New, Edit) of an existing list in the when a feature is activated? I have tried the code below, but it seems that the ...
0
votes
1answer
2k views

Error occurred in deployment step 'Activate Features' while trying to deploy an event receiver?

I cant seem to figure out what the issue is while I try to deploy my event receiver targeted at a particular list on my site. All I am trying to do in the event receiver is to check (on ...
1
vote
2answers
4k views

Feature with Id 'guid' is not installed in this farm, and cannot be added to this scope

I have a WinForms project that acts as a Sharepoint 2013 Solution installer. It basically do some checking, create a sql database, adds and install a SP Solution and finally activates the feature. ...
1
vote
1answer
172 views

Activate Content Organizer feature from code

how to activate content organizer feature from c# code or by powershell script. I want to activate this feature on my subsite from my code ?
1
vote
4answers
2k views

How to enable site collection feature by default when deploying a visual webpart from visual studio?

I am making a visual web part in SP 2010 using visual studio 2010. I want it so that when I add and deploy my wsp file, it should by default keep the site collection feature activated for the web ...
0
votes
2answers
203 views

SP2010 - site collection feature not activating on MySite creation

I've created a new feature in a pre-existing project, closely modelled on features that are already within that solution. These features activate automatically when a new MySite is created, but the ...
2
votes
2answers
327 views

Activate webfeatures on all SharePoint online webs

I want to activate a webfeature on all subsites of a sitecollection in Office 365 / SharePoint online. I thought i can do the actions in a SiteCollection Feature, but that's throwing a timeout error. ...
1
vote
2answers
5k views

Activating Site Collection Level Feature with PowerShell Script

I am trying to activate a Site scoped feature using a powershell script. I have another scrip which deploys my solution and I see my feature is installed correctly in Site Collection feature gallery. ...
0
votes
2answers
1k views

Sharepoint package installation - Feature is not visible in Site collection -> settings

I am not very experienced with Sharepoint 2010 and I am having trouble installing a package. I downloaded a package from "iLove SharePoint" as I need to call web service from a workflow. The package ...
0
votes
0answers
362 views

debug feature activation

I have a visual studio project with Sharepoint Site structure. I didn't write any Event Receivers that will add my items (SP List Definitions, List Instances, ...) to the site. That means I use ERs ...
2
votes
1answer
34 views

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory?

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory? What I'm trying to do is re-provision data every time my feature is activated without deleting the SPList. The idea is to ...
-1
votes
1answer
128 views

get correct url from feature

To make it simple as the title suggest I want the correct url from the feature! atm when i was testing in test eviroment it worked well! I got the url using: SPSite siteCollection = ...
1
vote
3answers
52 views

New to Developing SharePoint Web Parts and Features

I recently Developed a really simple web part scoped to site (or at least it's feature is). I also created a feature that up[on activation is suppose to create a new content type. That's fine and ...
0
votes
0answers
59 views

Features in Sharepoint 2010

I created an empty Project and used the default Feature1 thats created with the project to then create the following: public override void FeatureActivated(SPFeatureReceiverProperties properties) ...
0
votes
1answer
139 views

Execute SPFeatureReceiver only on site creation

We have recently upgraded from SharePoint 2007 to 2010 and we aren't yet ready to train users on the new interface, so I've created a SPFeatureReceiver that will set the site template back to the 2007 ...
1
vote
1answer
348 views

How can I find the Feature Activation Dependency Powershell

I am running a recursive function that activates many features in powershell however I need to find the child feature a feature is dependent on before it is activated. How can I do this in powershell. ...
1
vote
1answer
205 views

Site-level fields created by the Community Site features and its dependencies must not be removed

I get this error: Site-level fields created by the Community Site features and its dependencies must not be removed. when trying to create a Community Site or Active the Community Site Feature, ...
1
vote
1answer
423 views

Enable-SPFeature doesn't work, but activation via Site Settings does. Why?

I have a weird problem... I'm trying to deploy a sharepoint solution in production. This project works fine in the test environment, but in production trying to enable the feature returns this error: ...
2
votes
2answers
141 views

Strange issue with feature activation

I'm having a problem while activating a feature. I have a custom dll that I referenced in this new project, and I'm trying to execute some code on the feature activation. The problem is that I get the ...
0
votes
0answers
104 views

List View Webpart is not getting added while activating feature using powershell

I created a feature and on activation of it I am trying to add list view webpart. Using powershell command activating feature and it gets activated but List View Web part it is not getting added on to ...
1
vote
1answer
250 views

Sharepoint 2010 failed to apply web.config modifications to Web Application

I have a SharePoint solution deployed into a specific web application on the production SharePoint site. When I try to enable the feature from the site features in Site Settings I get an error saying ...
0
votes
1answer
76 views

Activating a WebApplication scoped feature on a single web app touches all web app web.configs

I have a WebApplication scoped feature, and I have set ActivateOnDefault to false, to prevent the feature from being activated on every web application when installed. The feature is a simple ...
0
votes
1answer
45 views

error creating blog subsite in code

Im creating a blog subsite in the featureactivated event but it errors out everytime i activate the feature. looking at the logs i can see there is an access denied entry however the blog subsite is ...
1
vote
1answer
129 views

Does the SPField.OnAdded() method get called from a CAML deployment?

If I create a custom list definition and instance in CAML, as part of a feature, and I have included a custom field as part of that list, will that field's OnAdded() method get called when the feature ...
1
vote
1answer
1k views

How can I activate a wsp solution uploaded to solution gallery via code in SharePoint 2013

I'm creating a site definition which provisions a subsite based to a webtemplate(wsp) file. This webtemplate file is packed in a feature containing a module.When the feature is activated the wsp file ...
0
votes
0answers
562 views

Error activating ShrePoint Server Publishing Infrastructure feature

I have installed SharePoint Server 2010 Enterprise Edition in Windows Azure. After successful installation and configuration,I created a web application. When I tried to activate SharePoint Server ...
2
votes
2answers
5k views

Getting SPWeb in feature receiver

While testing my solution I receive an error on Feature activation: Detected use of SPRequest for previously closed SPWeb object. Please close SPWeb objects when you are done with all objects ...
2
votes
1answer
323 views

SPListCollection.EnsureSitePagesLibrary() throwing SPException (specified title already exists in this Web site)

I am attempting to call SPListCollection.EnsureSitePagesLibrary() upon FeatureActivated. The method is throwing the following exception: Microsoft.SharePoint.SPException: A list, survey, ...
1
vote
2answers
440 views

Add script reference to all pages in a site collection when a feature is activated

I'd like to have a feature which adds a script reference to all pages in a site collection when activated. This seems like a scenario where I should just modify the master page, but for it to affect ...
1
vote
1answer
562 views

Feature Activated Event not triggered when creating a new sub site with web template

When I create a new site I have a Web Scoped FeatureActivated event that I would like to run. The feature does get Activated but the FeatureActivated event is not triggered. The site is created with ...
1
vote
1answer
997 views

Can't find WebApplication scoped feature

I've deployed a wsp that has 2 features. The one scoped at a web level is listed where I'd expect to see it and activates without a problem. The feature scoped at a web application can't be found ...
1
vote
0answers
387 views

Set Record Declaration Settings programmatically

I created a feature receiver whereby on activation will activate and set certain features and its properties. One of that feature is InPlaceRecords. Below is my code in the FeatureActivated method:- ...
0
votes
3answers
1k views

Getting SPWeb Object in two ways

I want to access SPWeb object in feature under its FeatureActivated method. There are two ways to do this: Public Override void FeatureActivated(SPFeatureReceiverProperties properties) { //Method 1 ...
2
votes
1answer
917 views

Error occurred in deployment step 'Activate Features': Feature with Id 'xxxxx-xxx' is not installed in this farm, and cannot be added to this scope

while installing a feature, VS ouput the error: Error occurred in deployment step 'Activate Features': Feature with Id 'xxxxxxx-xxxx' is not installed in this farm, and cannot be added to this scope. ...
0
votes
1answer
153 views

Convert site to a publishing site

I need to activate publishing features on certain sites without losing their site content (lists and libraries). The publishing feature is activated in site collection. When I try to activate the ...
0
votes
1answer
84 views

Why do i have to activate my web features before i can create a website

I have created a web template using visual studio 2010, it has two features. Feature1 - Contains WebTemplate element (scoped site) Feature2 - Contains List Definitions (scoped web) I package, upload ...
0
votes
1answer
328 views

Disable auto activate feature

I have a really strange behaviour, I'm working with SharePoint 2007 and I have a feature web application scoped, and i don't want it automatically being activated on deploying the solution, but it ...
0
votes
1answer
160 views

Unable to get list “Calendar” list in feature while creating site

I want to create custom calendar list programatically. SPListTemplate template = web.ListTemplates["Calendar"]; var newListID = web.Lists.Add(fromTitle, description, template); But i cannot do ...
0
votes
4answers
2k views

How to programmatically get Feature ID?

In order to programmatically activate a feature, you need its Feature ID (some type of GUID) that is set in the .feature file. Is there a pretty way of retrieving this value programmatically, so that ...
0
votes
2answers
1k views

Error occurred in deployment step 'Activate Features': Invalid field name

SharePoint Error message Error occurred in deployment step 'Activate Features': Invalid field name.{guid}
0
votes
1answer
96 views

Associate my custom feature to default publishing site template with FeatureSiteTemplateAssociation

I want to have an event receiver on site collection creation, but it is not available. So as an alternative way i think of writing a custom feature, and associating it with the default publishing site ...
0
votes
2answers
759 views

Automatically Activate Feature when subsite created

I have created a web template with 2 features, one is scoped site (to create web template) and the other is scoped web (this is for creating a list instance) Every time i deploy the solution and ...