A feature-activation is a process which makes a feature active programatically, using power shell or through a web interface. A feature needs to be active in order to be used.

learn more… | top users | synonyms

1
vote
1answer
147 views

Activate Content Organizer feature from code

how to activate content organizer feature from c# code or by powershell script. I want to activate this feature on my subsite from my code ?
1
vote
4answers
1k views

How to enable site collection feature by default when deploying a visual webpart from visual studio?

I am making a visual web part in SP 2010 using visual studio 2010. I want it so that when I add and deploy my wsp file, it should by default keep the site collection feature activated for the web ...
0
votes
2answers
175 views

SP2010 - site collection feature not activating on MySite creation

I've created a new feature in a pre-existing project, closely modelled on features that are already within that solution. These features activate automatically when a new MySite is created, but the ...
2
votes
2answers
262 views

Activate webfeatures on all SharePoint online webs

I want to activate a webfeature on all subsites of a sitecollection in Office 365 / SharePoint online. I thought i can do the actions in a SiteCollection Feature, but that's throwing a timeout error. ...
1
vote
2answers
4k views

Activating Site Collection Level Feature with PowerShell Script

I am trying to activate a Site scoped feature using a powershell script. I have another scrip which deploys my solution and I see my feature is installed correctly in Site Collection feature gallery. ...
0
votes
2answers
1k views

Sharepoint package installation - Feature is not visible in Site collection -> settings

I am not very experienced with Sharepoint 2010 and I am having trouble installing a package. I downloaded a package from "iLove SharePoint" as I need to call web service from a workflow. The package ...
0
votes
0answers
286 views

debug feature activation

I have a visual studio project with Sharepoint Site structure. I didn't write any Event Receivers that will add my items (SP List Definitions, List Instances, ...) to the site. That means I use ERs ...
2
votes
1answer
32 views

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory?

Is there a relative URL for files hosted in the TEMPLATE\FEATURES directory? What I'm trying to do is re-provision data every time my feature is activated without deleting the SPList. The idea is to ...
-1
votes
1answer
118 views

get correct url from feature

To make it simple as the title suggest I want the correct url from the feature! atm when i was testing in test eviroment it worked well! I got the url using: SPSite siteCollection = ...
1
vote
3answers
52 views

New to Developing SharePoint Web Parts and Features

I recently Developed a really simple web part scoped to site (or at least it's feature is). I also created a feature that up[on activation is suppose to create a new content type. That's fine and ...
0
votes
0answers
56 views

Features in Sharepoint 2010

I created an empty Project and used the default Feature1 thats created with the project to then create the following: public override void FeatureActivated(SPFeatureReceiverProperties properties) ...
0
votes
1answer
129 views

Execute SPFeatureReceiver only on site creation

We have recently upgraded from SharePoint 2007 to 2010 and we aren't yet ready to train users on the new interface, so I've created a SPFeatureReceiver that will set the site template back to the 2007 ...
1
vote
1answer
300 views

How can I find the Feature Activation Dependency Powershell

I am running a recursive function that activates many features in powershell however I need to find the child feature a feature is dependent on before it is activated. How can I do this in powershell. ...
1
vote
1answer
160 views

Site-level fields created by the Community Site features and its dependencies must not be removed

I get this error: Site-level fields created by the Community Site features and its dependencies must not be removed. when trying to create a Community Site or Active the Community Site Feature, ...
1
vote
1answer
380 views

Enable-SPFeature doesn't work, but activation via Site Settings does. Why?

I have a weird problem... I'm trying to deploy a sharepoint solution in production. This project works fine in the test environment, but in production trying to enable the feature returns this error: ...
2
votes
2answers
120 views

Strange issue with feature activation

I'm having a problem while activating a feature. I have a custom dll that I referenced in this new project, and I'm trying to execute some code on the feature activation. The problem is that I get the ...
0
votes
0answers
102 views

List View Webpart is not getting added while activating feature using powershell

I created a feature and on activation of it I am trying to add list view webpart. Using powershell command activating feature and it gets activated but List View Web part it is not getting added on to ...
1
vote
1answer
225 views

Sharepoint 2010 failed to apply web.config modifications to Web Application

I have a SharePoint solution deployed into a specific web application on the production SharePoint site. When I try to enable the feature from the site features in Site Settings I get an error saying ...
0
votes
1answer
74 views

Activating a WebApplication scoped feature on a single web app touches all web app web.configs

I have a WebApplication scoped feature, and I have set ActivateOnDefault to false, to prevent the feature from being activated on every web application when installed. The feature is a simple ...
0
votes
1answer
45 views

error creating blog subsite in code

Im creating a blog subsite in the featureactivated event but it errors out everytime i activate the feature. looking at the logs i can see there is an access denied entry however the blog subsite is ...
1
vote
1answer
125 views

Does the SPField.OnAdded() method get called from a CAML deployment?

If I create a custom list definition and instance in CAML, as part of a feature, and I have included a custom field as part of that list, will that field's OnAdded() method get called when the feature ...
1
vote
1answer
926 views

How can I activate a wsp solution uploaded to solution gallery via code in SharePoint 2013

I'm creating a site definition which provisions a subsite based to a webtemplate(wsp) file. This webtemplate file is packed in a feature containing a module.When the feature is activated the wsp file ...
0
votes
0answers
509 views

Error activating ShrePoint Server Publishing Infrastructure feature

I have installed SharePoint Server 2010 Enterprise Edition in Windows Azure. After successful installation and configuration,I created a web application. When I tried to activate SharePoint Server ...
2
votes
2answers
5k views

Getting SPWeb in feature receiver

While testing my solution I receive an error on Feature activation: Detected use of SPRequest for previously closed SPWeb object. Please close SPWeb objects when you are done with all objects ...
2
votes
1answer
308 views

SPListCollection.EnsureSitePagesLibrary() throwing SPException (specified title already exists in this Web site)

I am attempting to call SPListCollection.EnsureSitePagesLibrary() upon FeatureActivated. The method is throwing the following exception: Microsoft.SharePoint.SPException: A list, survey, ...
1
vote
2answers
392 views

Add script reference to all pages in a site collection when a feature is activated

I'd like to have a feature which adds a script reference to all pages in a site collection when activated. This seems like a scenario where I should just modify the master page, but for it to affect ...
1
vote
1answer
498 views

Feature Activated Event not triggered when creating a new sub site with web template

When I create a new site I have a Web Scoped FeatureActivated event that I would like to run. The feature does get Activated but the FeatureActivated event is not triggered. The site is created with ...
1
vote
1answer
876 views

Can't find WebApplication scoped feature

I've deployed a wsp that has 2 features. The one scoped at a web level is listed where I'd expect to see it and activates without a problem. The feature scoped at a web application can't be found ...
1
vote
0answers
339 views

Set Record Declaration Settings programmatically

I created a feature receiver whereby on activation will activate and set certain features and its properties. One of that feature is InPlaceRecords. Below is my code in the FeatureActivated method:- ...
0
votes
3answers
1k views

Getting SPWeb Object in two ways

I want to access SPWeb object in feature under its FeatureActivated method. There are two ways to do this: Public Override void FeatureActivated(SPFeatureReceiverProperties properties) { //Method 1 ...
2
votes
1answer
794 views

Error occurred in deployment step 'Activate Features': Feature with Id 'xxxxx-xxx' is not installed in this farm, and cannot be added to this scope

while installing a feature, VS ouput the error: Error occurred in deployment step 'Activate Features': Feature with Id 'xxxxxxx-xxxx' is not installed in this farm, and cannot be added to this scope. ...
0
votes
1answer
137 views

Convert site to a publishing site

I need to activate publishing features on certain sites without losing their site content (lists and libraries). The publishing feature is activated in site collection. When I try to activate the ...
0
votes
1answer
84 views

Why do i have to activate my web features before i can create a website

I have created a web template using visual studio 2010, it has two features. Feature1 - Contains WebTemplate element (scoped site) Feature2 - Contains List Definitions (scoped web) I package, upload ...
0
votes
1answer
290 views

Disable auto activate feature

I have a really strange behaviour, I'm working with SharePoint 2007 and I have a feature web application scoped, and i don't want it automatically being activated on deploying the solution, but it ...
0
votes
1answer
146 views

Unable to get list “Calendar” list in feature while creating site

I want to create custom calendar list programatically. SPListTemplate template = web.ListTemplates["Calendar"]; var newListID = web.Lists.Add(fromTitle, description, template); But i cannot do ...
0
votes
4answers
2k views

How to programmatically get Feature ID?

In order to programmatically activate a feature, you need its Feature ID (some type of GUID) that is set in the .feature file. Is there a pretty way of retrieving this value programmatically, so that ...
0
votes
2answers
1k views

Error occurred in deployment step 'Activate Features': Invalid field name

SharePoint Error message Error occurred in deployment step 'Activate Features': Invalid field name.{guid}
0
votes
1answer
95 views

Associate my custom feature to default publishing site template with FeatureSiteTemplateAssociation

I want to have an event receiver on site collection creation, but it is not available. So as an alternative way i think of writing a custom feature, and associating it with the default publishing site ...
0
votes
2answers
685 views

Automatically Activate Feature when subsite created

I have created a web template with 2 features, one is scoped site (to create web template) and the other is scoped web (this is for creating a list instance) Every time i deploy the solution and ...
0
votes
2answers
105 views

How do i create a feature in web template?

I have created a web template in visual studio, it includes the standard element file and onet file, it also has a feature which is scoped to site level. All this works fine, i can deploy it and can ...
0
votes
3answers
6k views

Failed to load receiver assembly when activate feature

I have a problem when activating a Site scoped feature. Every time I try to activate the solution with STSADM or Powershell I get this error: C:\Program Files\Common Files\Microsoft Shared\Web Server ...
0
votes
3answers
1k views

rootWeb.AllProperties[“__InheritsCustomMasterUrl”] = “True”; not working

I am developing a branding project, in this project i have custom master page, i can successfully deploy it and automatically apply to the root web. But i want all the subsites inherit the master page ...
1
vote
3answers
487 views

How to activate feature in a custom site

I have created a publishing web template. Now I need to activate a feature once the site is provisioned. In order to achieve this, I've created an event receiver with something like this: public ...
1
vote
4answers
1k views

Error while activating custom feature

I have a wsp package installed as farm solution. package has event reciever on activating feature. When I go to Site Collection Features and activate this feature i get an error Error File ...
0
votes
1answer
486 views

Failed with 0x80004005 to create the view query or web parts for web

Feature 1 creates Site Columns Feature 2 creates Content Type and adds the site columns created by feature1 Feature 3 creates a List definition for mylist I have two Web tempaltes. I have added ...
1
vote
2answers
327 views

waiting for a feature to be activated when the SPWeb is created completly

I have created a web scoped feature. In FeatureActivated method I try to GetLimitedWebPartManager from default.aspx file. But the web has not been created yet and default.aspx does not exists.
1
vote
1answer
104 views

Access exceptions when trying to add a content type to list

In the following method, 'list' is simply an SPList ("Documents"). I'm attempting to add ContentTypes to the list and then update it. This code is found in the FeatureActivated event of an event ...
0
votes
2answers
579 views

Web-scoped Feature falsely activated during Visual Studio deployment

In Visual Studio I have a solution containing two features with their Scope set to "Web". These two features work as expected but the only thing that is going "wrong" is that they are activated when I ...
0
votes
1answer
344 views

Sandboxed Solution to create a Document Library and enabling manual declartion as record

I need to create a SharePoint Feature, when activated needs to create a Document Library and then enable the manual declaration as record. Following is the code which is working fine in a Console ...
0
votes
2answers
780 views

“Thread abort exception” in event receiver after adding a solution?

I am developing an event receiver for the web provisioned event. It does quite a few things, culminating to add and deploying a solution and activating a feature from it. When I do the following: ...