0
votes
1answer
30 views

Feature activation terminated if code is running too long (SP 2010)

Is it possible that feature activation will fail or will end unexpectedly (without any exceptions in ULS) when it takes too long for code to finish the job? We have a feature which during activation ...
0
votes
1answer
37 views

Unable to see timer job

I have created a custom timer job, which contains a feature. I have successfully activated the feature on my web application, but it does not show up under the job definitions. Feature.xml is as ...
0
votes
1answer
28 views

Activating web feature from event receiver doesn't do anything

I have the following code that should run to automatically disable the Minimal Download Strategy feature when a new site is being provisioned. Unfortunately nothing happens. No errors are captured in ...
2
votes
2answers
195 views

Difference between enabling feature from PowerShell and activating it via site collection features page?

I am trying to create a SharePoint list based on a list template via a feature. The code for creating the list is in the FeatureActivated event handler of the feature's EventReceiver.cs file. The list ...
0
votes
0answers
11 views

The right place to add / remove timer jobs [duplicate]

Still fairly new to SP. Have a question about adding timer jobs via features. A couple of weeks ago when I was even newer to SP, I followed one or two tutorials on the subject. The code in these used ...
2
votes
1answer
43 views

Deleting lists upon feature deactivation

I have a FeatureReceiver class for a feature that deploy a couple of list instances. In the FeatureDeactivating event I want to remove those instances as well as other artifacts which get deployed ...
1
vote
0answers
64 views

FeatureActivated() not binding two SPEventReceiverDefinitions

I have a feature which I have placed in the onet.xml in to make it active whenever the site collection is created. The feature contains two event receiver definitions for permission groups. One is for ...
1
vote
1answer
169 views

Deployment Issue with Custom FIeld Types

SHORT DESCRIPTION Custom Field Types are not being correctly deployed/activated on all but one Virtual Machine. I have several VMs with identical SharePoint environments. I have a Visual Studio ...
0
votes
1answer
126 views

Execute SPFeatureReceiver only on site creation

We have recently upgraded from SharePoint 2007 to 2010 and we aren't yet ready to train users on the new interface, so I've created a SPFeatureReceiver that will set the site template back to the 2007 ...
2
votes
1answer
299 views

SPListCollection.EnsureSitePagesLibrary() throwing SPException (specified title already exists in this Web site)

I am attempting to call SPListCollection.EnsureSitePagesLibrary() upon FeatureActivated. The method is throwing the following exception: Microsoft.SharePoint.SPException: A list, survey, ...
1
vote
1answer
466 views

Feature Activated Event not triggered when creating a new sub site with web template

When I create a new site I have a Web Scoped FeatureActivated event that I would like to run. The feature does get Activated but the FeatureActivated event is not triggered. The site is created with ...
0
votes
2answers
103 views

How do i create a feature in web template?

I have created a web template in visual studio, it includes the standard element file and onet file, it also has a feature which is scoped to site level. All this works fine, i can deploy it and can ...
1
vote
4answers
1k views

Error while activating custom feature

I have a wsp package installed as farm solution. package has event reciever on activating feature. When I go to Site Collection Features and activate this feature i get an error Error File ...
0
votes
0answers
237 views

FeatureActivated is not firing after activating feature in code-behind

I've a strange problem with activating a feature from C#: I have a list with a event receiver attached, which creates a new sub-site every time a new listitem has been added: var newWeb = ...
0
votes
1answer
99 views

Problem activating feature on child webs

I have a feature that is manually activated. In a feature receiver I also activate the feature on any child SPWebs in existence. I would like some code to run only on the SPWeb where the feature is ...
2
votes
2answers
139 views

How to catch the feature activate time

I am trying to write one program such that, when ever a feature is activated then it should display the activated time in the sharepoint list. for that i written following code. public class ...
1
vote
1answer
986 views

how to remove a published content type from subscribed site collections

I have a small Visual Studio 2010 project with one farm level feature that I deploy to a site collection which is configured as my content type hub. The FeatureActivated event adds a site column and ...
3
votes
1answer
531 views

Is SPFeatureCollection.Add method asynchronous?

I have a quite complex application that is split into several features. In order to hide this complexity, I set the IsHidden property of the feature to true, then have created a "master" feature. ...
0
votes
1answer
227 views

Custom Site Content type is not getting mapped for the required taxonomy field

I have a custom project site template which is coded in c#.net VS 2010, I have deployed the projects related to the project site template into central admin through VS After deploying the solution I ...
0
votes
1answer
131 views

Hooking feature reciever issue

I have invalidly hooked feature reciever. Feature has two configuration files The first, SharePoint looks like this: < feature ...
0
votes
1answer
148 views

Using a feature receiver to add a directory to the web applications folder

Wondering if someone knows how to add a directory/folder to the web applications folder within IIS using a feature event receiver (FeatureActivated). Any help appreciated.
1
vote
1answer
702 views

removing a sharepoint solution duplicates entry in web.config?

My intentions is to be able to add and remove web.config changes when a solution is installed or uninstalled. The code below and the powershell below works ALMOST as expected. When I add sp ...
5
votes
1answer
137 views

How to handle web references becoming stale in a web feature activation

We have a number of web-scoped features all stapled to a site definition, so they are all activated in turn when a web is created from the definition. It seems the feature receivers all share the ...
1
vote
2answers
3k views

The breakpoint will not currently be hit - debuging feature receiver

I need to debug my feature receiver, so I set up few breakpoints, but when I hit F5 in VS2010, they are all missed, and it says that "The breakpoint will not currently be hit. No symbols have been ...
4
votes
2answers
270 views

Feature Activation Logic (Prevent Activation)

I have three site collection features used to set branding throughout the site collection. I want to prevent the accidental activation of one of the features if one of the three is already activated; ...
1
vote
2answers
127 views

Backup a file while custom feature activated?

We have a custom application page "custom.aspx" on the Layout folder, would like to rename the original file "custom.aspx" to "custom_bak.aspx" before the updated/modified custom application page ...
7
votes
3answers
3k views

How do you “stop” activating a feature within the feature receiver?

I have a feature receiver with some long running code, hence I use SPLongOperation and delegate for better visual appearance. Basically my feature receiver looks like so: public override void ...