0
votes
1answer
276 views

Programatically publishing Content Type in Content type Hub

I have a custom content type which I am deploying to a Site collection in which content type hub is configured. To use the content types in different site collection after the content type is deployed ...
0
votes
1answer
28 views

Inheritance of Content Types in a Single Feature

I am having the same issue as seen in http://stackoverflow.com/q/9699451/240372 yet the solution does not work for me. The ID's for my Content Types are the following A ...
0
votes
1answer
318 views

ListDefinition and ListInstance failures with custom content type

In VisualStudio 2012 I have a custom content type that I want to use in a ListInstance. When I create a ListDefinition or ListInstance using VisualStudio and add my ContentType I get feature ...
0
votes
2answers
1k views

Error occurred in deployment step 'Activate Features': Invalid field name

SharePoint Error message Error occurred in deployment step 'Activate Features': Invalid field name.{guid}
1
vote
1answer
110 views

Access exceptions when trying to add a content type to list

In the following method, 'list' is simply an SPList ("Documents"). I'm attempting to add ContentTypes to the list and then update it. This code is found in the FeatureActivated event of an event ...
1
vote
2answers
1k views

how to remove a published content type from subscribed site collections

I have a small Visual Studio 2010 project with one farm level feature that I deploy to a site collection which is configured as my content type hub. The FeatureActivated event adds a site column and ...
0
votes
1answer
240 views

Custom Site Content type is not getting mapped for the required taxonomy field

I have a custom project site template which is coded in c#.net VS 2010, I have deployed the projects related to the project site template into central admin through VS After deploying the solution I ...
0
votes
4answers
2k views

Can't deploy custom content type

I have an content type in my feature, and sudenly when I tried to debug my feature, i got the following error: Error occurred in deployment step 'Activate Features': The content type with Id ...
1
vote
2answers
150 views

Using CodePlex Feature Generator

I was just wonder whether any acutally used the feature generator from codeplex or not. I have following questions... Does it create good version (meaning not missing anything major from feature) ...