An XML element is everything from (including) the element's start tag to (including) the element's end tag.

learn more… | top users | synonyms

2
votes
2answers
444 views

Office 365- Master Page deployed via SharePoint Module( in Visual Studio) is not available in Master Page Gallary

I followed the steps given in the below article: http://www.codeproject.com/Tips/817340/Creating-Custom-Master-Page-for-Hosted-Apps Created a Custom Master Page. Applied it to my App. Its working ...
1
vote
1answer
68 views

List instance with default url

I am currently working with sharepoint hosted apps. Each app has a List, which i create from visual studio. The client needs some default rows for each list. In some cases a row may have an image. ...
1
vote
1answer
2k views

Unable to Edit Web Part Properties in Web Part Zone in 2013

I have a custom page layout that I have designed using Visual Studio. Within it I have several web part zones and I have a zone where I would like users to be able to edit the properties of the web ...
0
votes
1answer
10 views

Blocked duplication way of Elements.xml

I'm trying to blocked duplication by elements.xml I read that an element must be indexed and i have to use the EnforceUniqueValues So i added on my elements.xml Indexed="TRUE" ...
0
votes
1answer
50 views

Elements.xml not setting document title property

I am writing a custom app to interact with a document library. During deployment I have a module to populate the document library with some sample data, however I am not able to populate the Title ...
0
votes
1answer
46 views

How to add display-output-escaping= “yes” in SharePoint?

I am a fresh Share point worker. I made up a workflow to create item in List, and it works. After Creating in Word Fields, it has in both side of rich text. I wanted to add display-output-escaping= ...
0
votes
1answer
34 views

How to Read XML attribute?

I have XMl file that has various file attachments when the attachment is empty the xsi:nil="true" will be set so i want to read this attribute
0
votes
1answer
87 views

Setting the value of a boolean XMLElement

I'm having a problem when assigning a value to a Boolean check/tick box within InfoPath xml code. I've created text boxes using inner text values but this gives the error of an incorrect data type. ...
0
votes
1answer
636 views

How to bind tree view with XMLdatasource dynamically in c#

I have a scenario where I have a SPListItemCollection of SharePoint 2013 and I have to bind tree view with XMLDataSource. I have to add nodes to XML and iterate to add child nodes also but all these ...
0
votes
1answer
249 views

Set a date in an InfoPath form to null

I'm trying to write an InfoPath form from code. I'm working with the xml of a form, and when I write a date it gives me no error but when I open the form in SharePoint and click on Save, it says that ...
0
votes
1answer
371 views

How to reference/write the file path in Elements.xml for UserControl in Sandbox Solution?

I have 1 solution (which is deploying as SandBox Solution). I have added JavaScript files, Images, Application Page & UserControl in one Module under project folder. I have one Element.xml file ...
1
vote
0answers
20 views

Changes not update for schema.xml on SharePoint hosted app update

I have done my changes in my list's schema.xml. I have added extra view over existing list. I have also publish my app earlier but when I update my app over existing one it will reflect all changes ...
1
vote
0answers
85 views

Reading Each XML Node in Powershell to create list in SharePoint

I have an XML file which I got from running webservices of below format. It contains each List name in the site collection under node. Now using this file I have to create lists in another site ...
1
vote
0answers
44 views

List Content types not getting updating while adding a site column to already deployed site content type using elements.xml

I have a site content type deployed through element.xml and is used inside lists. I added one site column and referenced that in content type. So my element.xml looks like below <?xml ...
1
vote
0answers
248 views

Deploy custom newform for custom list using wsp for SharePoint Online

I have a custom list which inherits 2 custom content types. Each content type contains around 50 odd fields. I have to customize the layout of the form and integrate jquery for the newform and ...
1
vote
0answers
292 views

Content Type Columns not showing for Image Library

I have created the following 2 Site Column Definitions and a Content Type that incorporates both of the site columns A List Definition of type Picture Library that utilizes the Content type. however ...
1
vote
0answers
244 views

SharePoint 2013 Promoted Links in Elements.xml?

Does anyone have a working example of an <AllUserWebPart> or <View> within an Elements.xml file that includes a "Promoted Links" web part on a page. I just can't seem to get my ...
1
vote
0answers
344 views

Config standard SiteUsers WebPart in SP2010

I´ve got a problem with a normal SiteUsers WebPart. Currently I have this code: <WebPart xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" ...
0
votes
0answers
21 views

Event Receiver attached to a blog post list is not fired

I've created an event receiver for a blog post. Unfortunately it's not fired. What I've noticed is: ItemAdded is not executed ItemAdded is executed for a custom list but not for my post list. My ...
0
votes
0answers
16 views

Changing ClientWebPart title to hyperlink

I have created a sharepoint app but need to somehow create a link back to the site page the user came from if they click on the app. Preferably I would like to use the client webpart content to do ...
0
votes
0answers
72 views

A duplicate field name “XXXX” was found when create a site from te

I backup a subsite as a template, and then I need to creat a new sub site in the same site collection from this template. There is always an error A duplicate field name "XXXX" was found I check file ...
0
votes
0answers
19 views

Declaratively created content type is losing event receivers on list

I declaratively created a content type which has an attached event receiver. I attached this ct to a list which is also being done via xml declaration. In principle all components are working. The ...
0
votes
0answers
17 views

SharePoint manipulating content on ListItem insertion

Long story short, I am parsing an XML document and adding items to the Body field of a discussion board. The XML has a <body> element that contains encoded HTML that I am adding to the list ...
0
votes
0answers
61 views

Fieldref - open in new window

I want to know how to make in SharePoint so that a link by FieldRef opens in new window. I have got some column and one with a link which opens, but only the same window. Sharepoint 2013 <View ...