Preparation of components or SharePoint itself for use.

learn more… | top users | synonyms

2
votes
1answer
41 views

Migrate Web Part from one environment to another?

SharePoint Foundation 2010. I have added a very basic web part to my development environment. It is honestly just the Visual Web Part template. I would like to export this web part and import to ...
2
votes
1answer
1k views

deploy custom site list solution to web application scope?

I created a custom list definition in Visual Studio. Then, I generated a .wsp and sent it to our server admin to install. He got a warning: The solution contains no Web application scoped ...
2
votes
1answer
552 views

How to add and use external assemblies in solutions?

I need to use DocumentFormat.OpenXml.dll in my code. In the solution package, I included this external dll in the Additional Assemblies. It looks like this: I also need to reference it, so that I ...
2
votes
1answer
508 views

Why CustomRibbonButton for List not displaying in RibbonBar?

I have added 1 Element File for CustomRibbon Button. And added 1 Feature to deploy this RibbonButton. When I deploy this, it deploys and Feature is Activated but not displaying the Button in ...
2
votes
0answers
333 views

Why does WSP Deployment Type 'ApplicationServer' require features to be manually installed?

When I create a WSP with Deployment Type set to WebFrontEnd and deploy, all of the features contained within are automatically installed. Features that are set up as ActivateOnDefault="TRUE" (Farm or ...
1
vote
0answers
16 views

Deploy a file to the “Forms” folder of a Document Library using Powershell

I am dynamically building up a file that I then want to upload to SharePoint 2013 using PowerShell. I want to upload this file into the "Forms" folder of a Document Library - So not into the Document ...
1
vote
0answers
29 views

Update long running workflow in SP 2013

I have a question concerning how to manage installation of new versions of workflow features, in case when there are already running instances. It seems on my development machine that after installing ...
1
vote
0answers
271 views

XsltListViewWebPart: select default view

I'm trying to configure an XsltLisViewWebPart for deployment to a SharePoint site. I'm provisioning the views beforehand using: List oList = clientContext.Web.Lists.GetByTitle(list.Title); ...
1
vote
0answers
18 views

How do you clean up the test features and solutions from the farm?

we have been playing around with sharepoint wsps and visual studio and there are lot of test files in the layout folder, coltrol templates and images folders, etc. Also there exist wsps and features ...
1
vote
0answers
146 views

Able to Export a site but unable to import in another webapplication

Here I am using SharePoint 2013. I exported site collection with no errors, but when trying to Import site onto different web application as a site, I got below error Verbose: List URL: ...
1
vote
0answers
171 views

SharePoint2013, provider-hosted, remoteAppUrl resolution in Elemets.xml

In my experience when a provider-hosted app is built in VS ~remoteAppUrl gets resolved according to the build profile. The end results is that all webparts' Elements.xml get their page location set at ...
1
vote
0answers
22 views

How to deploy a cross-site publishing environment to prod

I'm building out a cross-site publishing environment on a dev server. So, it will have the following sites/assets: publishing site (myserver/sites/devpubsite) product Catalog Site ...
1
vote
0answers
169 views

SharePoint App Deployment error : 'Failed to install app for SharePoint'

I created a test MVC sharepoint app succesfully in a solution. Now I need to integrate this into a main solution project. But when I added a SharePoint MVC App into the solution and hit F5, I am ...
1
vote
0answers
98 views

Move listitems in SharePoint Hosted app

I am trying to creating a SharePoint 2013 Hosted app that get a selected listitem and move it to another folder of library in the same web. When I debug my code everything runs without any problem. ...
1
vote
0answers
23 views

Requirments for running my web application under https

I have created a new web application that uses https. After that I added a new site collection to it, but my question is "will SharePoint web application and the site collection works under HTTPS out ...
1
vote
0answers
119 views

VS 2013 not deploying silverlight solution in sandboxed on stand alone dev: SPUCWorkerProcess not running error

I have a stand alone machine with SP2010 set up on Windows Server 2008 R2. Office, SPD, VS2013, Expression, etc. There is no AD or anything as it is stand alone installation using local accounts and ...
1
vote
0answers
18 views

Deployment Question

We have a live sharepoint site and one development and one UAT server. Whenever we want to refresh the live site content to UAT, we are having problems. Most of the web parts are failing and ending up ...
1
vote
0answers
51 views

SafeControls not added on all front-ends

On deployment in our acceptation farm, I noticed something weird happening. I deployed a wsp solution, just standard stuff. The solution contained a GAC assembly and some safecontrols. Our farm ...
1
vote
0answers
57 views

Migrating .aspx pages created on SharePoint 2010

We're developing a solution based on a closed-source SharePoint-based application here at work and we're pretty stuck on the deployment portion. We have 2 servers, production and development. We need ...
1
vote
0answers
126 views

Error - Service Application creation

I was helping a client today to run scripts for creating web apps, site collections and service applications. Creating normal web applications and site collections worked fine but we got some ...
1
vote
0answers
43 views

Listdefinitions use Listname as Contenttype

I have a Sharepoint 2010 Foundation, VS2010 and i use the Sharepointfactory(spsf.codeplex.com), if this is important. My typical approach are: I create first some fields, then i use these in a ...
1
vote
0answers
248 views

how to maintain workflow task list data when retracting or removing workflow association

whenever i try to remove workflow association or retract workflow solution (.wsp) all associated task list data also gets deleted. i want to prevent this behavior as task list data is important for ...
1
vote
0answers
139 views

Deploy Sharepoint Dashboad page and KPI List to other site

I have a report library in Sharepoint site where i have several dashboard pages. Each of these dashboard pages have kpi and excel web acess web parts in them (only out of box no custom web parts). A ...
1
vote
0answers
1k views

File not found on WebPart Deployment

I followed the Instructions on msdn and also this one here but unfortunatley nothing seems to work. I've built a custom webpart and packaged it into a .wsp file since i'm trying to import this ...
0
votes
0answers
14 views

Deploying an HTML App to Multiple Sites

I am developing an HTML app for SharePoint Online. This will be a hybrid app which will consist of an HTML page, JavaScript and CSS files, and image resources. This app will be hosted on a page in a ...
0
votes
0answers
13 views

SharePoint App Model and auto generated app Ids

Here is my problem: I have a SharePoint Hosted app. My environment consists of of the following App settings: App prefix: apps App Domain suffix: mydomain-apps.com I have two Web Applications so ...
0
votes
0answers
10 views

Set App External Content Type Connection Settings to OData Service Endpoint During Deployment

Is there anyway I can set the connection settings for the apps external content type during deployment/activation. The OData endpoint is hardcoded in the ECT file to my dev environment. Is there a ...
0
votes
0answers
12 views

Visual Studio Sharepoint App add New Item give me “Access Denied”

I think, that VS try to fetch data about site from Sharepoint but use my Windows credentials, which do not have proper permissions in Sharepoint for that site. How do I specify different credentials ...
0
votes
0answers
28 views

Issue when *directly* deploying a Solution on SharePoint 2013

I have been having trouble deploying a WSP file (a solution containing visual web parts and [primarily] core backend logic) to our SharePoint 2013 server. Deploying through Visual Studio works ...
0
votes
0answers
43 views

Deployed .WSP via powershell, but now jquery wont work

I followed the steps in This article to deploy my solution, which uses some jQuery. however now that I've deployed it, it doesn't work. what can I do to get this working again? It worked perfect in my ...
0
votes
0answers
92 views

Auto Create Folders When deploying module

I'm trying building some modules on my solution for Sharepoint deployment from visual studio. So the main goal is deploy css, scripts files into the style library. So I added the feature module on vs ...
0
votes
0answers
38 views

Error occurred in deployment step 'Activate Features': The file Image Library/KeynoteBackdrop1.png has been modified by i:0#.w|xyz\harsh.dave

I have created a following module - <Module Name="Images" Url="Image Library" RootWebOnly="TRUE" > <File Path="SliderFiles\KeynoteBackdrop1.png" Url="KeynoteBackdrop1.png" ...
0
votes
0answers
22 views

VS SP project cannot connect to SP Site

I am building the same SP project in VS 2010 on two different accounts on the same server. On the admin account (with the final version), I needed to change the Site URL and found that it cannot ...
0
votes
0answers
49 views

The job 'GUID' is already running and cannot be canceled- PowerShell

A deployment or retraction is already under way for the solution "xxx.wsp", and only one deployment or retraction at a time is supported it occurs if anomalies deployment is running for the same ...
0
votes
0answers
42 views

Add all DLLs to GAC?

My SharePoint 2010 solution has two projects, one responsible for the back end (WCF web service) and one for the front end (webparts). I added the DLL from the back end to GAC via Visual Studio ...
0
votes
0answers
48 views

Deployed sharepoint-hosted app not accessible

I have created a sharepoint-hosted app (sharepoint 2013) and I cannot publish it. I already deployed another provider-hosted apps, the CNAME is configured an seems to work... but when I try to ...
0
votes
0answers
68 views

IE default security settings block any App scripts from running

I wrote a Sharepoint-hosted app for use by a single company. But in order for my javascript to execute on their local intranet, which uses Microsoft Windows Server 2008, I have to instruct them to ...
0
votes
0answers
81 views

Deploying app part to office 365, takes long time to load

When I am debugging the solution, the app part is working properly. After testing I deployed this app part to Office 365 site, and added app part to the page. It's taking very long time to load the ...
0
votes
0answers
55 views

Deploying web part to https site

I'm trying to deploy custom Visual Web Part created in Visual Studio 2013 as a farm solution in Sharepoint 2013. The thing is, the site I want to specify for debugging is a https site. After ...
0
votes
0answers
13 views

Setup separated account for Search Service and get SQL deny error

I have a new account "wss_search". Then I re-create the existing "Search Service Application" and assign wss_search as the new application pool owner. Also I have granted wss_search have full control ...
0
votes
0answers
34 views

Deployment time at Visual Studio's output window

I am deploying webpart solution or another wsp project from Visual Studio and i need to see finishing time. Are there any way to see the time when deploy finished or any error occured for interrupt ...
0
votes
0answers
20 views

Missing feature when deploing with -Local parameter

We have package with publishing page template and content type. All this stuff is in web scoped feature. Whe we deploys our package globally (wothout -local param) Install-SPSolution -Identity "Name" ...
0
votes
0answers
69 views

Restoring my Site collection from my development machine to my staging machine will show blank page

I have a team site collection inside my development machine; containing Apps, text, pictures, etc. So i back up the site collection from my development machine, i create a new web application inside ...
0
votes
0answers
95 views

SharePoint 2010 custom service with no GAC deployment

I am working with a Custom Share Point 2010 service development. The issue is if the Solution is scoped at GAC then I can access my Service with /mex extension, to the url. But, if the solution is ...
0
votes
0answers
43 views

How do I Duplicate a SharePoint 2007 Publishing Subsite

I don't know a lot about SharePoint so pardon my terminology and please let me know what additional information is needed. I work for a franchiser who gives each franchisee their own website. These ...
0
votes
0answers
302 views

Not all changes apply after re-deploying solution (custom workflow action for SharePoint Designer)

currently I'm creating a custom workflow action for SharePoint Designer 2010. After the first deploy succeeded everything looked fine. But after that I changed several things and re-deployed the ...
0
votes
0answers
183 views

Roll back deployment stategy and performance testing (2010)

I am currently on the cusp of deploying a solution which will be upgrading existing .wsp solutions and also running a powershell script to upgrade masterpages, content types and page layouts on the ...
0
votes
0answers
132 views

Problem with adding webparts with limitedWebManager.ImportWebPart PowerShell

When creating a web in Visual Studio it generates a web part where the namespace and the class name is the same. I'm thinking that this is giving me a problem with the limitedWebManager.ImportWebPart ...
0
votes
0answers
315 views

Quickest way to backup and restore a web application content database across farms?

When I perform a complete backup of my development content database using Backup-SPSite and restore the site on a separate farm using Restore-SPSite its currently taking around 25 mins to backup and ...
0
votes
0answers
128 views

Updated SharePoint Solution not recongnized

I've modified a minor bug in a User Control of a custom SharePoint solution that was initially deployed on SharePoint 2007 but now it is deployed on SharePoint 2010. I was hoping to just update the ...